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Overview

This book is intended for the user who needs to become quickly familiar with Part Design product. The Part 
Design User's Guide has been designed to show you how to create a part. There are several ways of creating a 
part and this book aims at illustrating the several stages of creation you may encounter. 

This overview provides the following information:

●     Part Design in a Nutshell

●     Before Reading this Guide

●     Getting the Most out of This Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide

Part Design in a Nutshell

The Part Design application makes it possible to design precise 3D mechanical parts with an intuitive and 
flexible user interface, from sketching in an assembly context to iterative detailed design. Part Design 
application will enable you to accommodate design requirements for parts of various complexities, from simple 
to advanced.

This application, which combines the power of feature-based design with the flexibility of a Boolean approach, 
offers a highly productive and intuitive design environment with multiple design methodologies, such as post-
design and local 3D parameterization.

As a scalable product, Part Design can be used in cooperation with other current or future companion products 
such as Assembly Design and Generative Drafting. The widest application portfolio in the industry is also 
accessible through interoperability with CATIA Solutions Version 4 to enable support of the full product 
development process from initial concept to product in operation.

Before Reading this Guide



Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, 
standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that 
describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and 
the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required:

●     Sketcher User's Guide: explains how to sketch 2D elements.

●     Wireframe and Surface User's Guide: explains how to create wireframe geometry and surfaces.

Getting the Most out of this Guide

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial 
Getting Started. This tutorial will show you how to create a basic part from scratch.

Once you have finished, you should move on to the next sections dealing with the handling of CATPart data, 
then the creation and modification of various types of features you will need to construct parts. This guide also 
presents other Part Design capabilities allowing you to design complex parts. You can also take a look at the 
sections describing the Part Design Workbench at the end of the guide. 

Accessing Sample Documents

To perform the scenarios, you will be using sample documents contained in the online/prtug/samples 
folder. 

When samples belong to capabilities common to different products, those samples will be found in the 
online/cfysm_XX/samples folder. 

For more information about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.

Conventions Used in this Guide

To learn more about the conventions used in this guide, refer to the Conventions section. 
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Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View Mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or Advanced Tasks

Interoperability

Workbench Description

Customizing

Administration Tasks

Reference



Methodology

Frequently Asked Questions

Glossary

Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionalities

Create Technological Results
The Create Technological Results capability supplies technological information on the features 
included in a body. This information can then be reused by downstream applications such as Generative 
Drafting for example or by downstream users.

Delete and Keep Operand in Context
After deleting a Boolean operation performed between a body and a body included in an Ordered 
Geometrical Set (OGS), you can keep the operand body in its original position within the OGS. This is 
made possible using Delete and Keep Operand in Context, a new capability available from 
contextual menus.

Enhanced Functionalities

Boolean Operations from Bodies Located in Ordered Geometrical Sets
It is now possible to perform a Boolean operation between bodies located in Ordered Geometrical Sets.

Holes on Non-planar Faces
The positioning sketch is now linked to the non-planar surface, so that whenever the surface is 
modified or moved the hole moves too accordingly.

Holes
The Hole capability now lets you thread tapered holes.

Threads
The Thread capability now lets you select conic surfaces for threading operations.

Point
A lock mechanism is available to prevent an automatic change of the point type while selecting the 
geometry.

Line
A lock mechanism is available to prevent an automatic change of the line type while selecting the 
geometry.

Plane
A lock mechanism is available to prevent an automatic change of the plane type while selecting the 
geometry.

Customizing Settings

Show Newly Created External References
The Create external elements as shown elements option available in the General tab of the 
Options dialog box has been renamed as Show newly created external references.

Restrict External selection with Link to Published Elements
The Only use published elements for external selection keeping link option available in the 
General tab of the Options dialog box has been renamed as Restrict external selection with link 
to published elements.

Allow Publication of Faces, Edges, Vertices, and Axes Extremities
The Publish a face, edge, axis, vertices or extremity option available in the General  tab of the 
Options dialog box has been renamed as Allow publication of faces, edges, vertices, and axes 
extremities.

Update all External References



The Synchronize all external references for update option available in the General tab of the 
Options dialog box has been renamed as Update all external references.

Expand sketch-based Feature Nodes at Creation
The Sketches option available in the Display tab of the Options dialog box has been renamed as 
Expand sketch-based feature nodes at creation.

Part Infrastructure Settings
Using Tools>Macro>Start Recording, you can now record any modifications made to Part 
Infrastructure settings in a Visual Basic file.  Additionally, you can now launch a dedicated VB macro in 
order to set parameters for Part infrastructure.



Getting Started

Before getting into the detailed instructions for using parts, the following tutorial aims at giving you a feel as 
to what you can do with the product. It provides a step-by-step scenario showing you how to use key 
functionalities. 

The main tasks described in this section are:

Entering the Part Design Workbench
Creating a Pad
Drafting a Face
Filleting an Edge
Editing the Pad

Mirroring the Part
Sketching a Circle from a Face

Creating a Pocket
Shelling the Part

 

 

All together, the tasks should take about ten minutes to complete.

The final part will look like this:

Now, let's get to sketching the profile!



Entering the Part Design Workbench

 

This first task shows you how to enter the Part Design workbench.

 1.  Select File > New... (or click the New  icon). 

The New dialog box is displayed, allowing you to choose the type of document you need.

2.  Select Part in the List of Types field.

3.  Click OK. 

The New Part dialog appears if your session is configured as explained in the Customizing chapter of this 

guide. For more information, refer to the documentation related to the Part Document tab.

Hybrid Design
 

By default, the Enable hybrid design option is on, meaning that you are allowed to insert wireframe and 

surface elements in bodies. 

To facilitate your design, we recommend you never change this option during your session. 

4.  Click OK to validate your preferences and close the New Part dialog box.

The Part Design workbench is loaded and an empty CATPart document opens.

If the New Part dialog box does not appear, the Part Design workbench is immediately loaded and an 

empty CATPart document opens.



The commands for creating and editing features are available in the workbench toolbar. Now, let's 

perform the following task Creating a Pad.



Creating a Pad

This task shows you how to create a pad, that is extrude a profile sketched in the Sketcher 
workbench. For more about this workbench, refer to Sketcher User's Guide Version 5.

Open the GettingStarted.CATPart document to open the required profile.

Your profile belongs to Sketch.1 and was created on plane xy. It looks like this:

1.  Select the profile if not already selected and click the Pad icon  . 

The Pad Definition dialog box appears. Default options allow you to create a basic pad.

2.  As you prefer to create a larger pad, enter 60 mm in the Length field. 
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The application previews the pad to be created.

3.  Click OK.

The pad is created. The extrusion is performed in a direction which is normal to the sketch 

plane. The application displays this creation in the specification tree:

The application lets you control the display of some of the part components. To know more 

about the components you can display or hide, refer to the General section that describes 

how to customizing the Tree and Geometry Views.

For more about pads, refer to Creating Pads, Creating 'Up to Next' Pads, Creating 'Up to Last' Pads, 

Creating 'Up to Plane' Pads, Creating 'Up to Surface' Pads, Creating Pads not Normal to Sketch 

Planes.



Drafting a Face

 

This task shows you how to draft a face.

 1.  Click the Draft Angle icon .

The Draft Definition dialog box appears. The application displays the default pulling direction on the part.

2.  Select the face as shown by the arrow as the face to be drafted.

The application detects all the faces to be drafted. The selected face is now in dark red whereas the other 

faces are in a lighter red.

3.  Click the Selection field of the Neutral Element frame and select the upper face.

The neutral element is now displayed in blue, the neutral curve in pink.

4.  Enter 9 degrees in the Angle field.

5.  Click OK. The part is drafted:



For more about drafts, refer to Creating Basic Drafts, and to Creating Drafts with Parting Elements.



Filleting an Edge
In this task you will learn how to use one of the fillet commands designed to fillet edges.

 1.  Click the Edge Fillet icon .

The Edge Fillet Definition dialog box appears. It contains default values.

2.   Select the edge to be filleted, that is, to be rounded. 

 

The  icon now available after the Objects to fillet field lets you edit the list of the objects to be 
filleted. For more information about that capability, refer to Editing a List of Elements. 

Clicking Preview lets you see what the default fillet would look like.



3.  Enter 7 mm as the new radius value and click OK.

Here is your part:  

For more about fillets, refer to Creating Edge Fillets, Creating Face-Face Fillets, Creating Tritangent 
Fillets, Creating Variable Radius Fillets.



Editing the Pad

 

Actually, you would like the pad to be thicker. This task shows you how to edit the pad, then how to 
color the part. 

 
1.  Double-click Pad.1.

You can do it in the specification tree if you wish.

2.  In the Pad Definition dialog box that appears, enter 90 mm as the new length value.

3.  Click OK.

The part is modified accordingly.

4.  Now select Part Body.

5.  Select Edit > Properties and click the Graphic tab to change the color of your part.

6.  Set the color of your choice in the Color combo box and click OK.



To have details about how to change graphic properties, refer to Infrastructure User's Guide 

Version 5.

The part now looks like this:
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Mirroring the Part

 

Now, you are going to duplicate the part using the Mirror capability. This task shows you how easy it is.

 
1.  Select the reference face you need to duplicate the part. Select the face as shown:

2.  Click the Mirror icon .

The name of this face appears in the Mirroring element field. 

3.  Click OK.

The part is mirrored and the specification tree indicates this operation. 



For more information about mirroring, refer to Mirror.



Sketching a Circle from a Face

 

In this task, you will learn how to: 
●     sketch a circle on an existing face

●     use this circle in order to create a pocket

 
1.  Select the upper face to define the working plane.

2.  Click the Sketcher icon  to enter the Sketcher workbench.

3.  Once in the Sketcher workbench, click this Circle icon  to create a basic circle.

4.  Click the circle center in the middle of the face and drag the cursor to sketch the circle.

5.  Click once you are satisfied with the size of the circle.

6.  Click the Exit workbench icon  to return to the 3D world. This is your part: 



For more about Sketcher elements, refer to Sketcher User's Guide Version 5.



Creating a Pocket

 

In this task, you will learn a method to create a pocket using the profile you have just created.

 
1.  Select the circle you have just sketched, if it is not already selected.

2.  Click the Pocket icon .

The Pocket Definition dialog box is displayed and the application previews a pocket with default 

parameters.

3.  Set the Up to last option to define the limit of your pocket. 

The application will limit the pocket onto the last possible face, that is the pad bottom.

4.  Click OK.

This is your pocket:



For more about pockets, refer to Creating Pockets.



Shelling the Part

 

To end the scenario, you will learn how to shell the part.

 
1.  Select the bottom face of the part. 

2.  Click the Shell icon .

The selected face turns purple and the Shell Definition dialog box appears.

3.  Enter 5mm as the inner thickness value.

4.  Click OK to shell the part.  

You have defined a positive value, which means that you are going to obtain a thin part 

thickness.



 

For more information about shells, refer to Creating Shells.

You have finished the scenario. Now, let's take a closer look at the application.



Basic Tasks

The basic tasks you car perform in the Part Design workbench are mainly the creation of features and surfaces 
you use to create your part. To create features you sometimes sketch profiles first or use existing features.

This section explains and illustrates how to create various kinds of features and surfaces. The table below lists 
the information you can find.

Opening a New CATPart Document
Sketch-Based Features

Dress-Up Features
Surface-Based Features
Transformation Features

Reference Elements
Using Surfaces and Curves

Modifying Parts
Setting Constraints
Replacing Elements

Displaying and Editing Properties
Creating Annotations

Handling Parts
Hybrid Design



Opening a New CATPart Document

 

This task shows you how to open a new CATPart document.

1.  Select File > New (or click the New  icon).

The New dialog box is displayed, allowing you to choose the type of document you need.

2.  Select Part from the List of Types field. 

3.  Click OK. 

Customized Session

The New Part dialog appears if your session is configured as explained in the Customizing chapter of this 

guide. For more information, refer to the documentation related to the Part Document tab.

4.  Enter the name you want to assign to the part if the default one does not satisfy you.

5.  Select the options you need for your design environment.

Hybrid Design
 

If you select Enable hybrid design, the capability then applies to all the bodies you will create in your 

CATIA session (and not only to the new CATPart document you are opening). As a consequence, if your 

session contains CATPart documents already including traditional bodies, the new bodies you will create 

in these documents will possibly include wireframe and surface elements.

To facilitate your design, we recommend you never change your preferences during your session. 

6.  Click OK to validate your options and close the New Part dialog box.

The Part Design workbench is loaded and an empty CATPart document opens.



If the New Part dialog box does not appear, the Part Design workbench is immediately loaded and an 

empty CATPart document opens.

The Part Design workbench document is divided into: 

❍     the specification tree 

❍     the geometry area

❍     specific toolbars: for information, refer to Workbench Description.

A number of contextual commands are available in the specification tree and in the geometry. 

Remember that these commands can also be accessed from the menu bar.

You will notice that the application provides three planes to let you start your design. Actually, designing 

a part from scratch firsts require designing a sketch. Sketching profiles is performed in the Sketcher 

workbench which is fully integrated into Part Design. To open it, just click the Sketcher icon  and 



select the work plane of your choice. 

The Sketcher workbench then provides a large number of tools allowing you to sketch the profiles you 

need. For more information, refer to the Sketcher User's Guide.



Sketch-Based Features

Features are entities you combine to make up your part. The features presented here are obtained by applying 
commands on initial profiles created in the Sketcher workbench (See Sketcher User's Guide) or in the 
Generative Shape Design workbench (See Generative Shape Design User's Guide) as well as surfaces.

Some operations consist in adding material, others in removing material. In this section, you will learn how to 
create the following features:

 

 
Create a Pad: Click this icon, select the profile to be extruded and enter the parameters you need 
in the dialog box. 

Using the Sub-elements of a Sketch: right-click the Selection field from the Pad or Pocket dialog 
box and select Go to Profile Definition to display the Profile Definition dialog box.

 
Create an 'Up to Next' Pad: Click this icon, select the profile to be extruded, set the Type option to 
Up to next and enter the parameters you need in the dialog box. 

 
Create an 'Up to Last' Pad: Click this icon, select the profile to be extruded, set the Type option to 
Up to last and enter the parameters you need in the dialog box. 

 
Create an 'Up to Plane' Pad: Click this icon, select the profile to be extruded, enter the parameters 
you need, set the Type option to `Up to plane' in the dialog box and select the required plane. 

 
Create an 'Up to Surface' Pad: Click this icon, select the profile to be extruded, enter the 
parameters you need, set the Type option to Up to surface in the dialog box and select the 
required surface. 

 
Create a Pad from a Surface: Click this icon, select the surface to be extruded and enter the 
parameters you need.

 
Create a Pad not Normal to Sketch Plane: Click this icon, select the profile to be extruded, expand 
the dialog box, enter the required parameters, define a new reference for the extrusion direction. 



 
Create a Multi-Pad: Click this icon, select the sketch to be extruded and specify a length value for 
each domain.

Create a Drafted Filleted Pad: Click this icon, select the profile to be extruded and enter the 
parameters you need in the dialog box. 

 
Create a Pocket: Click this icon, select the profile and enter the parameters you need in the dialog 
box. 

 
Create a Pocket from a Surface: Click this icon, select the surface to be extruded and enter the 
parameters you need.

 
Create a Multi-Pocket: Click this icon, select the sketch to be extruded and specify a length value 
for each domain.

Create a Drafted Filleted Pocket: Click this icon, select the profile to be extruded and enter the 
parameters you need in the dialog box. 

  
Create a Thin Solid: Click one of these icons, check the Thick option and enter values to define the 
thickness.

Create a Shaft: Click this icon, select the profile to be revolved about the axis and enter angle 
values.

 
Create a Groove: Click this icon, select the profile to be revolved about the axis and enter angle 
values.

 
Create a Hole: Click this icon, select the face to locate the hole to be created and enter the 
required parameters in the dialog box.



Create a Hole on a Non-planar Face: select a non-planar face and a point on that face, then click 
this icon and enter the required parameters in the Hole Definition dialog box.

Locating Holes: To constrain the location of the hole, multi-select two edges of the face  on which 
you wish to position the hole, then that face.

 
Create a Threaded Hole: Click this icon, select the face to locate the hole, define the hole shape, 
check Threaded, click Specifications and enter the required values in the Thread dialog box..

 
Create a Rib: Click this icon, select the profile to be swept along a center curve, select this center 
curve and set the position option in the dialog box. 

Trimming Ribs or Slots: If the rib or the slot cannot be trimmed by existing material, the only way 
of obtaining a rib is by using the Thick Profile option.

 
Create a Slot: Click this icon, select the profile to be swept along a center curve, select this center 
curve and set the position option in the dialog box.

 
Create a Stiffener: Click this icon, select the profile to be extruded, and specify whether this 
extrusion is to be done in two or three directions.

Create a Multi-sections Solid: Click this icon, select the section curves, the guide curves and if 
necessary the spine of your choice.

Remove a Multi-sections Solid: Click this icon, select the section curves, the guide curves, the 
closing points and if necessary the spine of your choice.

Create a Solid Combine: Click this icon, select the components which intersections you want to 
compute.

How Sketches are Located in the Specification Tree

Up to Part Design Version 5 release 14 the sketches used for creating sketch-based features were located 
directly below the features in the specification tree. Now, to improve the visibility of your design process this 
behavior has changed: new rules define the location of sketch entities in the specification tree. The How 
Sketches are Located in the Specification Tree section covers this new behavior.



Creating Pads 

 

Creating a pad means extruding a profile or a surface in one or two directions. The application lets you choose the 
limits of creation as well as the direction of extrusion.

This task shows you how to create a basic pad using a closed profile, the Dimension and Mirrored extent options.

Open the Pad1.CATPart document.

 
1.  Select Sketch.1 as the profile to be extruded.

About Profiles 
●     You can use profiles sketched in the Sketcher or planar geometrical elements created in the Generative Shape 

Design workbench (except for lines).

●     You can also select diverse elements constituting a sketch. For more information, refer to Using the Sub-Elements 
of a Sketch. 

●     If you launch the Pad command with no profile previously defined, just click the  icon available in the dialog 
box. You then just need to select a sketch plane to enter the Sketcher and then create the desired profile.

As soon as you click the  icon, the Running Commands window displays to show you the history of 
commands you have run. This informative window is particularly useful when many commands have 
already been used, in complex scenarios for example.

You can select Generative Shape Design surfaces, non-planar faces and even CATIA V4 surfaces. For more 
information, refer to Creating Pads or Pockets from Surfaces.

●     By default, if you extrude a profile, the application extrudes normal to the plane used to create the profile. To see 
how to change the extrusion direction, refer to Creating Pads not Normal to Sketch Plane.

●     If you extrude a surface (for example created in the Generative Shape Design workbench), you need to select an 
element defining the direction because there is no default direction.

2.  Click the Pad icon .

The Pad Definition dialog box appears and the application previews the pad to be created.
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●     If you are not satisfied with the profile you selected, note that you can:

●     click the Selection field and select another sketch.

●     use any of these creation contextual commands available from the Selection field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract: generates separate elements from non-connex sub-elements. See Extracting 
Geometry.

 If you have chosen to work in a hybrid design environment, the geometrical elements created on the fly via the 
contextual commands mentioned above are aggregated into sketch-based features.
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  Limits

You will notice that by default, the application specifies the length of your pad (Type= Dimension option). But 
you can use the following options too: 

●     Up to Next  

●     Up to Last

●     Up to Plane

●     Up to Surface

 

 

●     If you set the Up to Plane or Up to Surface option, contextual commands creating new planes or surfaces 
you may need are then available from the Limit field:

❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limit.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limit.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limit.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries. See Extrapolating Surfaces.

If you create any of these elements, the application then displays the corresponding icon in front of the field. 
Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the contextual 
commands mentioned above are aggregated into sketch-based features.

 
3.  Enter 40 in the Length field to increase the length value.

  You can increase or decrease length values by dragging LIM1 or LIM2 manipulators.

The length value cannot exceed 1 000 000 mm.



 
Clicking the icon  opens the Sketcher. You can then edit the profile. Once you have done your modifications, 
you just need to quit the Sketcher. The Pad dialog box then reappears to let you finish your design. 

●     The Thick option adds thickness to both sides of your profile. To know how to use it, refer to Creating Thin 
Solids.

  
●     The Reverse side button applies for open profiles only. This option lets you choose which side of the profile is 

to be extruded. When designing thin solids, the option is meaningless.

 
4.  Click the Mirrored extent option to extrude the profile in the opposite direction using the same length value. 

If you wish to define another length for this direction, you do not have to click the Mirrored extent button. 

Just click the More button and define the second limit.  

5.  Click Preview to see the result.

6.  Click OK. 

The pad is created. The specification tree indicates that it has been created.



A Few Notes About Pads 
●     The application allows you to create pads from open profiles provided existing geometry can trim the pads. The pad 

below has been created from an open profile which both endpoints were stretched onto the inner vertical faces of the 
hexagon. The option used for Limit 1 is Up to next. The inner bottom face of the hexagon then stops the extrusion. 
Conversely, the Up to next option could not be used for Limit2.

Preview Result

●     Pads can also be created from sketches including several profiles. These profiles must not intersect. In the following 
example, the sketch to be extruded is defined by a square and a circle. Applying the Pad command on this sketch lets 
you obtain a cavity:

Preview Result

●     Before clicking the Pad command, ensure that the profile to be used is not tangent with itself.



Using the Sub-Elements of a Sketch 
 

 

This task shows you how to select different elements belonging to the same sketch for creating pads.

The steps described here also apply for pockets, shafts, grooves, stiffeners, ribs and slots.

 

Sketch three rectangles in a Sketcher session.

 1.  Click the Pad icon .

The Pad Definition dialog box is displayed.

2.  Click the Selection field from the dialog box.

3.  Right-click and select Go to Profile Definition. 

The Profile Definition dialog box is displayed.

4.  You can define whether you need the Whole geometry, that is the whole sketch, or Sub-elements only. 

For the purposes of our scenario, check Sub-elements if not already done.

5.  Select an edge.

The sketch name as well as the edge name appear in the dialog box. The application also previews the 



pad.

6.  Click Add to add another element.

7.  Select an edge belonging to another profile. 

The application now previews this pad too.

8.  Repeat steps 6 and 7 using an edge belonging to the third profile.

9.  Select edge2 from the starting elements field and click Remove to remove the associated profile from the 

selection.

10.  Click OK to validate your selection. 

The Pad Definition dialog box reopens. You then just have to enter the parameters of your choice to 

extrude two profiles.

11.  Optionally click Preview before confirming the creation.

 If you encounter complex profiles causing ambiguity cases, the application lets you determine which lines you 
want to use as illustrated below:

The application detects an ambiguity as shown by the red 
symbol : the user can determine three different lines 
from this point.

The user has defined the line he needs to end the 
selection.



Creating 'Up to Next' Pads

This task shows you how to create a pad using the Up to Next option. This creation mode lets the 
application detect the existing material to be used for trimming the pad.

Open the Pad2.CATPart document.

 
1.  Select the circle as the profile to be extruded.

2.  Click the Pad icon .

The Pad Definition dialog box appears and the application previews a pad with a default 

dimension value.

3.  Click the arrow in the geometry area to reverse the extrusion direction (or click the Reverse 

Direction button).

4.  In the Type field, set the option to Up to next.

This option assumes an existing face can be used to trim the pad. The application previews the 

pad to be created. The already existing body trims the extrusion.

Optionally, click Preview to see the result.
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5.  Click OK. 

The pad is created. The specification tree indicates this creation.

 

By default, the application extrudes normal to the plane used to create the profile. To learn how to 
change the direction, refer to Creating Pads not Normal to Sketch Plane .



Creating 'Up to Last' Pads

This task shows how to create pads using the Up to last option.

Open the Pad3.CATPart document.

 
1.  Select the circle as the profile to be extruded.

2.  Click the Pad icon .

The Pad Definition dialog box appears and the application previews a pad with 10 mm as the 

default dimension value.

3.  Click the arrow in the geometry area to reverse the extrusion direction (or click the Reverse 

Direction button).

4.  In the Type field, set the option to Up to last.

The last face encountered by the extrusion trims the pad.

Optionally, click Preview to see the result.
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5.  Click OK. 

The pad is created. The specification tree indicates this creation.

 

By default, the application extrudes normal to the plane used to create the profile. To see how to 
change the direction, refer to Creating Pads not Normal to Sketch Plane .



Creating 'Up to Plane' Pads

 

This task shows how to create pads using the Up to plane option.

Open the Pad4.CATPart document.

 
1.  Select the profile to be extruded.

2.  Click the Pad icon .

The Pad Definition dialog box appears and the application previews a pad with 10 mm as the 

default dimension value.

3.  In the Type field, set the Type option to Up to plane.

4.  Select Plane.1. 

The application previews the pad to be created. The plane trims the extrusion. An Offset option 

is now available.

Contextual commands creating the planes you need are available from the Limit field:
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❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the 
trimming element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the 
trimming element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the 
trimming element.

If you create any of these elements, the application then displays the plane icon in front of the 

Limit field. Clicking this icon enables you to edit the element.

5.  Enter -20 as the offset value. This offset is the distance between the plane and the top face of 

the pad to be created.

Optionally click Preview to see the result. 

6.  Click OK.

The pad is created. The specification tree indicates this creation.

 

By default, the application extrudes normal to the plane used to create the profile. To see how to change 
the direction, refer to Pad not Normal to Sketch Plane .



Creating 'Up to Surface' Pads

This task shows you how to create pads using the Up to surface option.

Open the Pad5.CATPart document.

 
1.   Select the profile to be extruded.

2.  Click the Pad icon . 

The Pad Definition dialog box appears and the application previews a pad with a default dimension value.

3.  In the Type field, set the Type option to Up to surface. 

4.  Select the vertical circular face. This face belongs to the same body as the existing pad.

Using the Up to surface option, you can select a face belonging to the same body as the sketch or a face 

belonging to Part Body.

The face trims the extrusion.

Contextual Commands

Contextual Commands

Contextual commands creating the surfaces you need are available from the Limit field:

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

If you create any of these elements, the application then displays the join or the extrapol icon in front of 

the Limit field. Clicking this icon enables you to edit the element.
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5.  An Offset option is available in the dialog box. Enter -30 as the offset value. This offset is the distance 

between the surface and the top face of the pad to be created.

Optionally click Preview to see the result.

6.  Click OK.

The pad is created. The specification tree indicates this creation.

 

●     By default, the application extrudes normal to the plane used to create the profile. To see how to change the 
direction, refer to Pad not Normal to Sketch Plane .

●     You cannot use the same surface to trim both limits of a pad, even if you define an offset value for one of the 
limits.



Creating Pads or Pockets from Surfaces

This task explains how to extrude surfaces in any direction. The scenario below shows you how to create 
a pad, but the method and options described are also valid for creating pockets.

Open the ThickSurface.CATPart document.

 
1.  Select Extrude.1 as the surface to be extruded.

The different surfaces you can select are: 

❍     surfaces created in the Generative Shape Design workbench

❍     CATIA Version 4 surfaces

❍     non-planar faces.

2.  Click the Pad icon .

The Pad Definition dialog box appears. You need to define an extrusion direction. To do so, 

either you select a geometric element or set the Up to Plane limit and select the plane of your 

choice. In that case, the direction will be given by the normal to that plane (for more, see 

pockets). 

3.  Click the Reference field and select Plane.1 as the plane defining the extrusion direction. 

The direction is the normal to the plane.
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Make sure that the surface to be extruded is not tangent to the extrusion direction nor to the plane.

For both limits to be defined, you can use all the options described in the tasks showing the pad 

creation: 

●     Dimension

●     Up to Next  

●     Up to Last

●     Up to Plane

●     Up to Surface

4.  Enter 21mm and 11mm as the first and second limit values respectively.

5.  Click OK to confirm. 

The new element identified as Pad.XXX is added to the specification tree.



Non-planar faces 

If you create a pad or a pocket from a non-planar face, that face is displayed as a datum in the 
specification tree.

 
Pockets 

In the following example, two different types of limits are defined for trimming the material extruded 
then removed from each side of the surface.

 
Initial part 

  

Preview

The option used to define the first limit LIM 1 is Up 
to plane (the white arrow points to the selected 
plane). The extrusion direction is then defined by this 
plane.

LIM2 is defined by a dimension type limit.

 



 Result

Material has been removed from each side of the 
surface.

 

 

The options for creating thin solids are not available when you select a surface as the element to be 
extruded.

 



Creating Pads not Normal to Sketch Planes

 

This task shows how to create a pad using a direction that is not normal to the plane used to create the 
profile.

Open the Pad6.CATPart document.

 
1.  Select the profile you wish to extrude.

2.  Click the Pad icon .

The Pad Definition dialog box appears and the application previews the pad to be created.

3.  Set the Up to plane option and select plane yz. For more about this type of creation, refer to 

Creating Up to Plane Pads.

4.  Click the More button to display the whole dialog box. 

5.  Uncheck the Normal to profile option and select the line as shown to use it as a reference. 
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The application previews the pad with the new creation direction.

Contextual commands creating the directions you need are available from the Reference field:



❍     Create Line: for more information, see Creating Lines

❍     Create Plane: see Creating Planes

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the line or the plane icon in 

front of the Reference. Clicking this icon enables you to edit the element.

When copying and pasting a pad using the As specified in Part document option (for more, see 
Handling Parts in a Multi-Document Environment,  note that if the extrusion direction used does not 
belong to the same body as the pad, this direction is not taken into account by the Copy and Paste 
commands.

6.  Click OK to confirm the creation.

The pad is created. The specification tree indicates this creation.



Creating Multi-Pads 

 

This task shows you how to extrude multiple profiles belonging to a same sketch using different length values. 
The multi-pad capability lets you do this at one time. At the end of the task you will see how to edit the 
resulting feature. 

●     Creating a Multi-Pad

●     Editing a Multi-Pad

❍     Adding an Extrusion Domain

❍     Deleting an Extrusion Domain

 
Open the Pad1.CATPart  document.

Creating a Multi-Pad
 

1.  Click the Multi-Pad icon   .

2.  Select Sketch.2 that contains the profiles to be extruded. Note that all profiles must be closed and 

must not intersect. In case a profile would be open, the application would not take it into account.

The Multi-Pad Definition dialog box appears and the profiles are highlighted in green. For each of 

them, you can drag associated manipulators to define the extrusion value.

The red arrow normal to the sketch indicates the proposed extrusion direction. To reverse it, you just 

need to click it. 

The Multi- Pad Definition dialog box displays the number of domains to be extruded. In our example, 

the application has detected seven extrusions to perform, as indicated in the Domains section.
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3.  Select Extrusion domain.1 from the dialog box.

Extrusion domain.1 now appears in blue in the geometry area.

4.  Specify the length by entering a value. For example, enter 10mm.

5.  You need to repeat the operation for each extrusion domain by entering the value of your choice. For 

example, select Extrusion domain.2 and Extrusion domain.7 and enter 30mm and 40mm 

respectively. 

For complex sketches, the Preview button proves to be quite useful.

6.  Note that you can multi-select extrusion domains from the list before defining a common length: multi-

select Extrusion domain.3, Extrusion domain.4, Extrusion domain.5 and Extrusion domain.6, 

then enter 50 as the common length value.



One length value is now defined for each profile of Sketch.2.

7.  Click the More button to expand the dialog box.

8.  In the Second Limit field, you can specify a length value for the opposite direction. For example, select 

Extrusion domain.1 and enter 40mm in the Length field. 

Note that the Thickness section displays the sum of the two lengths. Extrusion domain.1 's total 

length is 50 mm.

Unchecking the Normal to sketch option lets you specify a new extrusion direction. Just select the 

geometry of your choice to use it as a reference.

9.  Click OK to create the multi-pad.

The multi-pad (identified as Multi-Pad.xxx) is added to the specification tree.



 

Editing a Multi-Pad

The rest of the scenario shows you what happens when :

●     Adding an Extrusion Domain

●     Deleting an Extrusion Domain

Adding an Extrusion Domain

Example 1: the new profile is sketched outside existing extrusion domains

 

10.  Double-click Sketch.2 to edit it: for example, 

sketch a closed profile outside Extrusion 

domain.1.



 

11.  Quit the Sketcher. A warning message informs you that the application has detected that the initial 

geometry has been modified. Close the window.

12.  Double-click MultiPad.1 . The Feature Definition Error window displays, providing the details of the 

modification.

13.  Click OK to close the window. The Multi-Pocket Definition dialog box reappears.

The new extrusion domain Extrusion domain.8 is indicated.

14.  Select it and define the value of your choice.

15.  Click OK to confirm. Multi-pad.1 is now composed of eight pads.



 Example 2: the new profile is sketched inside an existing extrusion domain

15.  Double-click sketch.2 and for example, add a 

closed profile inside Extrusion domain.2.

16.  Quit the Sketcher. A warning message informs you that the application has detected that the initial 

sketch has been modified. Close this window.

17.  Double-click MultiPad.1. The Feature Definition Error window displays, providing the details of the 

modification.

When sketching a profile inside an existing extrusion domain, the application  deletes that existing 

domain and replaces it with a new one. This is why the message window displays : 

❍     1 extrusion domain deleted (Extrusion domain.2)

❍     2 extrusion domains created (Extrusion domain.9, which replaces Extrusion domain.2 and 
Extrusion domain.10)

18.  Click OK to close the window. 

The Multi-Pad Definition dialog box reappears. Extrusion domain.2 is no more displayed. On the 

contrary, two new extrusion domains Extrusion domain.9 and Extrusion domain.10 are indicated 

with 0mm as their default thickness.



19.  Select Extrusion domain.9 if not already done and define 30mm as the length value.

20.  Select Extrusion domain.10, that is the circle, and define 60mm as the length value.

21.  Click OK to confirm. 

Multi-pad.1 is now composed of nine pads.



23.  Quit the Sketcher: the application has detected that the initial sketch has been modified:

24.  To tackle the problem, you can: 

❍     edit or delete MultiPad.1. 

❍     or you can edit or delete Extrusion domain.6

Make sure that MultiPad.1 is selected and click the Edit button. The Feature Definition Error 

window displays, providing the details of the modification.

Deleting an Extrusion Domain

22.  Double-click Sketch.2 and for example, delete 

Extrusion Domain.6.



25.  Click OK to close the window. 

The Multi-Pad Definition dialog box reappears. Only eight extrusion domains are indicated in the 

Domains category.

26.  Click OK to confirm.

The new multi-pad feature is composed of eight pads.



Creating Drafted Filleted Pads

 

This task shows you how to create a pad while drafting its faces and filleting its edges.  

We recommend you the use of this command to speed up your design.

Open the Hole1.CATPart document and sketch a profile similar to the one below.

 
1.  Quit the Sketcher and select the profile to be extruded. 

2.  Click the Drafted Filleted Pad icon  .

The Drafted Filleted Pad Definition dialog box appears and the application previews the pad to be created.

3.  Enter 30 as the length value.

4.  Selecting a second limit is mandatory. Select Pad1 top face as the second limit. 
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Note that planes can define second limits too.

5.  Let's go on with the draft definition. Enter 7 as the draft angle value.

Drafting faces is optional. If you do not wish to use this capability, just uncheck the Angle option. 

6.  Check the Second limit option to define the neutral element. So, Pad1 top face is also used as the neutral element.

7.  Enter a radius value for each edge type to define the three fillets.

❍     Lateral radius: defines the fillets on vertical edges

❍     First limit radius: defines the round corner fillets

❍     Second limit radius: defines the filets on the edges of the second limit.

Filleting edges is optional too. If you do not wish to use this capability, just uncheck the options.

Clicking Preview previews the pad, the draft and the fillets and display them in the specification tree. If you have 

deactivated the draft or fillet options, the draft or the fillets are then displayed as deactivated features in the tree, i.e. 

with red parentheses.

8.  Click OK to create the features.

If you look at the specification tree, you will note that you have created:

❍     one pad

❍     one draft

❍     three fillets

This means that for edition purposes, you need to double-click the appropriate feature. This is your new part:



Creating Pockets

 

Creating a pocket consists in extruding a profile or a surface and removing the material resulting from 
the extrusion. The application lets you choose the limits of creation as well as the direction of extrusion. 
The limits you can use are the same as those available for creating pads. To know how to use them, see 
Creating Up to Next Pads, Creating Up to Last Pads, Creating Up to Plane Pads, Creating Up to Surface 
Pads. 

This task first shows you how to create a pocket, that is a cavity, in an already existing part, then you 
will edit this pocket to remove the material surrounding the initial profile.

Open the Pocket1.CATPart document.

 
1.  Select the profile to extrude, that is Sketch.2.

 
About Profiles 

●     You can use profiles sketched in the Sketcher workbench or planar geometrical elements created in 
the Generative Shape Design workbench (except for lines).

●     You can create pockets from sketches including several closed profiles. These profiles must not 
intersect. 

●     You can select diverse elements constituting a sketch too. For more information, refer to Using the 
Sub-Elements of a Sketch. 

●     Instead of selecting profiles, you can select surfaces created in the Generative Shape Design 
workbench, non-planar faces and even CATIA V4. To know how to create a pocket from a surface, 
refer to Creating Pads or Pockets from Surfaces.
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2.  Click the Pocket icon . 

The Pocket Definition dialog box is displayed and the application previews a pocket.

●     If you launch the Pocket command with no profile previously defined, just click the icon  to 
access the Sketcher and sketch the profile you need.

 
●     If you are not satisfied with the profile you selected, note that you can:

❍     click the Selection field and select another sketch.

❍     use any of these creation contextual commands available from the Selection field:
■     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the 

profile you need as explained in the Sketcher User's Guide.

■     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

■     Create Extract:  generates separate elements from non-connex sub-elements.  See 
Extracting Geometry.

If you create any of these elements, the application then displays the corresponding icon in front of 
the field. Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the geometrical elements created on the fly 
via the contextual commands mentioned above are aggregated into sketch-based features.
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 You can define a specific depth for your pocket or set one of these options: 
●     up to next

●     up to last

●     up to plane

●     up to surface

If you wish to use the Up to plane or Up to surface option, you can then define an offset between the 
limit plane (or surface) and the bottom of the pocket. For more information, refer to Up to Surface Pad.

 
3.  To define a specific depth, set the Type parameter to Dimension, and enter 30mm.

Alternatively, select LIM1 manipulator and drag it downwards to 30.

Clicking the icon  opens the Sketcher. You can then edit the profile to modify your pocket. Once you 
have done your modifications, you just need to quit the Sketcher. The Pocket dialog box reappears to 
let you finish your design.

 

About Directions

By default, if you extrude a profile, the application extrudes normal to the plane used to create the 
profile. To specify another direction, click the More button to display the whole Pocket Definition dialog 
box, uncheck the Normal to profile option and select a new creation direction in the geometry.

●     When copying and pasting a pocket using the As specified in Part document option (for more, see 
Handling Parts in a Multi-Document Environment), note that if the extrusion direction used does not 
belong to the same body as the pocket, this direction is not taken into account by the Copy and 
Paste commands.

●     If you extrude a surface (for example  created in the Generative Shape Design workbench), you need 
to select an element defining the direction because there is no default direction.

Limits



If you set the Up to Plane or Up to Surface option, contextual commands creating new planes or 
surfaces you may need are then available from the Limit field:

●     Create Plane: see Creating Planes

●     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limit.

●     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limit.

●     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limit.

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

●     Create Extrapol: extrapolates surface boundaries. See Extrapolating Surfaces.

If you create any of these elements, the 
application then displays the 
corresponding icon in front of the 
Reference field.

Clicking this icon enables you to edit the 
element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the 
contextual commands mentioned above are aggregated into sketch-based features.

To know how to use the Thick option, refer to Creating Thin Solids.

4.  Optionally click Preview to see the result. Click OK to create the pocket.

The specification tree indicates this creation. This is your pocket:

5.  Double-click Pocket.1 to edit it. As the application lets you choose the portion of material to be 

kept, you are going to remove all the material surrounding the initial profile. 

The Reverse side option lets you choose between removing the material defined within the 

profile, which is the application's default behavior, or the material surrounding the profile. 



6.  Click the Reverse side button or alternatively click the arrow as shown:

The arrow now indicates the opposite direction.

7.  Click OK to confirm.

The application has removed the material around the profile.

A Few Notes About Pockets 
●     The application allows you to create pockets from open profiles provided existing geometry can trim the 

pockets. 

●     If your insert a new body and create a pocket as the first feature of this body, the application creates 
material:



●     Pockets can also be created from sketches including several profiles. These profiles must not intersect. In 
the following example, the initial sketch is made of eight profiles. Applying the Pocket command on this 
sketch lets you create eight pockets:

●     The Up to next limit is the first face the application detects while extruding the profile. This face must 
stops the whole extrusion, not only a portion of it, and the hole goes thru material, as shown in the figure 
below:



  

Preview Result

●     When using the Up to Surface option, remember that if the selected surface partly stops the extrusion, 
the application continues to extrude the profile until it meets a surface that can fully stop the operation.



Creating Multi-Pockets 

 

This task shows you how to create a pocket feature from distinct profiles belonging to a same sketch and this, 
using different length values. The multi-pocket capability lets you do this at one time. At the end of the task, 
you will see how to edit the resulting multi- pocket.

●     Creating a Multi-Pocket

●     Editing a Multi-Pocket

❍     Adding an Extrusion Domain

❍     Deleting an Extrusion Domain

 
Open the Pocket1.CATPart document and make Bodi.1 as the current feature.

Creating a Multi-Pocket
 

1.  Click the Multi-Pocket icon .

2.  Select Sketch.4 that contains the profiles to be extruded. Note that all profiles must be closed and 

must not intersect. In case a profile would be open, the application would not take it into account.

The Multi-Pocket Definition dialog box appears and the profiles are highlighted in green. For each of 

them, you can drag associated manipulators to define the extrusion value.

The red arrow normal to the sketch indicates the proposed extrusion direction. To reverse it, you just 

need to click it. 

The Multi-Pocket Definition dialog box displays the number of domains to be removed. In our 

example, the application has detected six domains, as indicated in the Domains section.
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3.  Select Extrusion domain.1 from the dialog box. 

Extrusion domain.1 now appears in blue in the geometry area.

4.  Specify the length by entering a value. For example, enter 10mm.

5.  You need to repeat the operation for each extrusion domain by entering the value of your choice. For 

example, select Extrusion domain.2 and Extrusion domain.6 and enter 30mm and 40mm 

respectively.

For complex sketches, the Preview button proves to be quite useful.

6.  Note that you can multi-select extrusion domains 

from the list before defining a common length: 

multi-select Extrusion domain.3, Extrusion 

domain.4, and Extrusion domain.5, then enter 

50 as the common length value.



7.  Click More to expand the dialog box.

In the Second Limit field, you can specify a length value for the direction opposite to the direction 

previously defined. 

Note that the Thickness section displays the sum of two lengths defined for a given extrusion domain.

Unchecking the Normal to sketch option lets you specify a new extrusion direction. Just select the 

geometry of your choice to use it as a reference.

8.  Click OK to create the multi-pocket.

The multi-pocket (identified as Multi-Pocket.xxx)  is added to the specification tree.



Editing the Multi-Pocket

The rest of the scenario shows you what happens when :

●     Adding an Extrusion Domain

●     Deleting an Extrusion Domain

 
Adding an Extrusion Domain

Example 1: the new profile is sketched outside existing extrusion domains

9.  Double-click Sketch.4 to edit it: for example, 

sketch a closed profile outside Extrusion 

domain.1.



10.  Quit the Sketcher. A warning message informs you that the application has detected that the initial 

geometry has been modified. Click Close to close the window.

11.  Double-click MultiPocket.1. The Feature Definition Error window displays, providing the details of 

the modification.

12.  Click OK to close the window.

The Multi-Pocket Definition dialog box reappears.

The new extrusion domain Extrusion domain.7 is indicated. 

13.  Select it and define the value of your choice. 

14.  Click OK to confirm.

Multi-pocket.1 is now composed of seven pockets.



 Example 2: the new profile is sketched inside an existing extrusion domain

 

15.  Double-click Sketch.4 to edit it: for example, add 

a closed profile inside Extrusion domain.2.

16.  Quit the Sketcher. A warning message informs you 

that the application has detected that the initial 

geometry has been modified. Close the window.

17.  Double-click MultiPocket.1. The Feature Definition Error window displays, providing the details of 

the modification:

When sketching a profile inside an existing extrusion domain, the application  deletes that existing 

domain and replaces it with a new one. This is why the message window displays:



 

❍     1 extrusion domain deleted (Extrusion domain.2)

❍     2 extrusion domains created (Extrusion domain.8 and Extrusion domain.9, that replaces 
Extrusion domain.2)

18.  Click OK to close the window. 

The Multi-Pocket Definition dialog box reappears. Extrusion domain.2 is no more displayed. On the 

contrary, two new extrusion domains Extrusion domain.8m Extrusion domain.9 are indicated with 

0mm as their default thickness.

19.  Select Extrusion domain.8 and define 40mm as the length value.

20.  Select Extrusion domain.9, that is the rectangle, and define 30mm as the length value. 

21.  Click OK to confirm.

Multi-pocket.1 is now composed of eight pockets. 



 
Deleting an Extrusion Domain

 
21.  Double-click Sketch.4 and delete Extrusion 

Domain.5.

22.  Quit the Sketcher.

The application has detected that the initial geometry has been modified:

23.  To tackle the problem, you can: 

❍     edit, deactivate or even delete MultiPocket1. 

❍     or you can edit or delete Extrusion domain.5

Make sure that MultiPocket.1 is selected and click the Edit button. The Feature Definition Error 

window displays, providing the details of the modification.



 

24.  Click OK to close the window. 

The Multi-Pocket Definition dialog box reappears. Only seven extrusion domains are indicated in the 

Domains category.

25.  Click OK to confirm. 

The new multi-pocket feature is composed of seven pockets.



Creating Drafted Filleted Pockets

 

This task shows you how to create a pocket while drafting its faces and filleting its edges.  

We recommend you the use of this command to speed up your design.

Open the Pocket1.CATPart document.

 
1.  Select the profile to be extruded, that is Sketch.2. 

2.  Click the Drafted Filleted Pocket icon .

The Drafted Filleted Pocket Definition dialog box appears and the application previews the 

pocket to be created.
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3.  Enter 22 as the pocket depth value.

4.  Selecting a second limit is mandatory. Select Pad1 top face as the second limit.

Your specifications for creating the pocket are now defined.

5.  Let's go on with the draft definition. Enter 7 as the draft angle value. 

Drafting faces is optional. If you do not wish to use this capability, just uncheck the Angle 

option.

6.  Check the Second limit option to define the neutral element. So, note that the pad top face is 

also used as the neutral element.

7.  Enter 4 as the radius value to define the three fillets.

❍     Lateral radius: defines the fillets on vertical edges

❍     First limit radius: defines the round corner fillets

❍     Second limit radius: defines the filets on the edges of the second limit.

Filleting edges is optional too. If you do not wish to use this capability, just uncheck the options.

8.  Click Preview to check if the application can compute the fillets properly.



Clicking Preview previews the pocket, the draft and the fillets and display them in the 

specification tree. If you have deactivated the draft or fillet options, the draft or the fillets are 

then displayed as deactivated features in the tree, i.e. with red parentheses. 

In the specification tree red parentheses appear on EdgeFillet.1, meaning that it cannot be 

computed by the application. Looking more closely at this fillet you can see that due to the shape 

of the initial sketch, it is effectively impossible to compute that fillet.

Note that there is a priority in the order of appearance of the fillets (from top to bottom) in the 

specification tree. The first fillet corresponds to the Lateral radius option in the dialog box, the 

second fillet to the First limit radius option and the last fillet to the Second limit radius 

option.

9.  Click OK to create the features. 

If you look at the specification tree, you will note that you have created:

❍     one pocket

❍     one draft

❍     two fillets

This implies that if you want to edit the drafted filleted pocket, you need to double-click the 

appropriate feature. This is your new part:





Creating Thin Solids 

 

When creating pads, pockets and stiffeners, you can add thickness to both sides of their profiles. The 
resulting features are then called "thin solids".

This task shows you how to add thickness to a pad. The method described here is also valid for pockets. To 
know how to obtain a thin solid from a stiffener, refer to the task Stiffener.

You can create thin solids using the Shaft and Groove capabilities.

 

Open the GettingStarted.CATPart document and quit the Sketcher.

 1.  Click the Pad icon .

2.  Select Sketch.1 if not already done.

3.  Check the Thick option. 

This opens the whole Pad Definition dialog box. You can now define your thin pad using the options 

available in the Thin Pad frame.

The options for creating thin solids are not available when you select a surface as the element to be 
extruded. For more information, refer to Creating Pads or Pockets from Surfaces.

4.  Enter 18mm as Thickness1 's value, and click 

Preview to see the result. A thickness has 

been added to the profile as it is extruded. The 

profile is previewed in dotted line.
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5.  Enter 10mm as Thickness2 's value, and click 

Preview to see the result. Material has been 

added to the other side of the profile.

6.  To add material equally to both sides of the 

profile, check Neutral fiber and click Preview 

to see the result.

The thickness you defined for Thickness 1 is 

evenly distributed: a thickness of 9mm has 

been added to each side of the profile.

 

 

This capability can be applied to several profiles contained in the same sketch.

 
Thin Pad options let you extrude profiles from networks 

Using the Thin Pad options you can extrude profiles from networks.



Thickness 1 and Thickness 2 are defined.
Checking the Merge Ends option trims extrusions to 
existing material. 

Keep in mind that the creation order of the different 
elements constituting the profile never affects the 
resulting extrusion.

 
If you decide to use the options Up to Plane or Up to Surface, the Merge ends capability is not available.

 

How Extrusions are Trimmed 

In the following example, the network goes beyond the edges of the part.

Initial profile is made of two intersecting lines The application trims extrusions to the faces of the 
pocket

 



Creating Shafts

This task illustrates how to create a shaft, that is a revolved feature, by using an open profile.

Open the Revolution.CATPart document and make sure that PartBody is set as current.

1.  Select Sketch.2 as the open profile to be extruded.

An open profile (not even closed by the revolution axis) cannot be be used as the first feature in a 

body.

About Profiles 
●     You can create shafts from sketches including several closed profiles. These profiles must not 

intersect and they must be on the same side of the axis. 

●     Moreover, you can define whether you need the whole sketch, or sub-elements only. For more 
information, refer to Using the Sub-elements of a Sketch.

●     You can use open profiles in geometrical sets provided you create a thin solid. 

●     If needed, you can change the sketch by clicking the field and by selecting another sketch in the 
geometry or in the specification tree.

●     You can also use any of these creation contextual commands available from the Selection field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract: generates separate elements from non-connex sub-elements.  See Extracting 
Geometry.
If you create any of these elements, the application then displays the corresponding icon in front 
of the field. Clicking this icon enables you to edit the element.

●     If you have chosen to work in a hybrid design environment, the geometrical elements created on the 
fly via the contextual commands mentioned above are aggregated into sketch-based features.

●     But you can also edit your sketch by clicking the icon  that opens the Sketcher. Once you have 
done your modifications, the Shaft Definition dialog box reappears to let you finish your design.

●     If you launch the Shaft command with no profile previously defined, just click the icon  and 
select a plane to access the Sketcher, then sketch the profile you need.

●     You can use wireframe geometry as your profile and axes created with the Axis System capability.

About Axes

●     When the selected sketch both contains a profile and an axis, the latter is selected by default as the 
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revolution axis. This is the case in our scenario.

 
●     From V5R15 onwards, you can select an axis belonging to a plane distinct from the profile plane. Just 

make sure that the axis does not intersect the profile.

 
●     Contextual commands creating the directions you need are available from the Selection field:

❍     Create Line: see Creating Lines

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the axis.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the axis.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the axis.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Selection. Clicking this icon enables you to edit the element.

 

2.  Click the Shaft icon .

A message is issued warning you that the application cannot trim the feature and that you need 

to change the specifications.

3.  Click OK to close the warning message and display the Shaft Definition dialog box.

The application displays the name of the selected sketch in the Selection field from the Profile 

frame. In our scenario, the profile and the axis belong to the same sketch. Consequently, you do 

not have to select the axis.



Reverse Side

The Reverse Side button lets you choose between creating material between the axis and the 

profile or between the profile and existing material. You can apply this option to open or closed 

profiles.

4.  In our scenario, as our open profile cannot be trimmed if we use the default direction, that is in 

the direction of the axis, click the Reverse Side button or alternatively click the arrow pointing to 

360 degrees so as to obtain this preview:

The extrusion will be done in the direction opposite to the axis and it will be trimmed to existing 

material.

There are three ways of reversing the revolution direction:



❍     clicking the Reverse Direction button, or 

❍     using the Reverse direction contextual command available on the arrow or 

❍     just clicking the arrow. 

The application  previews limits LIM1 that corresponds to the first angle value, and LIM2 that 

corresponds to the second angle value. The first angle value is by default 360 degrees.

 
5.  Enter the values of your choice in the First angle and Second angle fields. 

Make sure that the sum of the two angles is less than 360 degrees.

Alternatively, select the LIM1 or LIM2 manipulator and drag them onto the value of your choice.

6.  Click OK to confirm.

The shaft is created. The specification tree 

mentions it has been created.

You can create shafts by selecting a surface as illustrated 
in this example:



Thin Solids 

You can add thickness to both sides of the profile used to create the shaft. 

In the example below, the shaft is created using the Thick Profile option. Checking this option opens the 
whole Shaft Definition dialog box, which lets you then define Thickness 1 and Thickness 2. To 
perform the scenario, use Sketch.6.

 

 Initial profile Resulting shaft

The profile is previewed in dotted line. 
Thickness has been added to both sides of 
the profile.

 
Additional Options 

●     The Neutral Fiber option adds material equally to both sides of the profile. The thickness defined for 
Thickness 1 is evenly distributed to each side of the profile.

●     The Merge Ends option attaches the profile endpoints to adjacent geometry (axis or if possible to 
existing material) as illustrated below:



 

 Initial profile Resulting shaft

The profile has been attached to the axis.

 

Restrictions
●     Using the Thick Profile option, you can create shafts from open profiles but you cannot use the 

Merge End option.

●     The Thin Shaft capability does not allow you to extrude networks.



Creating Grooves

 

Grooves are revolved features that remove material from existing features. This task shows you how to 
create a groove, that is how to revolve a profile about an axis (or construction line).

Open the Revolution.CATPart document and set Body as the current body.

 1.  Click the Groove icon .

2.  Select Sketch.3 as the profile to be used.

The Groove Definition dialog box is displayed.

The application previews a groove entirely revolving about the axis.
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 The application displays the name of the selected sketch in the Selection field from the Profile frame.

About Axes 
●     the Selection field in the Axis frame is reserved for the axes you explicitly select. For the purposes 

of our scenario, the profile and the axis belong to the same sketch. Consequently,  you do not have 
to select the axis.

●     Contextual commands creating the directions you need are available from the Selection field:
❍     Create Line: see Creating Lines

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the axis.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the axis.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the axis.

If you create any of these elements, the application then displays the corresponding icon in front of the 
Selection. Clicking this icon enables you to edit the element.



 ●     You can create grooves from sketches including several closed profiles. These profiles must not 
intersect and they must be on the same side of the axis. 

●     You can define whether you need the whole sketch, or sub-elements only. For more information, 
refer to Using the Sub-elements of a Sketch.

●     If needed, you can change the sketch by clicking the Selection field and by selecting another sketch 
in the geometry or in the specification tree.

●     You can also use any of these creation contextual commands available from the Selection field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract:  generates separate elements from non-connex sub-elements. See Extracting 
Geometry.

If you create any of these elements, the application then displays the corresponding icon in front of the 
field. Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the geometrical elements created on the fly 
via the contextual commands mentioned above are aggregated into sketch-based features.

 

●     Clicking the icon  opens the Sketcher. You can then edit the profile. Once you have done your 
modifications, the Groove Definition dialog box reappears to let you finish your design. 

●     You can use wireframe geometry as your profile and axes created with the Axis System capability.

●     If you launch the Groove command with no profile previously defined, just click the icon  and 
select a plane to access the Sketcher, then sketch the profile you need.

●     An open profile (not even closed by the revolution axis) cannot be be used as the first feature in a 
body.

The application  previews the limits LIM1 and LIM2 of the groove to be created. 

You can select these limits and drag them onto the desired value or enter angle values in the appropriate 
fields. For our scenario, select LIM1 and drag it onto 100, then enter 60 in the Second angle field.

 
About Profiles 
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3.  Optionally click Preview to see the result. 

Just a portion of material is removed now.

 
 

4.  Click the Reverse Direction button to inverse the revolution direction, or use the Reverse 

direction contextual command available from the arrow. 

As an alternative, click the arrow to obtain the direction as shown:

5.  Click OK to confirm the operation.

The application removes material around the cylinder. The specification tree indicates the groove 

has been created. This is your groove:



6.  Double-click the groove to edit it. Now, you are going to remove the material surrounding the 

profile. 

7.  Click the Reverse Side button or alternatively click the arrow in the geometry.

The Reverse Side option lets you choose between creating material between the axis and the 

profile, which is the default direction, or between the profile and existing material. You can apply 

this option to open or closed profiles. 

8.  Enter 360 as the first angle value and 0 as the second angle value. The application previews the 

new groove.

9.  Click OK to confirm.

The material surrounding the profile has been removed.

You can create grooves by selecting a surface as 
illustrated in this example:



 Thin Solids 

You can add thickness to both sides of the profile to be used to create the groove.

In the example below, the groove is created using the Thick Profile option. Checking this option opens 
the whole Groove Definition dialog box, which lets you then define Thickness 1 and Thickness 2. To 
perform the scenario, use Sketch.8.

 

 Initial profile Resulting groove

The profile is previewed in dotted line. Thickness 
has been added to both sides of the profile.

The Merge Ends option is used: the application 
attaches the profile endpoints to adjacent geometry 
(axis or if possible to existing material).

 
Additional Options 

●     The Neutral Fiber option adds material equally to both sides of the profile. The thickness defined for 
Thickness 1 is evenly distributed to each side of the profile.



 Restrictions
●     The Thin Groove capability does not allow you to extrude networks.

●     Using the Thick Profile option, you can create grooves from open profiles but you cannot use the 
Merge End option.



Creating Holes 

Creating a hole consists in removing material from a body. Various shapes of standard holes can be created. 
These holes are:

Simple Tapered Counterbored 

Countersunk Counterdrilled 

In this section, you will find information about the main parameters you need for creating a hole:
●     Extensions

●     Tolerancing Dimensions

●     Hole Bottom

●     Directions

●     Threads

●     Hole Types

This task illustrates how to create a countersunk hole while constraining its location.

To create a hole in Part Design, just open the Hole1.CATPart document. Otherwise, to create a hole in 
the Functional Molded Part workbench, sketch a rectangle in the Sketcher workbench then return to the 
workbench and create a shellable prism.
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1.  Click the Hole icon  to create a hole in Part Design. 

or 

1.  Click the Hole icon  to create a hole in Functional Molded Part.

2.  Select the circular edge and upper face as shown.

The application can now define one distance constraint to position the hole to be created. The 

hole will be concentric to the circular edge. 

The Hole Definition dialog box appears and the application previews the hole to be created. The 

Sketcher grid is displayed to help you create the hole.

Clicking the icon  opens the Sketcher. You can then constrain the point defining the hole position. 
Once you have quit the Sketcher, the Hole Definition dialog box reappears to let you define the hole 
feature. For more about locating holes, refer to Locating Holes.

 

Extensions

For the Hole Bottom

Whatever hole you choose, you need to specify the bottom limit you want. There is a variety of limits:

Blind Up to Next Up to Last



 

Up to Plane Up to Surface

 

By default, the application previews a blind hole whose diameter is 10mm and depth 10mm. Keep the 
Blind option.

 

 
●     Contextual creation commands are available on the BOTTOM  text: 

❍     Blind

❍     Up to next

❍     Up to last

❍     Up to plane

❍     Up to surface

❍     Flat bottom

❍     V bottom

 

●     The Limit field is available if you set the Up to Plane or Up to Surface option.

●     If you wish to use the Up to Plane or Up to Surface option , you can then define an offset between 
the limit plane (or surface) and the bottom of the hole. For more information, refer to Up to Surface 
Pad in the Part Design User's Guide.

●     The Up to next  limit is the first face the application detects while extruding the profile, but this face 
must stops the whole extrusion, not only a portion of it, and the hole goes thru material.



 

 Preview Result

 

For the Hole Top

The hole top is trimmed in two ways depending on whether the hole is created in a positive body or not.

 

●     If you create a hole in a positive body, that is a body containing material, the application always 
trims the top of the hole using the Up to Next option. In other words, the next face encountered by 
the hole limits the hole. 
In this example, the hole encounters a fillet placed above the face initially selected. The application 
redefines the hole's top onto the fillet.



●     If you create a hole in a negative body, that is a body containing no material or a body with a 
negative feature as its first feature, the application always trims the top of the hole using the Up to 
Plane option and the plane used is the sketch plane.

3.  Now, define the hole you wish to create. Enter 24mm as the diameter value and 25mm as the 

depth value.

 

Tolerancing Dimensions

You can define a tolerancing dimension for the hole diameter just by clicking the icon  to the right 
of the Diameter field. This capability displays the Limit of Size Definition dialog box that enables you 
to choose one method among four for defining your tolerance:

●     Checking the General Tolerance option: sets a pre-defined tolerance class for angular sizes 
according to the standard selected for the session. By default, the general tolerance class is ISO 
2768 - f.

●     Checking the Numerical values option: uses the values you enter to define the Upper Limit and 
optionally, the value of the Lower Limit field if you unchecked the Symmetric Lower Limit option.

●     Checking the Tabulated values option: uses normative references. 

●     Checking the Single limit option: just enter a minimum or maximum value. The Delta/nominal 
option lets you enter a value in relation to the nominal diameter value. For example, if the nominal 
diameter value is 10 and if you enter 1, then the tolerance value will be 11.



 The Options frame displays options directly linked to the standard used in the application. To know or 
change that normative reference, select Tools > Options > Mechanical Design > Functional 
Tolerancing and Annotations, and in the Tolerancing tab enter the new standard in the Default 
Standard at creation option.
For more information, refer to the 3D Tolerancing and Annotations User's Guide.

After you set a tolerancing dimension, the icon turns red: . Toleranced holes are identified by a 
specific icon in the specification tree.

Note that this capability is not available for countersunk and tapered holes and that a 3D Functional 
Tolerancing and Annotation license is required to be able to access this capability.



Hole Bottom

To define the shape of the hole's end, you can choose between three options:

●     Flat:  the hole is flat. 

Even if the hole is of the 'up to surface' or 'up to plane'  type, and even if an offset value is set from 
the target trimming element, the flat shape is never trimmed. The resulting geometry is therefore fully 
compliant with mechanical specifications.

Before Release 13  From Release 13
 

●     V-Bottom: the hole is pointed. You just need to define how much it is pointed by specifying an angle 
value. 

Even if  the hole is of the 'up to surface' or 'up to plane'  type , and even if an offset value is set from 
the target trimming element, the V-bottom shape is never trimmed. The resulting geometry is therefore 
fully compliant with mechanical specifications.

●     Trimmed: this option can be used if the limit chosen for the hole is of the 'Up to Next, 'Up to Last', 
'Up to Plane' or 'Up to Surface'  type. The plane or surface used as the limit, trims the hole's bottom. 

Note that hole features created with application releases anterior to Release 13 inherit the Trimmed 
option when necessary. In that case, a warning message is issued by the application.

Example of a Counterbored Hole With a V-bottom Trimmed by a Surface (Section View)



 

 Example of a Counterbored Hole Trimmed by a Surface (Section View)

 

 
4.  Set the Bottom option to V-Bottom to create a pointed hole and enter 110 in the Angle field to 

define the bottom shape.



 

Directions

By default, the application creates the hole normal to the sketch face. But you can also define a creation 
direction not normal to the face by deselecting the Normal to surface option and selecting an edge or a 
line.

 
●     Contextual commands creating the directions you need are available from the Direction field:

❍     Create Line: for more information, see Creating Lines

❍     Create Plane: see Creating Planes

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the line or the plane icon in front of 
the Direction field. Clicking this icon enables you to edit the element.



 
Threads

You can also define a threaded hole  by clicking the Thread Definition tab and checking the Threaded 
button to access the parameters you need to define.

From V5R16 onward, it is possible to thread tapered holes.

 
Hole Types

5.  Click the Type tab to access the type of hole you wish to create.

If you choose to create a...

❍     Counterbored hole: the counterbore diameter must be greater than the hole diameter and 
the hole depth must be greater than the counterbore depth.

❍     Countersunk hole: the countersink diameter must be greater than the hole diameter and 
the countersink angle must be greater than 0 and less than 180 degrees.

❍     Counterdrilled hole: the counterdrill diameter must be greater than the hole diameter, the 
hole depth must be greater than the counter drill depth and the counterdrill angle must be 
greater than 0 and less than 180 degrees.

 
6.  You are going to create a countersunk hole. 

To create such a hole you need to choose 

two parameters among the following options:

❍     Depth & Angle

❍     Depth & Diameter

❍     Angle & Diameter

Set the Angle & Diameter parameters in 

the Mode field.

You will notice that the glyph assists you in 



defining the desired hole.  

 

7.  Enter 80 degrees in the Angle field. 

The preview lets you see the new angle.

8.  Enter 35 mm in the Diameter field.

The preview lets you see the new diameter. 

9.  Click OK.

The hole is created. The specification tree indicates this creation. You will notice that the sketch 

used to create the hole also appears under the hole's name. This sketch consists of the point at 

the center of the hole.

If working in the Functional Molded Part workbench, Hole.X is added to the specification tree in 

the FunctionalBody.X node. By default, as a protected feature, holes are in no show mode. To 

see the red protected area you have just created, set the Show mode.



Creating Holes on Non-planar Faces

 
When creating a hole on a non-planar face, the associativity is ensured so that if you modify the face, the hole's location is modified 
accordingly.  This task shows you how to create a hole on a non-planar face.

 

To perform this scenario in the Part Design workbench, create a pad with a non-planar face then a point on this face. To perform this 
scenario in the Functional Molded Part workbench, create a shellable prism with a non-planar face and then a point on this face.

 
1.  Multi-select the point to locate the hole and the non-planar face (or non-planar face if working in Functional Molded Part) on which 

you wish to create this hole.

This operation creates a coincidence constraint setting the hole's position on the face.

2.  Click the Hole icon  if you wish to create a hole in Part Design, or click the Hole icon to create a hole in Functional 

Molded Part.

The application creates a plane which is tangent to the selected face at the selected point. This plane will be used as support for 

the positioning sketch. 

3.  In the Hole Definition dialog box, define the hole shape and enter the parameter values you want to use.

4.  When done, click OK to create the hole.

The plane tangent to the face is not visible in the 3D area, but appears in the specification tree. You cannot edit it.

5.  Modify the point's location:

The hole is moved accordingly.

●     In case you select the face and then create a point by clicking on the face, the point is not constrained but associativity is ensured 
between the hole and the face.



●     The capability explained in this task is not available when editing holes created with versions prior to Version 5 Release 16.

 



Locating Holes

 

This task shows how to constrain the location of the hole to be created without using the Sketcher 
workbench`s tools.

 

To perform the scenario in Part Design, just open the Hole1.CATPart document. Otherwise, to perform 
the scenario in the Functional Molded Part workbench, sketch a rectangle in the Sketcher workbench 
then return to the workbench, and then create a shellable prism.

 
1.  Multi-select both edges as shown and the upper face which is the face on which you wish to 

position the hole.

2.  Click the Hole icon .

The preview displays two constraints defining the distances between the hole's center and the 

edges.

3.  Define the parameters in the dialog box to create the desired hole (see Creating Holes).

The application previews the constraints you are creating.

4.  To access the constraint values, double-click the constraint of interest. This displays the 

Constraint Definition dialog box in which you can edit the value.

5.  Click OK to create the hole.

The application positions the hole using constraints.

file:///E|/www/celr16/Doc/online/cfysm_C2/samples/Hole1.CATPart


 

The alternative way of accessing the constraints consists in double-clicking the sketch in the specification 
tree to enter the Sketcher workbench. You can then edit the constraints if you wish to reposition the 
hole.

Remember That... 
●     The area you click determines the location of the hole, but you can drag the hole onto desired location 

during creation using the left mouse button. If the grid display option is activated, you can use its 
properties.

●     Selecting a circular face makes the hole concentric with this face. However, the application creates no 
concentricity constraint.



●     Multi-selecting a circular edge and a face makes the hole concentric to the circular edge. In this case, the 
application creates a concentricity constraint.

●     Remember that the Sketcher workbench provides commands to constrain the point used for locating the 
hole. See Setting Constraints in the Part Design User's Guide.

●     Selecting a line and a face positions the hole along the line.



●     Editing the line modifies the hole accordingly.

●     Selecting an edge and a face allows the application to create one distance constraint. While creating the 
hole, you can double-click this constraint to edit its value.

  



Creating Threaded Holes
The Thread capability removes material surrounding the hole. From V5R16 onward, all hole types can be 
threaded.
To define a thread, you can enter the values of your choice, but you can use standard values or personal 
values available in files too.  

This task shows you how to create a threaded hole using values previously defined in a file. 

 

Open the Hole1.CATPart document to create a threaded hole in the Part Design workbench. Otherwise, to 
perform this scenario in the Functional Molded Part workbench, sketch a rectangle in the Sketcher 
workbench then return to the Functional Molded Part workbench and create a shellable prism.

 1.  Click the Hole icon  if you wish to create a hole in Part Design, or click the Hole icon to 

create a hole in Functional Molded Part.

2.  Select the face on which you wish to create the hole.

3.  In the Hole Definition dialog box that displays, define the hole shape and enter the parameters 

of your choice. For more information, refer to Creating Holes.

4.  Click the Thread tab.

5.  Check Threaded to access the thread definition options. 
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In the Type field,  you can choose among three different thread types: 

❍     No Standard: uses values entered by the user

❍     Metric Thin Pitch: uses ISO standard values 

❍     Metric Thick Pitch: uses ISO standard values

In addition to these three types, you can add your personal standards as described in Reusing 

Values Already Defined in a File

 
●     Metric Thin Pitch: ISO standard 

Refer to ( ISO 965-2 ). The application uses the minimum standard values. 



 

Nominaldiam Pitch Minordiam 

8.0 1.0 6.917

10.0 1.0 8.917

10.0 1.25 8.647

12.0 1.25 10.647

12.0 1.5 10.376

14.0 1.5 12.376

16.0 1.5 14.376

18.0 1.5 16.376

18.0 2.0 15.835

20.0 1.5 18.376

22.0 1.5 20.376

22.0 2.0 19.835

24.0 2.0 21.835

27.0 2.0 24.835

30.0 2.0 27.835

33.0 2.0 30.835

36.0 3.0 32.752

39.0 3.0 35.752

42.0 3.0 38.752

45.0 3.0 41.752

48.0 3.0 44.752

52.0 4.0 47.67

56.0 4.0 51.67

60.0 4.0 55.67

64.0 4.0 59.67

 
●     Metric Thick Pitch: ISO standard 

Refer to ( ISO 965-2 ). The application uses the minimum standard values. 



 

Nominaldiam        Pitch Minordiam 

1 0.25 0.729

1.2 0.25 0.929
1.4 0.3 1.075
1.6 0.35 1.221

1.8 0.35 1.421

2.0 0.4 1.567

2.5 0.45 2.013

3.0 0.5 2.459

3.5 0.6 2.850

4.0 0.7 3.242

5.0 0.8 4.134

6.0 1.0 4.917

7.0 1.0 5.917

8.0 1.25 6.647

10.0 1.5 8.376

12.0 1.75 10.106

14.0 2.0 11.835

16.0 2.0 13.835

18.0 2.5 15.294

20.0 2.5 17.294

22.0 2.5 19.294

24.0 3.0 20.752

27.0 3.0 23.752

30.0 3.5 26.211

33.0 3.5 29.211

36.0 4.0 31.670

39.0 4.0 34.670

42.0 4.5 37.129

45.0 4.5 40.129

48.0 5.0 42.587

52.0 5.0 46.587

56.0 5.5 50.046

60.0 5.5 54.046

64.0 6.0 57.505



 

●     No Standard 

If you keep the No Standard option, the field available below is Thread Diameter. You just need to 
enter the values you need in this field as well as in the fields below.

The Edit formula... contextual command is available from the Thread Diameter field, meaning that 
you can define formulas for managing diameters values.

 

●     Reusing Values Already Defined in a File 

There are two ways of accessing values listed in a file: either by navigating to the file of interest or by 
making this data available prior to launching the Hole command. For more, see the file is already 
available.

By navigating to the file you need 

6.  Simply click Add to access this file. 

A dialog box displays, in which you can navigate to reach the file containing your own values. 

This file may be of one of the following types:  

❍     Microsoft Excel files (general format)

❍     Lotus files

❍     tabulated files (in Unix environment)

The file types supported are the same as those used for design tables.

The values defined in your file will apply specifically to the part of your CATPart document, not to 

other documents.

7.  Navigate to StandardGaz.txt  file and click Open to get the values it contains.

The Hole Definition dialog box reappears. Your file looks like this:
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The file was created as follows:

Nominal diameter Pitch Minor Diameter Key

 

❍     The first row contains no numerical values

❍     the other rows below are reserved for numerical values, except for the last column which 
contains descriptions very often represented by letters.

❍     the mandatory items are keys that define the names associated with the values.

Moreover, the name of the standard is the same as the name of the file without the extension. 

You should remember these recommendations for creating your own personal files. 

8.  Set the Type option to StandardGaz.

9.  In the Thread Description field, set G7/8. 

The Edit formula... contextual command is now available from the Thread Description field, 

meaning that you can define formulas for managing diameters values.

You can note that the values associated with the G7/8 key (see the contents of the StandardGaz 

file) appear in the Hole Diameter field as well as the Pitch field (distance between each crest) are 

provided in the corresponding fields. 

You cannot edit these fields.



 By selecting the file from the Type list: the file is already available 

 
This behavior is made possible only if the administrator has performed these operations:

●     The administrator first needs to locate in a directory the source files used for the standards. For 

example, he can select E:/user/standard as the directory containing the StandardGaz.txt file. 

●     Then, he has to concatenate this path with the official path in the CATReffilesPath environment 

variable as follows: The result is the following: whenever the Hole command is launched, the 

application identifies all standards provided by the administrator. The user does no need to navigate 

to the file any longer.

Using the Remove function, you cannot remove standard files defined by the administrator.



 10.  If necessary, edit the thread depth then the hole depth if you need to modify the value you had 

previously set in the Extension tab. This value must not exceed the thread diameter value.

11.  Check the Left-Threaded option.

12.  Click OK to confirm your operation and close the Hole Definition dialog box.

The application displays the hole in the geometry area but not the thread. Note also that an icon 

specific to this feature is displayed in the specification tree.

 

A Few Words About Removing Files 

The Remove button removes files containing user-defined values. You cannot remove files containing 
standard values. 

Clicking the Remove button displays the list of user-defined files. You then just need to select or multi-
select (using ctrl key) the files and click OK to confirm the operation.

Note also that you cannot remove a standard file if it is used for a hole created in the CATPart document.



Threading Tapered Holes

You can thread tapered holes in the same way as you thread any other hole types. Once you have 
selected a tapered hole, the image in the dialog box assists you:

The following figure illustrates how the different parameters you need to value are defined:

 



Creating Ribs

This task shows you how to create a rib, that is how to sweep a profile along a center curve to create material. 

To define a rib, you need a center curve, a planar profile and possibly a reference element or a pulling direction.  You can 
combine the different elements as follows:

Closed Profile Open Profile

Open Center 
Curve

 

(Existing material)

(Thick Profile option,  no 
existing material) 

(Thick Profile option, 
existing material) 

Closed Planar 
Center Curve

 
(Thick Profile option, no existing material) 

Closed 3D Center 
Curve

 

(Thick Profile option) 



Center Curves 
Moreover, before using center curves, the following rules should be kept in mind: 

●     3D center curves must be continuous in tangency

●     If the center curve is planar, it can be discontinuous in tangency.

●     center curves must not be composed of several geometric elements

 

Open the Rib.CATPart document.

 1.  Click the Rib icon .

The Rib Definition dialog box is displayed.

2.  Select the profile you wish to sweep, i.e. Sketch.2.

The profile has been designed in a plane normal to the plane used to define the center curve. It is a closed profile. 
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About Profiles 
●     In some cases, you can define whether you need the whole sketch, or sub-elements only. For more information, refer to 

Using the Sub-elements of a Sketch.

●     Clicking the icon  opens the Sketcher . You can then edit the profile. Once you have done your modifications, you just 
need to quit the Sketcher. The Rib Definition dialog box then reappears to let you finish your design. 

●     If you launch the Rib command with no profile previously defined, just click the icon  to access the Sketcher and 
then sketch the profile you need.

●     You can also create your profile by using any of these creation contextual commands available from the Profile field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile you need as 
explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract:  generates separate elements from non-connex sub-elements. See Extracting Geometry.

If you create any of these elements, the application then displays the corresponding icon in front of the field. Clicking this 
icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the contextual commands 
mentioned above are aggregated into sketch-based features.

 
●     You can use an open profile provided existing material can trim the rib. For more information, refer to Trimming Ribs or 

Slots.

●     Ribs can also be created from sketches including several profiles. These profiles must be closed and must not 
intersect. For example,  you can easily obtain a pipe by using a sketch composed of two concentric circles:

Profiles Result

3.  Select the center curve,  i.e. Sketch.1.

The center curve is open. To create a rib you can use open profiles and closed center curves too. 3D Center curves 

must not be discontinuous in tangency. 

You can also use planar wireframe geometry as your profile or center curve.

It is recommended that the profile be on the center curve in a plane normal to the center curve. Otherwise, it may 

lead to an unpredictable shape.

The application now previews the rib to be created.
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Clicking the icon  opens the Sketcher to let you edit the center curve. Once you have done your modifications, you just 
need to quit the Sketcher. The Rib Definition dialog box then reappears to let you finish your design. 

 

Profile Control

You can control its position by choosing one of the following options: 

●     Keep angle: keeps the angle value between the sketch plane used for the profile and the tangent of the center curve.

●     Pulling direction: sweeps the profile with respect to a specified direction. To define this direction, you can select a plane or 
an edge. For example, you need to use this option if your center curve is a helix. In this case, you will select the helix axis 
as the pulling direction. 

●     Reference surface: the angle value between axis h and the reference surface is constant.

●     Contextual commands creating the directions you need are available from the Selection field:
❍     Create Line: For more information, see Creating Lines.

❍     Create Plane: see Creating Planes.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon in front of the Selection field. 
Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the contextual commands 
mentioned above are aggregated into sketch-based features.
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4.  To go on with our scenario, let's maintain the Keep angle option. Remember, the angle value is 90 degrees.

5.  Click OK.

The rib is created. The specification tree mentions this creation. 

The Merge rib's ends option is to be used in specific cases. It create materials between the ends of the rib and existing 
material provided that existing material trims both ends. For an example, refer to Trimming Ribs or Slots.

7.  Delete this rib to create another one by using Pulling direction. After setting this option, select plane xy to define z 

axis as the pulling direction. The plane used to define the profile will remain normal to plane xy.

The preview looks like this:



8.  Delete this rib to create another rib by using Reference surface.  First, display the multi-sections surface in the 

Show space, then set the Reference surface option and select the multi-sections as the reference surface. The angle 

value between h axis and the surface equals 0. It remains constant.

The preview looks like this:

And the rib like this:



 
Thin Solids 

9.  Check the Thick Profile option to add thickness 

to both sides of Sketch.2. New options are then 

available:

 

10.  Enter 2mm as Thickness1's value, and 5mm as Thickness2's value, then preview the result.

Material is added to each side of the profile.

 
Checking the Merge Ends option trims the rib to exiting material. For more information, refer to Trimming Ribs.

And the rib like this:



 

10.  To add material equally to both sides of the profile, check Neutral fiber and preview the result.

The thickness you defined for Thickness1 (2mm) is now evenly distributed: a thickness of 1mm has been added to 

each side of the profile.

11.  Click OK to create the rib.

The rib looks like this:

 

A Few Words about the Keep Angle Option

The position of the profile in relation to the center curve determines the shape of the resulting rib. When sweeping the 
profile, the application keeps the initial position of the profile in relation to the nearest point of the center curve. The 
application computes the rib from the position of the profile.

In the example below, the application computes the intersection point between the plane of the profile and the center curve, 
then sweeps the profile from this position. 

 



 



Trimming Ribs or Slots

 

This page illustrates two different cases of ribs obtained from open profiles, then the use of the Merge 
rib's ends and Merge Ends options available in the Rib Definition dialog box.

 
●     Open Profiles Trimmed by Existing Material 

 

 Initial Profile (in black) and Center Curve (in 
red)

Resulting Rib

The rib is obtained just by extending its open 
profile onto existing material. 

 
●     Open Profiles with No Trimming Material 

 If the rib cannot be trimmed by existing material, the 
only way of obtaining a rib is by using the Thick 
Profile option: 

To create this, thickness has been added to each side 
of the profile

  Resulting Rib



 
●     Merge rib's ends Option 

The Merge rib'ends option extends and trims the center curve to existing material. Each extremity of 
the rib is then trimmed to existing material. The example below clearly shows how the blue rib is 
trimmed.

 

Without using the Merge rib's ends option Using the Merge  rib's ends option

 
●     Merge Ends Option 

 The Merge Ends option is to be used for thin ribs (or 
slots). It trims a set of profiles to themselves while 
trimming them to existing material too.

If you consider this initial sketch composed of two 
curves :



 Without using the Merge Ends option, you obtain 
this result:

 Using the Merge Ends option, you obtain this result: 

 



Creating Slots
This task shows you how to create a slot, that is how to sweep a profile along a center curve to remove 
material. 

To define a slot, you need a center curve, a planar profile, a reference element and optionally a pulling 
direction. 

To create slots you can combine the different elements as follows:

Closed Profile Open Profile

Open Center Curve
 

 

(Thick Profile Option)

Closed Planar Center 
Curve   

Closed 3D Center Curve
 

(Thick Profile Option)

Center Curves 
Moreover, the following rules should be kept in mind: 

●     3D center curves must be continuous in tangency.

●     if the center curve is planar, it can be discontinuous in tangency.

●     center curves must not be composed of several geometric elements

 
Open the Slot.CATPart document.
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1.  Click the Slot icon .

The Slot Definition dialog box is displayed.

2.  Select the profile, i.e. Sketch.2.

The profile has been designed in a plane normal to the plane used to define the center curve. It is 

closed.



 About Profiles 

●     You can use wireframe geometry as your profile too.

●     It is recommended that the profile be on the center curve in a plane normal to the center curve. 

Otherwise, it may lead to an unpredictable shape.

●     In some cases, you need to define whether you need the whole sketch, or sub-elements only. For 
more information, refer to Using the Sub-elements of a Sketch.

●     Slots can also be created from sketches including several profiles. These profiles must be closed and 
must not intersect. 

●     If you launch the Slot command with no profile previously defined, just click the icon  to access 
the Sketcher and then sketch the profile you need.

●     You can also create your profile by using any of these creation contextual commands available from 
the Profile field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract:  generates separate elements from non-connex sub-elements. See Extracting 
Geometry.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Selection field. Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the 
contextual commands mentioned above are aggregated into sketch-based features.

 
●     You can use an open profile provided existing material can trim the slot. For more information, refer 

to Trimming Ribs or Slots.

3.  Click the icon  to open the Sketcher. This temporarily closes the dialog box.

4.  Edit the profile. For example, enlarge it.

5.  Quit the Sketcher. 

The Slot Definition dialog box reappears.

Profile Control

You can control the profile position by choosing one of the following options:
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●     Keep angle: keeps the angle value between the sketch plane used for the profile and the tangent of 
the center curve.

●     Pulling direction: sweeps the profile with respect to a specified direction. For example, you need to 
use this option if your center curve is a helix. In this case, you will select the helix axis as the pulling 
direction.

●     Reference surface: the angle value between axis h and the reference surface is constant.

●     Contextual commands creating the directions you need are available from the Selection field:
❍     Create Line: For more information, see Creating Lines

❍     Create Plane: see Creating Planes

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Selection field. Clicking this icon enables you to edit the element.

 If you have chosen to work in a hybrid design environment, the elements created on the fly via the 
contextual commands mentioned above are aggregated into sketch-based features.

6.  To go on with our scenario, let's maintain the Keep angle option. Now, select the center curve 

along which the application will sweep the profile.

The center curve is open. To create a slot you can use open profiles and closed center curves too. 

Center curves can be discontinuous in tangency.

The application previews the slot.
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●     Clicking the icon  opens the Sketcher to let you edit the center curve. 

●     The Merge slot's ends option is to be used in specific cases. It lets the application create material 
between the ends of the slot and existing material. For an example, refer to Trimming Ribs or Slots.

 
7.  Check the Thick Profile option to add thickness to both sides of Sketch.2. 

New options are then available:

8.  Enter 2mm as Thickness1 's value, and 5mm as Thickness2 's value, then preview the result.

Material is added to each side of the profile.

Checking Merge Ends trims the slot to existing material. For an example, refer to Trimming Ribs 

or Slots.

9.  To add material equally to both sides of the profile, check Neutral fiber and preview the result. 

The thickness you defined forThickness1 (2mm) is now evenly distributed: a thickness of 1mm 

has been added to each side of the profile.

10.  Click OK.

The slot is created. The specification tree indicates this creation.





Creating Stiffeners

 

This task shows you how to create a stiffener by specifying creation directions.

Open the Stiffener.CATPart document.

1.  Select the profile to be extruded, that is Sketch.6 (located in the Part Body entity).

This open profile has been created in a plane normal to the face on which the stiffener will lie. 

 
About Profiles 

●     You can use wireframe geometry as your profile.

●     In some cases, you can define whether you need the whole profile, or sub-elements only. For more 
information, refer to Using the Sub-elements of a Sketch.

●     Clicking the icon  opens the Sketcher. You can then edit the profile. Once you have done your 
modifications, the Stiffener Definition dialog box reappears to let you finish your design.

●     You can also create your profile by using any of these creation contextual commands available from 
the Selection field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract:  generates separate elements from non-connex sub-elements. See Extracting 
Geometry.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Selection field. Clicking this icon enables you to edit the element.
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●     If you click the Selection field and select another sketch, the application immediately creates the 
stiffener.

●     Clicking the icon  opens the Sketcher. You can then edit the profile to modify your stiffener. 
Once you have done your modifications, you just need to quit the Sketcher. The dialog box is closed 

and the icon  is activated. 

●     If you have chosen to work in a hybrid design environment, the elements created on the fly via the 
contextual commands mentioned above are aggregated into sketch-based features.

If you need to use an open profile, make sure that existing material can fully limit the extrusion of this 
profile

2.  Click the Stiffener icon . 

The Stiffener Definition dialog box is displayed. 

Two creation modes are available: 

❍     From side: the extrusion is performed in the profile's plane and the thickness is added 
normal to the plane.

❍     From top: the extrusion is performed normal to the profile's plane and the thickness is added 
in the profile's plane. 

From side is the default option. The application previews a stiffener which thickness is equal to 

10mm. The extrusion will be made in three directions, two of which are opposite directions. 

Arrows point in these directions.



3.  Uncheck the Neutral Fiber option.

The extrusion will be made in two directions only. To obtain the directions you need, you can also 

click the arrows. Note that you can access contextual menu items on these arrows. These 

commands are the same as those available in the dialog box.

4.  Check the Neutral Fiber option again.

This option adds material equally to both sides of the profile.



5.  Enter 12 as the thickness value.

This thickness is now evenly distributed: a thickness of 6mm is added to each side of the profile. 

Optionally click Preview to see the result. 

6.  Click OK. 

The stiffener is created. The specification tree indicates it has been created.

 

"From Top" Stiffeners 

The From top option lets you create stiffeners from a network as illustrated below. You can, if you wish, 
create this stiffener by working on Body.2. Prior to doing so, ensure that Sketch.8 is the current 
object).

Figure 1: Sketch.8 includes several lines.



 Figure 2: With the From top option on, the extrusion is performed normal to the profile's plane and the 
thickness is added in the profile's plane. Note also that the resulting stiffener is always trimmed to 
existing material.

There are two ways of defining the thickness. 

●     The Neutral fiber option adds the same thickness to both sides of the profile. You just need to 
specify the value of your choice in Thickness 1 field and this thickness is evenly added to each side 
of the profile.

  

●     Conversely, if you wish to add different thicknesses on both sides of the profile, just uncheck the 
Neutral fiber option and then specify the value of your choice in Thickness 2 field.



The creation of "from top" stiffeners is never done with respect to the creation order of the profile.

  Whatever the creation order of Line.1, Line.2 and Line.3....

....the stiffener looks like this:



Creating Multi-sections Solids
This task shows how to create a multi-sections solid. 

You can generate it by sweeping one or more planar section curves along a computed or user-defined 
spine. The feature can be made to respect one or more guide curves. The resulting feature is a closed 
volume.

Open the Multi-sections.CATPart document.

1.  Click the Multi-sections Solid icon .

The Multi-sections Solid Definition dialog box appears.

2.  Select the three section curves as shown: 

They are highlighted in the geometry  area.
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The Multi-sections Solid capability assumes that the section curves to be used do not intersect.

3.  Click Preview to get an idea of the feature to be created.

You can note that by default, tangency discontinuity points are coupled:



 Smooth Parameters

In the Smooth parameters section, you can check the following options:

❍     Angular Correction: smoothes the lofting motion along the reference guide curves. This 
may be necessary when small discontinuities are detected with regards to the spine tangency 
or the reference guide curves' normal. The smoothing is done for any discontinuity which 
angular deviation is smaller than 0.5 degree, and therefore helps generating better quality for 
the resulting multi-sections solid. 

❍     Deviation: smoothes the lofting motion by deviating from the guide curves. 

If you are using both Angular Correction and Deviation parameters, it is not guaranteed that 

the spine plane be kept within the given tolerance area. The spine may first be approximated 

within this deviation tolerance, then each moving plane may rotate within the angular correction 

tolerance.

Spine

In the Spine tab page, you can select the Spine check box to use a spine that is automatically 

computed or select a curve to impose that curve as the spine.

Note that:

❍     It is strongly recommended that the spine curve be normal to each section plane and must be 

continuous in tangency. Otherwise, it may lead to an unpredictable shape.

❍     If the plane normal to the spine intersects one of the guide curves at different points, it is 
advised to use the closest point to the spine point for coupling.

❍     If the spine is automatically computed spine and one or two guide curves are selected: the 
multi-sections solid is limited by the guide extremities. If there are more than two guide 
curves, the spine stops at a point corresponding to the barycenter of the guide extremities. In 
any case the tangent to the spine extremity is the mean tangent to the guide extremities. 

Coupling

Several coupling types are available in the Coupling tab: 



❍     Ratio: the curves are coupled according to the curvilinear abscissa ratio.

❍     Tangency: the curves are coupled according to their tangency discontinuity points. If they do 
not have the same number of points, they cannot be coupled using this option. 

❍     Tangency then curvature: the curves are coupled according to their curvature discontinuity 
points. If they do not have the same number of points, they cannot be coupled using this 
option. 

❍     Vertices: the curves are coupled according to their vertices. If they do not have the same 
number of vertices, they cannot be coupled using this option.

In case you do not have a GS1 nor GSD license but a WS1 license, you can select two sections only and 
you are not allowed to perform manual couplings.

Guides

4.  For the purpose of our scenario, you are going to use guide curves. Click the Guide field and 

select the four joins. The curves to be used must be joined.

They are highlighted in the geometry  area.

It is possible to edit the multi-sections solid reference elements by first selecting a curve in the 

dialog box list then choosing a button to either:

❍     Remove the selected curve 

❍     Replace the selected curve by another curve.

❍     Add another curve.

By default, the application computes a spine, but if you wish to impose a curve as the spine to be 

used, you just need to click the Spine tab then the Spine field and select the spine of your 

choice in the geometry.

Relimitation

The Relimitation tab lets you specify the feature relimitation type.



 You can choose to limit the multi-sections solid only on the start section, only on the end section, 

on both, or on none.

❍     when one or both are checked: the multi-sections solid is limited to corresponding section

❍     when one or both are when unchecked: the multi-sections solid is swept along the spine: 

❍     if the spine is a user spine, the multi-sections solid is limited by the spine 
extremities or by the first guide extremity met along that spine.

❍     if the spine is an automatically computed spine, and no guide is selected: the 
feature is limited by the start and end sections 

❍     if the spine is an automatically computed spine, and guides are selected, the 
feature is limited by the guides extremities 

5.  Click OK to create the volume.

The feature (identified as Multi-sections Solid.xxx) is added to the specification tree.

  



Creating Removed Multi-sections Solids
 

This task shows how to remove a multi-sections solid. 

The Removed Multi-sections Solid capability generates lofted material solid by sweeping one or 
several planar section curves along a computed or user-defined spine then removes this material. The 
material can be made to respect one or more guide curves.

Open the RemovedMulti-sections.CATPart document.

1.  Click the Removed Multi-sections Solid icon .

The Removed Multi-sections Solid Definition dialog box appears.

2.  Select both section curves as shown Sketch.3 and Sketch.4:

They are highlighted in the geometry  area.
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In P1 mode, you can select two sections only.

 
3.  Select Closing Point 2 as shown on Section 2 to redefine the closing point.

4.  Click Closing Point 2 arrow to reverse the direction.



It is possible to edit the feature reference elements by first selecting a curve in the dialog box 

list then choosing a button to either:

❍     Remove the selected curve 

❍     Replace the selected curve by another curve.

❍     Add another curve.

By default, the application computes a spine, but if you wish to impose a curve as the spine to 

be used, you just need to click the Spine tab then the Spine field and select the spine of your 

choice in the geometry.

Spine

In the Spine tab page, you can select the Spine check box to use a spine that is automatically 

computed or select a curve to impose that curve as the spine.

Note that:

❍     It is strongly recommended that the spine curve be normal to each section plane and must 

be continuous in tangency. Otherwise, it may lead to an unpredictable shape.

❍     If the plane normal to the spine intersects one of the guide curves at different points, it is 
advised to use the closest point to the spine point for coupling.

❍     If the spine is automatically computed spine and one or two guide curves are selected: the 
multi-sections solid is limited by the guide extremities. If there are more than two guide 
curves, the spine stops at a point corresponding to the barycenter of the guide extremities. 
In any case the tangent to the spine extremity is the mean tangent to the guide extremities. 



Coupling

Several coupling types are available in the Coupling tab: 

❍     Ratio: the curves are coupled according to the curvilinear abscissa ratio.

❍     Tangency: the curves are coupled according to their tangency discontinuity points. If they 
do not have the same number of points, they cannot be coupled using this option. 

❍     Tangency then curvature: the curves are coupled according to their curvature 
discontinuity points. If they do not have the same number of points, they cannot be coupled 
using this option. 

❍     Vertices: the curves are coupled according to their vertices. If they do not have the same 
number of vertices, they cannot be coupled using this option.

Relimitation

The Relimitation tab lets you specify the removed multi-sections solid relimitation type. You 

can choose to limit the feature only on the Start section, only on the End section, on both, or 

on none.

❍     when one or both are checked: the feature is limited to corresponding section

❍     when one or both are when unchecked: the feature is swept along the spine: 

■     if the spine is a user spine, the feature is limited by the spine extremities

■     if the spine is an automatically computed spine, and no guide is selected: the feature is 
limited by the start and end sections 

■     if the spine is an automatically computed spine, and guides are selected, the feature is 
limited by the guides extremities.



In the Smooth parameters section, you can check:

❍     the Angular Correction option to smooth the lofting motion along the reference guide 
curves. This may be necessary when small discontinuities are detected with regards to the 
spine tangency or the reference guide curves' normal. The smoothing is done for any 
discontinuity which angular deviation is smaller than 0.5 degree, and therefore helps 
generating better quality for the resulting multi-sections solid. 

❍     the Deviation option to smooth the lofting motion by deviating from the guide curves.

If you are using both Angular Correction and Deviation parameters, it is not guaranteed that 

the spine plane be kept within the given tolerance area. The spine may first be approximated 

within this deviation tolerance, then each moving plane may rotate within the angular correction 

tolerance.

5.  Click OK to create the removed multi-sections solid.

The feature (identified as Multi-sections Solid.xxx) is added to the specification tree.

  

Smooth Parameters



Creating Solid Combines 
 

This task shows you how to create a solid combine, that is a solid resulting from the intersection of two 
or more extruded profiles.

Open the Solid_Combine.CATPart document.

1.  Click the Solid Combine icon .

The Combine Definition dialog box appears.

2.  Select Sketch.1 as the first component to be extruded. 

Sketches must contain closed profiles. Note that if you launch the Solid Combine command with 

no profile previously defined, just access the Sketcher by clicking the icon  available in the 

dialog box and sketch the profile you need.

 
Components

The components you can select are:

●     Sketches

●     Surfaces

●     Sketches sub-elements: for this, use the Go to Profile definition contextual command. (for more 
information, refer to Using the Sub-elements of a Sketch)

●     3D planar curves
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●     A sketch containing more than one domains cannot be selected for creating solid combine features.

●     A sketch containing closed mono-domain or a single domain of multi-domain sketch (using go to 
profile command) should be used to create Solid combine features.

●     If needed, you can change the component by clicking the Profile field and by selecting another 
sketch in the geometry or in the specification tree.

●     You can also use any of these creation contextual commands available from the Profile field:

❍     Create Sketch: launches the Sketcher after selecting any plane, and lets you sketch the profile 
you need as explained in the Sketcher User's Guide.

❍     Create Join:  joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extract:  generates separate elements from non-connex sub-elements.  See Extracting 
Geometry.

3.  Select Sketch.2 as the second component to be extruded. This sketch contains only one profile, 

namely a rectangle.

The Solid Combine capability computes the intersection between the profiles virtually extruded. 

By default, each component is extruded in a plane normal to its sketch plane. The application 

previews the result as soon as the second component has been selected.
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Extrusion Directions

There are two types of directions you can specify to compute the intersection. For the first and the 
second components, you can choose:

●     The Normal to profile option: this is the default option

●     Another direction indicated by a geometrical element you select. 

4.  For the purposes of our scenario, uncheck the Normal to profile option for the first component 

and select the line created in Sketch.3 to indicate the extrusion direction.

5.  Click OK to confirm and create the solid combine feature. 

The new element (identified as Combine.xxx) is added to the specification tree.

   



How Sketches are Located in the Specification 
Tree (Hybrid Design)

Up to Part Design Version 5 release 14 the sketches used for creating sketch-based features were 
located directly below the features in the specification tree. Now, to improve the visibility of your design 
process this behavior has changed: depending on how sketches are created, sketch entities are not 
necessarily displayed below the features they support.

This page covers the following topics:

●     Sketch Entities Aggregated by Sketch-based Features

●     Sketch Entities Referenced by Sketch-based Features

●     Specific Cases: Ribs, Slots, Multi-section Solids and Solid Combines

●     Specific Cases: Power Copies and User-Defined Features

●     Reordering Sketch Locations

Sketch Entities Aggregated by Sketch-based Features

The sketches used for creating sketch-based features are aggregated by, or to put it in another way, 
located just below those features in the tree when:

●     You are working in a hybrid design environment.

●     You are using a sketch created prior to the feature

●     The sketch is not already aggregated by another feature

 

Sketch Entities Referenced by Sketch-based Features
●     Sketches are referenced by sketch-based features when these sketches are already aggregated by 

previous features. In the example below, Pad.4 references Sketch.6 which is already use to create 
Pad.3.



 
●     Sketches are referenced by sketch-based features if these sketches are not directly located above the 

node of the features you are creating. In the example below, Pad 4 created using Sketch.7 because 
an intermediary feature, Draft.1 was created after the sketch.

 

Specific Cases: Ribs, Slots, Multi-section Solids and 
Solid Combines

Ribs, slots, multi-section solids and solid combines require the use of two sketches at least.

●     If these sketches are successively located in the specification tree,

like this...
then, ribs, slots, multi-section solids or solid 

combines created from them aggregate them:



otherwise, each sketch is located according to the rules mentioned in the two previous paragraphs. 
For example, you will obtain this:

 

Specific Cases: Power Copies and User Features

When selecting a sketch-based feature to define a Power copy or a User Feature, remember that:

●     if the sketch is aggregated (placed just below the feature in the specification tree), that sketch is 
included in the selection as shown under Inputs of components.

●     otherwise, if the sketch is referenced, it is not therefore included in the definition of the power copy 
or user feature. If you need to include it because it will be requested at instantiation, do select it. 

Reordering Sketch Locations

The rules mentioned above apply when you are creating sketch-based features. But when you are editing 
those features, at any time, you can modify the location of a sketch by using the Reorder capability. 
This capability moves and repositions sketches at the location of your choice, provided that the location 
you choose does not affect the integrity of your part. The application provides a quick help for that. For 
more information, refer to Reordering Features and Reordering Sketch-Based Features.



Dress-Up Features
Dressing up features is done by applying commands to one or more supports. The application provides a large 
number of possibilities to achieve the features meeting your needs. The application lets you create the 
following dress-up features:

 
Create an Edge Fillet: Click this icon, select the edge to be filleted, enter the radius value and set 
the propagation mode in the dialog box.

 
Create a Variable Radius Fillet: Click this icon, select the edge to be filleted, enter new radius 
values for both of the detected vertices, click as many points as you wish on the edge and enter 
appropriate radius values for each of them. If needed, define a new variation mode.

 
Create a Variable Radius Fillet Using a Spine: Click this icon, select the edges to be filleted, enter 
an angle value for both vertices at the corner, check the Circle Fillet option and select the spine.

 
Reshaping Corners: click the More button in the Edge Fillet or in the Variable Radius Fillet dialog 
box, click the Blend corners button to detect the corner to reshape.

 
Create a Face-Face Fillet: Click this icon, select the faces to be filleted and enter the radius value 
in the dialog box.

Create a Tritangent Fillet: Click this icon, select the faces to be filleted then the face to be 
removed.

 
Create a Chamfer: Click this icon, select the edge to be chamfered, set the creation mode then 
define the parameters you have set.

 Create a Basic Draft : Click this icon, set the Selection by neutral face selection mode or select 
the face to be drafted, then enter the required parameters. 

 Create a Draft with a Parting Element: Click this icon, set the Selection by neutral face selection 
mode or select the face to be drafted, expand the dialog box then enter the required parameters. 

 
Create an Advanced Draft: Click this icon, specify the type of operation you wish to perform, then 
define the parameters you have set.

 
Create a Variable Angle Draft: Click this icon, select the face to be drafted, click as many points as 
you wish and then enter the required parameters. 



Create a Draft from Reflect Lines: Click this icon, select the face to be drafted, then enter the 
required parameters. 

 
Create a Shell : Click this icon, select the faces to be shelled and enter the thickness values.

 
Create a Thickness: Click this icon, select the faces to be shelled and enter the thickness value.

 
Create a Thread/Tap: Click this icon, select the cylindrical surface you wish to thread, the planar 
limit face and enter the required values.

Create a Remove Face Feature : Click this icon, select the face to be removed and the faces to 
keep.

Create a Replace Face Feature: Click this icon, select the replacing face and the face to be 
removed.



Creating Edge Fillets
A fillet is a curved face of a constant or variable radius that is tangent to, and that joins, two surfaces. Together, 
these three surfaces form either an inside corner or an outside corner. 

In drafting terminology, the curved surface of an outside corner is generally called a round and that of an inside 
corner is normally referred to as a fillet. 

Edge fillets are smooth transitional surfaces between two adjacent faces.

 

The purpose of this task is to fillet several edges. First you will fillet nine edges, then you will fillet a face and 
trim this fillet to a plane. The cases illustrated here are simple. They use a constant radius: the same radius 
value is applied to the entire edges. To see more complex fillets, refer to Creating Variable Radius Fillets or 
Variable Radius Fillet Using a Spine.

 
Open the Edge_Fillet1.CATPart document.

 1.  Click the Edge Fillet icon .

The Edge Fillet Definition dialog box appears.

The  icon now available after the Objects to fillet field lets you edit the list of the faces to be filleted. For 

more information about that capability, refer to Editing a List of Elements. 
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2.  Select the edge as shown.

3.  The edge selected then appears in the Objects to fillet field. The application displays the radius value.

Clicking Preview previews the fillet to be created. This capability is supported on Part Design P2 only.

4.  Two propagation modes are available: 

❍     Minimal: edges tangent to selected edges can be taken into account to some extent. The 
application continues filleting beyond the selected edge whenever it cannot do otherwise. In our 
example below, the fillet is computed on the selected edge and on a portion of tangent edges:

❍     Tangency: tangencies are taken into account so as to fillet the entire edge and possible tangent 
edges.

5.  For the purpose of our scenario, set the Tangency option. The preview clearly shows that the whole 

edge will be filleted.



If you set the Tangency mode, the Trim ribbons option becomes available: you can then trim the 

fillets to be created. For more, refer to Trimming ribbons. 

6.  Enter 15mm as the new radius value. The radius value is updated in the geometry area.

7.  Select the eight vertical edges.

8.  Click OK.

The edges are filleted. The creation of this fillet is indicated in the specification tree.



9.   Click the Edge Fillet icon   again and select the upper face as the new element to be filleted.

10.  Enter 5mm as the radius value.

11.  Click More to access four additional options.

To know how to use:
●     the Edges to keep option, refer to Keeping Edges.

●     the Blend corner(s) option, refer to Reshaping Corners.

 
Limiting Elements 



12.  Click the Limiting element field and select Plane.1 as the plane that will intersect the fillet. 

An arrow appears on the plane to indicate the portion of material that will be kept. Clicking this arrow 

reverses the direction and therefore indicates that the portion of material that will be kept will be the 

opposite one.

This capability is supported on Part Design P2 only.

❍     It is possible to use one or more limiting elements.

❍     Contextual commands creating the limiting elements you need are available from the Limiting 
elements field:

■     Create Point: For more information, see Creating Points

■     Create Midpoint: creates the midpoint of the line you select

■     Create Endpoint: creates the endpoint of the line you select

■     Create Plane: see Creating Planes

■     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

■     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

■     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

■     Create Intersection: Creating Intersections

■     Create Projection: see Creating Projections

■     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

■     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon in front 
of the Limiting element(s) field. Clicking this icon enables you to edit the element.
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❍     You can create limiting elements just by clicking on the edge to be filleted. The application 
displays this element as a blue disk:

❍     You can select points as limiting elements. These points must be located on the edge to be filleted 
and they must have been created using the On curve option available in the Point Definition 
dialog box.

13.  Click OK.

The second fillet is trimmed to Plane.1. Both fillets are displayed in the specification tree. The 

final part looks like this:



 

Interrupting Fillet Computations

In case you made a mistake when defining a fillet (wrong radius value for example), you can interrupt the 
feature computation launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a 
Cancel option. To interrupt the operation, just click that Cancel button. This interrupts the process and then 
displays an Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the feature.

This new capability is available for any types of fillet features you are creating or editing.

Keeping Edges 

When filleting an edge, the fillet may sometimes affect other edges of the part, depending on the radius value you 
specified. In this case, the application detects these edges and stops the fillet to these edges, as illustrated in the 
example below:

Edge to be filleted The upper edge is not filleted

There are two ways of keeping these edges:
●     by explicitly specifying the Edges to be kept 

●     by asking the application to find a solution

Both methods may not give the same result depending on the geometry. If you prefer to let the application find a 
solution, the application finds an appropriate physical edge in the geometry, then considers it as the edge to be 
kept. If no edge can be found, then it finds a solution by itself.

Selecting an Edge

The application issues an error message asking you if you wish to select the edge you do not want to fillet. If you 
click Yes, then you just need to click the Edit button from the Update Diagnosis dialog box that appears, click the 
Edges to keep field from the Edge Fillet dialog box and select the edge in the geometry. The application then 
displays the selected edge in pink meaning that the edge will not be affected by the fillet operation. The fillet is 
eventually computed and does not affect the "keep" edge.

The Application Finds a Solution



If you do not wish to explicitly select the edge you do not want to fillet, just click No in the Feature Definition Error. 
The application then tries to find a solution.

Ignoring Edges
When the update process detects that sharp edges (edges are considered as sharp when the angle between the two 

faces is greater than 0.5 deg) interrupt fillet operations, it is possible to continue filleting just by selecting an edge 

adjacent to the edge to be filleted. In the example below, the application displays the edge causing trouble in 

yellow: 

An error message is issued, prompting you to select an edge adjacent to the filleted edge. Just by selecting both 
edges to the right and the left of the previewed fillet, the application can then compute the whole fillet properly:

Trimming Ribbons 

If you choose to use the Tangency propagation mode, you can also trim overlapping  fillets. To do so, simply check 
the "Trim ribbons" option.

Selected edges



Overlapping fillets are not trimmed

Both fillets are trimmed

 



Compare the above results to the fillets created with the Minimal propagation mode: The fillets are only trimmed.



Creating Variable Radius Fillets
Variable radius fillets are curved surfaces defined according to a variable radius. A variable radius corner means that at least 
two different constant radii are applied to two entire edges.

This task shows how to create a standard variable radius fillet. After performing the scenario, see also Variable Radius Fillets 
Using a Spine.

 
Open the VariableRadiusFillet1.CATPart document.

 1.  Click the Variable Radius Fillet icon . 

The Variable Radius Fillet Definition dialog box appears.

2.  Select the edge to be filleted. 

You can define variable radius fillets on closed edges. See Variable Radius Fillets Using Closed Edges. 

The application detects both vertices and displays two identical radius values.

The  icon available after the Edges to fillet field lets you edit the list of the faces to be filleted. For more 

information about that capability, refer to Editing a List of Elements. 

Optionally, click Preview to see the fillet to be created.

3.  Enter a new radius value to simultaneously change the radius of both vertices. For example, enter 12mm. The new 

radius value is displayed on both vertices. The preview is modified accordingly.
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Two propagation modes are available: 

❍     Minimal: the application does not take any tangencies into account. If filleted edges overlap, the application 
trims the fillets and creates a sharp edge. 

❍     Tangency: tangencies are taken into account so as to fillet entire edges. If you set the Tangency mode, the 
Trim ribbons option becomes available: you can then trim the fillets to be created. For more, refer to Trimming 
ribbons. 

Points

Contextual commands creating the points you need are now available from the Points field:

●     Create Point: For more information, see Creating Points

●     Create Midpoint: creates the midpoint of the line you select

●     Create Endpoint: creates the endpoint of the line you select

●     Create Intersection: see Creating Intersections

●     Create Projection: see Creating Projections

●     Create Plane: see Creating Planes

If you create any of these elements, the application then displays the corresponding icon in front of the Points field. Clicking 
this icon enables you to edit the element.

4.  To add a point on the edge to make the variable radius fillet more complex, click the Points field. You can also add 

points by selecting planes. For more information, refer to the end of the task. You can add as many points as you 

wish.

5.  Click the Points field then a point on the edge to be filleted. 

The application displays the radius value on this point. Note that to remove a point from the selection, you just need 

to click this point.

6.  Enter a new radius value for this point: enter 4. The new radius value is displayed.

This is your preview:

7.  The variation mode is set to Cubic: keep this mode. To see the Linear propagation mode, refer to More About 

Variable Radius Fillets.



8.  Click OK to confirm the operation. 

The edge is filleted. The specification tree indicates this creation.

9.  To edit this fillet, double-click EdgeFillet.1 in the specification tree.

10.  Expand the dialog box by clicking More. 

Four additional options are available.

To know how to use:
●     the Edges to keep option, refer to Keeping Edges.

●     the Blend corner(s) option, refer to Reshaping Corners.

 

Limiting Elements

11.  Click the Limiting elements field and select Plane.1 as the plane that will trim the fillet.

An arrow appears on the plane pointing to the portion of material that will be kept. 



  

 
●     This capability is supported on Part Design P2 only.

●     It is possible to use one or more limiting elements.

●     Contextual commands creating the limiting elements you need are available from the Limiting element(s) field:
❍     Create Point: For more information, see Creating Points

❍     Create Midpoint: creates the midpoint of the line you select

❍     Create Endpoint: creates the endpoint of the line you select

❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limiting element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting element.

❍     Create Intersection: Creating Intersections

❍     Create Projection: see Creating Projections

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon in front of the Limiting 
element(s) field. Clicking this icon enables you to edit the element.

●     You can create limiting elements just by clicking on the edge to be filleted. The application displays this element as a 
blue disk.

●     You can select points as limiting elements. These points must be located on the edge to be filleted and they must have 
been created using the 'On curve' option available in the Point Definition dialog box.
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12.  Click this arrow to reverse the direction and therefore specify that the portion of material to be kept will be the 

opposite one.

13.  Click OK.

The variable radius fillet is trimmed to Plane.1. The final part looks like this:

 

Interrupting Fillet Computations

In case you made a mistake when defining a fillet (wrong radius value for example), you can interrupt the feature 
computation launched after clicking OK, provided that the computation requires at least 5 seconds to perform.
When a computation exceeds 5 seconds, a progress bar appears and provides a Cancel option. To interrupt the operation, 
just click that Cancel button. This interrupts the process and then displays an Update Diagnosis dialog box enabling you to 
edit, deactivate, isolate or even delete the feature.

This capability is available for any types of fillet features you are creating or editing.

More About Variable Radius Fillets 
●     This is the fillet you would obtain using the Linear variation mode. Examine the 

difference!

 

●     To add additional points on the edge to be filleted, you can select planes. The application computes the intersections between 
these planes and the edge to determine the useful points. 

In this example, three planes were selected. Now, if you move these planes later, the application will compute the intersections 
again and modify the fillet accordingly.



●     Points can be added too by selecting 3D points.

●     You can use the radius value R=0 to create a variable radius fillet.

  Variable Radius Fillets Using a Spine 
There may be times when you need to fillet consecutive edges with no tangent continuity but which you want to treat as a single 
edge logically. You can do this by using a spine. Compare the fillets below:

Standard Fillet

 

●     

Fillet Using a Spine

To fillet the edge, the application uses circles contained in planes normal to the spine. It is then possible to control the shape of 
the fillet. 

The spine can be a wireframe element or a Sketcher element.

the Generative Shape Design product license is required to access this capability. 

 
●     



Variable Radius Fillets Using Closed Edges 

●     The application defines a default vertex on closed edges when applying the Variable Radius Fillet command. To define your 
fillet, first of all you need to remove this vertex, and then use 3D points or planes only.

●     The Linear propagation mode is not valid for closed edges and edges continuous in tangency.

 



Reshaping Corners  

Sometimes, while filleting you can see that corners resulting from the operation are not satisfactory. The 
"Blend Corners" capability lets you quickly reshape these corners. 

Open the BlendCorner.CATPart document.

1.  Click the Edge Fillet icon  and fillet the four edges as shown using 5mm as the radius value. 

Careful! When you select edges, the order of selection affects the final shape of the fillet. This 

explains why you may sometimes encounter error messages when filleting.

To obtain the shape we need for our scenario,  select the edges counter-clockwise.

Take a closer look at the resulting corner: the shape style is not satisfactory. 

2.  To round the corner again, double-click the fillet and in the dialog box click the More button to 

access additional options.

3.  Click the Blend corners button to detect the corner to reshape. In our present example, only 

one corner is detected. The application shows it in the geometry area.
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4.  The setback distance determines for each edge a free area measured from the vertex along the 

edge. In this area, the system adds material so as to improve the corner shape.

When the application detects several corners, it is not possible to reshape just a few of them: all of them 
will be edited.

The Blend Corner option is available through the Variable Radius Fillet command  too.

5.  Enter a value in the setback distance field. For example, 13.

6.  Click Preview to examine the result.

To edit the distance for the top edge, click 13 and enter 22 as the new value in the Setback 

distance field.

7.  Repeat the operation for the edge below using the same distance value.



8.  Click OK to confirm the operation.

The corner is reshaped.

  

 



Creating Face-Face Fillets 

 

You generally use the Face-face fillet command when there is no intersection between the faces or 
when there are more than two sharp edges between the faces.

This task shows how to create a basic face-face fillet then a face-face fillet using a hold curve.

 
Open the FaceFillet1.CATPart document.

 1.  Click the Face-Face Fillet icon . 

The Face-Face Fillet Definition dialog box appears.

2.  Select the faces to be filleted. 

3.  Enter a radius value in the Radius field if you are not satisfied with the default one. For example, 

enter 31mm.
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4.  Click Preview to see the fillet to be created.

5.  Click the More button to access the Limiting element option.

Limiting Element

6.  Click the Limiting element field and select Plane.1 as the trimming plane.

An arrow appears on the plane to indicate the portion of material that will be kept.

7.  As you wish to keep the opposite portion of material, click this arrow to reverse the direction. 



 

●     Contextual commands creating the limiting elements you need are now available from the Limiting 
element field:

❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

  

If you create any of these elements, the 
application then displays the 
corresponding icon in front of the 
Limiting element field. Clicking this icon 
enables you to edit the element.

 
8.  Click OK.

The faces are filleted. The fillet is trimmed by Plane.1. This creation is indicated in the 

specification tree.
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Interrupting Fillet Computations

In case you made a mistake when defining a fillet (wrong radius value for example), you can interrupt 
the feature computation launched after clicking OK, provided that the computation requires at least 5 
seconds to perform.
When a computation exceeds 5 seconds, a progress bar appears and provides a Cancel option. To 
interrupt the operation, just click that Cancel button. This interrupts the process and then displays an 
Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the feature.

This capability is available for any types of fillet features you are creating or editing.

Hold Curve 

Instead of entering a radius value, you can use a "hold curve" to compute the fillet. Depending on the 
curve's shape, the fillet's radius value is then more or less variable.

 
Open the FaceFillet2.CATPart document.

The Generative Shape Design product license is required to access this capability. 

●     Contextual commands creating the curves you need are available from the Hold Curve field:
❍     Create Line: For more information, see Creating Lines

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Boundary: see Creating Boundary Curves.

❍     Create Extract: see Extracting Geometry.

❍     Create Intersection: see Creating Intersections.

❍     Create Projection: see Creating Projections.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Hold Curve field. Clicking this icon enables you to edit the element.
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 1.  Prior to performing this task, ensure that Body.1 is set as the current object (to do so, use the 

Define in work object command). Select both faces as shown then expand the dialog box to 

access further options.

2.  Select Join.2 as the hold curve. The curve must be sketched on one of the selected faces. 

 
Spine

3.  Select Sketch.1 as the spine. The spine provides a better control of the fillet.

The spine can be a wireframe element or a Sketcher element.

To compute the fillet, the application uses circles contained in planes normal to the spine. It is 

then possible to control the shape of the fillet.



 
●     Contextual commands creating the spines you need are available from the Spine field:

❍     Create Line: For more information, see Creating Lines

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Boundary: see Creating Boundary Curves.

❍     Create Extract: see Extracting Geometry.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Spine field. Clicking this icon enables you to edit the element.

 
4.  Preview the fillet.

5.  Repeat the operation and select Copy of Sketch.3 as the spine.

The fillet has a different shape.
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Creating Tritangent Fillets 

The creation of tritangent fillets involves the removal of one of the three faces selected.

This task shows how to create a tritangent fillet.

You need three faces two of which are supporting faces.

Open the TritangentFillet.CATPart document.

 1.  Click the Tritangent Fillet icon  .

The Tritangent Fillet Definition dialog box appears.

2.  Select the faces to be filleted. 

3.  Select the face to be removed, that is the upper face. The fillet will be tangent to this face. 

This face appears in dark red.
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Optionally, click Preview to see the fillet to be created.

Limiting Elements

You can trim tritangent fillets to a plane, face or surface. To do so, expand the dialog box and click the 
Limiting element field.

 
4.  Select Plane.2 as the limiting element.

An arrow appears on the plane to indicate the portion of material that will be kept. Clicking this 

arrow reverses the direction and therefore indicates the opposite portion of material.

 
●     Contextual commands creating the limiting elements you need are available from the Limiting 

element field:
❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limiting  
element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting  
element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting  
element.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon in front of 
the Limiting elements field. Clicking this icon enables you to edit the element.

5.  Click OK. 

The faces are filleted. The fillet is trimmed to Plane.2. The creation of this fillet is indicated in 

the specification tree.
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Interrupting Fillet Computations

In case you made a mistake when defining a fillet (wrong radius value for example), you can interrupt 
the feature computation launched after clicking OK, provided that the computation requires at least 5 
seconds to perform.
When a computation exceeds 5 seconds, a progress bar appears and provides a Cancel option. To 
interrupt the operation, just click that Cancel button. This interrupts the process and then displays an 
Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the feature.

This capability is available for any types of fillet features you are creating or editing.

 
Multi-selecting three faces then clicking the Tritangent Fillet icon  tells the application to remove 
the third face.

 



Creating Chamfers 

Chamfering consists in removing or adding a flat section from a selected edge to create a beveled 
surface between the two original faces common to that edge. You obtain a chamfer by propagation 
along one or several edges.

 

This task shows how to create two chamfers by selecting two edges. 

 
Open the Chamfer.CATPart document.

 1.  Click the Chamfer icon  .

The Chamfer Definition dialog box appears. The default parameters to be defined are Length1 

and Angle. You can change this creation mode and set Length1 and Length2.

2.  Select the edges to be chamfered.

Chamfers can be created by selecting a face: the application chamfers its edges.

3.  Keep the default mode: enter a length value and an angle value.
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4.  Optionally, click Preview to see the chamfers to be created.

The application previews the chamfers with the given values.

 

Propagation

Two propagation modes are available: 

●     Minimal: edges tangent to selected edges can be taken into account to some extent. The 
application continues chamfering beyond the selected edge whenever it cannot do otherwise. In our 
example below, the chamfer is computed on the selected edge and on a portion of tangent edges:



  

 
●     Tangency: the application chamfers the entire selected edge as well as its tangent edges. It 

continues chamfering beyond the selected edge until it encounters an edge that is non-continuous in 
tangency as shown in our example:

  

  In our scenario, because both selected edges imply no tangencies, the choice of a propagation 
mode is unnecessary.

5.  Click OK.

The specification tree indicates this creation. These are your chamfers:





Creating Basic Drafts

Drafts are defined on molded parts to make them easier to remove from molds. The characteristic elements 
are:

●     pulling direction: this direction corresponds to the reference from which the draft faces are defined.

●     draft angle : this is the angle that the draft faces make with the pulling direction. This angle may be 
defined for each face.

●     parting element : this plane, face or surface cuts the part in two and each portion is drafted according to 
its previously defined direction. For an example, refer to Creating Drafts with Parting Elements.

●     neutral element : this element defines a neutral curve on which the drafted face will lie. This element will 
remain the same during the draft. The neutral element and parting element may be the same element, as 
shown in Creating Drafts with Parting Elements.

 

There are two ways of determining the objects to draft: either by explicitly selecting the object or by 
selecting the neutral element, which makes the application detect the appropriate faces to use.
This task shows you how to create a basic draft by selecting the neutral element.

 
Open the Draft2.CATPart document.

 1.  Click the Draft Angle icon  .

The Draft Definition dialog box is displayed and an arrow appears on a plane, indicating the 

default pulling direction. This dialog box displays the constant angle draft option as activated. If 

you click the icon to the right, you then access the command for creating variable angle drafts.
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The  icon now available after the Faces to draft field lets you edit the list of the faces to be drafted. 
For more information about that capability, refer to Editing a List of Elements. 

 
2.  Check Selection by neutral face to determine the selection mode.

3.  Select the upper face as the neutral element. This selection allows the application to detect the 

face to be drafted.

The neutral element is now displayed in blue, the neutral curve is in pink. The faces to be drafted 

are in dark red.

The Propagation option can be set to: 

❍     None: there is no propagation

❍     Smooth: the application integrates the faces propagated in tangency onto the neutral face to 
define the neutral element.

For more about the neutral element, refer to A Few Notes about Drafts.

Pulling Direction

The pulling direction is now displayed on top of the part. It is normal to the neutral face.  



The Controlled by reference option is now activated, meaning that whenever you will edit the element 
defining the pulling direction, you will modify the draft accordingly.

Note that when using the other selection mode (explicit selection), the selected objects are displayed in 
dark pink.

 
●     Contextual commands creating the pulling directions you need are available from the Selection field:

❍     Create Line: For more information, see Creating Lines.

❍     Create Plane: see Creating Planes.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the corresponding icon next to the 
Selection field. Clicking this icon enables you to edit the element.

4.  The default angle value is 5. Enter 7 degrees as the new angle value.

The application displays the new angle value in the geometry.



5.  click Preview to see the draft to be created.

It appears in blue.

 
6.  Click More to access additional options. 

To know how to use the options Parting Element and Draft Form, refer to Creating Drafts with Parting 

Elements.

 
Limiting Elements

7.  Click the Limiting Element(s) field. While drafting a face, you can limit it by selecting one or 

more faces or planes that intersect it completely.

8.  Select Plane.1 as the limiting element.

The arrow points to the portion of material to be kept to perform the operation.

9.  Select Plane.2 as the second limiting element.

Note that the number of limiting elements you select is indicated in the dialog box, just in front of 



the Limiting Elements field.

10.  Click the arrow to reverse its direction, and therefore retain the opposite side of the feature.

 When using several limiting elements, make sure that they do not intersect on the face to be drafted.

 Contextual commands creating the limiting elements you need are available from the Limiting 
Element(s) field:

●     Create Plane: for more information, see Creating Planes

●     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the  limiting 
element.

●     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting  
element.

●     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting 
element.

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

●     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and 
Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon next to 
Limiting Element(s). Clicking this icon enables you to edit the element.
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 11.  Click OK to confirm the operation.

The faces are drafted but the part areas included between both limiting planes have not been 

modified, as specified through the limiting element option.

A Few Notes about Drafts 

Editing Drafts 

●     If you edit the sketch used for defining the initial pad, the 
application integrates this modification and computes the 
draft again. In the following example, a chamfer was added 
to the profile.

●     You can now transform a constant angle draft into a variable angle draft. To do so, double-click your draft, 
then click the variable angle draft option in the dialog box to access the appropriate options. For more 
information, refer to Creating Variable Angle Drafts.

Neutral Elements 



●     It is possible to select several faces to define the neutral element. By default, the pulling direction is given 
by the first face you select. This is an example of what you can get:

Draft Definition Result

●     You can use neutral elements that do not intersect the faces to be drafted. This is an example of what you 
can get:

Draft Definition Result

Methodology 



●     If you need to draft several faces using a pulling direction normal to the neutral element, keep in mind the 
following operating mode that will facilitate your design:

❍     Click  and first select the neutral element of your choice. The pulling direction that appears is then 
normal to the neutral element. Select the face to be drafted and click OK to create your first draft. 

❍     Now, to create the other drafts in the same CATPart document, note that by default the application 
uses the same pulling direction as the one specified for creating your first draft. As designers usually 
use a unique pulling direction, you do not need to redefine your pulling direction.

●     If you perform a difficult drafting, for example if you obtain twisted faces, use the Deactivate and Extract 
Geometry commands to solve your difficulties. For more information, refer to Extracting Geometry.

 



Creating Advanced Drafts  

The Advanced Draft command lets you draft basic parts or parts with reflect lines but it also lets you 
specify two different angle values for drafting  complex parts.  

This task shows you how to draft two faces with reflect lines, and this by specifying two different angle 
values and by using both modes available.

We recommend the use of this command to users already familiar with draft capabilities. 

Open the Draft4.CATPart document..

1.  Select View > Toolbars > Advanced Dress-Up Features to access the Advanced Dress-Up 

toolbar.

2.  Click the Advanced Draft icon . 

The Draft Definition (Advanced) dialog box is displayed and you can see a default pulling 

direction (xy plane) in the geometry.
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3.  Specify that you wish to draft two faces with reflect lines by clicking 

both icons as shown:

Note that two modes are available : 

❍     Independent: you need to specify two angle values.

❍     Driving/Driven: the angle value you specify for one face 

affects the angle value of the second face.



If you have a Cast and Forged Part Optimizer license, the Fitted option is also available. This option lets 
you perform a draft operation on two opposite sides of the part while adjusting the resulting faces on the 
parting element you chose.

 For the purposes of our scenario, ensure that the Independent option is on.

The  icon available after the Faces to draft field lets you edit the list of the faces to be drafted. For 
more information about that capability, refer to Editing a List of Elements. 

Neutral Element

4.  In the Neutral Element frame, click No Selection and select the fillet as shown. 

 
Pulling Direction

●     Contextual commands creating the reference elements you need are available from the Selection 
field:

❍     Create Line: For more information, see Creating Lines.

❍     Create Plane: see Creating Planes.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the corresponding icon next to the 
Selection field. Clicking this icon enables you to edit the element.

5.  In the Pulling Direction frame, click Pulling Direction in the Selection field and select the 

part's bottom face to specify a new pulling direction.

6.  Enter 10 as the angle value.



Parting Element

7.  Click the Parting Element tab to define the parting element.

8.  Check the Use parting element option and select the green surface as the parting element.

The Parting Line Adjustment option adjusts the smoothness of the transition zone on the draft 

surface. A transition zone occurs when a neutral element that was driving becomes driven, or 

vice versa. A zero parting line adjustment would yield a sharp edge on the draft surface. Usually, 

the default value (0.1mm) proves to be efficient most of the time. For more information, refer to 

More about the Parting Line Adjustment Option. 

9.  Click the 2nd Side tab to define the second face to be drafted.

10.  In the Neutral Element frame, click No Selection from the combo list and select the second 

fillet.

Both faces to be drafted are now selected. The application displays the reflect line in pink.

11.  Enter 6 as the angle value.



12.  Click OK to confirm.

Both faces are drafted using a distinct angle value, as specified.

 Due to the use of the angle values you have set, this operation results in a "step" where both drafted 
faces meet. To avoid such a result, you can use the Driving/Driven option as explained hereafter. 

Using the Driving/Driven option

13.  Double-click Draft.1 in the specification tree to edit it. 

The Advanced Draft dialog box appears.

14.  Set the Driving/Driven option. You can note that the Driving side option is checked, meaning 

that the angle value you specified for the first face you selected (10 degrees) is the driving value.

15.  If you click the 2nd Side tab, you can notice that the angle value field is no longer available. 

In concrete terms, the application will compute the value for the second face so as to avoid the 

"step effect".

16.  Click OK to confirm the operation.

The application has adjusted the second drafted face.



●     If you prefer to set the angle value you specified for the second face you selected (6 degrees) as the 
driving value, just click the 2nd Side tab and check Driving side.

●     Sometimes, some resulting faces of the "Driven draft" are not apt for being removed from molds. In 
this case, we recommend you to check this using the Draft Analysis capability. 

More about the Parting Line Adjustment Option
You will use the Parting Line Adjustment option to ensure that later on you will be able to apply 

machining techniques onto the part. To illustrate that option, let's consider the part we used in the 

scenario. 

1.  Set the Fitted option.

This option lets you perform a draft operation on two opposite sides of the part while adjusting 

the resulting faces on the parting element you chose.

2.  Keep 0.1mm as the parting line adjustment value, and enter 17 degrees to change the draft 

angle value you previously set to the draft. 

This excessive value does not reflect angle values designers usually use, but this lets us quickly 

see what happens next. You obtain a draft which is not satisfactory. As indicated by the arrow, 

the curvature radius would invalid any machining process because it is too small:



3.  If you click the Top View  icon from the View toolbar, the curvature radius causing trouble 

for being too small, becomes more visible, as pointed to by the arrow:

4.  Now, changing the parting line adjustment value to 0.7 mm would add material up to the curve 

pointed to by the arrow. Consequently, the curvature radius would be more acceptable.

5.  Changing the parting line adjustment value to 0.9mm would let you obtain an even larger 

curvature radius:



 

Concretely speaking, when setting the parting line adjustment parameter, you define a length 

value that sets a maximum thickness to be added to the draft to enlarge the wrong curvature 

radius. As illustrated in the case just above, that length is represented by L. The chosen value is 

0.9mm, which means that L might be 0.9mm or even a little bit less.

Considering the rest of the curvatures of the draft feature, depending on the part shape, that 

thickness will most often be thinner, but will never exceed the value you entered.

Methodology

This option thus adds material to the part. If then you decide to use it, you should keep in mind 

that you need to enter reasonable values not to add too much material prior to machining 

processes. Usually, 0.1mm set as the default value provided by the application, proves to be 

efficient most of the time. 

Concerning draft angle values, again make sure the value you enter does not add too much 

material. In the worst cases, this would prevent you from removing parts from molds. 

In other words, a successful draft operation requires a fine tuning between the draft angle value 

you set and the parting line adjustment you may perform. The challenge being to add the 

minimum material to the part.

Useful Tools

Remember that you can always check curvatures by performing Surface Curvature Analyses and 

draft validity by using the Draft Analysis capability. 



Creating Variable Angle Drafts 

Sometimes, you cannot draft faces by using a constant angle value, even if you set the Square mode. 
This task shows you an another way of drafting: by using different angle values.

Open the  Draft2.CATPart document..

1.  Click the Variable Angle Draft icon .

As an alternative, you can use Draft Angle , then click the Variable Angle Draft icon 

available in the dialog box. For more information, see Creating Basic Drafts. 

The Draft Definition dialog box that appears, displays the variable angle draft option as 

activated. If you click the icon to the left, you then access the command for performing basic 

drafts.

2.  Select the face to be drafted.

Multi-selecting faces that are not continuous in tangency is not allowed for this command. 
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The  icon to the right of the Faces to draft field lets you edit the list of the faces to be drafted. For 
more information about that capability, refer to Editing a List of Elements. 

3.  Select the upper face as the neutral element.

An arrow appears on the part, indicating the default pulling direction. The application detects two 

vertices and displays two identical radius values.

4.  Increase the angle value: only one value is modified accordingly in the geometry.

5.  To edit the other angle value, select the value in the geometry and increase it in the dialog box. 

For instance, enter 9.

Alternatively, double-click this value to display the 
Parameter Definition dialog box, then edit the value.



 6.  Click Preview to see the draft to be created.

7.  To add a point on the edge, click the Points field.

Point

8.  Click a point on the edge.

The application displays the angle value on this point.

❍     You can add as many points as you wish. You can also add points by selecting 3D planes or 
3D points. In this case, the application computes the intersections between these planes and 
the edge to determine the useful points or the projections onto the edge.

❍     If after clicking the points of interest, you decide to change the faces to draft or the neutral 
element, the application removes the points and lets you define points again.

❍     Note that to remove a point from the selection, you just need to click this point.

❍     Contextual commands creating the points you need are available from the Points field:
■     Create Point: For more information, see Creating Points

■     Create Midpoint: creates the midpoint of the line you select

■     Create Endpoint: creates the endpoint of the line you select

■     Create Intersection: see Creating Intersections

■     Create Projection: see Creating Projections

■     Create Plane: see Creating Planes

If you create any of these elements, the application then displays the corresponding icon in 
front of the Points field. Clicking this icon enables you to edit the element.

9.  Enter a new angle value for this point: for example, enter 17. 

The new radius value is displayed.



Clicking the More button displays additional options. To know how to use the options: 

❍     Parting Element, refer to Creating Drafts with Parting Elements.

❍     Limiting Element(s), refer to Creating Basic Drafts

10.  Click OK to confirm.

The final drafted part looks like this:

Closed Edges 

The application defines a default vertex on closed edges when applying the Variable Angle Draft 
command. To define your draft, first of all you need to remove this vertex, and then use 3D points 
or 3D planes only.

 



Creating Drafts with Parting Elements
This task shows how to draft a part by using a parting element. 

Prior to performing this task, refer to Basic Draft, then open the Draft1.CATPart document.

 
1.  Select the face to be drafted. 

2.  Click the Draft Angle icon . 

The Draft Definition dialog box displays and an arrow appears on the part, indicating the default pulling direction. 

The selected face is red and highlighted. The application detects that other faces are to be drafted and displays them 

in light red.

 The  icon now available after the Faces to draft field lets you edit the list of the faces to be drafted. For more information 
about that capability, refer to Editing a List of Elements. 

3.  Click the Selection field and select plane xy to define the neutral element. 

The application displays the neutral curve in pink.

 
4.  Enter 13 degrees as the new angle value. 

For more information, see Angle Values.

5.  Now click More to display the whole dialog box and access the Parting Element capability.
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Parting Element

6.  To define the parting element,  you can check:

❍     Parting = Neutral to reuse the plane you selected as the neutral element, 

or 

❍     Define parting element and then explicitly select a plane or a planar face as the parting element.

7.  Select Parting =Neutral. You then can also check the Draft both sides option as illustrated at the end of the 

scenario. 

To get information about the Draft form option, refer to Angle Values.

 

8.  Click Preview: the draft is displayed in blue.

9.  Click OK. 

Material has been removed, the face is drafted. 



●     Contextual commands creating the parting elements you need are available from the Selection field:

❍     Create Plane: see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the parting element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the parting element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the parting element.

❍     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

❍     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and Extrapolating Curves.

If you create any of these elements, the application then displays the corresponding icon next to the Selection field. 
Clicking this icon enables you to edit the element.

 
10.  In the specification tree, double-click the draft to edit it.

11.  Check Draft both sides to draft the pad in both opposite directions from the parting element.

12.  Click OK to confirm.

The pad now looks like this:

Angle Values 
●     You can draft faces using a negative value.

●     If the chosen angle value exceeds the angle value of the faces adjacent to the face to be drafted, an error message is 
issued. To perform the draft, you then need to activate the Square option available from the Draft form drop list. The 
use of the Square option does not guarantee that parts will be easily removed from their molds.
Here is an example of a drafted face obtained using the Square option:
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Methodology 

If you perform a difficult drafting, for example if you obtain twisted faces, use the Deactivate and Extract Geometry 
commands to solve your difficulties. For more information, refer to Extracting Geometry.



Creating Drafts from Reflect Lines  

 

 

This task shows you how to draft a face by using reflect lines as neutral lines from which the resulting faces will be 
generated. In this scenario, you will also trim the material to be created by defining a parting element.

Open the Draft3.CATPart document.

1.  Click the Draft Reflect Line icon .

The Draft Reflect Line Definition dialog box is displayed and an arrow appears, indicating the default 

pulling direction.

Pulling Direction
●     Contextual commands creating the pulling directions you need are available from the Selection field:

❍     Create Line: For more information, see Creating Lines.

❍     Create Plane: see Creating Planes.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

If you create any of these elements, the application then displays the corresponding icon next to the Selection 
field. Clicking this icon enables you to edit the element.

2.  Select the cylinder.

The application detects one reflect line and displays it in pink. This line is used to support the drafted faces.
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The  icon now available after the Faces to draft field lets you edit the list of the faces to be drafted. For more 
information about that capability, refer to Editing a List of Elements. 

3.  Enter an angle value in the Angle field. For example, enter 11. The reflect line is moved accordingly.

4.  Click Preview to get an idea of what the draft will look like.

5.  Click the More button to expand the dialog box.

Parting Element

6.  Check the Define parting element option and select plane zx as the parting element.

Contextual commands creating the parting elements you need are available from the Selection field:
●     Create Plane: for more information, see Creating Planes

●     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the parting element.

●     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the parting element.

●     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the parting element.

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.



●     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and Extrapolating 
Curves.

If you create any of these elements, the application then displays the corresponding icon next to the Selection 
field. Clicking this icon enables you to edit the element.

Limiting Elements

The Limiting Element(s) option limits the face to be drafted by selecting one or more faces or planes that 
intersect it completely. To know how to use this option, refer to Basic Draft.

Contextual commands creating the limiting elements you need are available from the Limiting Element(s) field:

●     Create Plane: for more information, see Creating Planes

●     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the limiting element.

●     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the limiting element.

●     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the limiting element.

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

●     Create Extrapol: extrapolates surface boundaries or curves. See Extrapolating Surfaces and Extrapolating 
Curves.

If you create any of these elements, the application then displays the corresponding icon next to the Limiting 
Element(s) field. Clicking this icon enables you to edit the element.

7.  Click OK to create the draft.

file:///E|/www/celr16/Doc/online/cfyug_C2/cfyugextrapolcurves.htm
file:///E|/www/celr16/Doc/online/cfyug_C2/cfyugextrapolcurves.htm
file:///E|/www/celr16/Doc/online/cfyug_C2/cfyugextrapolcurves.htm
file:///E|/www/celr16/Doc/online/cfyug_C2/cfyugextrapolcurves.htm


Using the command described in this task, you can draft faces after filleting edges, as illustrated in the example 
below:

The application detects the reflect line on the selected 
fillet. The face is drafted.

  
 



Creating Shells

 

Shelling a feature means emptying it, while keeping a given thickness on its sides. Shelling may also 
consist in adding thickness to the outside. 
This task shows how to create a cavity.

 
Open the Shell.CATPart document.

 
1.  Select the face to be removed.

2.  Click the Shell icon . The Shell Definition dialog box appears.

The selected face becomes purple.

3.   Enter 15mm in the Default inside thickness field.
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4.  Click OK. 

The feature is shelled: the selected face is  left open. This creation appears in the specification 

tree.

5.  Double-click the shell to edit it.

6.  Decrease the inside thickness value. Enter 4mm.

7.  Click OK.

The cylinder is now hollowed:



8.   Double-click the shell again and click the Other thickness faces field.

9.  Select the face as shown.

10.  Double-click the thickness value displayed on this face.

11.  In the dialog box that appears, enter 10mm.

12.  Click OK to confirm and close the dialog box.

13.  Click OK to create the shell feature.

The length between the selected face and the shell is 10mm.

 



A Few Notes About Shells 

●     In some specific cases, you may need to perform two shell operations consecutively. To avoid problems, 
the value for the second shell should be lower by half than the value of the first shell.

●     If you need to shell a multi-domain body, perform only one Shell operation : select one face by domain to 
avoid problems. The specification tree then includes only one Shell feature as illustrated below.



Solving Problems 

Ignoring Faces 

In some specific cases, the application cannot shell the selected face. An error message appears informing you 
that the body cannot be built properly. After closing that window, another message appears proposing you to 
ignore the faces causing trouble. If you accept that solution, the shell is performed and the face causing 
trouble is removed.

Later on if you edit the shell, the ignored face is previewed and the Reset ignored faces option is then 
available in the Shell Definition dialog box.

By checking this option, the ignored face is reinitialized and the indication Ignored face in the geometry is 
deleted. If the check box is unchecked, the previous ignored face is still taken into account for the next feature 
definition.

Ignoring faces in many cases  avoids a costly and difficult manual rework of the part.



 

Extracting Geometry 

Sometimes, you will need to use Extract to be able to add thickness to a face. The Extract capability lets you 
generate separate elements from initial geometry, without deleting geometry. This command is available after 
clicking a dialog box prompting you to deactivate the shell and extract the geometry. Once the operation has 
been done, the Extracted Geometry (Shell.1) node is displayed in the tree. This category includes the 
elements created by the application.

The Extract capability is available if only one face was selected to perform the shell operation.

Note also that if you have Generative Shape Design installed, the geometry resulting from the Extract 
operation is associative.



Creating Thicknesses

 

Sometimes, some thicknesses have to be added or removed before machining the part. 
This task shows you how to add thickness to a part.

 
Open the Thickness.CATPart document..

 1.  Click the Thickness icon  . 

The Thickness Definition dialog box is displayed.

2.  Select the faces to thicken, i.e. both faces as shown:

3.  The faces become red and the application displays the thickness value in the geometry.

4.  Enter a positive value. For example, enter 15 mm.

5.  Click OK.
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The part is thickened accordingly. This creation appears in the specification tree.

6.  Double-click the thickness to edit it.

7.  Click the Other thickness faces field and select the lateral face as shown.

8.  Double-click the thickness value displayed on this face.

9.  In the dialog box that appears, enter 25mm.

10.  Click OK to confirm and close the dialog box.

11.  Click OK to create the thickness feature.

12.  The length between the selected face and the resulting face is 25mm.



A Few Notes About Thickness 

In some specific cases, the application cannot offset the selected face. An error message appears informing 
you that the body cannot be built properly. After closing that window, another message appears proposing you 
to ignore the faces causing trouble. If you accept that solution, the thickness is added to the selected face and 
the face causing trouble is removed. 

Ignoring faces in many cases avoids a costly and difficult manual rework of the part.

In the basic example below, the face causing trouble is the variable radius fillet.

After ignoring the fillet, the thickened body looks like this:



 
The fillet icon is still displayed in the specification tree.

If you edit the thickness, the ignored face is previewed:

The Reset ignored faces option is then available in the Thickness Definition dialog box.

By checking this option, the  ignored face is reinitialized and the Ignored face indication in the geometry is 
deleted. If the check box is unchecked, the previous ignored face is still taken into account for the next feature 
definition.

Extracting Geometry 

Sometimes, you will need to use the Extract command to be able to add thickness to a face. The Extract 
capability lets you generate separate elements from initial geometry, without deleting geometry. This 
command is available after clicking a dialog box prompting you to deactivate the thickness feature and extract 
the geometry. Once the operation has been done, the Extracted Geometry (Thickness.1) node is displayed 
in the tree. This category includes the elements created by the application.

The Extract capability is available if only one face was selected to perform the thickness operation.

Note also that if you have Generative Shape Design installed, the geometry resulting from the Extract 
operation is associative.

 



Creating Threads and Taps 

 

The Thread-Tap capability creates threads or taps, depending on the cylindrical entity of interest. 

This task shows you how to thread a cylindrical pad. Click Creating threads on on conic faces for 
reference information.

 
Open the Thread.CATPart document.

 

1.  Click the Thread/Tap icon .

The Thread/Tap Definition dialog box is displayed. 

2.  Select the cylindrical surface you wish to thread, that is Face.1.
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From V5R15 onward, thread and tap definitions no longer depend on the polarity of the cylinder 

geometry. The Thread/Tap capability now lets you specify whether you wish to create a thread 

or a tap just by checking the appropriate option.

Because of the geometrical element type you have just selected, by default, the application 

proposes you to create a thread. As shown below, the Thread option is now enabled and a new 

help image is displayed in the dialog box:

However, if you prefer to create a tap, just check Tap.

3.  Select the upper face as the limit face. Limit faces must be planar.

The application previews the thread.

 



In the dialog box, the Geometrical Definition frame displays the name of the faces you have 

selected. The Reverse Direction button (as well as the arrow in the geometry area) lets you 

reverse the thread direction if needed.

The Numerical Definition frame provides three different thread types:

❍     No Standard: if you keep the No Standard option, the field available below is Thread 
Diameter. You just need to enter the values you need in this field as well as in the fields 
below.

❍     Metric Thin Pitch: uses ISO standard values 

❍     Metric Thick Pitch: uses ISO standard values

In addition to these three types, you can add your personal standards as described in Reusing 

Values Already Defined in a File

 

●     Metric Thin Pitch: ISO standard 

Refer to ( ISO 965-2 ).

The application uses the minimum standard values. 

Nominaldiam  Pitch Minordiam 

8.0 1.0 6.917

10.0 1.0 8.917

10.0 1.25 8.647

12.0 1.25 10.647

12.0 1.5 10.376



14.0 1.5 12.376

16.0 1.5 14.376

18.0 1.5 16.376

18.0 2.0 15.835

20.0 1.5 18.376

22.0 1.5 20.376

22.0 2.0 19.835

24.0 2.0 21.835

27.0 2.0 24.835

30.0 2.0 27.835

33.0 2.0 30.835

36.0 3.0 32.752

39.0 3.0 35.752

42.0 3.0 38.752

45.0 3.0 41.752

48.0 3.0 44.752

52.0 4.0 47.67

56.0 4.0 51.67

60.0 4.0 55.67

64.0 4.0 59.67

●     Metric Thick Pitch: ISO standard 

Refer to ( ISO 965-2 ).

The application uses the minimum standard values. 

Nominaldiam        Pitch Minordiam 

1 0.25 0.729

1.2 0.25 0.929

1.4 0.3 1.075

1.6 0.35 1.221

1.8 0.35 1.421

2.0 0.4 1.567



2.5 0.45 2.013

3.0 0.5 2.459

3.5 0.6 2.850

4.0 0.7 3.242

5.0 0.8 4.134

6.0 1.0 4.917

7.0 1.0 5.917

8.0 1.25 6.647

10.0 1.5 8.376

12.0 1.75 10.106

14.0 2.0 11.835

16.0 2.0 13.835

18.0 2.5 15.294

20.0 2.5 17.294

22.0 2.5 19.294

24.0 3.0 20.752

27.0 3.0 23.752

30.0 3.5 26.211

33.0 3.5 29.211

36.0 4.0 31.670

39.0 4.0 34.670

42.0 4.5 37.129

45.0 4.5 40.129

48.0 5.0 42.587

52.0 5.0 46.587

56.0 5.5 50.046

60.0 5.5 54.046

64.0 6.0 57.505



●     No Standard 

4.  For the purposes of our scenario, keep No Standard. As you are creating a thread, you cannot 

modify the thread diameter value. If you were creating a tap, you could modify it.

Note that the Edit formula... contextual command is available from the Thread Diameter field, 

meaning that you can define formulas for managing diameters values.

5.  Enter 49 mm as the thread depth.

Note that the Support Diameter and Support height fields are grayed. They are merely 

informative. 

6.  Enter 1.5 mm as the pitch value. The Pitch field defines the distance between each crest.

7.  Check Left-Threaded.

8.  Click Preview.

Red lines provide a simplified representation of the thread.

9.  Click OK to confirm. 

There is no geometrical representation is the geometry area, but the thread (identified as 

Thread.xxx) is added to the specification tree. The corresponding icon is specific to this feature. 

Diameter, depth and pitch values appear below Thread in the specification tree.



If you create a tap, the application identifies it as Thread.XXX too in the specification tree, but 

displays a specific icon as shown below:

●     Reusing Values Already Defined in a File 

Instead of using the No Standard type, you can use predefined standards stored in a personal file. There 
are two ways of accessing values listed in a file: either by navigating to the file of interest or by making 
this data available prior to launching the Hole command. For more, see the file is already available.

By navigating to the file you need 

When creating taps, if you wish to use values already defined in one of your files, click the Add button to 
access this file. A dialog box displays, in which you can navigate to reach the file containing your own 
values. This file may be of one of the following types: 

- Microsoft Excel files (general format)



- Lotus files

- tabulated files (in Unix environment)

The values defined in your file will apply specifically to the part of your CATPart document, not to other 
documents. For more about using predefined values, refer to Creating Threaded Holes, steps 6 to 9. The 
operating mode described in this task is valid for threads and taps too.

By selecting the file from the Type list: the file is already available 

This behavior is made possible only if the administrator has performed these operations:

The administrator first needs to locate in a directory the source files used for the standards. For 
example, he can select E:/uses/standard as the directory containing the StandardGaz.txt file. Then, he 
has to concatenate this path with the official path in the CATReffilesPath environment variable as follows:

Set CATReffilesPath=Officialpath ; E:/user/standard 

●     You can extract drawings from threads and taps in the Generative Drafting workbench. For more, see 
Generative Drafting User's Guide Version 5.

●     You obtain a hole, not a tapped hole, by removing a threaded cylinder from a body. 

Cavities on cylindrical surfaces 

●     If the cavity is a hole, proceed using the options available in the Hole Definition dialog box as 
described in Creating Threaded Holes.

●     If the cavity is a groove or a pocket defined on a cylindrical surface, you must use a plane tangent to 
the surface as the limit face.



Creating threads on conic faces

From V5R16 onward, it is possible to thread conic faces. The following figures illustrate how the different 
parameters you need to value are defined:

Threads

Note that if the thread diameter value is not equal to the support diameter at the limit plane, the 
application issues an error message.

Taps

The thread diameter must be greater than the support diameter at the limit plane, otherwise, the 
application issues an error message.

 



Creating Remove Face Features

When parts are far too complex for finite elements analyses, there is a way of making them more 
simple. This task shows you how to simplify a part by removing some of its faces.

Open the Update.CATPart document. As the Remove Face capability only deals with the geometry of 
the part, not the history of its design, you can use it for imported parts, like in the following scenario, or 
Version 4 parts. 

1.  Click the Remove Face icon . 

The Remove Face Definition dialog box appears.

2.  Select the inner face as the face to be removed. 

The face turns purple indicating that it will be removed.

3.  Click the Faces to keep field and select both faces as shown.

The faces turn blue, indicating that they will not be removed.
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4.  Check the Show all faces to remove option to preview all the faces adjacent to the purple face 

that will be removed.

5.  Click OK to confirm.

All of the faces have been removed. The new feature identified as RemoveFace.XXX is added to 

the specification tree.



6.  Launch the command again and select the faces as shown as the faces to be removed.

Two contextual commands are available from the Faces to remove field:

❍     Clear selection: removes all selected faces from the selection.

❍     Tangency propagation: includes all faces tangent to selected faces in the selection

 From the Faces to keep field, only the Clear selection contextual command is available.



 7.  Click OK to confirm.

All selected faces have been removed. The new feature identified as RemoveFace.XXX is added 

to the specification tree.

 



Creating Replace Face Features

 

The Replace Face capability lets you replace a face or a set of tangent faces with:
●     a surface or,

●     a face belonging to the same body as the selected face. 

The last two scenario show you the benefits provided by the capability: you can align faces, which is 
sometimes a way of simplifying volumes, but also adjust shapes prior to manufacturing operations.

The first scenario shows you how to modify the shape of a part by extruding one of its face up to an 
external surface. 

Open the Faces.CATPart document.

 1.  Click the Replace Face icon .

The Replace Face Definition dialog box appears.

2.  Select the yellow surface as the replacing surface.

3.  Click the arrow to reverse the indicated direction.

4.  Select the part's bottom face. 

The face turns purple indicating that it will be replaced.
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5.  Click OK to confirm the operation.

The part has been reshaped and the new feature (identified as ReplaceFace.xxx) is added to 

the specification tree.



 

Replacing Faces with Other Faces

From V5R15 onwards, you can:

●     Align a face with another face as illustrated in this second scenario.

●     Replace a set of tangent faces with a set of other tangent faces as illustrated in the last scenario. 

Aligning Faces

To perform this scenario, you will use Body.3 which you will have previously set as the current body.

1.  Click the Replace Face icon .

2.  Select the horizontal face on the smaller pad. 

The first face you select is always the replacing face. Once selected, it is shown in blue.

3.  Select the horizontal face from the left pad.

Once selected, the face to be replaced is shown in purple.

4.  Click OK to confirm the operation.

Both faces are aligned.



To perform this scenario, use Body.2.

1.  Click the Replace Face icon .

2.  Select the horizontal face on the left. 

This face, which is the replacing face is now displayed in blue. Because it is tangent to the face 

produced by a fillet operation, that face is also selected and in turn includes the vertical face. 

Three faces are then selected as indicated by the blue color.

3.  Select the horizontal face on the right.

Three tangent faces are selected as the faces to be replaced and are shown in purple:

4.  Click OK to confirm the operation.

The result you obtain shows that replacing these faces affects the fillet radius value to the left.

Replacing Faces



Automatic Reroute

Automatic reroute of children takes place if you replace a face by a surface with only one face. In case of 
complicated industrial CATPart documents containing several topological faces, manual reroute of children may 
be required to be done, depending on the complexity of the document.

 



Surface-Based Features
 

 
Create a Split: Click this icon, select the body to be split then the splitting element.

Create a Thick Surface: Click this icon, select the object to be thickened, define the offset 
directions and enter offset values.

Create a Close Surface: Click this icon, select the body and select the object to be closed.

Create a Sew Surface: Click this icon, select the body and the surface to be sewn.



Creating Splits

 

You can split a body with a plane, face or surface. The purpose of this task is to show how to split a body 
by means of a surface.

Open the Split.CATPart document.

 1.  Click the Split icon . 

2.  Select Surface.1 as the splitting surface.

The Split Definition dialog box is displayed.

An arrow appears indicating the portion of body that will be kept. If the arrow points in the wrong 

direction, you can click it to reverse the direction.
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Contextual commands creating the splitting elements you need are available from the Splitting 
Element field:

●     Create Plane: for more information, see Creating Planes

●     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the splitting 
element.

●     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the splitting 
element.

●     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the splitting 
element.

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

●     Create Extract: See Extracting Geometry.

If you create any of these elements, the application then displays the corresponding icon next to the 
Splitting Element field. Clicking this icon enables you to edit the element.

4.  Click OK.

The body is split. Material has been removed. The specification tree indicates you performed the 

operation.

 

Avoid using input elements that are tangent to each other since this may result in geometric instabilities 
in the tangency zone.

 

Hybrid Design

When adding a surface-based feature or a surface feature modifying another surface-based feature or 
surface belonging to the same body, Part Design features based on that second feature then reference 
the new added feature. In other words, a replace operation is automatically performed. Let's take an 
example.

Open the AutomaticReplace.CATPart document.
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1.  Double-click Split.1 and note that this feature references Extrude.1.

2.  Define Extrude.1 as the current object using Define in Word Object.

3.  Go into Shape Design workbench and create an Edge Fillet onto the faces of Extrude.1 using this 

Edge Fillet command .

4.  If required, update Split.1 (local update).

5.  Double-click Split.1 and note that it now references EdgeFillet.2.

This behavior differs from what happens in a non-hybrid design environment.  In a traditional 

environment, Split.1 would not have been affected by the insertion of EdgeFillet.2. and would still 

reference Extrude.1.

 



Creating Thick Surfaces 

 

You can add material to a surface in two opposite directions by using the Thick Surface capability. This 
task shows you how to do so.

 
Open the ThickSurface.CATPart document.

 
1.  Select the element you wish to thicken, that is the extrude element.

2.  Click the Thick Surface icon .

The Thick Surface Definition dialog box is displayed.

In the geometry area, the arrow that appears  on the extrude element indicates the first offset 

direction. If you need to reverse the arrow, just click it.
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3.   Enter 10mm as the first offset value and 6mm as the second offset value . 

 

Two contextual commands creating the object you need are available from the Object to offset field:
●     Create Join: joins surfaces or curves. For more information, see Joining Surfaces or Curves.

●     Create Extract: See Extracting Geometry.

If you create any of these elements, the application then displays the corresponding icon next to the 
Object to offset field. Clicking this icon enables you to edit the element.

4.  Click OK.

The surface is thickened. The specification tree indicates you performed the operation. Note that 

the resulting feature does not keep the color of the original surface.
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Extracting Geometry 

Sometimes, you will need to use the Extract command to be able to add thickness to a face. The 
Extract capability lets you generate separate elements from initial geometry, without deleting geometry. 
This command is available after clicking a dialog box prompting you to deactivate the Thick Surface 
feature and extract the geometry. Once the operation has been done, the Extracted Geometry 
(ThickSurface.1) node is displayed in the tree. This category includes the elements created by the 
application.

The Extract capability is available if only one face was selected to perform the Thick Surface operation.

Note also that if you have Generative Shape Design installed, the geometry resulting from the Extract 
operation is associative.

 

Hybrid Design

When adding a surface-based feature or a surface feature modifying another surface-based feature or 
surface belonging to the same body, Part Design features based on that second feature then reference 
the new added feature. In other words, a replace operation is automatically performed. For an example, 
refer to Creating Splits.



Creating Close Surface Features

 

This task shows you to close surfaces.

 
Open the CloseSurface.CATPart document.

 
1.  Select the surface to be closed, i.e. Trim.3.

2.  Click the Close Surface icon .

The Close Surface Definition dialog box is displayed.

Two contextual commands creating the object you need are available from the Object to close field:

●     Create Join: joins surfaces or curves. See Joining Surfaces or Curves.

●     Create Extract: See Extracting Geometry.

If you create any of these elements, the application then displays the corresponding icon next to the 
Object to close field. Clicking this icon enables you to edit the element. 

3.  Click OK.

The surface is closed. The specification tree indicates you performed the operation. 
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Hybrid Design

When adding a surface-based feature or a surface feature modifying another surface-based feature or 
surface belonging to the same body, Part Design features based on that second feature then reference 
the new added feature. In other words, a replace operation is automatically performed. For an example, 
refer to Creating Splits.



Creating Sew Surfaces  

Sewing is a Boolean operation combining a surface with a body. This capability adds or removes material by 
modifying the surface of the solid. 

You can sew all types of surfaces onto bodies. Depending on your geometry, two kinds of sewing operations 
can be performed: 

●     If the surface has been designed so that its boundary entirely lays on the solid, you can sew it using the 
surface boundary projection onto the solid. In this case you can use the Simplify Geometry option or not 
(unchecked option).

Sewing features (in boundary projection mode) is more productive (CPU cost) and more stable (geometric 
tangency condition) than creating a solid using the Close Surface command (when possible) because no 
surface/surface intersections are computed.

●     If the surface crosses the solid,  you can make the application compute the intersection of the surface 
with the solid prior to sewing the surface. In this case, you need to use the Intersect body option.

This task shows you both methods.

Open the SewSurface.CATPart document.

1.  The surface boundary is on the solid. Select Join.1 as the surface you wish to sew onto the body.

2.  Click the Sew Surface icon .

The Sew Surface Definition dialog box is displayed:
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With topology simplification

Keep the Simplify geometry option active. Using this option, if in the resulting solid there are 

connected faces defined on the same geometric support (faces separated by smooth edges), these 

faces will be merged into one single face.

Arrows appear indicating the side where material will be added or kept. Note that clicking an arrow 

reverses the given direction. The arrows must point towards the solid. 

3.  Click OK.

The surface is sewn onto the body. You may notice that the bottom of the solid is made of one 

single face. The specification tree indicates you performed the operation.

4.  To see the simplification, just hide Join.1.

Some operations you perform after sewing using Simplify geometry may make the simplified 

geometrical result disappear. As shown in the example below, filleting an edge belonging to a sewn 

surface makes the sewn geometry disappear.

Sewn Geometry Filleted Edge
 



 

Without topology simplification

5.  Double-click SewSurface.1 in the specification tree to edit it and deactivate the Simplify 

geometry option.

6.  Click OK.

The bottom of the solid is made of three connected faces. The smooth edges resulting from the 

sewing appear because no topological simplification has been performed.

Using the "Intersect body" option 

You will use the Intersect body option when the surface straightly crosses the solid without being tangent. 
The application then needs to compute the intersection between the surface and the solid, the portions of 
surface with "free edges" being eventually removed.

Note that Intersect body should not be used in case of solids having Through holes or pockets and where 
it is not possible for surface to add material for sew operation.



 

In the following example, the application can compute the intersection:

Checking Intersect body in the Sew Surface Definition dialog box automatically activates the Simplify 
geometry option.

The arrow indicates the portion of material  that will be kept:
 

The surface is sewn onto the body. Some material has been removed. 



If you have a Cast and Forged Part Optimizer license, you can also remove faces while sewing surfaces onto 
bodies.

 

Hybrid Design

When adding a surface-based feature or a surface feature modifying another surface-based feature or 
surface belonging to the same body, Part Design features based on that second feature then reference the 
new added feature. In other words, a replace operation is automatically performed. For an example, refer to 
Creating Splits.

   



Transformation Features

Create a Translation: Click this icon, select the body to be translated, define the translation direction 
and enter the distance value.

Create a Rotation: Click this icon, select the body to be rotated, define the rotation axis and enter 
the angle value.

Create a Symmetry: Click this icon, select the body to be duplicated and define the symmetry 
reference.

Create a Mirror: Click this icon, select the body to be mirrored and define the reference.

Create a Rectangular Pattern: Click this icon,  select the feature to be duplicated, define the creation 
directions, choose the parameters you wish to define and set these parameters.

Create a Circular Pattern: Click this icon, select the feature to be duplicated, define the axial 
reference, the creation direction, choose the parameters you wish to define and set these 
parameters.

Create a User Pattern: Click this icon, select the feature to be duplicated, set whether you keep the 
original specifications or not and define the positions.

Exploding Patterns: Right-click the pattern you want to explode and select the RectPattern.1object > 
Explode... contextual command.

Create a Scaling: Click this icon, select the body to be scaled, define the reference and enter a factor 
value.

 



Creating Translations 

 

The Translate command applies to current bodies. This task shows you how to translate a body. 

 

To perform this task, open the CATPart of your choice.

 1.  Click the Translate icon .

The application issues a question about the result you wish to obtain:

❍     you can decide to keep the new specifications induced by the operation: in this case, just click 
Yes to go on using the command you have just selected.

OR

❍     you can decide not to keep the new specifications: in this case, click No to cancel the 
command you have just launched.

2.  Click Yes.

The Translate Definition dialog box appears.

3.  Select a line to take its orientation as the translation direction or a plane to take its normal as the 

translation direction. For example, select zx plane.

You can also specify the direction by means of X, Y, Z vector components by using the contextual 

menu on the Direction area. 

4.  Specify the translation distance by entering a value or using the Drag manipulator. For example, 

enter 100mm.

5.  Click OK to create the translated element.

The element (identified as Translat.xxx) is added to the specification tree.



 



Creating Rotations

 

This task shows you how to rotate geometry about an axis. There are different ways of calculating 
rotation axes, depending on the reference geometry you select. 

Open the Rotate.CATPart document.

1.  Click the Rotate icon .

The application issues a question about the result you wish to obtain:

❍     you can decide to keep the new specifications induced by the operation: in this case, just click 
Yes to go on using the command you have just selected.

OR

❍     you can decide not to keep the new specifications: in this case, click No to cancel the 
command you have just launched.

2.  Click Yes.

The Rotate Definition dialog box appears. 

The command applies to current bodies. Since PartBody is the current body, the command does 

not affect Pad.2.

3.  Define the rotation mode:
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❍     Axis-Angle (default mode): the rotation axis is defined by a linear element and the angle is 

defined by a value that can be modified in the dialog box or in the 3D geometry by using the 

manipulators. 

❍     Axis-Two Elements: the rotation axis is defined by a linear element and the angle is defined 

by two geometric elements (point, line or plane) 

■     Axis/point/point: the angle between the vectors is defined by the selected points and their 

orthogonal projection onto the rotation axis.

■     Axis/point/line: the angle between the vector is defined by the selected point and its 

orthogonal projection onto the rotation axis and the selected line.



■     Axis/line/line: the angle between the direction vectors of the projection is defined by the 

two selected lines in the plane normal to the rotation axis.

In case both lines are parallel to the rotation axis, the angle is defined by the intersection 

points of the plane normal to the rotation axis and these lines.

■     Axis/line/plane: the angle is defined between the selected line and the normal to the 

plane.



■     Axis/plane/plane: the angle is defined between the line normal to the two selected planes.

❍     Three Points:  the rotation is defined by three points.

■     The rotation axis is defined by the normal of the plane created by the three points passing 

through the second point. 

■     The rotation angle is defined by the two vectors created by the three points (between 

vector Point2-Point1 and vector Point2-Point3):



The orientation of the elements (lines or planes) is visualized in the 3D geometry by a red arrow. 

You can click the arrow to invert the orientation and the angle is automatically recomputed. By 

default, the arrow is displayed in the direction normal to the feature (line or plane).

For instance, in the plane/plane mode, the arrow is displayed on each plane:

4.  For the purpose of our scenario, set Three Points as the definition mode you want.

5.  Select three vertices of Pad.2 as the three points required.

The application calculates the rotation axis from these points: altogether they create a plane. The 



normal to that plane passing thru the second vertex you selected is the rotation axis that will be 

used. The rotation angle is defined by the two vectors created by the three vertices (between 

vector Point2-Point1 and vector Point2-Point3):

Example 1

Example 2

6.  Click OK to create the rotated element.

The element (identified as Rotate.xxx) is added to the specification tree. 

 



Symmetry 

 

This task shows you how to transform  geometry by means of a symmetry operation. The Symmetry 
command applies to current bodies.

Open the Symmetry.CATPart document.

 1.  Click the Symmetry icon .

The application issues a question about the result you wish to obtain:

❍     you can decide to keep the new specifications induced by the operation: in this case, just 
click Yes to go on using the command you have just selected.

OR

❍     you can decide not to keep the new specifications: in this case, click No to cancel the 
command you have just launched.

2.  Click Yes.

The Symmetry Definition dialog box appears.

3.  Select a point, line or plane as reference element. For the purpose of our scenario, select plane 

zx.

4.  Click OK to create the symmetrical element.

The original element is no longer visible but remains in the specification tree. The new element 

(identified as Symmetry.xxx) is added to the specification tree.
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Mirror 
Mirroring a body or a list of features consists in duplicating these elements using a symmetry. You can 
select a face or a plane to define the mirror reference.

This task shows how to mirror a list of features.

 
Open the EdgeFillet3.CATPart document.

 
1.  Multi-select both pads as the features to be mirrored.

2.  Click the Mirror icon .

The Mirror Definition dialog box appears.

3.  Select the lateral face to define the mirror reference.

The application previews the material to be created. 

4.  Click OK to confirm the operation.

The pads are mirrored and the specification tree mentions this creation.
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A Few Notes about Mirror

●     Using a plane to mirror a body lets you obtain two 
independent portions of material in a same body. 
The following mirror is obtained by using plane zx 
as the reference.

●     When editing a mirror feature, contextual commands creating the mirror references you need are 
now available from the Mirroring element field:

❍     Create Plane: for more information, see Creating Planes

❍     XY Plane: the XY plane of the current coordinate system origin (0,0,0) becomes the mirroring 
element.

❍     YZ Plane: the YZ plane of the current coordinate system origin (0,0,0) becomes the mirroring 
element.

❍     ZX Plane: the ZX plane of the current coordinate system origin (0,0,0) becomes the mirroring 
element.

If you create any of these elements, the application then displays the corresponding icon next to the 
Mirroring element field. Clicking this icon enables you to edit the element.

 



Creating Rectangular Patterns 
 

You may need to duplicate the whole geometry of one or more features and to position this geometry on a part. Patterns let you do so, and 
by the way accelerate the creation process.

The application allows you to define three types of patterns: 

●     Rectangular 

●     Circular

●     User patterns.

This document deals with the following:

●     How to create a rectangular pattern (step-by-step scenario)

●     Instances and Unequal Spacing

●     Complex Patterns

●     Patterning Current Solids

●     Patterning User Defined Features (UDFs)

You can also find information about patterns and updates by reading Optimizing Part Design Application, Patterns.

 

This task shows you how to duplicate the geometry of one pocket right away at the location of your choice using a rectangular pattern. 
Then, you will learn how to modify the location of the initial feature.

 
Open the RectangularPattern.CATPart document.

 
1.  Select the feature you wish to copy, that is the pocket as shown: 

2.  Click the Rectangular Pattern icon .

The Rectangular Pattern Definition dialog box that appears displays the name of the geometry to pattern.

If you click the Rectangular Pattern icon  prior to selecting any geometry, by default, the object to be patterned is the 

current solid. For more information, refer to Patterning Current Solids. 
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If you change your mind and decide to pattern the current solid, click the Object field and use the Get current solid 

contextual command.

Each tab is dedicated to a direction you will use to define the location of the duplicated feature. In this task, you will first set 

your specifications for the first direction.

Keep Specifications Option

Checking the Keep specifications option creates instances with the limit Up to Next ( Up to Last, Up to Plane or Up to Surface) 
defined for the original feature. In the example below, the limit defined for the pad, i.e. the Up to surface limit, applies to all 
instances. As the limiting surface is not planar, the instances have different lengths.

 

But for the purposes of our scenario, as the pocket's height is specified, activating the Keep specifications option is meaningless.

The Keep specifications option is not available if you are patterning a pattern.



 
Reference Direction

3.  Click the Reference element field and select the edge as shown below to specify the first direction of creation.

An arrow is displayed on the pad. If needed, click the Reverse button or click the arrow to modify the direction.

 
 

 

●     To define a direction, you can select an edge or a planar face.

●     Contextual commands creating the reference elements you need are available from the Reference element field:
❍     Create Line: For more information, see Creating Lines.

❍     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

❍     Create Plane: see Creating Planes.

If you create any of these elements, the application then displays the corresponding icon next to the Reference element field. 
Clicking this icon enables you to edit the element.

4.  Let the Instances & Spacing options to define the parameters you wish to specify.

The parameters you can choose are: 

❍     Instances & Length

❍     Instances & Spacing

❍     Spacing & Length

❍     Instances & Unequal Spacing:  distinct spacings can be assigned between instances. 

Choosing Instances & Spacing dims the Length field because the application no longer needs this specification to space the 
instances.

 

If you set Instances & Length or Spacing & Length parameters, note that you cannot define the length by using formulas.

5.  Enter 3 as the number of instances you wish to obtain in the first direction.



 

Deleting the instances of your choice is possible when creating the pattern. In the pattern preview, just select the points materializing 
instances. Conversely, selecting these points again will make the application create the corresponding instances.

6.  Define the spacing along the grid: enter 14 mm.

Defining the spacing along the grid and length of your choice would make the application compute the number of possible instances 
and space them at equal distances.

7.  Now, click the Second Direction tab to define other parameters.

Note that defining a second direction is not compulsory. Creating a rectangular defining only one direction is possible.

8.  Click the Reference element field and select the edge to the left to define the second direction.

If necessary, click the Reverse option to make the arrow point in the opposite direction.

9.  Let the Instances & Spacing option: enter 3 and 10 mm in the appropriate fields.

10.  Click Preview to make sure the pattern meets your needs.

Additional pockets will be aligned along this second direction.



11.  Click OK to repeat the pocket's geometry nine times.

This is the resulting pattern. RectPattern.1 feature is displayed in the specification tree. 

12.  Let's now edit the pattern to make it more complex: double-click the pattern to display the dialog box.

13.  Click the More button to display the whole dialog box. 

The options available let you position the pattern.



 
15.  To modify the position of the pockets, enter -5 degrees as the rotation angle value.

16.  Click Preview.

You can notice that all pockets have moved slightly:

17.  Now, modify the location of the initial pocket. To do so, enter 2 in the Row in Direction 1 field.

The application previews how the pattern will be moved. It will be moved along the direction as indicated:

18.  Finally, enter 2 in the Row in Direction 2 field.

The application previews how the pattern will be moved. It will be moved along these two directions defined in steps 17 and 

18: 



The Simplified representation option lightens the pattern's geometry. What you need to do is just check the option and double-click 
the instances you do not want to see. The instances are then represented in dashed lines during the pattern definition and then are no 
longer visible after validating the pattern creation. 

When the Simplified representation option is on, because the pattern's geometry representation is modified, the part mass is 
modified too.

This option is particularly used for patterns including a large number of instances. 

19.  Click OK.

The application has changed the location of all pockets. Only four of them remain on the pad.

 

Instances and Unequal Spacing

You can assign specific spacing values between each instance by proceeding as follows:

1.  Create a new pattern for the purpose of this task: select Pocket.1 as the object to pattern, and first set the Instances & 

Length parameter using the length values as shown here:

2.  Set the Instances & Unequal Spacing parameter for the first direction.

Spacing values are displayed between each instance.

3.  To edit the values between each instance, you need to edit values individually. First, select the spacing of interest if not already 

done.



4.  Then, choose one of the methods described hereafter: For example, if you wish to change 10mm for 17mm for the selected 

spacing, you can:

❍     double-click the length value in the geometry area. This displays the Parameter Definition dialog box in which you can 
enter the new value.

❍     directly enter the new value in the Spacing field of the Rectangular Pattern Definition dialog box.

5.  Repeat the operation for the other spacings.

6.  Click OK when done.

 
Removing Instances

Remember that clicking an instance once removes the instance from the specifications. Clicking once or double-clicking an instance 
does not lead to the same result then.

It is possible to create Cartesian patterns with variable steps. To do so, you need to define formulas. For more information, refer to 
Knowledge Advisor User's Guide Version 5.

 
●     During your design, you may need to rework instances specifically. You will then have to use the Explode contextual command to 

delete your pattern while keeping geometry. For more information, refer to Exploding Patterns.



 

Complex Patterns 

You can pattern a list of Part Design features by proceeding as follows:

1.  Multi-select the features to be duplicated.

These features must belong to the same body.

2.  Click the Rectangular Pattern icon .

The features are indicated in the Object field.

3.  Set the parameters you need as shown in the task above.

These rules are to be kept in mind before patterning a list of features.

❍     When multi-selecting, the first feature you select must not be a dress-up feature.

❍     Your list of features cannot include any transformation features, nor shells, nor splits, nor associated bodies.

❍     Your list of features cannot include any body.

 
Editing a List of Features 

Editing a list of features consists in adding or removing features from the list. To do so, you just have to click the Object field and 
select the feature of interest to add it or remove it from the list. 

Note however that adding a feature to a pattern is possible only if your pattern is already based on a feature list. In other words, you 
cannot add any feature to a basic pattern created using a single feature.

Patterning Current Solids

A current solid is composed of one or more features belonging to the same body. It is the result of the operations as mentioned in the 
specification tree, the last operation being the current one. For more about current features, see Scanning a part and defining local 
objects.

To pattern a current solid, just click the Rectangular Pattern icon . There is no need to select any geometry. By default, the 
object to pattern is the current solid. You then just have to enter your specifications in the dialog box. 

Note that if you change your mind and decide to pattern a feature, you just have to click the Object field and select the feature of 
your choice.



In the following example, the current solid is the result of one pad and one hole.
 

 The instances created via the Pattern command are composed of pads and holes only.

You cannot transform a patterned list of features into a patterned current solid and vice-versa.

 

Patterning User Defined Features (UDFs)

There are two ways of patterning a User Defined Feature. The order of selection affects the availability of the Keep specifications 
option as explained below:

1.  Select the UDF.

2.  Click the Rectangular Pattern icon .

The application treats the pattern feature as a complex pattern, that is a pattern made from a list of diverse features. The 

Keep specifications option is enabled and dimmed. The created pattern you create keeps the UDF specifications.

Or

1.  Click the Rectangular Pattern icon .

2.  Select the UDF.

Here the pattern is treated as a single feature. You are free to enable or disable the Keep specifications option.

Note that:

●     you can pattern only one UDF. 

●     patterning UDFs is allowed in Part Design, not in Generative Shape Design.

 

 



Creating Circular Patterns

 

The application allows you to define three types of patterns: 
●     Circular patterns

●     Rectangular patterns 

●     User patterns

This task shows you how to duplicate geometry of one or more features right away at the location of your choice using a circular 
pattern.

This document also deals with:

●     Complex Patterns 

●     Patterning User Defined Features (UDFs)

You can also find information about patterns and updates by reading Optimizing Part Design Application, Patterns.

 

Make sure the item you wish to duplicate is correctly located in relation to the circular rotation axis.

Open the CircularPattern.CATPart document.

 
1.  Select the pad whose geometry you wish to copy.

2.  Click the Circular Pattern icon .

The Circular Pattern Definition dialog box is displayed and the feature's name appears in the Object field.

If you change your mind and decide to pattern the current solid, click the Object field and use the Get current solid 

contextual menu item. For more information, refer to Patterning  Current Solids. 

Keeping Specifications

Checking the Keep specifications option creates instances with the limit Up to Next (Up to Last, Up to Plane or Up to Surface) 
defined for the original feature. The example below shows you that the limit defined for the pad, that is the Up to surface limit, 
applies to all instances. As the limiting surface is not planar, the instances have different lengths.
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Parameters

The Parameters field lets you choose the type of parameters you wish to specify so that the application will be able to compute the 
location of the items copied.

These parameters are:

●     Instances & total angle: the application computes the angular spacing after you specified the number of instances you wish to 
obtain and a total angle value.

●     Instances & angular spacing: the application computes the total angle after you specified the number of instances you wish to 
obtain and an angular spacing.

●     Angular spacing & total angle: the application computes the instances you can obtain by specifying an angular spacing and a 
total angle.

●     Complete crown: the application computes the angular spacing between the instances you decide to obtain.

●     Instances & unequal angular spacing:  distinct angle values can be assigned between each instance. 

●     If you set Instances & total angle or Angular spacing & total angle parameters, note that you cannot define the total angle 
when using formulas.

●     The Keep specifications option is not available if you are patterning a pattern.

 

3.  Set the Instances & Angular spacing options to define the parameters you wish to specify.

 

Choosing Instances & Angular spacing dims the Total angle field because the application no longer needs this specification to 
space the instances.

 
4.  Enter 7 as the number of pads you wish to obtain.

5.  Enter 50 degrees as the angular spacing.

Reference Direction

6.  Click the Reference element field and select the upper face to determine the rotation axis. This axis will be normal to the 

face.

To define a direction, you can select an edge, a line, a planar face or a plane. After selecting an edge, a line or a planar face, 

if necessary, you can also select a point to define the rotation center. If you select a plane, selecting a point is mandatory.



Two arrows are then displayed on the pad.

 
Clicking the Reverse button reverses the direction.

 

Contextual commands creating the reference elements you need are available from the Reference element field:
●     Create Line: For more information, see Creating Lines.

●     X Axis: the X axis of the current coordinate system origin (0,0,0) becomes the direction.

●     Y Axis: the Y axis of the current coordinate system origin (0,0,0) becomes the direction.

●     Z Axis: the Z axis of the current coordinate system origin (0,0,0) becomes the direction.

●     Create Plane: see Creating Planes.

If you create any of these elements, the application then displays the corresponding icon next to the Reference element  field. 
Clicking this icon enables you to edit the element.
If you modify the angular spacing, the application previews the result: arrows 1 and 2 are moved accordingly.



7.  Click Preview: the pad will be repeated six times. The instances are green, just like the original feature.

 

Crown Definition

8.  Now, you are going to add a crown to your part. To do so, click the Crown Definition tab.

9.  Set the Circle & Circle spacing options to define the parameters you wish to specify.

10.  Enter 2 in the Circles field.

11.  Enter -18 mm in the Circle spacing field.

This figure may help you to define your parameters:



12.  Click OK.

These are your new instances:

13.  Now, you are going to modify the position of the initial pad. Such a modification will affect all instances too. Double-click the 

pattern.

14.  Extend the dialog box by clicking More.

15.  Enter 20 in the Rotation angle field.

The application previews the rotation. 



 

 

●     Applying the Delete command on one instance deletes the whole pattern. However, deleting the instances of your choice is 
possible when creating or editing the pattern. To do so, just select the points materializing instances in the pattern preview. 
Selecting these points again will enable the application maintain the corresponding instances.

●     The Simplified representation option lets you lighten the pattern geometry. What you need to do is just check the option and 
double-click the instances you do not want to see. The instances are then represented in dashed lines during the pattern 
definition and then are no longer visible after validating the pattern creation. 

When the Simplified representation option is on, because the pattern's geometry representation is modified, the part mass is 
modified too.

This option is particularly used for patterns including a large number of instances. 

●     Remember then that clicking once or double-clicking an instance does not lead to the same result.

16.  Click OK.

All instances are moved accordingly.

The scenario above does not show the use of the Radial alignment of instances option. In addition to performing the steps 
described, you could have used this option that allows you to define the instance orientations.

The option is checked: all instances have the same 
orientation as the original feature.

The option is unchecked: all instances are normal to the lines tangent to the 
circle.

The application offers the capability of creating polar patterns (for example, spiral patterns). To do so, you need to define formulas. 
For more information about formulas, refer to the Knowledge Advisor User's Guide Version 5.

During your design, you may need to rework instances specifically. You will then have to use the Explode contextual menu item to 
delete your pattern while keeping geometry. For more information, refer to Exploding Patterns.

 



Complex Patterns 

You can pattern a list of Part Design features by proceeding as follows:

1.  Multi-select the features to be duplicated.

These features must belong to the same body. 

2.  Click the Circular Pattern icon . 

The features are indicated in the Object field.

3.  Set the parameters you need as shown in the task above.

These rules are to be kept in mind before patterning a list of features. 

❍     When multi-selecting, the first feature you select must not be 
a dress-up feature.

❍     Your list of features cannot include any transformation 
feature, nor shell, nor split, nor associated bodies.

❍     Your list of features cannot include any body.

 

 

Editing a List of Features 

Editing a list of features consists in adding or removing features from the list. To do so, you just have to click the Object field and select the 
feature of interest to add it or remove it from the list. 

Note however that adding a feature to a pattern is possible only if your pattern is already based on a feature list. In other words, you 
cannot add any feature to a basic pattern created using a single feature.

Instances and Unequal Angular Spacing

You can assign specific angular spacing between each instance by proceeding as follows:



1.  Set the Instances & unequal angular spacing parameter.

Angular spacing values are displayed between each instance.

2.  To edit the values between each instance, you need to edit values individually. First, select the angular spacing of interest if not 

already done.

3.  Then, choose one of the methods described hereafter: For example, if you wish to change 50 degrees for 80 degrees for the angular 

spacing selected as shown in our picture, you can:

❍     double-click the angle value in the geometry area. This displays the Parameter Definition dialog box in which you can enter 
the new value.

❍     directly enter the new value in the Angular spacing field of the Circular Pattern Definition dialog box.

4.  Repeat the operation for the other angular spacings.

5.  Click OK when done.

Patterning User Defined Features (UDFs)

There are two ways of patterning a User Defined Feature. The order of selection affects the availability of the Keep specifications option 
as explained below:

1.  Select the UDF.

2.  Click the Circular Pattern icon .

The application treats the pattern feature as a complex pattern, that is a pattern made from a list of diverse features. The Keep 

specifications option is enabled and dimmed. The created pattern you create keeps the UDF specifications.



Or

1.  Click the Circular Pattern icon .

2.  Select the UDF.

Here the pattern is treated as a single feature. You are free to enable or disable the Keep specifications option.

Note that:

●     you can pattern only one UDF. 

●     patterning UDFs is allowed in Part Design, not in Generative Shape Design.

 



Creating User Patterns 
The User Pattern command lets you duplicate a feature, a list of features or a body resulting from an 
association of bodies as many times as you wish at the locations of your choice. 

Locating instances consists in specifying anchor points. These points are created in the Sketcher.

 

This task shows you how to duplicate a feature list including a pocket and a fillet at the points defined in 
a same sketch plane.

You can also find information about patterns and updates by reading Optimizing Part Design Application, 
Patterns.

 
Open the UserPattern.CATPart document.

 
1.  Select the filleted pocket you wish to duplicate.

Note that whenever you are using a feature list, you need to multi-select the features in the 

order they were created.

2.  Click the User Pattern icon .

The User Pattern Definition dialog box is displayed. Both selected elements appear in the 

Object field.

file:///E|/www/celr16/Doc/online/prtug_C2/samples/UserPattern.CATPart


 

●     If you click the User Pattern icon  prior to selecting any geometry, by default, the object to be 
patterned is the current solid. For more information, refer to Patterning  Current Solids.

●     If you change your mind and decide to pattern the current solid, right-click the Object field and 
select Get current solid.

●     Checking the Keep specifications option creates instances with the limit Up to Next ( Up to Last, 
Up to Plane or Up to Surface) defined for the original feature.

The Keep specifications option is not available for:

●     feature lists

●     patterning patterns.

 
3.  Select Sketch 4 in the specification tree and click Preview. The sketch includes the nine points 

you need to locate the duplicated pockets. 



4.  As you just need seven points, click both points you do not need to unselect them.

Anchor

By default, the application positions each instance with respect to the center of gravity or the element to 
be duplicated. To change this position, use the anchor field: click the Anchor field and select a  vertex or 
a point.

Note that contextual commands creating the anchors you need are available from the Anchor field:

●     Create Point: for more information, see Creating Points

●     Create Midpoint: creates the midpoint of the line you select

●     Create Endpoint: creates the endpoint of the line you select

●     Create Intersection: see Creating Intersections

●     Create Projection: see Creating Projections

If you create any of these elements, the application then displays the corresponding icon next to the 
Anchor field. Clicking this icon enables you to edit the element.

 

5.  Click OK.

The pockets and fillets are created at the points of the sketch. The specification tree indicates this 

creation.



Editing a List of Features 

Editing a list of features consists in adding or removing features from the list. To do so, you just have to 
click the Object field and select the feature of interest to add it or remove it from the list. 

Note however that adding a feature to a pattern is possible only if your pattern is already based on a 
feature list. In other words, you cannot add any feature to a basic pattern created using a single feature.

Exploding Patterns 

During your design, you may need to rework instances specifically. You will then have to use the 
Explode contextual menu item to delete your pattern while keeping geometry. For more information, 
refer to Exploding Patterns.

Note

The application does not allow you to cut, nor copy user patterns.

 



Exploding Patterns 

 

During your design you may decide to perform specific operations on a certain number of instances 
created via the Pattern command. Before performing such operations, you need to explode your 
pattern, which makes each instance independent. 

This task shows you how to delete a pattern while keeping geometry.

 

The Explode command can be applied to patterns created with features and feature lists, not with 
bodies. This capability is available in P2 mode only. 

Open the RectangularPattern.CATPart document and perform a basic pattern.

 
1.  Right-click the pattern you want to explode. 

2.  Use the RectPattern.1object > Explode... contextual command. 

You obtain as many features in the specification tree as there were instances. The geometry 

remains unchanged. 
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Note that: 

●     if the original element you patterned contains a dress-up feature, for instance a fillet, exploding the 
pattern does not delete the fillet defined on each instance. 

●     However, if a dress-up feature has been defined on a pattern instance, exploding the pattern will 
delete this dress-up feature.

3.  You can now edit pockets individually. For example, you can move them to the location of your 

choice.

You cannot pattern wireframe, surface, volume elements nor current solids. ●     



Creating Scalings  
Scaling geometry means resizing it to the dimension you specify, using points, planes or planar sufaces 
as scaling references. 

This task shows how to scale a body in relation to a point.

Open the Scaling.CATPart document.
 

 

 
1.  Select the body to be scaled.

2.  Click the Scaling icon . 

The Scaling Definition dialog box appears.

3.  Select the reference point located on the body.

A graphic manipulator is displayed on the body.

4.  Enter a value in the Ratio field or select the manipulator and drag it. The ratio increases as you 

drag the manipulator in the direction pointed by the right end arrow.
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5.  Click OK.

The body is scaled. The specification tree indicates you performed this operation. 

 

You can also resize a body in relation to a face or plane. In the example below, the plane zx is the 
reference element and the ratio is 1.6. You obtain then an affinity.



Reference Elements
You can display the Reference Elements toolbar using View > Toolbars > Reference Elements 
(extended/compact).

 
Create Points: Click this icon, choose the creation method then define the required parameters.

 
Create Lines: Click this icon, choose the creation method then define the required parameters.

 
Create Planes: Click this icon, choose the creation method then define the required parameters.

 



Creating Points

 

This task shows the various methods for creating points: 
●     by coordinates

●     on a curve

●     on a plane

●     on a surface

●     at a circle/sphere center

●     tangent point on a curve

●     between

 
Open the Points3D1.CATPart document.

 1.  Click the Point icon  .

The Point Definition dialog box appears.

2.  Use the combo to choose the desired point type.

A new lock button  is available besides the Point type to prevent an automatic change of the type 

while selecting the geometry. Simply click it so that the lock turns red . 
For instance, if you choose the Coordinates type, you are not able to select a curve. May you want to 
select a curve, choose another type in the combo list.

 

Coordinates 
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●     Enter the X, Y, Z coordinates in the current axis-system.

●     Optionally, select a Reference Point.

The corresponding point is displayed.

 
●     When the command is launched at creation, the initial value in the Axis System field is the current 

local axis system. If no local axis system is current, the field is set to Default. 
Whenever you select a local axis system, the point's coordinates are changed with respect to the 
selected axis system so that the location of the point is not changed. This is not the case with points 
valuated by formulas: if you select an axis system, the defined formula remains unchanged.
This option replaces the Coordinates in absolute axis-system option.
 

If you create a point using the coordinates method and an axis system is already defined and 
set as current, the point's coordinates are defined according to current the axis system. As a 
consequence, the point's coordinates are not displayed in the specification tree.

The current local axis system must be different from the absolute axis.

 

On curve 
 



●     Select a curve.

●     Optionally, select a reference point.
If this point is not on the curve, it is projected onto the curve.
If no point is selected, the curve's extremity is used as reference.

●     Select an option point to determine whether the new point is to be created: 
❍     at a given distance along the curve from the reference point

❍     a given ratio between the reference point and the curve's extremity.

●     Enter the distance or ratio value.
If a distance is specified, it can be: 

❍     a geodesic distance: the distance is measured along the curve

❍     an Euclidean distance: the distance is measured in relation to the reference point (absolute 
value).
The corresponding point is displayed.

It is not possible to create a point with an euclidean distance if the distance or the ratio 
value is defined outside the curve.

You can also: 
■     click the Nearest extremity button to display the point at the nearest extremity of the 

curve.

■     click the Middle Point button to display the mid-point of the curve.

Be careful that the arrow is orientated towards the inside of the curve (providing the curve 
is not closed) when using the Middle Point option.

●     use the Reverse Direction button to display: 
❍     the point on the other side of the reference point (if a point was selected originally)

❍     the point from the other extremity  (if no point was selected originally).



●     click the Repeat object after OK if you wish to create equidistant points on the curve, using the 
currently created point as the reference, as described in Creating Multiple Points and Planes in the 
Wireframe and Surface User's Guide. 
You will also be able to create planes normal to the curve at these points, by checking the Create 
normal planes also option, and to create all instances in a new geometrical set by checking the 
Create in a Body option. If the latter option is not checked, instances are created in the current 
geometrical set.

❍     If the curve is infinite and no reference point is explicitly given, by default, the reference 
point is the projection of the model's origin

❍     If the curve is a closed curve, either the system detects a vertex on the curve that can be 
used as a reference point, or it creates an extremum point, and highlights it (you can then 
select another one if you wish) or the system prompts you to manually select a reference 
point.

Extremum points created on a closed curve are aggregated under their parent command and put in 
no show in the specification tree.



 
●     Select a plane.

❍     If you select one of the planes of any local axis system as the plane, the origin of this axis system 
is set as the reference point and featurized. If you modify the origin of the axis system, the 
reference point is modified accordingly.

●     Optionally, select a point to define a reference for computing coordinates in the plane.
❍     If no point is selected, the projection of the model's origin on the plane is taken as reference.

●     Optionally, select a surface on which the point is projected normally to the plane.
❍     If no surface is selected, the behavior is the same.

Furthermore, the reference direction (H and V vectors) is computed as follows: 
With N the normal to the selected plane (reference plane), H results from the vectorial product of 
Z and N (H = Z^N). 
If the norm of H is strictly positive then V results from the vectorial product of N and H (V = 
N^H).
Otherwise, V = N^X and H = V^N.
Would the plane move, during an update for example, the reference direction would then be 
projected on the plane. 

●     Click in the plane to display a point.

 

On plane 
 



 

On surface 
 

●     Select the surface where the point is to be created.

●     Optionally, select a reference point. By default, the surface's middle point is taken as reference. 

●     You can select an element to take its orientation as reference direction or a plane to take its normal 
as reference direction.
You can also use the contextual menu to specify the X, Y, Z components of the reference direction.

●     Enter a distance along the reference direction to display a point.

 
●     Choose the dynamic positioning of the point:

❍     Coarse (default behavior): the distance computed between the reference point and the mouse 

click is an euclidean distance. Therefore the created point may not be located at the location of 

the mouse click (see picture below).

The manipulator (symbolized by a red cross) is continually updated as you move the mouse over 

the surface.



❍     Fine: the distance computed between the reference point and the mouse click is a geodesic 

distance. Therefore the created point is located precisely at the location of the mouse click.

The manipulator is not updated as you move the mouse over the surface, only when you click on 

the surface.

 Sometimes, the geodesic distance computation fails. In this case, an euclidean distance might be used 
and the created point might not be located at the location of the mouse click. This is the case with closed 
surfaces or surfaces with holes. We advise you to split these surfaces before creating the point.

 

Circle/Sphere center 



 

●     Select a circle, circular arc, or ellipse, or

●     Select a sphere or a portion of sphere.

A point is displayed at the center of the selected element.

 

Tangent on curve 
 



●     Select a planar curve and a direction line.
A point is displayed at each tangent. 
The Multi-Result Management dialog box is displayed because several points are generated. Refer to 
the Managing Multi-Result Operations chapter.

 

Between
 

●     Select any two points.

●     Enter the ratio, that is the percentage of the distance from the first selected point, at which the new 
point is to be.
You can also click Middle Point button to create a point at the exact midpoint (ratio = 0.5).

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is 
not closed) when using the Middle Point option.

●     Use the Reverse direction button to measure the ratio from the second selected point.
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If the ratio value is greater than 1, the point is located on the virtual line beyond the selected 
points.

3.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 
●     Parameters can be edited in the 3D geometry. For more information, 

refer to the Editing Parameters chapter.

●     You can isolate a point in order to cut the links it has with the geometry 
used to create it. To do so, use the Isolate contextual menu. For more 
information, refer to the Isolating Geometric Elements chapter.
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Creating Lines
This task shows the various methods for creating lines: 

●     point to point

●     point and direction

●     angle or normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 
It also shows you how to create a line up to an element, define the length type and automatically reselect 
the second point.

 
Open the Lines1.CATPart document.

1.  Click the Line icon  .

The Line Definition dialog box is displayed. 

2.  Use the drop-down list to choose the desired line type.

A line type will be proposed automatically in some cases depending on your first element 
selection.

A new lock button  is available besides the Line type to prevent an automatic change of the type 

while selecting the geometry. Simply click it so that the lock turns red . 
For instance, if you choose the Point-Point type, you are not able to select a line. May you want to select 
a line, choose another type in the combo list.

 

Defining the line type

Point - Point 
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●     Select two points.
A line is displayed between the two points.
Proposed Start and End points of the new line are shown.

●     If needed, select a support surface.
In this case a geodesic line is created, i.e. going from one point to the other according to the shortest 
distance along the surface geometry (blue line in the illustration below).
If no surface is selected, the line is created between the two points based on the shortest distance.



 If you select two points on closed surface (a cylinder for example), the result may be unstable. 
Therefore, it is advised to split the surface and only keep the part on which the geodesic line 
will lie. 

●     Specify the Start and End points of the new line, that is the line endpoint location in relation to the 
points initially selected.
These Start and End points are necessarily beyond the selected points, meaning the line cannot be 
shorter than the distance between the initial points.

●      Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
and End points.

The projections of the 3D point(s) must already exist on the selected support. 

 
Point - Direction 

 



●     Select a reference Point and a Direction line.
A vector parallel to the direction line is displayed at the reference point. 
Proposed Start and End points of the new line are shown.

●     Specify the Start and End points of the new line.
The corresponding line is displayed.



 
Angle or Normal to curve 

 



 

●     Select a reference Curve and a Support surface containing that curve.
❍     If the selected curve is planar, then the Support is set to Default (Plane).

❍     If an explicit Support has been defined, a contextual menu is available to clear the selection.

●     Select a Point on the curve.

●     Enter an Angle value.

A line is displayed at the given angle with respect to the tangent to the reference curve at the 
selected point. These elements are displayed in the plane tangent to the surface at the selected point. 
You can click on the Normal to Curve button to specify an angle of 90 degrees. 
Proposed Start and End points of the line are shown. 

●     Specify the Start and End points of the new line.
The corresponding line is displayed.

●     Click the Repeat object after OK if you wish to create more lines with the same definition as the 
currently created line. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of instances to 
be created before pressing OK.

As many lines as indicated in the dialog box are created, each separated from the initial line by a 
multiple of the angle value.



You can select the Geometry on Support check box if you want to create a geodesic line onto a 
support surface. 
The figure below illustrates this case.
Geometry on support option not checked: Geometry on support option checked:

This line type enables to edit the line's parameters. Refer to Editing Parameters to find out more.

 
Tangent to curve 
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●     Select a reference Curve and a point or another Curve to define the tangency. 
❍     if a point is selected (mono-tangent mode): a vector tangent to the curve is displayed at 

the selected point.

❍     If a second curve is selected (or a point in bi-tangent mode), you need to select a support plane. 
The line will be tangent to both curves.

■     If the selected curve is a line, then the Support is set to Default (Plane).

■     If an explicit Support has been defined, a contextual menu is available to clear the selection.



 

When several solutions are possible, you can choose one (displayed in red) directly in the 
geometry, or using the Next Solution button.
Line tangent to curve at a given point: Line tangent to two curves:

●     Specify Start and End points to define the new line.
The corresponding line is displayed.



 
●     Select a reference Surface and a Point.

A vector normal to the surface is displayed at the reference point. 
Proposed Start and End points of the new line are shown.

If the point does not lie on the support surface, the minimum distance between the point and the 
surface is computed, and the vector normal to the surface is displayed at the resulted reference point.

●     Specify Start and End points to define the new line.
The corresponding line is displayed.

 
Normal to surface 

 



 
Bisecting 

 



●     Select two lines. Their bisecting line is the line splitting in two equals parts the angle between these 
two lines. 

●     Select a point as the starting point for the line. By default it is the intersection of the bisecting line 
and the first selected line.

●     Select the support surface onto which the bisecting line is to be projected, if needed.

●     Specify the line's length by defining Start and End values (these values are based onto the default 
start and end points of the line).
The corresponding bisecting line, is displayed.

●     You can choose between two solutions, using the Next Solution button, or directly clicking the 
numbered arrows in the geometry.

3.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 
●     Regardless of the line type, Start and End values are specified by entering 

distance values or by using the graphic manipulators.

●     Start and End values should not be the same.

●     Check the Mirrored extent option to create a line symmetrically in 
relation to the selected Start point. 
It is only available with the Length Length type.

●     In most cases, you can select a support on which the line is to be created. 
In this case, the selected point(s) is projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed 
vector or selecting the Reverse Direction button (not available with the 
point-point line type).

●     Parameters can be edited in the 3D geometry. For more information, refer 
to the Editing Parameters chapter.
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●     You can isolate a line in order to cut the links it has with the geometry 
used to create it. To do so, use the Isolate contextual menu. For more 
information, refer to the Isolating Geometric Elements chapter.

You cannot create a line of which points have a distance lower than the 
resolution.

 

Creating a line up to an element 
 This capability allows you to create a line up to a point, a curve, or a surface.
 

It is available with all line types, but the Tangent to curve type.

 
Up to a point

 
●     Select a point in the Up-to 1 and/or Up-to 2 fields.

Here is an example with the Bisecting line type, the Length Length type, and a point as Up-to 2 
element.



 
●     Select a curve in the Up-to 1 and/or Up-to 2 fields.

Here is an example with the Point-Point line type, the Infinite End Length type, and a curve as the 
Up-to 1 element.

 
Up to a curve

 
Up to a surface

 
●     Select a surface in the Up-to 1 and/or Up-to 2 fields.

Here is an example with the Point-Direction line type, the Length Length type, and the surface as the 
Up-to 2 element.

 

●     If the selected Up-to element does not intersect with the line being created, then an 
extrapolation is performed. It is only possible if the element is linear and lies on the 
same plane as the line being created.
However, no extrapolation is performed if the Up-to element is a curve or a surface.

●     The Up-to 1 and Up-to 2 fields are grayed out with the Infinite Length type, the Up-
to 1 field is grayed out with the Infinite Start Length type, the Up-to 2 field is 
grayed out with the Infinite End Length type.

●     The Up-to 1 field is grayed out if the Mirrored extent option is checked.

●     In the case of the Point-Point line type, Start and End values cannot be negative.



 

Defining the length type
 

●     Select the Length Type: 
❍     Length: the line will be defined according to the Start and End points values

❍     Infinite: the line will be infinite

❍     Infinite Start Point: the line will be infinite from the Start point

❍     Infinite End Point: the line will be infinite from the End point

 By default, the Length type is selected.
The Start and/or the End points values will be grayed out when one of the Infinite 
options is chosen.

 

Reselecting automatically a second point
 

This capability is only available with the Point-Point line method.

1.  Double-click the Line icon .

The Line dialog box is displayed.

2.  Create the first point.

The Reselect Second Point at next start option appears in the Line dialog box.

3.  Check it to be able to later reuse the second point.

4.  Create the second point.

5.  Click OK to create the first line.



The Line dialog box opens again with the first point initialized with the second point of the first 
line.

6.  Click OK to create the second line.

To stop the repeat action, simply uncheck the option or click Cancel in the Line Definition 
dialog box.

 



Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from a plane

●     parallel through point

●     angle/normal to a plane

●     through three points

●     through two lines

●     through a point and a line

●     through a planar curve

●     normal to a curve

●     tangent to a surface

●     equation

●     mean through points

 

 
Open the Planes1.CATPart document.

 1.  Click the Plane icon  .

The Plane Definition dialog box appears.

2.  Use the combo to choose the desired Plane type.

Once you have defined the plane, it is represented by a green square symbol, which you 
can move using the graphic manipulator.

A new lock button  is available besides the Plane type to prevent an automatic change of the type 

while selecting the geometry. Simply click it so that the lock turns red . 
For instance, if you choose the Through two lines type, you are not able to select a plane. May you want 
to select a plane, choose another type in the combo list.

 

Offset from plane
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●     Select a reference Plane then enter an Offset value.
A plane is displayed offset from the reference plane.

●     Use the Reverse Direction button to reverse the change the offset direction, or simply 
click on the arrow in the geometry.

●     Click the Repeat object after OK if you wish to create more offset planes. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of 
instances to be created before pressing OK.

As many planes as indicated in the dialog box are created (including the one you were 
currently creating), each separated from the initial plane by a multiple of the Offset value. 



 

●     Select a reference Plane and a Point.

A plane is displayed parallel to the reference plane and passing through the selected point.

 
Parallel through point 



 

 

●     Select a reference Plane and a Rotation axis.
This axis can be any line or an implicit element, such as a cylinder axis for example. To 
select the latter press and hold the Shift key while moving the pointer over the element, 
then click it.

●     Enter an Angle value.

The plane is displayed such as its center corresponds to the projection of the center of the 
reference plane on the rotation axis. It is oriented at the specified angle to the reference 
plane. 

●     Check the Project rotation axis on reference plane option if you wish to project the 
rotation axis onto the reference plane. If the reference plane is not parallel to the rotation 
axis, the created plane is rotated around the axis to have the appropriate angle with 
regard to reference plane.

●     Check the Repeat object after OK option if you wish to create more planes at an angle 
from the initial plane. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of 
instances to be created before pressing OK.

 
Angle or normal to plane 



As many planes as indicated in the dialog box are created (including the one you were 
currently creating), each separated from the initial plane by a multiple of the Angle value.
Here we created five planes at an angle of 20 degrees.

This plane type enables to edit the plane's parameters. Refer to Editing Parameters to find 
out how to display these parameters in the 3D geometry.

 

Through three points 
 

●     Select three points.

The plane passing through the three points is displayed. You can move it simply by 
dragging it to the desired location.
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Through two lines 

 

●     Select two lines.
The plane passing through the two line directions is displayed.
When these two lines are not coplanar, the vector of the second line is moved to the first line location 
to define the plane's second direction. 

●     Check the Forbid non coplanar lines option to specify that both lines be in the same plane.



 

Through point and line 
 

●     Select a Point and a Line.

The plane passing through the point and the line is displayed. 



 

Through planar curve 
 

●     Select a planar Curve.

The plane containing the curve is displayed.



 

●     Select a reference Curve.

●     You can select a Point. By default, the curve's middle point is selected.

It can be selected outside the curve.

A plane is displayed normal to the curve with its origin at the specified point. The normal is 
computed at the point on the curve that is the nearest to the selected point.

 
Normal to curve 



 

 
●     Select a reference Surface and a Point.

A plane is displayed tangent to the surface at the specified point.

 

Tangent to surface 



 
Equation 

 

●     Enter the A, B, C, D components of the Ax + By + Cz = D plane equation.

●     Select a point to position the plane through this point, you are able to modify A, B, and C 
components, the D component becomes grayed.

 
●     When the command is launched at creation, the initial value in the Axis System field is 

the current local axis system. If no local axis system is current, the field is set to Default. 
Whenever you select a local axis system, A, B, C, and D values are changed with respect 
to the selected axis system so that the location of the plane is not changed. This is not the 
case with values valuated by formulas: if you select an axis system, the defined formula 
remains unchanged.
This option replaces the Coordinates in absolute axis-system option.



 

●     Use the Normal to compass button to position the plane perpendicular to the compass 
direction.

 

●     Use the Parallel to screen button to parallel to the screen current view.

 

Mean through points 
 



●     Select three or more points to display the mean plane through these points.

It is possible to edit the plane by first selecting a point in the dialog box list then choosing 
an option to either:

❍     Remove the selected point

❍     Replace the selected point by another point.

3.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
●     Parameters can be edited in the 3D geometry. For more information, refer to the 

Editing Parameters chapter.

●     You can isolate a plane in order to cut the links it has with the geometry used to 
create it. To do so, use the Isolate contextual menu. For more information, refer to 
the Isolating Geometric Elements chapter.
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Using Surfaces and Curves

Join Surfaces or Curves: select at least two curves or surfaces to be joined. 

Extrapolate Surfaces: select a surface boundary, specify the extrapolation type and value.

Extract Geometry: select an edge or the face of a geometric element, and set the propagation type.

Create Intersections: select the two elements to be intersected.

Create Projections: select the element to be projected and its support, specify the projection 
direction.

Create Boundary Curves: select a surface's edge, set the propagation type, and re-define the curve 
limits if needed.
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Joining Surfaces or Curves

 

This task shows how to join surfaces or curves.
This involves:

●     using the check options

●     removing sub-elements

●     using the federation capability

 
Open the Join1.CATPart document.

 1.  Click the Join icon .

The Join Definition dialog box appears. 

In Part Design workbench, the Join capability is available as a contextual command named 'Create 
Join' that you can access from Sketch-based features dialog boxes.

2.  Select the surfaces or curves to be joined.
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3.  You can edit the list of elements to be joined:

❍     by selecting elements in the geometry: 
■     Standard selection (no button clicked):

when you click an unlisted element, it is added to the list 
when you click a listed element, it is removed from the list

■     Add Mode: 
when you click an unlisted element, it is added to the list 
when you click a listed element, it remains in the list

■     Remove Mode: 
when you click an unlisted element, the list is unchanged 
when you click a listed element, it removed from the list

❍     by selecting an element in the list then using the Clear Selection or Replace Selection 
contextual menu items.

If you double-click the Add Mode or Remove Mode button, the chosen mode is permanent, 
i.e. successively selecting elements will add/remove them. However, if you click only once, 
only the next selected element is added or removed.
You only have to click the button again, or click another one, to deactivate the mode.

4.  Right-click the elements from the list and choose the Check Selection command.

This lets you check whether an element to be joined presents any intersection (i.e. at least one 
common point) with other elements prior to creating the joined surface. If this command is not 
launched, possible intersections will not be detected.
The Checker dialog box is displayed, containing the list of domains (i.e. sets of connected cells) 
belonging to the selected elements from the Elements To Join list.



5.  Click Preview.

❍     An Information message is issued when no intersection is found.

❍     When an element is self-intersecting, or when several elements intersect, a text is displayed on 
the geometry, where the intersection is detected.

6.  Click Cancel to return to the Join Definition dialog box.

7.  Right-click the elements again and choose the Propagation options to allow the selection of 

elements of same dimension.



❍     Distance Propagation: the tolerance corresponds to the Merging distance value.

❍     Angular Propagation: the tolerance corresponds to the Angular Threshold value, if defined. 
Otherwise, it corresponds to the G1 tolerance value as defined in the part.

Each new element found by propagation of the selected element(s) is highlighted and added to the 
Elements To Join list.

Note that:
❍     The initial element to propagate cannot be a sub-element,

❍     Forks stop the propagation,

❍     Intersections are not detected.

8.  Click Preview in the Join Definition dialog box.

The joined element is previewed, and its orientation displayed. Click the red arrow to invert it if 
needed.

The join is oriented according to the first element in the list. If you change this element, the join's 
orientation is automatically set to match the orientation of the new topmost element in the list.

Using the check options

9.  Check the Check tangency option to find out whether the elements to be joined are tangent. If 

they are not, and the option is checked, an error message is issued when you click Preview...



... and elements in error are highlighted in the 3D geometry once you have clicked OK in the 
Update Error dialog box:

10.  Check the Check connexity option to find out whether the elements to be joined are connex. If 

they are not, and the button is checked, an error message is issued indicating the number of 

connex domains in the resulting join and elements in error are highlighted in the 3D geometry.

When clicking Preview, the free boundaries are highlighted, and help you detect where the 
joined element is not connex.

If two elements are not connex and the Check connexity option is deselected, the Multi-
Result Management dialog box is displayed.

11.  Check the Check manifold option to find out whether the resulting join is manifold.

The Check manifold option is only available with curves.
Checking it automatically checks the Check connexity option.

12.  You can check the Simplify the result option to allow the system to automatically reduce the 

number of elements (faces or edges) in the resulting join whenever possible.

13.  You can check the Ignore erroneous elements option to let the system ignore surfaces and 

edges that would not allow the join to be created.

14.  You can also set the tolerance at which two elements are considered as being only one using the 
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Merging distance.

By default, the value is set to 0.001 mm and corresponds to the value defined in Tools -> 
Options. To find out more about the merging distance value, refer to the General Settings 
chapter.

15.  Check the Angular Threshold option and specify the angle value below which the elements are to 

be joined.

If the angle value on the edge between two elements is greater than the Angle Tolerance 
value, the elements are not joined. This is particularly useful to avoid joining overlapping 
elements.

Removing Sub-Elements
16.  Click the Sub-Elements To Remove tab to display the list of sub-elements in the join.

These sub-elements are elements making up the elements selected to create the join, such as 

separate faces of a surface for example, that are to be removed from the join currently being 

created.

You can edit the sub-elements list as described above for the list of elements to be joined. 

17.  Check the Create join with sub-elements option to create a second join, made of all the sub-

elements displayed in the list, i.e. those that are not to be joined in the first join.

❍     This option is active only when creating the first join, not when editing it.

❍     A message is displayed to inform you of the creation of a second join.

18.  Click OK to create the joined surface or curve.

The surface or curve (identified as Join.xxx) is added to the specification tree. 

 

Sometimes elements are so close that it is not easy to see if they present a gap or not, even though they 
are joined. Check the Surfaces' Boundaries option from the Tools -> Options -> General -> Display -
> Visualization menu item.



 

Using the Federation Capability

 

The purpose of the federation is to regroup several elements making up the joined surface or curve that 
will be detected together with the pointer when selecting one of them. This is especially useful when 
modifying linked geometry to avoid re-specifying all the input elements.

 
Open the Join2.CATPart document.

1.  Create the join as usual, selecting all elements to be joined.

(Make sure you do not select Sketch.1).

2.  From the Join Definition dialog box, click the Federation tab, then select one of the elements 

making up the elements federation (providing the No federation and All propagation modes are 

not selected).

You can edit the list of elements taking part in the federation as described above for the list of 
elements to be joined.

3.  Choose a propagation mode, the system automatically selects the elements making up the 

federation, taking this propagation mode into account.
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❍     No federation: no element can be selected

❍     All: all elements belonging to the resulting joined curve/surface are part of the federation. 
Therefore, no element can be explicitly selected.

❍     Point continuity: all elements that present a point continuity with the selected elements and 
the continuous elements are selected.

Tangent continuity: all the elements that are tangent to the selected element, and the ones 
tangent to it, are part of the federation.
Here, only the top faces of the joined surface are detected, not the lateral faces.



To federate a surface and its boundaries in tangency, you need to select the face as well as 
the edges: both face and edges will be federated.

❍     No propagation: only the elements explicitly selected are part of the propagation.

4.  Choose the Tangency continuity propagation mode.

5.  Move to the Part Design workbench (select Start -> Mechanical Design -> Part Design), select 

the Sketch.1, and click the Pad  icon to create an up to surface pad, using the joined surface 

as the limiting surface.

6.  Select the front edge of the pad, and create a 2mm fillet using the Edge Fillet icon .

7.  Double-click Sketch.1 from the specification tree, then double-click the constraint on the sketch to 

change it to 10mm from the Constraint Definition dialog box.

Sketch prior to modification lying over two 
faces:  Sketch after modification lying over one face only:



 

8.  Exit the sketcher .

The up to surface pas is automatically recomputed even though it does not lie over the same faces 
of the surface as before, because these two faces belong to the same federation. This would not be 
the case if the federation including all top faces would not have been created, as shown below.

9.  Double-click the joined surface (Join.1) to edit it, and choose the No propagation mode.

10.  Click OK in the Join Definition dialog box.

A warning message is issued, informing you that an edge no longer is recognized on the pad.

11.  Click OK.

The Update Diagnosis dialog box is displayed, allowing you to re-enter the specifications for the 
edge, and its fillet.

You then need to edit the edge and re-do the fillet to obtain the previous pad up to the joined 
surface. 

12.  Select the Edge.1 line, click the Edit button, and re-select the pad's edge in the geometry.

13.  Click OK in the Edit dialog box.

The fillet is recomputed based on the correct edge.

 



Extrapolating Surfaces

 
This task shows you how to extrapolate a surface boundary.

 
Open the Extrapolate1.CATPart document.

1.  Click the Extrapolate icon .

The Extrapolate Definition dialog box appears.

2.  Select a surface Boundary.

3.  Select the surface to be Extrapolated.

4.  Select the extrapolation type:

❍     Length: enter the value in the Length field or use the manipulators in the 3D geometry.

It is not advised to enter a negative value in the Length field.

❍     Up to: the Up to field is enabled. Select an element belonging to the same support as the surface to be extrapolated (surface or plane).

This option is only available with the Tangent continuity type.

5.  Specify the Limit of the extrapolation by either:

❍     entering the value of the extrapolation length

❍     selecting a limit surface or plane

❍     using the manipulators in the geometry.

6.  Specify the Continuity type:

❍     Tangent

❍     Curvature

Tangent: Curvature:
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7.  Specify Extremities conditions between the extrapolated surface and the support surface. 

 
This option is now available with the Curvature continuity type.

❍     Tangent: the extrapolation sides are tangent to the edges adjacent to the surface boundary.

❍     Normal: the extrapolation sides are normal to the original surface boundary.

Tangent (Tangent continuity): Normal (Curvature continuity):

8.  Specify the Propagation type:

❍     Tangency continuity to propagate the extrapolation to the boundary's adjacent edges.

❍     Point continuity to propagate the extrapolation around all the boundary's vertices.

Tangent continuity: Point continuity:

9.  Click OK to create the extrapolated surface.

The surface (identified as Extrapol.xxx) is added to the specification tree.



Additional Parameters
 

●     Check the Constant distance optimization option to perform an extrapolation with a constant distance and create a surface without 
deformation.

This option is not available when the Extend extrapolated edges option is checked.

Open the Extrapolate4.CATPart document.

 1.  Select Boundary.1 as the Boundary and Surface.1 as the surface to be Extrapolated.
2.  Set a Length of 10mm.
3.  Check the Constant distance optimization option.
4.  Click OK to create the extrapolated surface.

 

 Constant distance optimization option checked Constant distance optimization option unchecked

●     The Internal Edges option enables to determine a privileged direction for the extrapolation. You can select one or more edges (in the following 
example we selected the edge of Surface.1) that will be extrapolated in tangency. You can also select a vertex once you have selected an edge in 
order to give an orientation to the extrapolation.

 
●     You can only select edges in contact with the boundary.

●     This option is not available with the Curvature continuity type and with the Wireframe and Surface product.

One edge selected Two edges selected 

 
●     Check the Assemble result option if you want the extrapolated surface to be assembled to the support surface.

 
●     Check the Extend extrapolated edges to reconnect the features based on elements of the extrapolated surface.

This option is especially useful if you work within an ordered geometrical set environment.

Open the Extrapolate3.CATPart document.
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1.  Set Extrude.1 as the current object.

2.  Select the boundary of Extrude.1 and Extrapol.1 as the surface to be extrapolated.

Extrude.3 is automatically rerouted, as well as all edges based on Extrude.1.

❍     This option is only available when both Continuity and Extremity types are specified as Tangent, and when the Assemble result 
option is checked.

❍     It is not available when the Constant distance optimization option is checked.

 



Extracting Geometry

 

This task shows how to perform an extract from elements (curves, points, surfaces, solids, volumes and so forth). 

This may be especially useful when a generated element is composed of several non-connex sub-elements. Using the extract capability you can 
generate separate elements from these sub-elements, without deleting the initial element.

 
Open the Extract1.CATPart document.

1.  Click the Extract icon .

The Extract Definition dialog box is displayed. 

In the Part Design workbench, the Extract capability is available as a contextual command named Create Extract that you can access 
from Sketch-based features dialog boxes.

2.  Select an edge or the face of an element.

The selected element is highlighted. 

Multi-selection is available to let you select several elements to be extracted.

3.  Choose the Propagation type: 

❍     Point continuity: the extracted element will not have a hole.

❍     Tangent continuity: the extracted element will be created according to tangency conditions. 

❍     Curvature continuity: the extracted element (necessarily a curve) will be created according to curvature conditions.
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❍     No propagation: only the selected element will be created.

4.  Click the Show parameters>> button to display further options. They are only valid for curves.

These options are only valid for curves.

❍     Distance Threshold: specifies the distance value between 0.001mm and 0.1 mm below which the elements are to be extracted.
■     The default value is 0.1mm, except if a Merging Distance has been defined different from 0.001mm in Tools -> Options. 

In this case, the Distance Threshold value is initialized with the Merging Distance value.
To have further information, refer to the General Settings chapter.

 ■     It is available with all propagation types, except for the No propagation type.

❍     Angular Threshold: specify the angle value between 0.5 degree and 5 degree below which the elements are to be extracted (the 
default value is 0.5deg)

❍     Curvature Threshold: specifies a ratio between 0 and 1 which is defined as follows:

if ||Rho1-Rho2|| / max (||Rho2||,||Rho1||) < (1-r)/r 
where Rho1 is the curvature vector on one side of the discontinuity, Rho2 the curvature vector on the other side, and r the ratio 
specified by the user;
then the discontinuity is smoothed. 

For example, r=1 corresponds to a continuous curvature and r=0.98 to the model tolerance (default value). A great discontinuity will 
require a low r to be taken into account.

 

 Curvature Threshold = 0.98 Curvature Threshold = 0.80 Curvature Threshold = 0.50
To sum up:

❍     when Point continuity is selected, only the Distance Threshold is activated

❍     when Tangent continuity is selected, both Distance and Angular Thresholds are activated

❍     when Curvature continuity is selected, all Thresholds are activated.

5.  Click OK to extract the element.

The extracted element (identified as Extract.xxx) is added to the specification tree.

 
Additional Parameters

 
●     The Complementary mode option, once checked, highlights, and therefore selects,  the elements that were 

not previously selected, while deselecting the elements that were explicitly selected.



●     Check the Federation option to generate groups of elements belonging to the resulting extracted element 
that will be detected together with the pointer when selecting one of its sub-elements. For further 
information, see Using the Federation Capability.

●     You can select a volume as the element to be extracted.
To do so, you can either:

❍     select the volume in the specification tree, or

❍     use the User Selection Filter toolbar and select the Volume Filter mode.
For further information, refer to the Selecting Using A Filter chapter in the CATIA Infrastructure User's 
Guide.

In both cases, the result of the extraction is the same whatever the chosen propagation type.

●     If you extract an internal edge that you want to propagate, and there is an ambiguity about the propagation 
side, a warning message is issued and you are prompted to select a support face. In this case, the dialog box 
dynamically updates and the Support field is automatically filled in.

 
Creating Contextual Extracts

 Some commands allow the creation of contextual extracts using the right-mouse button. They are aggregated to the feature using them and put 
in no show.
Here is an example with the Parallel Curve command when right-clicking the Curve field:

 

 ●     If you select the Create Extract contextual command, the Extract Definition dialog box opens.

●     If you select the Create Extract (in point) or Create Extract (in tangency) contextual command, no dialog box opens.
Both commands let you create extracts with a pre-defined propagation. You just need to select a sub-element such as wire edge, border 
edges, face, sub-elements of a volume or a solid. 

You cannot select edges as a support is needed.

You need to leave the mouse on the pre-selected sub-element to preview and compute the propagation (in green):
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Editing Extracts

 When editing extracts, the multi-selection capability is not available: if you select another element to be extracted, it is not appended to the list 
but replaces the former element.

 
Miscellaneous

 
●     In a .CATProduct document containing several parts, you can use the extract capability in the current part from the selection of an element 

in another part, provided the propagation type is set to No Propagation.
In this case, a curve (respectively a surface or point) is created in the current part if the selected element is a curve (respectively a surface 
or point); the Extract parent therefore being the created curve (respectively the surface or point).
Note: 

❍     if another propagation type is selected, the extraction is impossible and an error message is issued.

❍     when editing the extract, you can change the propagation type providing the parent belongs to the current part.

❍     in the current part, if you select an element using the Tangent, Point or Curvature continuity as the propagation type, a warning is 
issued and you have to select No propagation instead.

●     If the selected element is not tangent continuous and the propagation type is set to Tangent continuity, an error message is issued.

●     If the selected element is a wire that is not curvature continuous and the propagation type is set to Curvature continuity, an error message 
is issued.

●     If the selected element has a support face and is not a surface, even though the Complementary mode option is checked, the 
Complementary mode will not be taken into account for the extraction and the option will therefore be inactive. After the extraction, the 
option will be available again.

●     If the selected element is a border edge, the propagation is done along the boundary of the support and does not take into account internal 
edges.

●     When the result of an extract is not connex (during creation or edition) due to naming ambiguity, you can now select the part to keep to 
solve the ambiguity.

●     You cannot copy/paste an extracted element from a document to another. If you wish to do so, you need to copy/paste the initial element 
first into the second document then perform the extraction.

●     If there is several solutions for the propagation, the computation of the extract stops at the junction point.

 



Creating Intersections
This task shows you how to create wireframe geometry by intersecting elements.

You can intersect:

●     wireframe elements

●     solid elements

●     surfaces

Open the Intersection1.CATPart document.

 1.  Click the Intersection icon .

The Intersection Definition dialog box appears as well as the Multi-Selection dialog box allowing 

to perform multi-selection. 

2.  Select the two elements to be intersected.

The intersection is displayed.
Multi-selection is available on the first and second selection, meaning that you can select 
several elements to be intersected as well as several intersecting elements. For instance 
you can select a whole geometrical set.

3.  Choose the type of intersection to be displayed.
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❍     a Curve (when intersecting two curves):

 

❍     Points (when intersecting two curves):

 

❍     a Contour: when intersecting a solid element with a surface :

 

❍     a Face: when intersecting a solid element with a surface (we increased the transparency 
degree on the pad and surface):



4.  Click OK to create the intersection element.

This element (identified as Intersect.xxx) is added to the specification tree. 

 

The above example shows the line resulting
from the intersection of a plane and a surface The above example shows the curve resulting

from the intersection of two surfaces

Additional Parameters

Several options can be defined to improve the preciseness of the intersection.

Open the Intersection2.CATPart document.
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●     The Extend linear supports for intersection option enables you to extend the first, second or both 

elements. 
Both options are unchecked by default.
Here is an example with the option checked for both elements.

 

 
●     The Extrapolate intersection on first element check box enables you to perform an extrapolation 

on the first selected element, in the case of a surface-surface intersection. In all the other cases, the 
option will be grayed.
   
Intersection with the Extrapolation option 
unchecked:  Intersection with the Extrapolation option 

checked:

 



 ●     The Intersect non coplanar line segments check box enables you to perform an intersection on 
two non-intersecting lines. 
When checking this option, both Extend linear supports for intersection options are checked too.
   
Intersection between the light green line and the 
blue line: the intersection point is calculated after 
the blue line is extrapolated

 
Intersection between the pink line and the blue 
line: the intersection is calculated as the mid-
point of minimum distance between the two lines

 

 The following capabilities are available: Stacking Commands and Selecting Using Multi-
Output.

●     If you select a body or a hybrid body containing both solid and wireframe elements 
as input, only the solid elements are taken into account to compute the intersection.

●     Avoid using input elements which are tangent to each other since this may result in 
geometric instabilities in the tangency zone.
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Creating Projections

 

This task shows you how to create geometry by projecting one or more elements onto a  support. The 
projection may be normal or along a direction.
You can project: 

●     a point onto a surface or wireframe support

●     wireframe geometry onto a surface support

●     any combination of points and wireframe onto a surface support.

Generally speaking, the projection operation has a derivative effect, meaning that there may be a 
continuity loss when projecting an element onto another. If the initial element presents a curvature 
continuity, the resulting projected element presents at least a tangency continuity. If the initial element 
presents a tangency continuity, the resulting projected element presents at least a point continuity.

Open the Projection1.CATPart document.

1.  Click the Projection icon  .

The Projection Definition dialog box appears as well as the Multi-Selection dialog box allowing to 
perform multi-selection.

2.  Select the element to be Projected.

You can select several elements to be projected.  In this case, the Projected field indicates: x 
elements.
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3.  Select the Support element. 

4.  Use the combo to specify the direction type for  the projection:

❍     Normal: the projection is done normal to the support element.

❍     Along a direction: you need to select a line to take its orientation as the translation 
direction or a plane to take its normal as the translation direction.
You can also specify the direction by means of X, Y, Z vector components by using the 
contextual menu on the Direction field.



5.  Whenever several projections are possible, you can check the Nearest Solution option to keep 

the nearest projection.

The nearest solutions are sorted once the computation of all the possible solutions is performed.

6.  Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification tree. 

 
Smoothing Parameters

 You can smooth the element to be projected by checking either: 

●     None: deactivates the smoothing result
With support surface: the smoothing is performed according to the support. As a consequence, the 
resulting smoothed curve inherits support discontinuities.

●     Tangency: enhances the current continuity to tangent continuity

●     Curvature: enhances the current continuity to curvature continuity

●     You can specify the maximum deviation for G1 or G2 smoothing by entering a value or using the 

spinners. 

If the element cannot be smoothed correctly, a warning message is issued.

Moreover, a topology simplification is automatically performed for G2 vertices: cells with a curvature 

continuity are merged.



Only small discontinuities are smoothed in order to keep the curve's sharp vertices.

 Without support surface:

●     3D Smoothing: the smoothing is performed without specifying any support surface. As a 

consequence, the resulting smoothed curve has a better continuity quality and is not exactly laid 

down on the surface.

As a consequence, you may need to activate the Tolerant laydown option. Refer to the Customizing 

General Settings chapter.

This option is available if you previously select the Tangency or Curvature smoothing type.

With 3D smoothing option checked: With 3D smoothing option unchecked:

 

The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Creating Boundary Curves

 
This task shows how to create the boundary curve of a surface.

Open the Boundaries1.CATPart document.

1.  Click the Boundary icon .

The Boundary Definition dialog box appears. 

2.  Use the combo to choose the Propagation type:

❍     Complete boundary: the selected edge is propagated around the entire surface boundary.

❍     Point continuity: the selected edge is propagated around the surface boundary until a point 
discontinuity is met.

❍     Tangent continuity: the selected edge is propagated around the surface boundary until a tangent 
discontinuity is met.

❍     No propagation: no propagation or continuity condition is imposed, only the selected edge is kept.

You can select the propagation type before selecting an edge.

3.  Select a Surface edge.

The boundary curve is displayed according to the selected propagation type.

No propagation Tangent continuity
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Point continuity Complete boundary

4.  You can relimit the boundary curve by means of two elements.

If you relimit a closed curve by means of only one element, a point on curve for instance, the closure 
vertex will be moved to the relimitation point, allowing this point to be used by other features.

5.  Click OK to create the boundary curve.

The curve (identified as Boundary.xxx) is added to the specification tree.

You cannot copy/paste a boundary from a document to another. If you wish to do so, you need to 
copy/paste the surface first into the second document then create the boundary.

About the Propagation Type
❍     If you select the surface directly, the Propagation type no longer is available, as the complete boundary 

is automatically generated. 

Provided the generated boundary curve is continuous, you can still select a limiting point to limit the 
boundary. 

Using the red arrow; you can then invert the limited boundary. 



❍     If you select a curve which has an open contour, the Propagation type becomes available: choose the No 
Propagation type and select the curve again. The extremum points will define the boundary result.

 

 



Modifying Parts
 

Redefine Feature Parameters Select the object to be edited, double-click it, then enter new 
parameters in the dialog box that is displayed.

Update Parts: Click this icon. To resolve possible difficulties, click the Edit, Deactivate or Delete 
button in the dialog box that appears. 
Delete Features: Select the feature to be deleted and  the Edit > Delete... command. Optionally, 
delete its exclusive parents or its children by checking the corresponding options. 
Delete Unreferenced Elements: Select Tools > Delete Useless Elements..., and confirm the 
deletion by clicking OK in the dialog box that appears.
Deleting Boolean Operations Performed within OGSs. From the specification tree, right-click and the 
Boolean operation you wish to delete and select XXX.object>Delete and Keep Operand in 
Context.
Deactivate Elements: Right-click the element to be deactivated from the specification tree, and 
select Xxx object > Deactivate. 
Reorder Features: Select the feature to be reordered, Edit > xxx.object > Reorder... and the 
feature after which you wish to position your object.
Reordering Sketch-Based Features: Select the feature to be reordered, Edit > xxx.object > 
Reorder... and the feature after which you wish to position your object.

For reference information,  refer to Specification Tree Symbols.
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Editing Parts, Bodies and Features  

Editing a part may mean for example modifying the density of the part (See Displaying and Editing Properties 
), but most often editing consists in modifying the features composing the part. This operation can be done at 
any time. 

There are several ways of editing a feature. If you modify the sketch used in the definition of a feature, the 
application will take this modification into account to compute the feature again: in other words, associativity 
is maintained.

Now, you can also edit your features through definition dialog boxes in order to redefine the parameters of 
your choice.

Redefining Feature Parameters 

 

This task shows how to edit a draft and a pad. The process described here is valid for any other feature 
to be edited.

 
Open the Edit1.CATPart document.

 
1.  Double-click the draft to be edited (in the specification tree or in the geometry area).

The Draft Definition dialog box appears and the application shows the current draft angle value. 

Generally speaking, the application always shows dimensional constraints related to the feature 

you are editing. Concerning sketch-based features, it also shows the sketches used for extrusion 

as well as the constraints defined for these sketches.

Instead of double-clicking the element you wish to edit, you can also click this element and select the 
XXX.object > Definition... command which will display the edit dialog box.
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2.  Enter a new draft angle value.

3.  Click OK.

This is your new feature: 

4.  Now, double-click the pad.

The Pad Definition dialog box appears and the application shows the pad only, not the next 

operation.

You will notice that the pad was created in symmetric extent mode and that the application 

displays information about the initial profile.

5.  Enter a new length value.

6.  Uncheck the Mirrored extent option.

7.  Enter a length value for the second limit in the Length field.

Optionally, click Preview to see the new pad to be created.

8.  Click OK.

The modifications are taken into account. Your part now looks like this:



 
You can also access the parameters you wish to edit in the following way: 

1.  Right-click the feature in the specification tree and select feature.n object > Edit Parameters .

You can now view the feature parameters in the geometry area.

2.  Double-click the parameter of interest.

A small dialog box appears displaying the parameter value:

3.  Enter a new value and click OK. 

Note

If you wish to quit the Edit Parameters contextual command, just click the Select  icon.



Updating Parts 
This page explains how and when you should update your design. The following topics are discussed:

●     Overview

●     What Happens When the Update Fails? (scenario)

●     Canceling Updates

●     Interrupting Updates (scenario)

●     Update All Command

Overview

The point of updating a part is to make the application take your very last operation into account. Although some operations 
such as confirming the creation of features (clicking OK) do not require you to use the Update command because by default 
the application automatically does it, some changes to sketches, features etc. require the rebuild of the part. 

To warn you that an update is needed, the application displays the update symbol next to the part's name  and shows the 
geometry in bright red.

Keep in mind that:

●     To update the feature of your choice, just right-click that feature and select Local  Update.

●     Besides the update modes, you can also choose to visualize the update on the geometry as it is happening by checking the 
Activate Local Visualization option from the Tools > Options > Infrastructure > Part Infrastructure, General tab. 

In this case, as soon as you have clicked the Update icon : 
❍     the geometry disappears from the screen; 

❍     each element is displayed as it is updated, including elements in No Show mode. Once they have been updated, they 
remain in No Show mode. 

Two Update Modes

To update a part, the application provides two update modes:

●     automatic update, available in Tools > Options > Infrastructure > Part Infrastructure. If selected, this option lets 
the application update the part when needed.

●     manual update, available in Tools > Options-> Infrastructure > Part Infrastructure: lets you control the updates of 

your design. What you have to do is just click the Update All icon  whenever you wish to integrate modifications. 
The Update capability is also available via Edit > Update and the Update contextual menu item. A progression bar 
indicates the evolution of the operation.

What Happens When the Update Fails? 

Sometimes, the update operation is not straightforward because for instance, you entered inappropriate edit values or because 
you deleted a useful geometrical element. In both cases, the application requires you to reconsider your design. The following 
scenario exemplifies what you can do in such circumstances. 

Open the Update3.CATPart document.
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1.  Enter the Sketcher to replace the circular edge of the initial sketch with a line, then return to Part Design.

The application detects that this operation affects the shell. A yellow symbol displays on the feature causing trouble i.e. 

the shell in the specification tree. Moreover, a dialog box appears providing the diagnosis of your difficulties and the 

preview no longer shows the shell:

To resolve the problem, the dialog box provides the following options. If you wish to rework Shell.1, you can: 

❍     Edit it 

❍     Deactivate it

❍     Isolate it 

❍     Delete it  

2.  For the purposes of our scenario that is rather simple, click Shell.1 if not already done, then Edit.

The Feature Definition Error window displays, prompting you to change specifications. Moreover, the old face 

you have just deleted is now displayed in yellow.

The text Removed Face is displayed in front of the face, thus giving you a better indication of the face that has 

been removed. Such a graphic text is now available for Thickness and Union Trim features too.



3.  Click OK to close the window. 

The Shell Definition dialog box appears.

4.  Click the Faces to remove field if not already done and select the replacing face.

5.  Click OK to close the Shell Definition dialog box and obtain a correct part. The shell feature is rebuilt.

 

Canceling Updates 

You can cancel your updates by clicking the Cancel button available in the Updating...dialog box.

Interrupting Updates 

This scenario shows you how to update a part and interrupt the update operation on a given feature by means of a useful 
message you previously defined.

Open the Update.CATPart document and ensure that the manual update mode is on.
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1.  Right-click Hole.1 as the feature from which the update will be interrupted and select the Properties contextual menu 

item.

The Properties dialog box is displayed.

2.  Check the Associate stop update option. This option stops the update process and displays the memo you entered in 

the blank field. This capability is available in manual or automatic update mode.

3.  Enter any useful information you want in the blank field. For instance, enter "Fillet needs editing".

4.  Click OK to confirm and close the dialog box.

The entity Stop Update.1 is displayed in the specification tree, below Hole.1, indicating that the hole is the last feature 

that will be updated before the message window displays.

5.  Edit Sketch.1, which will invoke an update operation.

When quitting the Sketcher, the part appears in bright red.

6.  Run the update operation by clicking the  icon.

The Updating... as well as the Stop Update message windows are displayed. The Stop Update windows displays your 

memo and lets you decide whether you wish to stop the update operation or continue it.



7.  Click Yes to finish.

The part is updated. You can now edit the fillet if you consider it necessary.   

Using this capability in automatic update mode, the Stop Update dialog box that displays is merely informative.

 

8.  If you decide not to use this capability any longer, you can either: 

❍     right-click Hole.1, select Properties and check the Deactivate stop update option: the update you will perform 
will be a basic one. To show that the capability is deactivated for this feature, red parentheses precede Stop 

Update.1 in the specification tree: .

❍     right-click Stop Update.1 and select Delete to delete the capability.

Update All Command

The Update All command synchronizes copied solids linked to external references, but also updates the whole geometry of the 
part. For information about external references, refer to Handling Parts in a Multi-document Environment in the Part Design 
User's Guide.

There are cases where the command also displays the Replace Viewer window. This window either helps you redefine directions 
if needed or is merely informative and therefore lets you check the validity of your geometry.

 



Deleting Features
Whenever you have to delete geometry, you do not necessarily have to delete the elements used to create it. The application 
lets you define what you really want to delete.

If you wish to delete all unnecessary elements of a CATPart document, refer to Deleting Unreferenced Elements. From 
V5R16 onward, a new capability is dedicated to the deletion of Boolean operations. To know more about it, refer to Deleting 
Boolean Operations Performed within OGSs.

This section also deals with the following topics:

●     Deleting Features Built upon Dress-up Features

●     Deleting Constrained Features

●     Deleting Patterns

●     Deleting Aggregated Elements

This task shows how to delete a sketch on which geometry has been defined and what this operation involves.

Open the Delete.CATPart document.

 
1.  Select the rectangle you wish to delete.

2.  Select Edit > Delete.... 

The Delete dialog box is displayed, showing the element to be deleted and three options. 

❍     Delete exclusive parents: deletes the geometry on  which the element was created. This geometry can be 
deleted only if it is exclusively used for the selected element.

This option is already checked if you previously checked the Delete exclusive parents option in the Options 
dialog box. For more information, refer to General to know how to customize appropriate settings.

❍     Delete all children: deletes the geometry based upon the element to be deleted, in other words, dependent 
elements.

❍     Delete aggregated elements: deletes the geometry aggregated below the element to be deleted.

Here, the first option cannot be used because the rectangle has no parents. The third option cannot be used either 

due to the fact that there is no aggregated geometry.
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Replacing Features
3.  Click More.

Additional options and the elements affected by the deletion are displayed. If you can delete the sketch, you can also  

replace it with another element.

4.  Click ...PartBody/Sketch.2 to display Sketch.2 from the Replace section. 

Sketch.2 appears in the Replace field.

5.  Select Sketch4, that is the hexagon to replace Sketch 2 . 

This operation is now displayed in the dialog box.

Note that in case you are replacing a constrained feature, the related constraints are automatically deleted. For more 

information, see Deleting Constrained Features.

6.  Click OK. 

The sketch is deleted as well as its children: two pads one of which is filleted. 



A Few Notes About Deletion 

●     Deleting Features Built upon Dress-up Features

If you delete a feature (dress-up or not) previously used to create a dress-up feature, the dress-up feature is 
recomputed.

In this example, thickness was added to the pad, then material was removed from the whole part using the shell 
capability. In other words, the existence of the shell depends upon the existence of the thickness.

 

You will notice that only the thickness has been deleted. The application 
keeps the shell feature.

●     Keep in mind you can apply the Undo command if you inadvertently deleted a feature.

●     You are not allowed to delete a profile used to define a feature, unless you delete the profile to construct another one.

●     Deleting Constrained Features

If while you are deleting a constrained feature you decide to replace it with another feature, the related constraints are never re-
created. They are always automatically deleted. The application warns you via the Delete dialog box:

●     Deleting Patterns

Applying the Delete command on one instance of a pattern deletes the whole pattern.

●     Deleting Aggregated Elements
❍     Whenever you delete a feature, you can choose between deleting the corresponding aggregated element (element located 

just below the feature based on it, in the specification tree. For example, a sketch) or not.
In concrete terms, you can activate or deactivate the Delete aggregated elements option. By default, the option is 
checked.

❍     Deleting a surface or wireframe element may affect the specifications of a Part Design feature.

❍     When deleting a Boolean operation, by default all operated bodies (located below the Boolean operation node) are deleted 
too: just deselect the Delete aggregated elements option if you wish to keep the bodies.



Deleting Unreferenced Elements
This task shows you how to delete un-referenced elements, i.e. elements not participating in the creation 
of other geometrical elements.

Open the Delete.CATPart document.

 
1.  Select the Tools > Delete Useless Elements command. 

The Delete Useless Elements dialog box appears. 

It lists all the geometrical elements, datum or not, that are present in the document or in other 

documents when working in context: in a CATProduct document referencing CATPart documents. 

Elements used by a Part Design feature have the Keep, used by solid status meaning they 

cannot be deleted. In our scenario, three elements are mentioned with the Delete status.

file:///E|/www/celr16/Doc/online/prtug_C2/samples/Delete.CATPart


 

Keeping Some Elements  

If you do not wish to delete all possible elements, use the Keep contextual menu item. For instance, 
apply that command onto PartBody\Sketch.4.
The list of un-referenced elements is automatically updated, indicating a new status for the selected 
element (Keep). 

Sometimes, for some kept elements, the application detects other elements that are to be kept as a 
consequence. In that case, the status is "Keep, propagate".

In the bottom left corner of the dialog box, the global status is also updated.

 

 

 

2.  Click OK to confirm the deletion of all elements listed with the Delete status.

More About the Command
●     The Delete contextual menu item is available to delete an element which status is Keep. 

Also available in the contextual menu are the Center Graph and Reframe On items. 

●     Bodies, whether Geometrical Sets, Ordered Geometrical Sets or PartBodies located directly below the 
main Part are not displayed in the list, as when creating a new document, they are necessarily empty 
of geometric elements, and it does not make sense to delete them. 

 



Deleting Boolean Operations Performed within 
OGSs

Up to V5r16, when you deleted a Boolean operation (see Associating Bodies) performed between a body 
and a body included in an Ordered Geometrical Set (OGS), you could choose between deleting 
aggregated elements or not. If you decided not to delete aggregated elements, it was no longer possible 
to put the body back in the OGS (unless performing another Boolean operation) once the deletion has 
been performed.

From now on, you can keep the operand body in the context of the Boolean operation before its deletion. 
For this, you need to use a dedicated capability Delete and Keep Operand in Context. This new 
capability is available thru contextual menus and applies to Boolean operations performed with bodies 
set in ordered geometrical sets only.

This section shows an example of the use of the capability, then discusses the following topics:

●     Insertion of a New OGS

●     Notes

Delete and Keep Operand in Context

To use Delete and Keep Operand in Context you need to right-click and select the Boolean operation 
you wish to delete from the specification tree, then select the command thru the contextual menu.

In the example below, Delete and Keep Operand in Context is applied to Assemble.1 is selected.  



Assemble.1 is deleted. Operand Body remains in Ordered Geometrical Set.1.



Initial state

Ordered Geometrical Set. 2 has been inserted 
after confirming the deletion. The insertion of this 
OGS is a way of preventing interruptions of the 
sequential geometry creation.

Notes

This capability is not available:

●     For Boolean operations performed with Volumes

●     If the operand body is a solid body. For information, refer to Mixed Boolean Operations.

●     If the second operand is not aggregated by the Boolean operation as illustrated in the following 
example:

Insertion of a New OGS

In cases the deletion breaks the sequential construction of the geometry, a warning message is issued, 
letting you choose between canceling the operation (just click NO from that dialog box) or continuing it 
(just click YES from that dialog box).  In that particular case, the application inserts a new OGS instead 
of the Boolean operation.



Initial state

Body 2 has been added to Body1, but is not 
located below Add.1 in order to prevent 
interruptions of the sequential geometry creation. 
Consequently, Delete and Keep Operand in 
Context is not available.

  

 



Deactivating Elements
This task shows how to inactivate a geometric element: it acts as a temporary deletion.
This may be useful when, in a complex part, a branch of the part should not be affected by an update, or 
is not updating correctly for instance.
This capability will let you work on the other elements present in the document while ignoring a specific 
element. 

Open the Deactivate1.CATPart document.

 
1.  Right-click the element to be deactivated from the specification tree, and choose the Xxx object -

> Deactivate contextual command. 

2.  Click OK.

The selected element as well as its children and aggregated elements (if any and depending on 
the selected options) are deactivated.
The ( ) symbol is displayed in the specification tree, and the corresponding geometry is 
hidden. Also refer to Symbols Reflecting an Incident in the Geometry Building.

 

The selected element has no children nor aggregated elements
If the selected element does not have any children nor any aggregated elements (for instance Line.2), it 
is directly deactivated. This is indicated by the ( ) symbol in the specification tree: 

 

 

Other cases
 For all the other cases, the Deactivate dialog box appears and the geometry to be deactivated is 

highlighted.
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●     The selected element has children but no aggregated elements (for instance Extrude.4).

 

❍     The Deactivate all children is checked: it lets you deactivate the geometry based upon the 
element to be deactivated, that is dependent elements.
By default, the option is checked, except for modification features when a reroute is possible (see 
example below).
If you uncheck the option, a warning icon is displayed to inform you that there will be an update 
error.

❍     The Deactivate aggregated elements is disabled.

●     The selected element has aggregated elements but no children (for instance a Part Design feature 
based on a sketch, such as Pad.1).
Open the Deactivate2.CATPart document.

❍     The Deactivate all children is disabled.

❍     The Deactivate aggregated elements is checked: it lets you deactivate the geometry 
aggregated below the element to be deactivated.
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Whenever you deactivate a feature, you can choose between deactivating the corresponding 
aggregated element (element located just below the feature based on it, in the specification tree) 
or not (as shown below):

 

 

When deactivating a Boolean operation, by default all operated bodies (located 
below the Boolean operation node) are deactivated too: just deselect the 
Deactivate aggregated elements option if you wish to keep the bodies.

●     The selected element has children and aggregated elements (for instance Line.1).
Open the Deactivate3.CATPart document.

❍     Both Deactivate all children and Deactivate aggregated elements options are checked.
If you uncheck the Deactivate aggregated elements option, the Deactivate all children 
option is automatically disabled. Indeed, the aggregated elements have children unlike Line.1.
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●     The selected element is a modification feature, has children and a reroute is possible (for instance 

Join.1).

Open the Deactivate1.CATPart document.

 

 You can check the Deactivate all children option to avoid rerouting the element. All children 
are deactivated.

 

 When no reroute is possible, the Deactivate all children option is checked.
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In case of multi-selection, the number of elements is displayed in the 

Selection field. You can click the  icon to display the list of elements.

 

There are two deactivation modes: 
●     Copy mode: the deactivation is performed on the modification operation of the feature (providing a 

modification of a feature of same dimension). When selected, the feature can be seen in the 3D 
geometry.
Here are the features concerned by this mode: 

❍     Projection

❍     Curve Smooth

❍     Blend (with Trim option only)

❍     Corner (with Trim option only)

❍     Shape Fillet (with Trim option only)

❍     Connect Curve (with Trim option only)

❍     Parallel Curve

❍     Offset

❍     Variable Offset

❍     Rough Offset

❍     3D Curve Offset

❍     Split (on the Element to cut)

❍     Trim (on the Element to cut)

❍     All transformations in creation and modification modes

❍     Sweep (tangent sweeps with Trim option)

❍     Surface Extrapolation (with Assemble Result option only)

❍     Curve Extrapolation (with Assemble Result option only)

❍     Join (copy of the first element)

❍     Healing (copy of the first element)

❍     Combine

❍     Invert

❍     Near



❍     Develop

❍     Wrap Curve

❍     Wrap Surface

❍     Bump

❍     Shape Morphing

❍     Diabolo

●     Destructive mode: the deactivation makes the feature unusable. When selected, the feature cannot 
be seen in the 3D geometry.
Here are the features concerned by this mode: 

❍     Line

❍     Plane

❍     Circle

❍     Reflect Line

❍     Spiral

❍     Spline

❍     Helix

❍     Intersection

❍     Extrude

❍     Revolution

❍     Cylinder

❍     Sweep (except tangent sweeps with trim option)

❍     Multi-Sections Surface

  
 

●     When elements are imported using multi-part links (external 
references) or using a Copy-Paste As result with link, the 
deactivation concerns the link, not the feature. As a 
consequence, the feature can still be selected.

●     To re-activate the elements, right-click their name in the 
specification tree and choose the XXX object -> Activate 
contextual command. 

●     It is not possible to deactivate datum elements as they do not 
have an history. Indeed, a deactivation would destroy their 
geometry and a reactivation would therefore be impossible.

 

 



Reordering Features 

 

Reordering Part Design or Generative Shape Design features means moving and repositioning these 
features in the specification tree.
The Reorder capability allows you to reorganize your design, group features together, but also rectify 
design mistakes and eliminate some problems.

This section includes two scenarios showing you how to:

●     Reorder one feature

●     Reorder several features at a time

Additionally, it provides reference information on the following issues:

●     Yellow nodes

●     What you can do

●     Update operations

●     In work objects

Reordering Sketch-Based Features

When reordering sketch-based features, your environment configuration affects the way sketches are 
located in the specification tree. To know how sketches are located in the specification tree, refer to 
Reordering Sketch-Based Features.

Reordering Dress-Up Features

Remember that dress-up features cannot be created as the first features of bodies. Consequently, when 
reordering this type of features, you must keep in mind this rule which explains why you cannot reorder 
dress-up features just below bodies.

Reordering One Feature
Open the Reorder.CATPart document.
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1.  Your initial data consists of a pad that was mirrored and a second pad created afterwards. As 

the order of creation is wrong, you are going to reorder the second pad so as to mirror the 

whole PartBody. Position your cursor on Pad.2. and select Edit > Pad.2 object > Reorder... 

The Feature Reorder dialog box appears. 

2.  Select Pad.1 to specify the new location of the feature. 

This name appears in the After field.

 

3.  Click OK. 

The part rebuilds itself completely or partially, depending on the chosen option for Update 

operations. 

4.  When the update is complete, to see the resulting geometry, use Define in Work Object to set 

Mirror.1 as the current feature. 

The mirror feature appears after the creation of the second pad, which explains why this second 

pad is now mirrored.



Yellow Nodes

Non-available locations are indicated in yellow in the tree. A yellow feature indicates that the feature to 

be reordered cannot be located below it. If you select one of these forbidden locations, an error 

message is issued. In the example below, the user is trying to reorder Pad.1. As indicated by the yellow 

color set on all of the nodes, this feature cannot be reordered.

 

What You Can Do
●     You can reorder features located in a solid body (body that do not integrate wireframe nor 

generative shape design geometry), part body, body or ordered geometrical set. The general rule is 
that a feature must remain in the same branch under the part where the notion of order is defined, 
but there are exceptions to that:

❍     Solid features can be moved from one body to another even if these bodies do not belong to the 
same branch.

❍     Non-solid features (GSD features, sketches and datum features) can be moved from one 
Ordered Geometrical Set (or body) to another (body) in another branch provided that they are 
independent: they have no parents (except for XY, YZ or ZX planes or axis systems located just 
below the part in the tree) and no children.

●     A root OGS (Ordered Geometrical Set located directly under the Part) can be reordered to any 
empty set. But the root OGS has to be reordered alone: if two root OGSs are selected, an error 
message will be issued.



Specifying the new location

●     In ordered structures, such as ordered geometrical sets or bodies, the Reorder command 
guaranties that the order is preserved.

●     The target location for the feature you are reordering is the location after which the feature will be 
placed: the application aggregates the feature under the same father as the father selected and just 
as the next feature (the only exception to that rule is the case discussed in the following paragraph, 
see next bullet).
In the example below, you cannot reorder the pocket directly below the assemble operation because 
Boolean operations aggregate bodies only, not features. 

●     If you wish to reorder a Part Design feature in a distinct body located directly under the part, when 

selecting that body node, the feature will be located at the bottom of the body list.

●     If you wish to reorder a feature within the same body or ordered geometrical set located directly 

under the part, when selecting that body or geometrical set node, the feature will be moved just 

below the selected node.

Allowed Locations and Updates

Solid features are of only one type: they are all considered as modification features (except for the first 
one of the body)

In OGS or bodies, a distinction is to be made between modification features and creation features for 
surface features.



●     creation features (such as Extrude, Offset etc.) create a new object.

●     modification features (such as Split, Edge Fillet, Trim, Join etc.) create a new state in an existing 
object as well as absorb the preceding state.

When reordering surface features, the yellow node analysis is based upon the distinction between 
creation features and modification features. Both examples below illustrate the application behavior.

Reordering a Modification Feature

Under some circumstances, the application anticipates geometry reconnections and update problems 
and indicates them thru the display of yellow nodes. For example, let's consider this part :

EdgeFilet.1 highlighted above is based upon Trim.1 which itself is a modification feature based upon 
Extrude.1 as the main input (the narrow rectangle) and Extrude.2 (the wider rectangle).

Taking a look at the yellow node analysis, we consider that a feature can move in its main input feature 
chain (here we have EdgeFillet.1 - Trim.1 - Extrude.1 as a main input feature chain). The display of 
yellow nodes reflects this rule.



What happens is that EdgeFillet.1 is constructed upon geometry that only exists after Extrude.2. This 
means that moving EdgeFillet.1 after Extrude.1 cannot be done. Indeed, to ensure ordering rules are 
respected, the application would connect EdgeFillet.1 on Extrude.1 which would reveal geometrically 
impossible. Consequently, to facilitate your work, the application anticipates inconsistencies by 
extending yellow nodes to a reasonable position where the fillet can rebuild itself.

Reordering a Creation Feature

If a creation feature is directly based upon a modification feature (the Parent/Children capability lets 
you see this relationship), the rule is that you can reorder the creation feature within the main input 
chain of the modification feature. However, in some particular cases, the Reorder operation may result 
in update errors as illustrated in the following case.

If you wish to reorder Fill.1 and locate it before Join.1, which is its parent, the application allows you 
to do so because Join.1 is a modification feature. As Line.1 is the main input of Join.1 and as Line.1 is 
a creation feature, the application allows you to reorder Fill.1 up to Line.1.



 

To know more about reordering features in geometrical sets and ordered geometrical sets, refer to the 
Managing Geometrical Sets and Managing Ordered Geometrical Sets tasks described in the Generative 
Shape Design User's Guide.

 

Update Operations
●     Manual Update

If the Manual update option is on, a warning message is issued to inform you that you need to 
update the geometry.

●     Automatic Update
If the Automatic update option is on, the whole part is updated.

We recommend you use Manual update for complex geometry. This will help you control the 
way you gradually rebuild your geometry. Depending on your reorder operation, you will see 
more easily how the different features of the part are affected.

In Work Objects

After reordering a feature in the specification tree, local objects are defined as follows: the application 
sets the first feature that is not affected by the reorder operation as the new defined in work object. 
This is convenient when using the Scan command after the reorder operation to update the modified 
geometry step-by-step.

●     When reordering upwards, the in work object is the feature positioned just before the new position 
of the reordered feature.

●     When reordering downwards, the in work object is the feature positioned just before the original 
position of the reordered feature.



 

Reordering Several Features At a Time

You can reorder two or more features at a time as explained in the following second scenario.

Use the Reorder.CATPart document and add an edge fillet onto Pad.2.

 
1.  Multi-select Pad.2. and EdgeFillet.1 then select Edit > Selected objects > Reorder....

Our selection includes two features consecutively positioned under the same tree node.

Non-Consecutive Features

If the features are not strictly consecutively positioned under the same tree node, you can 

reorder them provided they are independent: with no parents (except for XY, YZ or ZX planes or 

axis systems located just below the part in the tree) and with nor children.

Otherwise, the operation is not possible and an error message is issued. 

In our scenario, the application detects non-available locations and display them in yellow.

2.  The Feature Reorder dialog box appears. Select Pad.1 to indicate the new location for Pad.2 

and EdgeFillet.1.

The dialog box shows that two elements are to be reordered after Pad.1.
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3.  Click OK to confirm.

The part rebuilds itself. Both Pad.2 and EdgeFillet.1 are now mirrored.

 



Reordering Sketch-Based Features

 

The way you configured your design environment affects the way the application locates sketches in the 
specification tree after reordering sketch-based features. This section discusses the two possible 
behaviors depending on whether you are reordering a sketch-based feature from:

●     one solid body to another one 

●     one body to another one

To know how to activate or deactivate a hybrid design environment, refer to the Part Document section 
of the Customizing chapter of this guide.

 From One Solid Body to Another One 

When working in a non-hybrid design environment, sketches are represented both in the Part Body and 
under the target body after reordering features based upon them.

1.  This part contains two bodies created in a non-hybrid design environment.

2.  After reordering Pad.1 to locate it in Body.2, Sketch.1 on which it is based, is represented both 

under PartBody and under Pad.1.



From One Body to Another One

1.  This part contains two bodies created in a hybrid design environment.

2.  After reordering Pad.1 to locate it in Body.2, Sketch.1 is represented under Pad.1 only.



Setting Constraints
 

 
Set Constraints: Click this icon, select the elements to be constrained then click where 
you wish to position the constraint value.

Set Constraints Defined in Dialog Box: Multi-select the elements to be constrained, click 
this icon and check the constraint type in the dialog box that appears.

Modify Constraints: Double-click the constraint to be modified and modify related data in 
the Constraint Definition dialog box that displays.

Rename Constraints: Select the constraint to be renamed, the xxx.n.object > Rename 
contextual menu item.

( ) Deactivate/Activate Constraints: Select the constraint to be (de)activated and the 
xxx.n.object > Rename parameter contextual menu item and enter the desired name 
in the dialog box that appears.

Change Constraint Appearance: Select your constraint and choose one of the contextual 
menu items changing the display mode.

Compute Mean Dimensions: Click this icon, then update the part. 



Setting 3D Constraints 

 
3D constraints are defined by means of one of the two constraint   commands available in this 
workbench. Depending on the creation mode chosen for creating wireframe geometry and surfaces (see 
Wireframe and Surface User's Guide), constraints set on these elements may react in two ways. You 
create references if support elements were created with the Datum mode deactivated. Conversely, you 
create constraints if you constrain datums. For more about datums, refer to Creating Datums. 

The constraints  you can set in Part Design workbench are:

  

●     Distance

●     Length

●     Angle

●     Fix/Unfix  

●     Tangency  

●     Coincidence  

●     Parallelism  

●     Perpendicularity  

This task shows you how to set a distance constraint between a face and a plane, then a reference 
between the face and another plane.



Open the Constraint1.CATPart document.

 
1.  Select the face you wish to constrain and Plane.1. This plane is a datum (there are no links to 

the other entities that were used to create that plane).

2.  Click the Constraint icon .

The application detects the distance value between the face and the plane. Moving the cursor 

moves the graphic symbol representing the distance.

3.  Click where you wish to position the constraint value.

The constraint is created.

●     The name of a constraint displays when passing the mouse over that constraint.

●     The application does not display constraints when these are too small. More precisely, the constraints 
visualization depends on the types of constrained elements. This means that when zooming out, a 
constraint set between two points is more likely to disappear than a constraint between two lines.
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4.  Now, set another constraint between the same face and Plane.2. Plane.2 is not a datum. Repeat 

the instructions described above using the face and Plane.2.

The application creates a reference. Creating a reference means that each time the application 

integrates modifications to the geometry, this reference reflects the changes too.

The reference is displayed in parentheses as shown below:

 

You cannot set a distance constraint between two faces belonging to Part Design features linked by their 
specifications. In the example below, the application creates a reference between the faces, not a driving 
constraint.

To know how to modify a constraint, refer to Modifying Constraints.

 

Note

You cannot view constraints if the plane in which they are located is normal to the screen. In that case, 
you just need to use the mouse, for example, to rotate the view and therefore  make the constraints 
visible.

 



Setting Constraints Defined in Dialog Box

 
This task shows you how to use this constraint command  which detects possible constraints 
between selected elements and lets you choose the constraint you wish to create. You are going to 
constrain a hole.

 

Open the Hole1.CATPart document and create a hole anywhere on the pad top face.

 
1.  Right-click the circular face and select Other Selection... to select the hole axis.

2.  Use the Ctrl button to select the face as shown:

3.  Click the Constraint Defined in Dialog Box icon .

The Constraint Definition dialog box is displayed. 
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The constraints  you can set in Part Design workbench are:

❍     Distance

 

❍     Length

 

❍     Angle

 

❍     Fix/Unfix

 

❍     Tangency

 

❍     Coincidence

 



❍     Parallelism

 

❍     Perpendicularity

 

The application detects three possible constraints between the axis and the face:

❍     Distance

❍     Angle

❍     Fix

The other constraints are grayed out indicating that they cannot be set for the elements you 

have selected.

4.  Check the Distance option. 

5.  Click OK to confirm. 

The distance constraint is created.



Modifying Constraints

Editing Constraints 

You can edit constraints by:
●     double-clicking on desired constraints and modify related data in the Constraint Definition dialog box that displays.

●     selecting desired constraints and use the XXX.N.object > Definition... contextual command.

...to display the Constraint Definition dialog box and modify related data.

About Diameter and Radius Constraints 

●     You can obtain a radius constraint by editing a diameter constraint. You just need to double-click the diameter constraint and 
choose the radius option in the dialog box that displays. 



●     If you need to create a formula remember that :

●     the parameter corresponding to the radius or diameter constraint is referred to as RadiusX.object.

●     this parameter always contains the radius value.

For more about formulas, refer to Knowledge Advisor User's Guide Version 5.

Renaming Constraints   
You can rename a constraint by selecting it and by using the XXX.N.object > Rename parameter contextual command.... In the 
dialog box that appears, you just need to enter the name of your choice.

Deactivating or Activating Constraints 

You can deactivate a constraint by selecting it and by using the XXX.N.object > Deactivate contextual menu item. Deactivated 
constraints appear preceded by red parentheses ( )  in the specification tree.

Conversely, to activate a constraint, use the Activate contextual command.

Changing Constraint Appearance 

Display mode 

When setting constraints, four display mode are available as explained in Symbols. Later, you can change display modes by 
selecting the constraint of interest and choose one of the following contextual commands.

●     Value Display: only the constraint (or parameter) value is displayed. 

●     Name Display: only the constraint (or parameter) name is displayed.

●     Name/Value Display: the constraint (or parameter) name and value are both displayed. 

●     Name /Value/Formula Display: the constraint (or parameter) name and value are displayed as well as the possible formula 
defined for this constraint.
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Permanent Display 

It is possible to permanently display the parameters of Part Design features as well as the valued constraints of Sketcher elements 
by using the XXX.object ->Edit Parameters contextual command. 

Provided that the Parameters of features and constraints option has been previously checked in the Options dialog box, (for 
more information see Display), the following dialog box appears:

If you validate the option, parameters or constraints attached to the selected feature are permanently displayed in the 3D area.

Colors 

To change the color of a given constraint, either you use the Properties contextual menu item or the Edit > Properties > 
Graphic (tab) command. You then just need to choose a color from the list (or you can define your own colors by selecting the 
More colors command at the bottom of the color list. To know more about defining personal colors, refer to Infrastructure User's 
Guide).

If you wish to change the color for a given status, use Tools > Options. For more, see the Infrastructure User's Guide.
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Computing Mean Dimensions 

 
This task shows you how to compute the mean dimensions of a part.

 

You must define the tolerances that you want before computing mean dimensions. For more about 
tolerances, refer to Infrastructure User's guide Version 5.

 
Open the Mean_Dimensions.CATPart document.

1.  Before computing mean dimensions, apply the Edit Parameters contextual menu item to Pad.1 

to display parameters, then take a look at the part you have just opened. The part includes 

three toleranced parameters as shown below.

Remember that to access tolerance values, you need to double-click the parameter of interest, 

then use the Tolerance > Edit... contextual menu item.

2.  Click the Mean Dimensions icon .

A dialog box appears informing you that the operation is performed. You then just need to 

update the part to observe the result.

3.  Click the Update All icon  to integrate the modifications to the part. Note that the update 

options set for your session (for more see General) do not affect the Mean Dimensions 

command behavior: you always have to explicitly update your part.
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Mean dimensions are displayed around the part.

 

Bear in mind that if parameters are driven by formulas, the application deactivates these formulas to 
compute mean dimensions.

 

4.  If you wish to go back to the previous state, click the Mean Dimensions icon  again.

A dialog box appears informing you that the part will be resized to nominal dimensions. 

5.  Click OK to confirm.

An additional message appears to inform you that the operation is performed and prompts you 

to update the part.

6.  Click OK to close the message window.

7.  Click the Update All icon  to resize the part to nominal dimensions.

 



Replacing or Moving Elements

Replace Elements: Right-click the element to be replaced and select Replace... Select the replacing element 
and optionally, select Delete to delete the replaced element as well as its exclusive parents.

Replace a Body: Right-click the attached body and select Replace... Select the replacing body.

Change the Sketch Support: Select the Sketchx.object > Change Sketch Support command then the 
replacing plane or face.

See also Creating Replace Face Features, Reordering Features, and Reordering Sketch-Based Features.

 



Replacing Elements 

 

The Replace command lets you replace sketches, faces, planes and surfaces by other appropriate elements. 

This task shows you how to replace a surface used for creating geometry with another surface. 

The operating mode described here is valid for replacing the geometrical elements used in the definition of any Part Design features.

Open the Replace.CATPart document.

1.  Select Extrude.1, that is the red surface used for trimming both the pocket and the hole.

2.  Right-click and select Replace....

The Replace dialog box is displayed, indicating the name of the surface to be replaced.

3.  Select Extrusion 2 as the replacing surface. 

Extrusion 2 now appears in the With field of the dialog box.

4.  Check the Delete replaced elements and exclusive parents option to delete Extrusion1.

5.  Click OK to confirm the operation.

The pocket and the hole are now trimmed by Extrusion 2. Extrusion 1 has been deleted.
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Replacing a Body

 

You can replace only bodies that underwent Boolean operations (for more see Associating Bodies). 

This task shows you how to replace a trimmed body with a basic body. As this basic body is not 
trimmed, during the operation you will have to redefine the Union Trim operation.

Open the ReplaceBody.CATPart document.

1.  Select Body. 3 as the body to be replaced.

2.  Right-click and select Replace....

The Replace dialog box is displayed.
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3.  Select Body.4 as the replacing body.

Note that:

❍     replacing bodies cannot be used for previous Boolean operations. 

❍     they can belong to the Part under study or to an external part.

4.  A Replace Viewer windows displays to help you select the replacing face. Select 

Face/Pad.3/Body.4 as the replacing face, directly from the geometry.  

5.  Click OK to confirm and close the dialog box.

Body.3 has been replaced with Body.4.





Changing a Sketch Support  
This task shows you how to change the position of a sketch by changing its support. Changing a sketch support amounts to editing the 
absolute axis definition of the sketch.

Open the Change_Sketch_Support.CATPart document. 

In this scenario, you will edit the absolute axis definition of Pocket.2/Sketch.3 by making it associative to Pocket.1. This will ensure 
that, when moving Pocket.1, Pocket.2 follows Pocket.1 without requiring you to edit the geometry of Sketch.3.

1.   From the specification tree, right-click Sketch.3. 

2.  In the contextual menu which is displayed, select Sketch.3 object > Change Sketch Support....

If a message appears, informing you that if you change its position, the sketch may become inconsistent or over-constrained, 

simply click OK. 

The Sketch Positioning dialog box appears. 
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3.  If the Move Geometry option at the bottom of this dialog box is checked, uncheck it. This will prevent the geometry from moving 

when performing the next operations in the dialog box.

In the Type field in the Sketch Support area, three options are available:

❍     Positioned: positions the sketch using the origin and orientation of the absolute axis.

❍     Sliding: default type used for non-positioned sketches (i.e. when you edit a non-positioned sketch, this option will be selected 
by default, as is the case in our example). This option is mainly used for compatibility purposes, and to enable you to turn non-
positioned sketches into positioned ones. 
With the Sliding option, the sketch is not positioned, i.e. the origin and orientation of the absolute axis is not specified. As a 
result, its absolute axis may "slide" on the reference plane when the part is updated.

❍     Isolated: isolates the sketch in order to break all absolute axis links (support, origin and orientation links) with the 3D or to 
solve update errors. Only the 3D position will be kept, to ensure that the sketch does not move. With the Isolated option, you 
cannot define the sketch support, origin and orientation.

4.  Select the Positioned option, and make sure Pad.1/Face is selected as the reference element for the sketch support (Reference 

field).

5.  At this point, check the Move Geometry option to specify that, from now on, the geometry should be moved when the sketch 

position is modified.

6.  Check the Swap box to swap H and V directions. The new sketch position is previewed in the geometry area.

You are now going to make the absolute axis associative with Pocket.1. 

7.  Uncheck the Move Geometry option once again to ensure that the geometry does not move according to the newly defined axis.

8.  In the Type field in the Origin area, select Intersection 2 lines.

9.  You will now specify the reference element for the origin. To do this, make sure the Reference field is active, and select a 

horizontal edge of Pocket.1 as shown below.



10.  Now, select a vertical edge of Pocket.1 as shown below.

11.  In the Orientation areas, leave the Type field set to Implicit and the Reference field set to No Selection. For more information on 

the other options available in the Origin and in the Orientation areas, refer to Creating a Positioned Sketch in the Sketcher User's 

Guide.

12.  Click OK. 

The absolute axis definition of Sketch.3 is modified and the position of the pocket is changed.

13.  From the specification tree, double-click Sketch.2 to edit it.



14.  On the sketch, double-click the value of Offset.57.

15.  In the Constraint Definition dialog box which is displayed, enter a new value, 90 for example, and click OK. The constraint is 

updated, and Sketch.2 is moved accordingly.

16.  Exit the Sketcher workbench. As you can see, Pocket.1 has been moved, and Pocket.2 is still positioned according to the 

absolute axis you defined for Sketch.3.





Displaying and Editing Properties 

Displaying and Editing Parts Properties: Right-click the part then select Edit > Properties. Click the 
Mass tab, edit the density, click the Product tab and enter information describing the part.

Displaying and Editing Bodies Properties: Right-click the body then select Edit > Properties. Click 
the Feature Properties tab, edit the name and click the Graphic tab to change the color of the 
body. 

Displaying and Editing Features Properties: Right-click the feature then select Edit > Properties. 
Check Deactivate to deactivate the feature and define the impacted elements to keep activated. 
Click the Feature Properties tab and edit the feature's name. Click the Graphic tab to change the 
color of the feature.  



Displaying and Editing the Part Properties

 

Gathered in a same dialog box, the part properties consist of different indications you will have 
sometimes to refer to. This task explains how to access and if needed, edit this information.

 

To perform this scenario, for example you can open the Stiffener.CATPart document.

 
1.  Select Part1 in the specification tree.

2.  Select Edit>Properties or select the Properties contextual command.

The Properties dialog box displays, containing two tabs dealing with the part:

❍     Mass

❍     Product

 

Mass

1.  Click the Mass tab to display technical information.

You cannot edit the density of the whole part. However,when a material is applied to the part, 

you can edit the density and the volume of the Part Body. If no material is applied to the part 

but if a material is applied to the PartBody, this material will be taken into account for the 

density calculation. If both the part and the PartBody have a material applied, the part material 

will have priority. 

To know how to apply materials to parts, refer to Real Time Rendering User's Guide Version 5. 
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●     The mass of the part is null if its part body contains no geometry.

●     Deactivating features does not affect the mass of the part.

 

Product

2.  Click the Product tab.



3.  Enter a new name for the part, for example Stiffener in the Part Number field. 

The new name appears in the specification tree.

4.  The other fields allow you to freely describe the part. Enter the information describing your part 

in the context of your company.

5.  Set the Source option. You can choose between:

❍     Unknown

❍     Made

❍     Bought

6.  Use the Description frame to enter additional information.



 

Define Other Properties

9.  Click the Define other properties... button to access options enabling you to define parameters 

and assign values to them.

10.  The New Parameter of type button lets you create a user parameter. This parameter can be 

assigned a single value. To create a parameter, just choose the one you need from the list. Then, 

click the button.

11.  The Edit name and value field becomes available. You can edit the parameter's name and 

assign a value to it.

The Delete Parameter button operates only for user parameters.

The External properties... button allows you to import parameters and parameter values from a 

text file or from an Excel file (Windows).

12.  Click OK to confirm the operation and close the Define other properties dialog box.

You can then note that the parameter you defined is displayed in the Product tab as illustrated 

here:



 



Displaying and Editing Bodies Properties

 

This task shows how to display and edit bodies properties. To know how to edit the graphic properties of 
a body refer to the Infrastructure documentation, Displaying and Editing Graphic Properties.

 

To perform this scenario, for example you can open the Assemble.CATPart document.

 
1.  Select Body.1 in the specification tree.

2.  Select Edit->Properties or select the Properties contextual command.

The Properties dialog box displays. 

Two tabs deal with bodies:

❍     Feature Properties

❍     Graphic

The Feature Properties tab displays the body's name. This name is editable if the part is not 

read only. Enter Assemble1 in the Name field. The new name appears in the specification tree. 

The application also displays the date of creation and of the last modification.

3.  Click the Graphic tab to change the color of the body. 

The graphic properties available for editing are: 
❍     Fill Color (colors the current object) and Transparency

❍     Edge Color, Line type and Thickness

❍     Global Properties

To have details about how to change graphic properties, refer to Infrastructure User's Guide.
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Before applying a color to a body, remember that: 
●     The features you create within a body take on the color of this body, whatever it is.

●     When applying a color to a feature, all the faces of this feature take on this color.

●     The color you apply to a face prevails over the other colors defined for features and bodies.

These three rules apply when associating bodies. 

●     The faces generated by any transformation take on the color of the body, as shown in the following 
example.

Before 

The body is composed of a pink pad and of a 
yellow pocket

After

Both faces the pattern has generated, i.e. the front 
face and the cylindrical face take on the color of the 
body which was the application default color.

4.  Click OK. 

The application takes these modifications into account and displays the new body name.

Technical information about bodies, such as mass, is not available. The application provides this type of 
information for the part. For more details, refer to Displaying and Editing the Part Properties.

 



Displaying and Editing Features Properties  

 

This task shows how to display and edit the properties of a pad. 

 

To perform this scenario, for example you can open the Properties.CATPart document.

 
1.  From the specification tree, select the feature, that is Pad2.

2.  Select Edit->Properties or right-click Properties. 

The Properties dialog box appears. It contains these tabs:

❍     Mechanical

❍     Feature Properties

❍     Graphic

The Mechanical tab displays the update status of the pad. The following attributes characterize 

features:

❍     Deactivated: checking this option will prevent the application from taking deactivated 
features into account during an update operation.

❍     To Update : indicates that the selected feature is to be updated.

❍     Unresolved : indicates that the selected feature cannot be computed by the application. 
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You cannot control the last two options. The symbol displayed in front of each attribute may 

appear in the specification tree in some circumstances. For more about updates, refer to 

Updating Parts.

3.  Check the Deactivated option to deactivate the pad. 

You will note that a new frame is displayed, providing additional information. The application 

actually warns you that the operation will affect the only child of the pad, that is the hole. 

In certain cases, features may have several children. What you need to do is select the children 

from the list and check the first option if you wish to deactivate them or just check the second 

option to deactivate all of the children affected.

4.  Click the Feature Properties tab.

5.  Enter New Pad as the new name for the pad in the Name field.

6.  Click Apply to display the new name in the specification tree.



7.  Click the Graphic tab to change the color of the feature.

The graphic properties available for editing are: 
❍     Fill Color (colors the current object) and Transparency 

❍     Global Properties

To have details about how to change graphic properties,  refer to Infrastructure User's Guide.

8.  Click OK to confirm the operation and close the dialog box. 

The geometry no longer shows the deactivated features and the specification tree displays red 

parentheses on them to symbolize their status.

 

file:///E|/www/celr16/Doc/online/basug_C2/basugbt0706.htm


Creating Annotations

 
Creating Texts with Leaders: click this icon, select a face and enter your text in the dialog box.

Creating Flag Notes with Leaders: click this icon, select the object you want to represent the 
hyperlink, enter a name for the hyperlink and the path to the destination file.

 



Creating a Text with Leader

This task shows you how to create an annotation text with leader

A text is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either before or after you 
create the free text.
You can change any text to another kind at any time.

Open the Common_Tolerancing_Annotations_01.CATPart document.

●     Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D 
Annotation.

1.  Double-click the Front View.1 annotation plane to activate it. 

2.  Click the Text with Leader icon:   

3.  Select the face as shown to define a location for the arrow end of the leader.
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If the active view is not valid, a message appears informing you that you cannot use the 
active view.
Therefore, the application is going to display the annotation in an annotation plane normal to 
the selected face.
For more information, see View/Annotation Planes.

The Text Editor dialog box appears.

4.  Enter your text, for example "New Annotation" in the dialog box.
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5.  Click OK to end the text creation. You can click anywhere in the geometry area too.

The text appears in the geometry. 
The text (identified as Text.xxx) is added to the specification tree.

 The leader is associated with the element you selected. If you move either the text or the 
element, the leader stretches to maintain its association with the element.

 Moreover, if you change the element associated with the leader, application keeps the 
associativity  between the element and the leader.

 Note that using the Text Properties toolbar, you can define the anchor point, text size and 
justification.

You can move a text using either the drag capability.
Note also that you can resize the manipulators
For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.



Creating a Flag Note with Leader

This task shows you how to create an annotation flag note with Leader.

A flag note allows you to add links to your document and then use them to jump to a variety of 
locations, for example to a marketing presentation, a text document or a HTML page on the intranet.
You can add links to models, products and parts as well as to any constituent elements.

A flag note is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either before or after you 
create the free text.
You can change any flag note to another kind at any time.

Open the Common_Tolerancing_Annotations_01.CATPart document.

●     Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D 
Annotation.

1.  Double-click the Front View.1 annotation plane to activate it.

 

2.  Click the Flag Note with Leader icon:   

3.  Select the face as shown to define a location for the arrow end of the leader.
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If the active view is not valid, a message appears informing you that you cannot use the 
active view.
Therefore, the application is going to display the annotation in an annotation plane normal to 
the selected face.
For more information, see View/Annotation Planes.

The Manage Hyperlink dialog box appears. 

 You may specify the flag note's name link in the Name field.

 You may specify one or several links associated with the flag note in the URL field clicking the 
Browse... button.

 In the Link to File or URL list  you can see the list of links.
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 To activate one of them, select it and click the Go to button.

 To remove one of them, select it and click the Remove button.

 To edit one of them, select it and click the Edit button.

4.  Enter your flag note name, for example "New Annotation" in the dialog box and specify a link: 

www.3ds.com

5.  Click OK to end the flag note creation. You can click anywhere in the geometry area too.

The flag note appears in the geometry.



The leader is associated with the element you selected. If you move either the text or the 
element, the leader stretches to maintain its association with the element.

 Moreover, if you change the element associated with the leader, application keeps the 
associativity  between the element and the leader.

 Note that using the Text Properties toolbar, you can define the anchor point, text size and 
justification.

The flag notes (identified as Flag Note.xxx and its name between brackets) are added to the 
specification tree in the Notes group.

You can move a flag note using either the drag capability.
Note also that you can resize the manipulators
For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.



Handling Parts

 Handling Parts in a Multi-Document Environment

Creating Technological Results



Handling Parts in a Multi-Document Environment 

In this task, you are going to copy a part body from one CATPart document to another, then edit the 
initial part body. This scenario shows you how the application harmonizes this type of ulterior 
modifications. Thanks to the underlying methodology, you can work in concurrent engineering.

Open the MultiDocument.CATPart document.

This scenario assumes there are two CATPart documents. Part3.CATPart is the target document, 
MultiDocument.CATPart contains the part body that will be copied, then edited in Part3.

The part body to be copied looks like this:

1.  Select Part Body.

2.  Select Edit > Copy to copy the part body.

3.  Open a new CATPart document 'Part3.CATPart' and position the cursor anywhere in the 

specification tree.

4.  Select Edit > Paste Special....

The Paste Special dialog box appears. Three paste options are available:

❍     As specified in Part document: the object is copied as well as its design specifications

❍     As Result With Link: the object is copied without its design specifications and the link is 
maintained between the reference and the copy.

❍     As Result: the object is copied without its design specifications and there is no link between 
the reference and the copy.
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5.  For our scenario, select the As Result With Link option if not already selected, and click OK.

Part Body is copied into the Part3.CATPart document. You will notice that the specification tree 

displays it under the name of Solid.1.

A cube represents this solid. 

6.  Now, if you wish, you can fillet four edges. You can actually perform any modification you need.



7.  Return into the first document.

8.  Use Remove to remove material from the part body.

9.  In the Part3.CATPart document, the cube graphic symbol used for Solid.1 in the tree now 

contains a red point. This means that the initial Part Body underwent transformations.

You can also notice that the update symbol is 
displayed next to Part3.

10.  What you need to do is synchronize the copied object with its reference. Just right-click Solid.1 

in the specification tree and select Synchronize.

The Synchronize command synchronizes copied geometry with its external references. 

11.  Update the geometry.

The solid now reflects the change: material is removed. The specification tree indicates that the 

part body has integrated the modifications made to the original part body.



Synchronize All

If your document contains several solids linked to external references to be synchronized, you just need 
to select the part and right-click Synchronize All. 

The command also synchronizes knowledge parameters.

Opening Pointed Documents 

The Open Pointed Document contextual command is available for external references. If you apply it 
onto Solid.1 for example, MultiDocument.CATPart opens (if closed of course) in your session.
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Creating Technological Results

 

The Create Technological Results capability supplies technological information on the features included in a body. This 
information can then be reused at any stage of your design by downstream applications such as Generative Drafting for 
example.

The scenario provided shows you how to use the Create Technological Results capability. It illustrates that after pasting 
bodies from one part to another, technological results are not only kept but can also be updated to reflect the changes 
performed during the different design stages.
The CATProduct document provided for this scenario, includes four parts in which you will need to create technological results 
at different stages. After importing geometrical and technological results from one part to another, you will complete the 
scenario by generating the technological results of your final design. Here are the main steps you will perform:

●     Generating the Technological Results for the First Part

●     Editing the Second Part and Generating the New Technological Results

●     Designing the Final Part

●     Generating the Technological Results for the Final Part 

In this section, you will also find the following reference information:

●     Deactivating Technological Results

●     Deleting Technological Results

Scenario 1
Open the MMLStructure.CATProduct document.

 
Generating the Technological Results for the First Part

To generate technological results, you need to apply the command to bodies. To generate the Technological Results for the 
first part, Basic Feature, you will run the command on the three bodies, not on PartBody since the geometry it contains is not 
relevant.

1.  The CATProduct document provided for this scenario, includes four parts:

❍     Basic Feature 
(first part)

❍     Slice (second 
part)

❍     Rough Part 
(third part)

❍     Finished Part 
(final part)
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To generate technological results for the first part, right-click Body.2 and select Body.2.object>Create 

Technological Results.

The technological information which the capability can generate is:

❍     Hole information

❍     Thread information

The application creates a Technological Results node for this body. This node contains itself two nodes, one for the 

hole, one for the thread/tap.

You cannot edit this node. What you can do is rename it by using Properties or delete it.

2.  Repeat this operation for the other two bodies of this part. You obtain a technological result node for each body:

Note that if now you edit Pocket.1 for example, the application automatically recalculates the technological results to 

reflect the changes to the pocket. The update symbol appearing the the Technological Results node while editing, 

indicates this behavior:



Editing the Second Part and Generating the New Technological Results

You are going to use the three bodies of Basic Features and their technological results to edit the second part in which you 
will simplify the structure by performing Assemble operations. When done, 

3.  Copy and paste the three bodies using Paste Special As Result with Link into the second part, Slice part.

4.  To simplify the structure of Slice, perform three Assemble operations so as to assemble pasted bodies with slice 

bodies. By assembling all bodies, you will just have to run the Create Technological Results on a single body 

(PartBody). You must obtain this:

5.  Create pattern features to duplicate the holes for the final design.

6.  Right-click PartBody and select PartBody>Create Technological Results. 

The technological results for the part are contained in the Technological Results node.

7.  For methodological reasons, we recommend you publish that body which now contains the technological results.



Designing the Final Part

Designing Finished Part as the final part, reusing the Slice and the Rough parts. For methodological reasons, we recommend 
you publish the PartBody of Rough part. 

8.  In Finished Part, copy and paste the published body of Rough part.

9.  Copy and paste the publication of the Slice part.

10.  Assemble both bodies generated so as to simplify the part structure.

11.  If now you click Tap/Thread Analysis  to analyze the threads and taps of the part, you can see that the 

application cannot provide the technological results for your design.

For information on the Tap/Thread Analysis capability, refer to Analyzing Taps and Threads. 



Generating the Technological Results for the Final Part 

Now that the part is fully designed, you can generate the technological results required by downstream applications.

12.  in Finished Part, right-click PartBody and select PartBody.object>Create Technological Results.

The Technological Results  node for PartBody is displayed in the tree. At this stage of your design, this node reflects 

all technological results which can be generated.

 



13.  Using the Tap/Thread Analysis  capability, you can check that the application now provides technological 

information.

Machining and Drafting operations can be performed using these technological results without reloading the first three 

CATPart documents. Reloading Finished Part allows to see the technological results of the whole CATProduct.

Deactivating Technological Results

If after generating technological results you need to go on designing and updating your part, we recommend you deactivate 
the technological results obtained. Deactivating generated technological results is a good way of reducing the time spent by 
the application in recalculating the changes made to the part. Keep in mind then, that to optimize your design, you can use 
the Deactivate capability available from contextual menus. 

Deleting Technological Results

It is possible to reduce the number of technological results generated by applying the Delete capability. To delete a 
technological result node, just right-click the node and select Delete.
This might be useful especially if you wish not to make all technological information available to everybody and need to 
restrict the information you provide.

Keep in mind that after deleting a technological result node, if later on you reapply Create Technological Results, the node 
you deleted is not recomputed. If you really need to retrieve that node, then just use Reset Deleted Technological Result.



Hybrid Design
Version 5 Release 14 introduces major enhancements to help you design parts. The underlying idea is to 
provide you with capabilities developed for gathering bi-dimensional and tri-dimensional elements within the 
same work environment. This is what is referred to as Hybrid Design. 

Working in a hybrid design environment concretely means that from now on you can create wireframe and 
surface features within the same body. This capability aims at having a quick understanding of parts creation. 

This new way of designing therefore induces interfaces homogeneity between Part Design and Generative 
Shape Design, which makes the use of these products much easier.

In this section, the following is discussed:

●     Creating Bodies

❍     Terminology

❍     Graphic Representations

❍     What Are Bodies Made Of ?

■     What Bodies Do Not Contain

❍     Specific Mechanisms Locate Features

❍     Impacts on Existing Capabilities

■     How Sketches are Located in the Specification Tree

■     Reorder

■     Delete

■     Visualization

■     Surface and Wireframe Elements Created on the Fly

■     Surface-based Features

■     Creation of features

■     Boolean Operations: Assemble, Intersect, Add, etc.

■     Power Copies

●     How to Integrate the Surface World into Solid Modeling 

❍     Using Surface-based Features to Integrate Surface Modeling into Solid Modeling

❍     Using Boolean Operations to integrate Volume Design into Solid Design

❍     Inserting Added Volumes

●     Graphic Properties

●     Deactivating Your Hybrid Design Environment

❍     Accessing the Hybrid Design Setting



❍     Recommendation

❍     Identifying Bodies and Solid Bodies 
 

 



Creating Bodies (Hybrid Design)
In this section, the following is discussed:

●     Terminology

●     Graphic Representations

●     What Are Bodies Made Of ?

❍     What Bodies Do Not Contain

●     Specific Mechanisms Locate Features

●     Impacts on Existing Capabilities

❍     Sketch Location in the Specification Tree

❍     Reorder

❍     Delete

❍     Visualization

❍     Surface and Wireframe Geometrical Elements Created on the Fly

❍     Surface-based Features

❍     Boolean Operations: Assemble, Intersect, etc.

❍     Power Copies

●     Insert Added Volumes

Terminology

A Body created from V5R14 onward is still referred to as Body.  Likewise, when creating a new part, the 
default body is referred to as Part Body.

Conversely, bodies created using application versions prior to V5R14 are no longer referred to as bodies but as 
Solid bodies in applications user's guides, not in specification trees.

Graphic Representations



●     A Body or PartBody you create in a hybrid design environment is identified with a green wheel icon in the 
specification tree:

 
. 

●     Solid bodies are identified with gray icons:

  

However, from V5R15 onward the green icons identifying existing bodies turn yellow if you change the type of 
design environment to a non-hybrid design type:

     

For further information, refer to Graphic Representations of Bodies and Solid Bodies.

PartBody created in a Hybrid Design 
Environment

Solid body (here PartBody) in a Hybrid 
Design Environment



What Are Bodies Made Of ?

A body has only one solid result. It can contain the following entities:

●     All Shape Design features

●     Ordered geometrical sets (OGSs): this is possible by using the Insert > Ordered Geometrical Sets 
command. For more information, refer to Inserting Bodies into Ordered Geometrical Sets.
Creating an OGS within a body is the same as creating an OGS within an OGS. Inserting Part Design 
Features in OGSs is not allowed. 

●     Sketches

●     Boolean Operations

●     Solid bodies: you can integrate them into bodies thru Boolean operations and Copy/Paste mechanisms. 
Example of a PartBody

 

What Bodies Do Not Contain

A body cannot contain the following:

●     Bodies

●     Geometrical Sets



●     Volumes: they cannot be created in a body but they can be created in an ordered geometrical set (OGS) 
contained in body. To see an example, refer to Inserting Added Volumes.

Specific Mechanisms Locate Features

Up to Version 5 release 14, bodies displayed their contents according to two major principles: ordering and 
absorption. Now that they can include additional feature types, namely surface and wireframe features, both 
mechanisms apply to them too. All features in a body are displayed in the tree so as to show a succession of 
steps defining the design. In other words, the order of apparition of features in the specification tree is 
consistent with the steps of creation of the design.
Unlike features within a solid body, features in a body can be set as current: a given step of the design 
creation is chosen and what is located after it is not accessible nor visible. 

Impacts on Existing Capabilities

Because of new rules to be followed, a certain number of existing capabilities have been upgraded so as to 
reflect the changes. Here are the new behaviors you now need to be familiar with:

●     Sketch Location in the Specification Tree

●     Reorder

●     Delete

●     Surface and Wireframe Geometrical Elements Created on the Fly

●     Surface-based Features

●     Visualization

●     Boolean Features

●     Power Copies

Insert Added Volumes

The Insert Added Volumes command lets you change from the volume design to solid modeling.



Creating Features in a Hybrid Design Environment
 In a body created in a hybrid design environment, the order of apparition of features in the specification tree is consistent with the steps of 

creation of the design. Creating a feature inside a current body often produces automatic replace mechanisms based on absorption rules. 
Concretely speaking, when creating a new feature in a current body, the geometry that pointed to the feature preceding the new feature is 
redirected to the new feature you are creating. Due to this automatic replace mechanism, you may encounter behaviors you now need to become 
familiar with.

Both examples below compare two results you can obtain depending on whether you work in a hybrid design environment or not. Just keep in 
mind that when creating a feature inside a body, whatever its location in the specification tree, that feature absorbs the geometry of the feature 
preceding it in the tree as illustrated in the following scenarios.

●     Creating a Pocket at a Given Location Inside the Body

●     Creating a Pocket As the Last Feature of a Body

 

Creating a Pocket at a Given Location Inside the Body

This first scenario provides a basic example of the absorption rule prevailing in a hybrid design environment.

1.  Create a new part ensuring that Enable hybrid design and Create a geometrical set options are on. For detailed information on these 

options, refer to the Customizing section of this guide.

2.  Create a pad, a hole then a fillet on the pad in PartBody set as the current body.

3.  In the Generative Shape Design workbench create an intersection between the pad and plane xy.

4.  Create a pocket.

5.  If now you decide to edit your Intersect feature, you will see that the pocket which was created just after the pad is to be taken into 

consideration.

 



Hybrid Design Environment

When editing Intersect.1, you can see that the initial specifications 
have been replaced: Pad.1 initially used to compute the 
intersection is no longer taken into consideration. Because we work 
in a hybrid design environment, Pad.1 has been absorbed by 
Pocket.1. As a consequence, Pocket.1 is a specification of 
Intersect.1.

Non-hybrid Design Environment

When editing Intersect.1, the initial specifications remain the same: 
Pad.1 initially used to compute the intersection is no still taken into 
consideration. 

Creating a Pocket As the Last Feature of a Body

This scenario shows you how the automatic replace mechanism affects the creation of a feature.

1.  Create a new part ensuring that Enable hybrid design and Create a geometrical set options are on.

2.  Create a pad in PartBody set as the current body.

3.  Set Geometrical Set1 as current.

4.  In the Generative Shape Design workbench extract an edge of the pad.

5.  Back in the Part Design workbench, create a pocket using the side face as shown below:



Once the pocket is created, you can note that the extracted edge is trimmed and shortened by the pocket. Conversely, in a non-hybrid 

design environment, the extracted edge would not be affected by the pocket creation.

Hybrid Design Environment

The extracted line is no longer continuous.

Non-hybrid Design Environment

The extracted line remains continuous.

 



Location of Operating Bodies in Boolean 
Operations

 

When performing a Boolean operation, whatever the operation type you perform (Add, Assemble, 
Intersect etc.), the second body you select -referred to as "operating body" hereafter - for performing a 
Boolean operation can be located in two different locations depending on the type of the body you 
selected first.

●     Operating bodies are moved just below the Boolean operation node if there is an interruption of the 
sequential construction of the geometry

●     Operating bodies remain at their initial locations in the trees if:
❍     there is an interruption of the sequential construction of the geometry

OR

❍     if they are used to perform a a mixed Boolean operation

Boolean Operations Versus Mixed Boolean Operations

To anticipate the location of operating bodies, remember that two displays are possible for non-mixed 
Boolean operations, whereas there is only one possible display for mixed Boolean operations.

Non-mixed Boolean Operations

When performing a non-mixed Boolean operation, the application can display the specification trees in 
two different ways:

●     If the sequential construction of the geometry is valid, the Boolean operation node contains the 
operating body. As shown in the scenario described in Assembling Bodies, for example, the second 
body selected is moved just below the Assemble node. It is "aggregated".

●     Conversely, if there is an interruption of the sequential construction of the geometry, the Boolean 
operation node never contains the operating body. The operating body remains at its initial location 
in the tree.

Mixed Boolean Operations

A hybrid design environment makes it possible to perform mixed Boolean operations. By "mixed", we 
mean operations between bodies and solid bodies, or between ordered geometrical sets and solid bodies, 
or even between geometrical set and bodies (and vice versa). In the case of mixed Boolean operations, 
the Boolean operation node never contains the operating body.

In the example below, an Assemble operation is performed between Body.2 and Body.1. Body.2 and 
Body.1 are two different body types. Body.2 is created in a hybrid design environment whereas as 
Body.1 is a solid body.



Mixed Configuration

 

Mixed Boolean Operation

Body.2 being the second body selected, it remains at its initial location in 
the tree.

->

Mixed Configurations

The table below lists all possible mixed configurations and all related behaviors.

 Body Selected first Operating Body Display in the tree for 
Operating Body

SOLIDS

Solid body Solid body Under Boolean operation

Solid body Body At its original location

Body
Body + sequential 
construction of the 
geometry

Under Boolean operation

Body

Body + interruption 
of the sequential 
construction of the 
geometry

At its original location



Body Solid body At its original location

    

VOLUMES

Geometrical set + Volume Body At its original location

Geometrical set + Volume Solid body At its original location

Ordered geometrical set + 
Volume

Body+ interruption 
of the sequential 
construction of the 
geometry

At its original location

Ordered geometrical set + 
Volume Body Under Boolean operation

Ordered geometrical set + 
Volume Solid body At its original location

Pre-V5R15 SP1 Mixed Boolean Operations

Documents including mixed Boolean operations created with software versions anterior to V5R15 SP1 
display Boolean operations nodes in a way different from what described just above: operating bodies 
are located under Boolean operations. To obtain the right display, just proceed as follows:

1.  Double-click the Boolean operation node of interest.

The corresponding dialog box appears as well as a message warning you that the operating body 

will be moved under the part.

2.  Click OK in the dialog box that appears.

The node then reflects the new display.

Restrictions

Mixed Boolean operations are not allowed for generating UDFs (User Defined Features) nor Power 
Copies.

Replacing Bodies

It is possible to replace a body with another body on condition that they are of the same type.

 



Visualization
In a hybrid design environment, features are visualized in the same way as in a traditional environment: if you 
apply the Hide/Show command onto Part Design features within a body, only the Part Design features 
belonging to that body are affected by the operation. Conversely, if you apply the Hide/Show command onto 
Shape Design features within the same body, only the Shape Design features belonging to that body are 
affected by the operation.

In the example below, applying the Hide/Show command onto Hole.1 hides all Part Design features.

Conversely, applying the Hide/Show command onto EdgeFillet.2 hides all Shape Design features.



Hiding or Showing All the Features of a Body

If you wish to show or hide all the Part Design and Shape Design features belonging to the same body, you 
need to select the body and then apply the Hide/Show capability.



How to Integrate the Surface World into Solid 
Modeling 

This section discusses the different ways of integrating surface modeling into solid modeling.
●     Using Surface-based Features to Integrate Surface Modeling into Solid Modeling

●     Using Boolean Operations to Integrate Volume Design into Solid Design

●     Using Insert Added Volume to Integrate Volume Design into Solid Design

Using Surface-based Features to Integrate Surface 
Modeling into Solid Modeling

Using surface-based features (Split , Thick Surface , Close Surface , Sew Surface ) is not a 
new way of integrating surfaces into solid modeling. However, what hybrid design changes is the fact that 
surfaces can now be included in the same body as the features they support. Here is an example of what you 
can now obtain:

 
In such a case, surfaces are necessarily defined prior to defining the feature. Indeed, this is because that the 
order principle inherent to hybrid design must be respected. If you modify these surfaces, the solid features 
located after the modifications will be affected by those modifications. 

Using Boolean Operations to Integrate Volume Design Into 
Solid Design

You can use Boolean operations (Assemble , Intersect , Add , Remove )  to integrate 
volumes into bodies. Boolean features are the only features that can reference volumes.



This task shows you how to integrate a volume via an Intersection operation.

Open the HybridDesign.CATPart document.

1.  Select Insert > Boolean Operations > Intersect...

The Intersect dialog appears.

2.  Select Volume Extrude.1. to create the intersection between the volume and the solid.

3.  Click OK to compute the result:

The intersection is visible, and you can note that Intersect.1 has no children, it references 

Volume Extrude1. If you wish to, just use the Parents/Children command onto it to
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Using Insert Added Volume to Integrate Volume Design into 
Solid Design

This task shows you how it is now possible to apply Part Design capabilities onto volumes created in 
Generative Shape Optimizer product. Prior to applying these capabilities, you need to perform just one 
operation as illustrated in this scenario.

To perform this scenario, create the volume of your choice.



1.  Select the extrude volume you have just created.

2.  Right-click and select the Volume Extrude.1 object-> Insert Added Volume... contextual 

command. 

The result is immediate. The Add.3 entity has been created. It contains a body on which you can 

apply Part Design capabilities.

3.  Now set Body.2 as the current object by using the Define in Work Object capability.

4.  For example, you can now chamfer the volume using the Part Design Chamfer capability . 





Graphic Properties
By default, solid features are gray, surface and shape features yellow, volumes light purple.

A body is assigned Fill, Edges, Line and curves, Points properties. The body's default Fill color property is the 
gray color. Solids integrated into a body inherits the default Fill color property. If you want to change the color 
of the whole solid, you need to change the property color of the body.

Shape Design Features

Shape design features color properties are stored on the leaf feature. 

The color property is automatically propagated to all modification features. For example, Extrude.1 and Split.1 
are always assigned the same color property.

 If you change the color of Extrude.1, Split.1 inherits from this color.



Solid Features

Each element included in a solid feature has its own property color. This behavior enables you to colorize the 
faces generated from Pad.1 with the color of Pad.1 and those generated from Pad.2 with the color of Pad.2. 
This is the same behavior as in solid bodies.

What You Should Know
●     As a consequence to the behaviors detailed above, if you modify the body's color, this only affects the solid 

situated in the body. To modify the color of all the shape design features included in a body, you need to 
modify the color of shape design features. Colors applied to Part Design features are not propagated to 
shape design features.

●     Applying a specific color to any feature is possible, whatever the feature type.

Restoring Graphic Properties

In case you need to restore graphic properties, you can use the Reset Property contextual command 
available from bodies. It resets the default fill property of the body to gray color. If the Apply to children 
option is checked, the properties of Shape Design Features and Solids are reset.



Deactivating Your Hybrid Design Environment
 For specific industrial scenarios, you may prefer to work in a traditional environment so as to restrict the 

location of surface and shape features to geometrical sets or ordered geometrical sets. To restore a 
traditional environment, you just need to deactivate a dedicated setting as explained below:

Accessing the Hybrid Design Setting

To access and deactivate the Hybrid Design setting :

1.  Select Tools > Options.

The Options dialog box is displayed.

2.  From the Infrastructure category, select the Part Infrastructure sub-category in the left-

hand box. 

3.  Click the Part Document tab and go to the Hybrid Design category.

4.  Just deselect Enable hybrid design inside part bodies and bodies which is the default 

option. 

You can now work in a non-hybrid design environment. 

Recommendation

If you select Enable hybrid design inside part bodies and bodies, the capability then applies to all the 
bodies you will create in your CATIA session (and not only to the new CATPart document you are opening). 
Consequently, if your session contains CATPart documents already including traditional bodies, the new bodies 
you will create subsequently in these documents will possibly include wireframe and surface elements. 

To facilitate your design, It is therefore recommended that you do not change this setting during your session. 

Graphic Representations of Bodies and Solid Bodies

The colors of body and solid body icons change when you switch from a design environment to a non-
hybrid design one and vice versa. Such a behavior ensures that the types of bodies you are handling can 
be quickly identified. 



Although it is preferable not to change your environment type in the course of your session, you should 
keep in mind both cases discussed below:

●     Case 1: activating a hybrid design environment

●     Case 2: deactivating a hybrid design environment

Case 1: activating a hybrid design environment 

When activating a hybrid design environment in the course of your session:

●     the bodies you create subsequently are identified with green icons in the specification tree.

●     If your CATPart document already contains solid bodies (bodies that cannot include wireframe nor 
surface elements), the application changes the green icons to gray icons:

Case 2: deactivating  a hybrid design environment

When deactivating a hybrid design environment in the course of your session:



●     the solid bodies you create subsequently are identified with green icons in the specification tree.

●     If your CATPart document already contains bodies, the application changes the green icons to yellow 
icons.

Hybrid environment

As a solid body, PartBody's icon is identified with 
the gray color

Non-hybrid environment

Body.1's icon turns yellow
 



Advanced Tasks
 

This section will explain and illustrate how to perform operations on bodies and will provide recommendations 
about how to optimize the use of the application. The table below lists the information you will find.

Associating Bodies
Using Tools

Using PowerCopies
Reusing your Design

Optimizing Part Design Application
Managing User Defined Features

Managing Part and Assembly Templates



Associating Bodies
You must use bodies as entities you will eventually associate to the Part Body using the capabilities described 
below to finish the design of your part. 

 Insert a New Body: Click the icon or select Insert > Body.

 Insert a Body into an Ordered Geometrical Set: Click the icon and fill in the fields of the dialog box 
that appears.

Insert a Geometrical Set: Click the icon  and fill in the fields of the dialog box that appears.

Insert a Body into an Ordered Geometrical Set: Click the icon  and fill in the fields of the dialog box 
that appears.

Insert Features into a New Body: Click the icon or select Insert >  Insert in new body.

Assemble Bodies: Select the required body, Insert > Boolean Operations > Assemble and the 
target body. 

Intersect Bodies: Select the first body, Insert > Boolean Operations > Intersect and the second 
body. 

Add Bodies: Select the body to be added, Insert > Boolean Operations > Add and the target 
body. 

 
Remove Bodies: Select the body to be removed, Insert > Boolean Operations > Remove and the 
target body. 

 
Trim Bodies: Select the body to be trimmed and Insert > Body.1.object > Union Trim... . Click 
the Faces to remove field and select the desired faces. Click the Faces to keep field and select the 
desired faces.

Remove Lumps: Select Part Body and right-click Part Body object > Remove Lump.... Click the 
Faces to remove field and select the desired faces.

 
Change a Boolean Operation into Another One: use the contextual menu item.

For reference information on how to associate bodies of different types, refer to Mixed Boolean Operations.



Inserting a New Body

This task shows you how to insert a new body into the part. When your part includes several bodies, you 
can then associate these bodies in different ways (refer to the tasks showing the different ways of 
attaching bodies in the Part Design User's Guide: Adding Bodies, Assembling Bodies, Intersecting Bodies, 
Removing Bodies, Trimming Bodies) to obtain the final shape of the part. 

Open any CATPart document.

This is the initial part, composed of Part Body and two bodies:



1.  Click the Body icon .

If the icon is not visible in the application, you can display the required toolbar by using View > 

Toolbars > Insert.

The result is immediate. the application displays this new body referred to as Body.3 in the 

specification tree. It is underlined, indicating that it is the active body.

Now, the image associated with bodies in the tree differs from the image representing the part 

body. A blue gear as well as a yellow plus or minus sign have been added to the green gear. 

These signs indicate the polarity of the body.

This new image lets you quickly tell a body from a part body especially if that one has been 

renamed.



You can construct this new body using the diverse commands available in this workbench or in other 
workbenches.

You will notice that Part Body and Body.3 are autonomous. The operations you would accomplish on 
any of them would not affect the integrity of the other one. Now, if you wish to combine them, refer to 
the tasks showing the different ways of attaching bodies in the Part Design User's Guide: Adding Bodies, 
Assembling Bodies, Intersecting Bodies, Removing Bodies, Trimming Bodies.

Showing or Hiding Bodies 

To hide all the features, even the sketches, of a current or non-current body, simply use the Hide 
components contextual menu item. 

Conversely, use the Show components contextual menu item to restore the view.

  



Inserting a Body into an Ordered Geometrical 
Set

This task shows you how to insert a body into an ordered geometrical set.

Open the OrderedGeometricalSets1.CATPart document.

1.  Select the Insert -> Body in a  Set... command. 

The Insert body dialog box is displayed.

2.  Enter the name of the body you wish to insert into the ordered geometrical set. Our part contains 

no bodies, so enter a name as you are creating the body. For example, enter New Body.

3.  Use the Father drop-down list to choose the body where the new ordered geometrical set is to be 

inserted. In our example, set Ordered Geometrical Set.1. All destinations present in the 

document are listed allowing you to select one to be the father without scanning the specification 

tree. They can be:

❍     ordered geometrical sets

❍     parts

By default the destination is the father of the current object. By default the body is created after 
the current feature.

4.  Set the Father option to the name of the ordered geometrical set you need. In our example, set 

Ordered Geometrical Set.1.

Possible destinations are the part and all Ordered Geometrical Sets already defined in the part. 

By default the destination is the father of the current object. By default the body is created after 

the current feature.

5.  It is possible to select elements of the Ordered Geometrical Set to put these elements inside the 
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body when creating it. Only consecutive elements can be selected. Volumes and bodies cannot be 

selected. In case of selection of elements, the destination became automatically the father of the 

selected elements and cannot be changed any more. Select for example, Split.1 and Offset.1.

6.  Click OK to confirm the operation.

The result is immediate.

You can now create the features you need in the new body inserted into the Ordered Geometrical 
Set.

 



Managing Geometrical Sets
Geometrical sets enable to gather various features in a same set or sub-set and organize the 
specification tree when it becomes too complex or too long. You can put any element you wish in the 
geometrical set, it does not have to be structured in a logical way. The order of these elements is not 
meaningful as their access as well as their visualization is managed independently and without any rule.

 

This task shows how to manage geometrical sets within the specification tree. This involves: 

●     inserting a geometrical set

●     removing a geometrical set

●     changing body

●     sorting the contents of a geometrical set

●     reordering elements

You will find other useful information in the Managing Groups and Hiding/Showing chapters.

●     You can insert and manipulate geometrical sets in the specification tree in much the same way as 
you manage files in folders. For instance, you can copy/paste elements from a geometrical set to a 
target geometrical set.

●     These management functions have no impact on the part geometry.

●     When loading the Generative Shape Design workbench, a Geometrical Set automatically becomes the 
current body. 
This also means that only the results of the Hybrid Body, i.e. the result of all the operations 
performed on geometry, is visible and not any intermediate state of the Hybrid Body.

●     You can define the Generative Shape Design feature that is to be seen when working with another 
application, such as Generative Structural Analysis for example. 

To do this, while in the Generative Shape Design workbench: 

1.  Choose the Tools -> External View... menu item.
The External View dialog box is displayed.

2.  Select the element belonging to a Geometrical Set that should always been seen as the 
current element when working with an external application.

3.  Click OK in the dialog box.

The selected element will be the visible element in other applications, even if other 
elements are created later in the .CATPart document, chronologically speaking.
To check whether an external view element has already been specified, choose the 
Tools -> External View... menu item again. The dialog box will display the name of 
the currently selected element. This also allows you to change elements through the 
selection of another element. Note that you cannot deselect an external view element 
and that only one element can be selected at the same time.
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Open any .CATPart document containing Geometrical Sets.
You can also open the GeometricalSets2.CATPart document.

Inserting a Geometrical Set

1.  In the specification tree, select an element as the location of the new geometrical set. 

This element will be considered as a child of the new geometrical set and can be a geometrical 

set or a feature.

2.  Select the Insert -> Geometrical Set menu command.

The Insert Geometrical Set dialog box is displayed.

 The Features list displays the elements to be contained in the new geometrical set.

3.  Enter the name of the new geometrical set.

4.  Use the Father drop-down list to choose the body where the new geometrical set is to be 

inserted. All destinations present in the document are listed allowing you to select one to be the 

father without scanning the specification tree. They can be:

❍     geometrical sets

❍     parts

5.  Select additional entities that are to be included in the new geometrical set.

If all selected entities belong to the same geometrical set, the father of the new 
geometrical set is automatically set to the father of these entities.

6.  Click OK to create the geometrical set at the desired location.

The result is immediate. CATIA displays this new Geometrical Set.x, incrementing its name in 
relation to the pre-existing bodies, in the specification tree. It is created after the last current 
geometrical set and is underlined, indicating that it is the active geometrical set. The next created 
element is created within this geometrical set.
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You cannot create a geometrical set within an ordered geometrical set and vice versa.

You can check the Create a Geometrical Set when creating a new part option in Tools 
-> Options -> Infrastructure -> Part Infrastructure -> Part Document tab if you 
wish to create a geometrical set as soon as you create a new part. For more information 
about this option, please refer to the Customizing section of the Part Design User's Guide.

Removing a Geometrical Set
Two methods are available:

1.  If you want to delete the geometrical set and all its contents:

●     Right-click the geometrical set then select the Delete contextual command.

 2.  If you want to delete the geometrical set but keep its contents:
This is only possible when the father location of the geometrical set is another geometrical set. 
This is not possible when the father location is a root geometrical set.

●     Right-click the desired geometrical set then select the Geometrical Set.x object -> Remove 

Geometrical Set contextual command.

The geometrical set is removed and its constituent entities are included in the father geometrical set.

You cannot delete a feature within a geometrical set created on the fly. Indeed this geometrical 
set is considered as private and can only be deleted globally.

Moving Elements of a Geometrical Set to a New Body

 
1.  From the specification tree, select the element then choose the Geometrical Set.object -> 

Change Geometrical Set...  item from the contextual menu.



Multi-selection of elements of different types is supported. However, note that the 
contextual menu is not available, and that you can access this capability using the Edit 
menu item.

The Change geometrical set dialog box is displayed, listing all the possible destinations.

2.  Select the Destination body where the geometrical set is to be located.

Here we selected GeometricalSet.3.

You can do so by selecting the body in the specification tree, or using the drop-down list from the 

dialog box.

By default, if you select a body, the geometrical set is positioned last within the new body. 

However, you can select any element in the new body, before which the moved geometrical set 

will be located.

3.  Select the element above which the one you already selected is to be inserted.



You can directly select this positioning element. In this case the Destination field is 
automatically updated with the Body to which this second element belongs.

4.  Click OK to move the geometrical set to the new body.

The element selected first is moved to its new location in the specification tree, but geometry 
remains unchanged. 

❍     Check the Move unshared parents option to move all parents of the first selected element 
to its new location, provided these parents are not shared by any other element of the initial 
body.
In this case, all the unshared parents are highlighted prior to the move.

❍     Check the Move all parents option to move all parents of the first selected element to its 
new location, regardless of whether these parents are used (shared) by any other element of 
the initial body.
In this case, all the parent elements are highlighted prior to the move.



❍     You can move a whole branch, i.e. a whole body and its contents, at a time.
Here we moved GeometricalSet.3 last in GeometricalSet.1.

 

You cannot move some elements of a multi-output alone to another body: only the whole 
multi-output can be moved.

Sorting the Contents of a Geometrical Set
You may need to sort the contents of a Geometrical Set, when the geometric elements no longer appear 
in the logical creation order. In that case, use the Auto-sort capability to reorder the Geometrical Set 
contents in the specification tree (geometry itself is not affected). 

The Geometrical Set.1 contains two extruded surfaces based on point-point lines. The specification tree 
looks like this:



 

1.  Right-click Geometrical Set.1 from the specification and choose the Geometrical Set.1 object -

> AutoSort command.

Instantly, the contents of the Geometrical Set are reorganized to show the logical creation 

process.

The geometry remains unchanged.

Reordering Elements within a Geometrical Set
 This capability enables you to reorder elements inside the same geometrical set.



1.  Right-click Geometrical Set.1 from the specification tree and choose the Geometrical Set.1 

object -> Reorder Children command.

The Reorder Children dialog box is displayed.

2.  Select an element.

3.  Use the arrows to move an element up or down.

 

Replacing Features
 This capability is only available on shape features.

Refer to the Replacing or Moving Elements chapter in the Part Design User's Guide.
 To manage this capability, the Do replace only for elements situated after the In Work Object 

option is available in Tools -> Options -> Part Infrastructure ->  General tab. It allows you to make 
the Replace option possible only for features located below the feature in Work Object and in the same 
branch.

 



Managing Ordered Geometrical Sets
Geometrical sets enable to gather various features in a same set or sub-set. The order of these features is not meaningful as their access 
as well as their visualization is managed independently and without any rule. However flexible, this structure does not fit the design 
process.
That is why ordered geometrical sets introduced notions of succession of steps that define the design, and absorption.
Creation features create a new object and modification features create a new state in an existing object as well as absorb the preceding 
state(s). Absorbed features are no longer visible nor accessible, as if ''masked'' by their absorbing feature.
In an ordered geometrical set, the order of apparition of features in the specification tree is consistent with the steps of creation of the 
design.
Unlike features within a geometrical set, features in an ordered geometrical set can be set as current: a given step of the design creation 
is chosen and what is located after it is not accessible nor visible.
This task shows how to manage ordered geometrical sets within the specification tree. This involves: 

●     inserting an ordered geometrical set

●     defining an in work object

●     visualizing features within an ordered geometrical set

●     selecting features within an ordered geometrical set

●     removing an ordered geometrical set

●     removing a feature within an ordered geometrical set

●     sorting the contents of an ordered geometrical set

●     reordering components within an ordered geometrical set

●     reordering features

●     modifying children

●     replacing features

●     switching from ordered geometrical set to geometrical set

●     inserting and deleting inside and ordered geometrical set

●     editing features within an ordered geometrical set

You will find other useful information in the Managing Groups and Hiding/Showing chapters.
You can define the Generative Shape Design feature that is to be seen when working with another application, such as Generative 
Structural Analysis for example. 

To do this, while in the Generative Shape Design workbench: 

a.  Choose the Tools -> External View... menu item.
The External View dialog box is displayed.

b.  Select the element belonging to an ordered geometrical set that should always been seen as the current element when 
working with an external application.

c.  Click OK in the dialog box.
The selected element will be the visible element in other applications, even if other elements are created later in the 
.CATPart document, chronologically speaking.
To check whether an external view element has already been specified, choose the Tools -> External View... menu 
item again. The dialog box will display the name of the currently selected element. This also allows you to change 
elements through the selection of another element. Note that you cannot deselect an external view element and that 
only one element can be selected at the same time.

Open any .CATPart document containing Geometrical Sets.
You can also open the OrderedGeometricalSets1.CATPart document.

Inserting an Ordered Geometrical Set
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1.  In the specification tree, select an element as the location of the new ordered geometrical set. 

This element will be considered as a child of the new ordered geometrical set.

Inserting an Ordered Geometrical Set does not break the succession of steps as the order applies to all the elements of a same 

root ordered geometrical set.

2.  Select the Insert -> Ordered Geometrical Set menu command.

The Insert ordered geometrical set dialog box is displayed.

The Features list displays the elements to be contained in the new ordered geometrical set.

3.  Enter the name of the new ordered geometrical set you wish to insert.

4.  Use the Father drop-down list to choose the body where the new ordered geometrical set is to be inserted. All destinations present 

in the document are listed allowing you to select one to be the father without scanning the specification tree. They can be:

❍     ordered geometrical sets

❍     parts

By default the destination is the father of the current object. By default the ordered geometrical set is created after the current 
feature.

5.  Select additional entities that are to be included in the new ordered geometrical set.

If all selected entities belong to the same ordered geometrical set, the father of the new ordered geometrical set is 
automatically set to the father of these entities.

6.  Click OK to create the ordered geometrical set at the desired location.

The result is immediate. CATIA displays this new Ordered Geometrical Set.x, incrementing its name in relation to the pre-existing 
bodies, in the specification tree. It is created after the last current ordered geometrical set and is underlined, indicating that it is 
the active ordered geometrical set. 

 

●     You can insert an ordered geometrical set after the current feature.

●     You cannot create an ordered geometrical set within a geometrical set and vice versa.

●     You can insert a body into an ordered geometrical set.
For further information, refer to the Inserting a Body into an Ordered Geometrical Set chapter.

 
Defining an In Work Object

 The next created element is created after the In Work object.
If the new feature to be inserted is a modification feature, features after the In Work object may be rerouted to the new created feature.

 
Visualizing features in an Ordered Geometrical Set

 
It can be useful to temporarily see its future geometry.
To do so, you can check the Geometry located after the current feature option in Tools -> Options -> Infrastructure -> Part 
Infrastructure ->  Display tab. It allows you to also display the geometry located after the current feature.



 

●     Only features that come before the current object and that are not absorbed by any feature preceding the current object are visualized 
in the specification tree.

 
●     A color assigned to a feature is propagated to all the features that successively modify this feature and so on.

This is why it is possible to set a specific color only on creation features.
Therefore, changing the color of a modification feature modifies the color of the initial state.
Here Extrude.1 is absorbed by Split.1. Therefore the color of Extrude.1 is propagated onto Split.1.

 

The same behavior applies on Show/No show attributes. 

  
 

Selecting Features within an Ordered Geometrical Set
The selection of features located after the current feature or absorbed features is not possible.

 

Here, for instance, when editing Extrude.1, the selection of Offset.1 is not possible because Offset.1 is located after Extrude.1 which is the 
current object. A black sign indicates that this selection is not possible. Additionally, the application displays a tooltip explaining why it is 
not possible. 
To ensure the consistency between the visualization in the 3D geometry and the selection in the specification tree, features that cannot be 
visualized in the 3D geometry cannot either be selected in the specification tree.

 



1.  Right-click the ordered geometrical set then select the Delete contextual command.

The ordered geometrical set and all its contents are deleted.

Removing a Feature within an Ordered Geometrical Set

1.  Right-click the feature then select the Delete contextual command.

 

●     deletion of a modification feature: the system reroutes the children on the element that is modified. Therefore the deleted feature will 
be replaced by the modified feature of upper level.
In our scenario, Split.1 is deleted. As a consequence, Offset.1 now points Extrude.1.

 ●     deletion of a creation feature: no reroute is possible.

Sorting the Contents of an Ordered Geometrical Set
 You may need to sort the contents of an ordered geometrical set, when the geometric elements no longer appear in the logical creation 

order. It may be the case if you enabled the selection of drawn or future geometry (see above). In that case, use the Auto-sort capability 
to reorder the ordered geometrical set contents in the specification tree.

The Ordered Geometrical Set.1 contains a line based on two points lines. The specification tree looks like this:

 

1.  Right-click the Ordered Geometrical Set.1 from the specification and choose the Ordered Geometrical Set.1 object -> AutoSort 

command.

Instantly, the contents of the Ordered Geometrical Set are reorganized to show the logical creation process.

The geometry remains unchanged. Datum features are put first in the specification tree.

Removing an Ordered Geometrical Set



Reordering Components within an Ordered Geometrical Set
This capability enables you to reorder elements inside the same ordered geometrical set.

 Reordering a creation feature based upon a modification feature

Open the Reorder1.CATPart document.
The Ordered Geometrical Set contains Split.1 (in purple) that splits Fill.1 by a white vertical plane, and Offset.1 (in red) is an offset of 
Split.1.

 

1.  Right-click the Ordered Geometrical Set.1 from the specification tree and choose the Ordered Geometrical Set.1 object -> 

Reorder Children command.

The Reorder Children dialog box is displayed.

2.  Select the element to be rerouted.

Here we chose to reorder Offset.1 (creation feature) before Split.1 (modification feature).

3.  Use the arrow to move Offset.1 up.

4.  Click OK.

Offset.1 is now located before Split.1 in the specification tree.
If you define Split.1 as the In Work object, you can see that Offset.1 is now based upon Fill.1.
Split.1 was not rerouted since Offset.1 does not modify Fill.1.
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 Reordering a modification feature based upon a modification feature

Open the Reorder2.CATPart document.
The Ordered Geometrical Set contains Split.2 (in blue) that splits Split.1 by a vertical plane. Split.1 itself splits Fill.1 (delimited by Sketch.1 
in purple).

 

1.  Right-click the Ordered Geometrical Set.1 from the specification tree and choose the Ordered Geometrical Set.1 object -> 

Reorder Children command.

The Reorder Children dialog box is displayed.

2.  Select the element to be rerouted.

Here we chose to reorder Split.2 (modification feature) before Split.1 (modification feature).

3.  Use the arrow to move Split.2 up.

4.  Click OK.

Split.2 is now located before Split.1 in the specification tree.
Split.2 is rerouted onto the input feature modified by Split.1, that is Fill.1 (in blue).
Otherwise Split.2 would still split Split.1 which comes after in the specification tree.
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Indeed, when you edit Split.2, you can notice that the Split.2 was rerouted onto Fill.1...

...and since Split.2 now modifies Fill.1, Split.1 was rerouted onto Split.2.

 An error message is issued if you try to move an element towards a position that breaks the order 
rules.

Note that the feature defined as the In Work object after the Reorder operation is not affected by this 
operation from an update point of view:

●     when reordering upward, the feature located just before the new position of the reordered feature 
becomes the In Work object.

●     when reordering downward, the feature just before the original position of the reordered feature 
becomes the In Work object.

You can use the Scan command after the Reorder operation to see what moved step by step.

 
Reordering Features

 The Reorder command allows you to move a feature in an Ordered Geometrical Set. These features can be:
●     Generative Shape Design features

●     sketches

For further information, please refer to the Reordering Features chapter in the Part Design User's Guide.

●     You cannot move an element from a geometrical set to an ordered geometrical set as it may break the order rules.

●     Reordering contextual features does not modify their mode: they are always set to Keep mode at creation and remain in Keep mode 
after being reordered.

 
Modifying Children

 The Modify Children command allows you to modify the contents of an ordered geometrical set by selecting its first and last component, as 
well as destroy it.

This command is only available on sub-ordered geometrical sets.



1.  Right-click the sub-ordered geometrical set from the specification tree and choose the Ordered Geometrical Set.x object -> 

Modifying children. 

The Edit dialog box opens with the First Element and Last element fields automatically valuated with the first and last elements 
of the ordered geometrical set.

2.  Select the elements you wish to place first and last.

In our scenario, we chose Line.1 as the first element and Split.1 as the last element.

3.  Click OK.

The specification tree is modified consequently. 
Elements before or after the first and last elements are rerouted in the father ordered geometrical set.

The Modify children command also allows you to remove the sub-ordered geometrical set. As a consequence, elements are 
rerouted in the father ordered geometrical set.



Refer to the Replacing or Moving Elements chapter in the Part Design User's Guide.
 The Do replace only for elements situated after the In Work Object option is available in Tools -> Options -> Part 

Infrastructure ->  General tab. It restricts the Replace capability only on features located before the feature in Work Object and in the 
same branch.
As a consequence, the succession of steps of the ordered geometrical set is no longer respected. We advise you not to check this option 
but rather work in a geometrical set environment. 

 
Switching From Ordered Geometrical Set to Geometrical Set

 While in an ordered geometrical set environment, you may want to switch to a geometrical set environment (for instance, if you do not 
want to work in an ordered environment any more).

1.  Right-click the Ordered Geometrical Set.1 from the specification tree and choose the Ordered Geometrical Set.1 object -> 

Switch to geometrical set command.

The Ordered Geometrical Set.1 becomes Geometrical Set.1. 
Absorbed features and features after the current object that were not visualized in the ordered geometrical set are put in no show 
in the geometrical set.

❍     This command is only available on a root ordered geometrical set.

❍     Switching from geometrical set to ordered geometrical set is not 
possible.

❍     Colors may be modified.

 

 
Inserting and Deleting Inside an Ordered Geometrical Set

 Inside an ordered geometrical set, the Insert and Delete commands may have impacts that result in replace actions based on absorption 
rules.

Open the OrderedGeometricalSets2.CATPart document.

Here, the edge fillet (Edge Fillet.1) is the current object.

 

 A split feature (Split.1) is inserted just after EdgeFillet.1. This new feature absorbs EdgeFillet.1 and therefore the latter is no more 
displayed and cannot be referenced by any feature located after the Split.1 in the specification tree. 

 
Replacing Features
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 To ensure the ordering rule, the links to the absorbed feature (EdgeFillet.1) must be rerouted to the inserted feature (Split.1). This 
replacement applies to all the features inside the root ordered geometrical set (Ordered Geometrical Set.1) located after the inserted 
feature and to all the features located inside other ordered geometrical sets roots (here, Ordered Geometrical Set.2).

 This replace action may not be applicable; in this case a warning message is issued. 
Using our example, had we selected the other side of Split.1, the replacement of the edge to extrapolate (defined in Extrapol.1 feature) 
would not have been possible.

 

 As a consequence of the replace action, the affected features (that is Extrapol.1 and Offset.1) become "not updated". The update following 
the insertion may also produce an error and in this case the design will have to be modified so that the inserted feature is compatible with 
the entire design. 

The replace actions performed by the Delete command are generally the opposite of the replace actions performed by Insert command. 
Using our example, deleting Split.1 leads to the replacement of Split.1 by EdgeFillet.1. Nevertheless, bear in mind that deleting a feature 
can lead to a configuration different from the one preceding the insertion of a feature (for instance, if inserting a Trim feature, all inputs 
will be replaced by this feature but if deleting it, the Trim feature will be replaced by its main input).

 Based on this mechanism stand two methodologies for: 
●     multiple references to an intermediate state of design inside an ordered geometrical set,

●     external links to the "end design" specified inside an ordered geometrical set.

 Multiple references

 Inside a root ordered geometrical set, a feature can be the input of several features (all creation features, except for the last feature, 
according to the order in the specification tree, which can be a modification feature). In some cases, the design may require to create 
several modification states of a same feature. To do so, it is necessary to create copies (Copy/Paste As Result With Link). 

Open the OrderedGeometricalSets3.CATPart document.

 This example shows how to allow multiple modifications of EdgeFillet.1 feature, considered as an "intermediate state of design". A copy of 
the feature is inserted just after it. In the beginning of every sub-set where this state of design will be used, a copy of the copy is created.
Using this construction, modifications applied to EdgeFillet.1 or to the copies of the copy will affect only the design in Sub OGS.1.
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 External Links

 The replace actions due to design modifications (insertion and deletion) do not affect external links (that is the links between an external 
element from the .CATPart document and a feature inside an ordered geometrical set). To ensure that the links will always reference the 
last state of design, it is necessary to create a copy (Copy/Paste As Result With Link) of the last current feature in a new ordered 
geometrical set. This copy can possibly be published. As a consequence, the external link will have to reference this copy or its publication.

Open the OrderedGeometricalSets4.CATPart document.

 In this example, Surface.2 is a copy of EdgeFillet.1.
The external link has to reference Surface.2 or its publication. 

 

A split feature is inserted after EdgeFillet.1. As a consequence, Surface.2 is rerouted to Split.1 and so is the external link.
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Editing Feature Within an Ordered Geometrical Set

 A feature can be created within an OGS using different feature types (creation or modification) depending on the options selected to create 
it.
If a feature is created as a modification feature, then when editing it, you are prevented from changing the options that were used to 
define its type.
Here is the list of commands whose options lead to a modification of the feature type:

 Command Name Panel options

Blend Trim First Support, Trim Second Support

Extrapol Assemble Result

Shape Fillet - BiTangent Fillet Trim Support 1, Trim Support 2

Shape Fillet - TriTangent Fillet Trim Support 1, Trim Support 2

Edge fillet, Variable edge fillet, tritangent fillet, face-face 
fillet Trim Support

Corner Trim element 1, Trim element 2

Circle-Bitangent and Radius Trim element 1, Trim element 2

Circle-Bitangent and Point Trim element 1, Trim element 2

Circle-Tritangent Trim element 1, Trim element 3

Connect Trim elements

Sweep-Line (With Tangency Surface) Trim with tangency surface

Sweep-Line (With Two Tangency Surfaces) Trim with first tangency surface, Trim with second tangency 
surface

Sweep-Circle (One guide and tangency Surface) Trim with tangency surface

Mating Flange Trim, Trim and Split

Bead Base surface Relimitation

Let's take an example with the Corner.

Open the CornerOGS.CATPart document.
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1.  Click the Corner icon .

The Corner Definition dialog box opens.

2.  Choose the Corner On Support type from the combo list.

3.  Deselect the Corner on Vertex option.

4.  Select Line.1 as Element 1 and Line.2 as Element 2.

5.  Check the Trim element 1 and Trim element 2 options to trim and assemble the two reference elements to the corner.

By selecting the Trim options, the corner is now considered as a modification feature.

6.  Click OK to create the corner.

7.  Double-click the corner (in the specification tree or in the 3D geometry) to edit it.

The Corner Definition dialog box opens.

Both Trim options are disabled.



Inserting Features into a New Body 

These tasks show you how to restructure your specifications tree by gathering two or more features into 
a new body. Depending on your geometry, this operation may affect the part's final shape or not.

For example, open the Publish.CATPart document.

1.  Multiselect Pad.1, Pad.2 and Draft.1 as the features you want to group in a new body. 

These features must belong to the same body or part body and they must be consecutive in the 

tree. The selection order does not matter. 

2.  Select Insert>Insert in new body.

Likewise, you can use the Insert in new... contextual command or simply click the icon  

available in the Insert toolbar. 

The new body is created at the location of the feature that was first on the list. You can edit the 

properties of this new body that behaves like any other body.

file:///E|/www/celr16/Doc/online/cfysm_C2/samples/Publish.CATPart


 
A Few Recommendations

Contextual Features

●     Among the features you select, you cannot select a contextual feature as the first feature in the tree. 
'Contextual features' refer to features whose geometry depend on other features. For example, fillets 
depend on other features.

●     If your selection includes a contextual feature but not its parent (or 'support'), you cannot use the 
Assemble in New Body capability.

'Up to ...' Features

●     Among the features you select, you cannot select an 'up to ...' feature as the first feature in the tree.

●     If your selection includes an 'up to ...' feature but not its parent, the application warns you that you 
can either quit the command or validate the selection bearing in mind that the capability can modify 
the geometry. To perform the scenario illustrating that, open the Insert.CATPart document.

The part is composed of three pads, one of which 'Pad.3' was created using the Up to next option.
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 1.  Multiselect Pad.2 and Pad.3. 

2.  Select Insert->Assemble in New Body.

A warning message is issued indicating that the operation may result in an update error or 

modifications to the geometry.

3.  If you wish to give up, click No. For the purposes of our scenario, click Yes.

You obtain a modified part.

  

 



Assembling Bodies 

 

Assembling is a Boolean operation integrating your part specifications. It allows you to create complex 
geometry. This task shows you two assemble operations. You will see then how the resulting parts look 
different depending on your specifications.

When working in a CATProduct document, it is not necessary to copy and paste the bodies belonging to 
distinct parts before associating them. You can directly associate these bodies using the same procedure 
as described in this task. 

Structuring Your Design 

Generally speaking, using Boolean Operations is a good way of structuring your part. Prior to designing, 
you can actually define the part's structure by associating a body containing geometry or not with empty 
bodies. Once these specifications are done, you can then concentrate on the geometry.

In this page, in addition to the scenario you can follow you will find the following information:

●     Bodies You Can Assemble

●     Location of Bodies in the Specification Tree

●     Notes

●     Empty Bodies and Polarity

●     Optimizing Your Design  

●     Interrupting Boolean Operations Computations

●     Copying/Pasting Boolean Operations

●     Colors

Open the Assemble.CATPart document and make sure Part Body is the current body.
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First, you are going to assemble a pocket to Part Body. You will note that as this pocket is the first 
feature of the body, material has been added (see Creating Pockets).

 

1.  To assemble them, select Body 2 and click the Assemble...icon  .

The Assemble dialog box that appears displays the name of the selected body, the Part Body 

and the feature (EdgeFillet.1) after which the Assemble feature is to be located.

By default, the application proposes to assemble the selected body to Part Body. For the purpose 

of our scenario, we keep this location.

From V5R15 onward, you can get an idea of the result just by clicking the Preview button. 



 2.  Click OK to confirm. 

During the operation, the application removes the material defined by the pocket from Part 

Body.

The new Part Body looks like this:

In the specification tree, Part Body now includes the Assemble.1 feature under which Body.2 is 

located.

3.  Now delete the assemble operation to go back to the previous state. You are going to perform 

the second assemble operation.

4.  Select Body.2 and Edit > Body2.object >  Assemble. 

The Assemble dialog box displays again.

5.  Select Body.1 in the specification tree to edit the To: field. 

Body.1 appears in the field, indicating that you are going to assemble Body.2 on Body.1.

6.  Click OK.

The material defined by the pocket from Body1 has been removed during the operation.

Bodies You Can Assemble



●     Assembling a set of bodies (multi-selected via the Ctrl key) is possible unless the bodies are located in 
ordered geometrical sets. This capability will increase your productivity. 

●     Assembling a body to a solid body and vice versa is possible. In that case, the second body you select 
remains at the same location in the specification tree once the Boolean operation is done. For reference 
information, refer to Mixed Boolean Operations.

●     From V5R16 onward, you can assemble a body set in an ordered geometrical set (OGS) to another 
body set in the same ordered geometrical set or in a distinct one. Note that the different Boolean 
operations can be performed using dedicated contextual commands.
Depending on whether the Boolean operation interrupts the sequential construction of the geometry or not, 
the application behaves differently. 

No interruption of the sequential construction of the geometry

If there is no interruption of the sequential construction of the geometry, two cases are to be considered:

❍     if the bodies are set in the same OGS, the operation is performed and the second body selected is 
located below the Boolean operation node.

❍     if the bodies are set in distinct OGS, the operation is performed and the second body selected is moved 
below the Boolean operation node.



Interruption of the sequential construction of the geometry

If there is an interruption of the sequential construction of the geometry, two cases are to be considered:

●     if the bodies are set in the same OGS, a warning message is issued informing you that the operation is 
going to be canceled: breaking the sequential construction of the geometry is not allowed when the 
operands belong the the same OGS.

●     if the bodies are set in distinct OGS,  a warning message is issued letting you choose between canceling 
the operation or going on. If you decide to continue, the second body you selected remains at its initial 
location in the tree.

Location of Bodies Once the Boolean Operation is Complete

Once a Boolean operation is done, the second body you selected is moved below the Boolean operation, as 
illustrated in the scenario above. However, there are exceptions to that rule:

●     In case of Mixed Boolean Operations, the second body remains at the same location in the specification 
tree. For reference information on how to associate bodies of different types, refer to Mixed Boolean 
Operations.

●     If assembling bodies results in an interruption of the sequential construction of the geometry, a warning 
message is issued letting you choose between canceling the operation or going on.
If you decide to continue, the second body you selected remains at its initial location in the tree.

In the example below, Pad.2 located in Body.2 was created using Extrude.1, located in PartBody, as one of 
its limits. When assembling Body.2 to PartBody, the sequential construction is broken and Body.2 



consequently remains at its initial location in the tree.

->

Notes
●     You cannot re-apply the Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 

already associated to other bodies. However, if you copy and paste the result of such operations elsewhere 
in the tree you can then use these commands.

●     Avoid using input elements that are tangent to each other since this may result in geometric instabilities in 
the tangency zone.

●     Contrary to other Boolean operations, you cannot edit an Assemble feature. If you wish to change your 
specifications, just proceed as explained in the task above.

Empty Bodies and Polarity 

By default, assemble operations have a positive polarity (plus sign in front of the body icon in the specification 
tree). If the assemble operation is the first feature of the body and if the assembled body is empty, the body 
has a positive polarity. 

Optimizing Your Design 

The Only Current Body option  displays only the features of the current body and greatly improves the 
application performances whenever you edit these features. For more information, refer to Display in Geometry 
Area.

Interrupting Boolean Operations Computations



In case you made a mistake when performing a Boolean operation, you can interrupt the feature computation 
launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a Cancel 
option. To interrupt the operation, just click that Cancel button. This interrupts the process and then displays 
an Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the Boolean operation 
in progress.

This new capability is available for any types of Boolean operations you are creating or editing.

Copying/Pasting Boolean Operations

To copy/paste Boolean Operations, you need to select the operation node as well as the operated body.

Colors

When performing a mixed Boolean operation, the resulting geometry inherits the color of the first geometric 
entity selected. 



Intersecting Bodies 
The material resulting from an intersection operation between two bodies is the material shared by these 
bodies. This tasks illustrates how to compute two intersections via a Boolean operation.

When working in a CATProduct document, it is not necessary to copy and paste the bodies belonging to 
distinct parts before associating them. You can directly associate these bodies using the same steps as 
described in this task.

Structuring Your Design 

Generally speaking, using Boolean Operations is a good way of structuring your part. Prior to designing, 
you can actually define the part's structure by associating a body containing geometry with empty 
bodies. Once these specifications are done, you can then concentrate on the geometry.

In this page, you will find the following information:

●     Bodies You Can Use

●     Location of Bodies Once the Boolean Operation is Complete

●     Notes

●     Optimizing Your Design  

●     Interrupting Boolean Operations Computations

●     Colors

 
Open the Intersect.CATPart document.

1.  The initial part is composed of three bodies. Each body contains one pad. To compute the 

intersection between the Part Body and Body 2, select Body.2.

Intersecting a set of bodies (multi-selected via the Ctrl key) is possible. This capability will 

increase your productivity.
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2.  Click the Intersect...  icon.

The Intersect dialog box displays to let you determine the second body you wish to use. By 

default, the application proposes to intersect the selected body to Part Body.

From V5R15 onwards, you can get an idea of the result just by clicking the Preview button. 

3.  Click OK to confirm.

The application computes the intersection between the two bodies.

Part Body now looks like this:



 

 
4.  Now delete the intersection to go back to the previous state. You are going to create a new 

intersection.

5.  Select Body 2 and right-click Edit > Body2.object >  Intersect. 

This displays the Intersect dialog box.

6.  Select Body1 in the specification tree to edit the To: field.

7.  Click OK. 

Body1 now looks like this: 



 
●     From V5R15, editing an Intersect feature is possible. To do so, you just need to double-click that 

feature and then select the new body you wish to intersect.

Bodies You Can Use

●     Performing a Boolean operation using set of bodies (multi-selected via the Ctrl key) is possible unless the 
bodies are located in ordered geometrical sets. This capability will increase your productivity. 

●     Making a body intersect with a solid body and vice versa is possible. In that case, the second body you 
select remains at the same location in the specification tree once the Boolean operation is done. For 
reference information, refer to Mixed Boolean Operations.

●     From V5R16 onward, you can make a body set in an ordered geometrical set (OGS) intersect with 
another body set in the same ordered geometrical set or in a distinct one. Note that the different Boolean 
operations can be performed using dedicated contextual commands.
Depending on whether the Boolean operation interrupts the sequential construction of the geometry or not, 
the application behaves differently. 

No interruption of the sequential construction of the geometry

If there is no interruption of the sequential construction of the geometry, two cases are to be considered:



❍     if the bodies are set in the same OGS, the operation is performed and the second body selected is 
located below the Boolean operation node.

❍     if the bodies are set in distinct OGS, the operation is performed and the second body selected is moved 
below the Boolean operation node.

Interruption of the sequential construction of the geometry

If there is an interruption of the sequential construction of the geometry, two cases are to be considered:

●     if the bodies are set in the same OGS, a warning message is issued informing you that the operation is 
going to be canceled: breaking the sequential construction of the geometry is not allowed when the 
operands belong the the same OGS.

●     if the bodies are set in distinct OGS,  a warning message is issued letting you choose between canceling 
the operation or going on. If you decide to continue, the second body you selected remains at its initial 
location in the tree.

Location of Bodies Once the Boolean Operation is Complete

Once a Boolean operation is done, the second body you selected is moved below the Boolean operation, as 
illustrated in the scenario above. However, there are exceptions to that rule:

●     Making a body and a solid body intersect and vice versa is possible. In that case, the second body you 
select remains at the same location in the specification tree once the Boolean operation is done. To see an 
example, refer to Mixed Boolean Operations.

●     If intersecting bodies results in an interruption of the sequential construction of the geometry, the second 
body you selected to perform the Boolean operation remains at its initial location in the tree when the 
operation is complete. To see an example, refer to the Location of Bodies Once the Boolean Operation is 
Complete paragraph of Assembling Bodies.

Notes
●     You cannot re-apply the Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 

already associated to other bodies. However, if you copy and paste the result of such operations elsewhere 
in the tree you can then use these commands.

●     Avoid using input elements that are tangent to each other since this may result in geometric instabilities in 
the tangency zone.

Optimizing Your Design 

The Only Current Body option  displays only the features of the current body and greatly improves the 
application performances whenever you edit these features. For more information, refer to Display in Geometry 
Area.



Interrupting Boolean Operations Computations

In case you made a mistake when performing a Boolean operation, you can interrupt the feature computation 
launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a Cancel 
option. To interrupt the operation, just click that Cancel button. This interrupts the process and then displays 
an Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the Boolean operation 
in progress.

This new capability is available for any types of Boolean operations you are creating or editing.

Colors

When performing a mixed Boolean operation, the resulting geometry inherits the color of the first geometric 
entity selected. 



Adding Bodies 

 

This task illustrates how to add a body to another body. Adding a body to another one means uniting 
them via a Boolean operation.

When working in a CATProduct document, it is no longer necessary to copy and paste the bodies 
belonging to distinct parts before associating them. You can directly associate these bodies using the 
same procedure as described in this task.

Structuring Your Design 

Generally speaking, using Boolean Operations is a good way of structuring your part. Prior to designing, 
you can actually define the part's structure by associating a body containing geometry with empty 
bodies. Once these specifications are done, you can then concentrate on the geometry.

In this page, you will find the following information:

●     Bodies You Can Use

●     Location of Bodies Once the Boolean Operation is Complete

●     Notes

●     Optimizing Your Design  

●     Interrupting Boolean Operations Computations

●     Colors

Open the Add.CATPart document and make sure Part Body is the current body.

 
1.  This is your initial data: the Add part is composed of three bodies. Each body includes a pad. 

These pads are therefore independent. To add Body.1 to Part Body, select Body.1.
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●     Adding a set of bodies (multi-selected via the Ctrl key) is possible. This capability will increase your 

productivity.

2.  Click the Add icon  .

The Add dialog box that appears displays the name of the selected body, the Part Body and the 

feature after which the Add feature is to be added.

By default, the application proposes to add the selected body to Part Body. For the purpose of 

our scenario, we keep this location. Note however that you could add Body.1 to Body.2 one just 

by selecting Body.2. 

From V5R15 onward, you can get an idea of the result just by clicking the Preview button.

3.  Click OK. 

The specification tree and Part Body now looks like this:



 

You will note that: 

❍     the material common to Part Body and Body.1 has been unified

❍     both pads keep their original colors.

4.  Double-click Add.1 to edit the Boolean operation.

The Add dialog box is displayed.

5.  Select Body.2 from the specification tree or from the geometry area.

PartBody and Body.2 are associated. The material common to Part Body and Body.2 is 

retrieved.

 



Bodies You Can Use

●     Performing a Boolean operation using a set of bodies (multi-selected via the Ctrl key) is possible unless the 
bodies are located in ordered geometrical sets. This capability will increase your productivity. 

●     Making a body intersect with a solid body and vice versa is possible. In that case, the second body you 
select remains at the same location in the specification tree once the Boolean operation is done. For 
reference information, refer to Mixed Boolean Operations.

●     From V5R16 onward, you can add a body set in an ordered geometrical set (OGS) to another body 
set in the same ordered geometrical set or in a distinct one. Note that the different Boolean operations can 
be performed using dedicated contextual commands.
Depending on whether the Boolean operation interrupts the sequential construction of the geometry or not, 
the application behaves differently. 

No interruption of the sequential construction of the geometry

If there is no interruption of the sequential construction of the geometry, two cases are to be considered:

❍     if the bodies are set in the same OGS, the operation is performed and the second body selected is 
located below the Boolean operation node.

❍     if the bodies are set in distinct OGS, the operation is performed and the second body selected is moved 
below the Boolean operation node.



Interruption of the sequential construction of the geometry

If there is an interruption of the sequential construction of the geometry, two cases are to be considered:

●     if the bodies are set in the same OGS, a warning message is issued informing you that the operation is 
going to be canceled: breaking the sequential construction of the geometry is not allowed when the 
operands belong the the same OGS.

●     if the bodies are set in distinct OGS,  a warning message is issued letting you choose between canceling 
the operation or going on. If you decide to continue, the second body you selected remains at its initial 
location in the tree.

Location of Bodies Once the Boolean Operation is Complete

Once a Boolean operation is done, the second body you selected is moved below the Boolean operation, as 
illustrated in the scenario above. However, there are exceptions to that rule:

●     Adding a body to a solid body and vice versa is possible. In that case, the second body you select remains 
at the same location in the specification tree once the Boolean operation is done. To see an example, refer 
to Mixed Boolean Operations.

●     If adding bodies results in an interruption of the sequential construction of the geometry, the second body 
you selected to perform the Boolean operation remains at its initial location in the tree when the operation 
is complete. To see an example, refer to the Location of Bodies Once the Boolean Operation is Complete 
paragraph of Assembling Bodies.

Notes
●     You cannot re-apply the Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 

already associated to other bodies. However, if you copy and paste the result of such operations elsewhere 
in the tree you can then use these commands.

●     Avoid using input elements that are tangent to each other since this may result in geometric instabilities in 
the tangency zone.

Optimizing Your Design 

The Only Current Body option  displays only the features of the current body and greatly improves the 
application performances whenever you edit these features. For more information, refer to Display in Geometry 
Area.

Interrupting Boolean Operations Computations

In case you made a mistake when performing a Boolean operation, you can interrupt the computation 
launched after clicking OK, provided that the computation requires at least 5 seconds to perform.
When a computation exceeds 5 seconds, a progress bar appears and provides a Cancel option. To interrupt 
the operation, just click that Cancel button. This interrupts the process and then displays an Update Diagnosis 



dialog box enabling you to edit, deactivate, isolate or even delete the Boolean operation in progress.

This new capability is available for any types of Boolean operations you are creating or editing.

Colors

When performing a mixed Boolean operation, the resulting geometry inherits the color of the first geometric 
entity selected. 

 



Removing Bodies 

 

This tasks illustrates how to remove a body from another body via a Boolean operation.

When working in a CATProduct document, it is no longer necessary to copy and paste the bodies 
belonging to distinct parts before associating them. You can directly associate these bodies using the 
same steps as described in this task.

Structuring Your Design 

Generally speaking, using Boolean Operations is a good way of structuring your part. Prior to designing, 
you can actually define the part's structure by associating a body containing geometry with empty 
bodies. Once these specifications are done, you can then concentrate on the geometry.

In this page, you will find the following information:

●     Bodies You Can Use

●     Location of Bodies Once the Boolean Operation is Complete

●     Notes

●     Optimizing Your Design  

●     Interrupting Boolean Operations Computations

●     Colors

Open the Remove.CATPart document.

 
1.  The part is composed of two bodies. To remove Body.1 from Part Body, select Body.1.
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●     Removing a set of bodies (multi-selected via the Ctrl key) is possible. This capability will increase 

your productivity.

2.  Click the  Remove... icon . 

●     When the part is made of more than two bodies, the Remove dialog appears to let you determine 
the operation you wish to perform. By default, the application proposes to remove the selected body 
from the Part Body. To change that, just select another body from which you want to remove the 
selected body. The dialog will show the new selected body.

 

From V5R15 onwards, you can:

●     get an idea of the result just by clicking the Preview button.

●     edit a Remove feature. To do so, you just need to double-click the feature and then select the new 
body to be removed.



Bodies You Can Use

●     Performing a Boolean operation using a set of bodies (multi-selected via the Ctrl key) is possible unless the 
bodies are located in ordered geometrical sets. This capability will increase your productivity. 

●     Making a body intersect with a solid body and vice versa is possible. In that case, the second body you 
select remains at the same location in the specification tree once the Boolean operation is done. For 
reference information, refer to Mixed Boolean Operations.

●     From V5R16 onward, you can remove a body set in an ordered geometrical set (OGS) from another 
body set in the same ordered geometrical set or in a distinct one. Note that the different Boolean 
operations can be performed using dedicated contextual commands.
Depending on whether the Boolean operation interrupts the sequential construction of the geometry or not, 
the application behaves differently. 

No interruption of the sequential construction of the geometry

If there is no interruption of the sequential construction of the geometry, two cases are to be considered:

❍     if the bodies are set in the same OGS, the operation is performed and the second body selected is 
located below the Boolean operation node.

❍     if the bodies are set in distinct OGS, the operation is performed and the second body selected is moved 
below the Boolean operation node.

Interruption of the sequential construction of the geometry

If there is an interruption of the sequential construction of the geometry, two cases are to be considered:

●     if the bodies are set in the same OGS, a warning message is issued informing you that the operation is 
going to be canceled: breaking the sequential construction of the geometry is not allowed when the 
operands belong the the same OGS.

●     if the bodies are set in distinct OGS,  a warning message is issued letting you choose between canceling 
the operation or going on. If you decide to continue, the second body you selected remains at its initial 
location in the tree.

Location of Bodies Once the Boolean Operation is Complete

Once a Boolean operation is done, the second body you selected is moved below the Boolean operation, as 
illustrated in the scenario above. However, there are exceptions to that rule:

●     Removing a body from a solid body and vice versa is possible. In that case, the second body you select 
remains at the same location in the specification tree once the Boolean operation is done. To see an 
example, refer to Mixed Boolean Operations.



●     If removing a body results in an interruption of the sequential construction of the geometry, the second 
body you selected to perform the Boolean operation remains at its initial location in the tree when the 
operation is complete. To see an example, refer to the Location of Bodies Once the Boolean Operation is 
Complete paragraph of Assembling Bodies.

Notes
●     You cannot re-apply the Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 

already associated to other bodies. However, if you copy and paste the result of such operations elsewhere 
in the tree you can then use these commands.

●     Avoid using input elements that are tangent to each other since this may result in geometric instabilities in 
the tangency zone.

Optimizing Your Design 

The Only Current Body option  displays only the features of the current body and greatly improves the 
application performances whenever you edit these features. For more information, refer to Display in 
Geometry Area.

Interrupting Boolean Operations Computations

In case you made a mistake when performing a Boolean operation, you can interrupt the feature computation 
launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a Cancel 
option. To interrupt the operation, just click that Cancel button. This interrupts the process and then displays 
an Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the Boolean operation 
in progress.

This new capability is available for any types of Boolean operations you are creating or editing.

Colors

When performing a mixed Boolean operation, the resulting geometry inherits the color of the first geometric 
entity selected. 

 



Trimming Bodies 

Applying the Union Trim command on a body entails defining the elements to be kept or removed while performing the 
union operation. 

The following rules are to be kept in mind:

Rule 1

REMOVE: Selected bodies ONLY are removed

Rule 2

KEEP: selected body is kept. All other bodies are removed

Rule 3

REMOVE is not necessary if KEEP specification exists



Concretely speaking, you need to select the required bodies and specify the faces you wish to keep or remove.

 
This task illustrates how to use the Union Trim capability.

When working in a CATProduct document, it is no longer necessary to copy and paste the bodies belonging to 
distinct parts before associating them. You can directly associate these bodies using the same steps as described in 
this task.

Open the UnionTrim.CATPart document.

1.  Select the body you wish to trim, i.e. Body.2.

2.  Click the Union Trim icon .

The Trim Definition dialog box is displayed. The faces you cannot select are displayed in red.

3.  Click the Faces to remove field and select Body.2 's inner face.
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The selected face appears in pink, meaning that the application is going to remove it.

4.  Click the Faces to keep field and select Part Body. 's inner face.

This face becomes blue, meaning that the application is going to keep it.

 

  Clicking the Preview button lets you check if your specifications meet your needs or not.



5.  Click OK to confirm.

The application computes the material to be removed. The operation (identified as Trim.xxx) is added to 

the specification tree.

●     You cannot re-apply the Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 
already associated to other bodies. However, if you copy and paste the result of such operations elsewhere in 
the tree you can then use these commands.

●     Avoid using input elements that are tangent to each other since this may result in geometric instabilities in the 
tangency zone.

●     As much as possible, avoid selecting faces trimmed by the operation. In some cases, defined trimmed faces 
have the same logical name: the application then issues a warning message requiring a better selection.

 

Interrupting Boolean Operations Computations

In case you made a mistake when performing a Boolean operation, you can interrupt the feature computation 
launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a Cancel 
option. To interrupt the operation, just click that Cancel button. This interrupts the process and then displays an 
Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even delete the Boolean operation in 
progress.

This new capability is available for any types of Boolean operations you are creating or editing.

   



Keeping and Removing Faces 

The Remove Lump command lets you reshape a body by removing material. To remove material, 
either you specify the faces you wish to remove or conversely, the faces you wish to keep. In some 
cases, you need to specify both the faces to remove and the faces to keep.

Using this command is a good way to get rid of cavities you inadvertently created. 

This task illustrates how to reshape a body by removing the faces you do not need. Depending on the 
faces you select for removal, you will obtain two distinct bodies.

Open the RemoveLump.CATPart document.

1.  Select the body you wish to reshape, that is Part Body.

2.  Click the Remove Lump icon .

The Remove Lump Definition dialog box appears. You just need to specify the faces you wish 

to remove as well as the faces you need to keep.
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3.  Click the Faces to remove field and select the colored face. 

From V5R15 onwards, you can get an idea of the result just by clicking the Preview button.

The selected face appears in pink, meaning that it will be removed during the operation.

4.  Click OK. 

The new body looks like this:

5.  Now, delete Trim.1 in the specification tree and repeat steps 1 and 2.

6.  In the dialog box that appears, click the Faces to remove field and select the bottom face.

This face appears in pink.

7.  Click OK.

 



The new body looks like this :

The faces selected as the faces to be kept are displayed in blue.

You cannot re-apply Assemble, Add, Trim, Intersect, Remove and Remove Lump commands to bodies 
already associated to other bodies. However, if you copy and paste the result of such operations 
elsewhere in the tree you can then use these commands.

 
Cavities 

Remove Lump allows you to delete cavities, which is a good way to control the quality of the part. As 
shown in the example below, the initial part includes a cavity resulting from a shell operation.

 

 Applying Remove Lump and selecting the face to be kept...



 

 reshapes the part. The application has removed the faces that are not adjacent to the selected face.

 

 

Interrupting Boolean Operations Computations

In case you made a mistake when performing a Boolean operation, you can interrupt the feature 
computation launched after clicking OK, when the computation requires a few seconds to perform.
In concrete terms, if the computation exceeds a certain amount of time, a window appears providing a 
Cancel option. To interrupt the operation, just click that Cancel button. This interrupts the process 
and then displays an Update Diagnosis dialog box enabling you to edit, deactivate, isolate or even 
delete the Boolean operation in progress.

This capability is available for any types of Boolean operations you are creating or editing.

  



Changing a Boolean Operation into Another One 
   

This task shows you how to change a Boolean operation (Add, Assemble, Remove and even Union Trim) 
into another one and this, very quickly. This capability largely increases your productivity, since it is no 
longer necessary to restructure your design from scratch.

Open the Intersect.CATPart document.

1.  The initial part is composed of three bodies. Assemble Body.1 to Part Body.

2.  Remove Body.2 from Assemble.1.

You obtain Remove.1:
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3.  Fillet Pad.3 's top edge.

4.  Select Remove.1 and right-click Remove.1 object >  Change to Assemble..

The   Change to Add...contextual command is available too.

You obtain Assemble.2. Note that the fillet is still defined on Pad.3's top edge.



5.  Select Assemble.2 and right-click Assemble.2 object >  Change to Union Trim...

The   Change to Add... and  Change to Remove...contextual menu items are 

available too.

6.  Click OK.

You obtain Trim.1:



7.  Double-click Trim.1 and select the cylinder's top face as the face to keep. You obtain this part :



  



Using Tools

Edit a List of Elements: Click the icon to display the Element list 
dialog box. Remove any element clicking the Remove button or 
Replace any element using the Replace button.  

Scan the Part and Define Local Objects: Select Edit > Scan or Define 
in Work Object..., click the buttons to move from one local feature to 
the other, then the Exit button.

Define in Work Object Defining a feature as local without scanning the whole part is possible 
using the Define in Work Object contextual command.

Perform a Draft Analysis: Define a direction using the compass, click 
this icon, select the part, and enter the minimum draft angle value in 
the field below the green frame.

Perform a Surface Curvature Analysis: Select a body, click this icon and 
enter new values in the color range.

 
Analyze Thread/Tap: Click this icon and check or uncheck display 
options.

Create Datums: Click this icon to deactivate the History mode.

 Isolate Geometric Elements: Select the element to be isolated and right-
click XXXobject > Isolate.

Apply a Material: Select the element on which the material should be 
applied, click this icon, select any material and click Apply Material.

 Extract Geometry: the capability is proposed when an update operation 
detects difficulties in building the part.



Display Parents and Children: Select the feature under study, Tools > 
Parent/Children... and use the diverse contextual commands to 
display parents and children.

Define an Axis System: Click this icon, enter coordinates or select 
geometry to define the three axes.

 Publish Elements: Select Tools > Publication, select the element to 
be published then rename it.

Work on 3D Support: click the icon and select a define the 3D support 
type: Reference or Local.



Editing a List of Elements 

This task shows you how to edit a list of elements within any command allowing multi-selection for input 
elements, when the list is not already explicitly available from the dialog box. 

To see an example of this capability, open the VariableRadiusFillet1.CATPart document.

 1.  Click the Variable Radius Fillet icon . 

2.  Select any edge for filleting. 

The application detects both vertices and displays them as 2 elements in the Points field.

3.  Click the  icon to display the Point Elements dialog box. 

This dialog box allows you to:

❍     view the selected elements

❍     remove any element clicking the Remove button

❍     replace any element using the Replace button and selecting a new one in the geometry or 
the specification tree. 

4.  Select two additional points on the edge.

The Point Elements dialog box now displays four points.

5.  Select PointOnEdge.2 from the list and click the Remove button. 

The point is removed from the list.

6.  Select PointOnEdge.3 from the list and click the Replace button. 
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7.  Select a new point on the edge: PointOnEdge.3 has been replaced with PointOnEdge.5. 

8.  Click Close in the Element list dialog box to return to the initial command: Variable Radius 

Fillet in this case. The Variable Radius Fillet dialog box is updated accordingly: only 3 

elements are identified as being selected.



Scanning a Part and Defining In Work Objects  

 

This task shows how to scan the part and define a current object without taking the complete part into 
account. Therefore, it is useful for the analysis of the better understanding of the part design.
Both geometrical sets and ordered geometrical sets can be scanned. 

 
Open the Scan1.CATPart document.

 1.  Select the Edit -> Scan or Define in Work Object... command or click the  icon from the 

Select toolbar.

The Scan toolbar appears enabling you to navigate through the structure of your part. 
Moreover, the part can be updated feature by feature.
You actually need to click the buttons allowing you to move from one current feature to the 
other. Sketch elements are not taken into account by the command.

2.  Select the Scan mode to define the way of scanning:

 

Structure
All features of the part are now scanned in the order of display in the specification tree. 
The current position in the graph corresponds to the in work object.

 

Internal elements of sketches, part bodies and bodies, ordered geometrical 
sets, and elements belonging to a geometrical set are not taken into account 
by this mode.

 

●     Click the Display Graph icon .

The Scan Graph dialog box appears and displays all the features belonging to Scan1 part.

file:///E|/www/celr16/Doc/online/cfysm_C2/samples/Scan1.CATPart


 

Update
 All features of a part are scanned in the order of the update (which is not necessarily the order of the 

specification tree). 
The current position in the scan graph does not correspond to the in work object: indeed the 
underlined object in the graph is not necessarily the one underlined in the specification tree. 

 

●     Datum features appear first; geometrical sets and ordered geometrical 
sets do not appear in the Scan Graph.

●     Deactivated features appear in the Scan Graph.

●     The part is put in no show, so is its 3D display, in order to build a new 
3D display that contains the same features but in a different order.
As a consequence, if a geometrical set or an ordered geometrical set is 
in no show, it is ignored and its elements are considered as being in 
show. 
To put the contents of this geometrical set or ordered geometrical set in 
no show, use the Geometrical_Set.x object -> Hide components 
contextual command. Refer to the Hiding/Showing Geometrical Sets or 
Ordered Geometrical Sets and Their Contents chapter for further 
information.
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●     Click the Display Graph icon .

The Scan Graph dialog box appears and displays all the features belonging to Scan1 part.

The Update mode is not available with Power Copies.

3.  Select a feature in the Scan Graph or in the specification tree. The application highlights the 

feature in question in the specification tree as well as in the geometry area and make it current.

In our example, we chose EdgeFillet.1.

❍     A preview of the current object's parents is available: 
■     if the parents are visible: the thickness of lines and points is increased and the 

surfaces' edges are in dotted lines; faces and edges are highlighted.

■     if the parents are not visible: the surfaces appear as transparent; lines and points 
are in yellow dotted lines.

❍     If a parent of the in work object is in no show, it is temporarily shown when its child 
is the in work object.

4.  Click the Previous arrow  to move to the previous feature, that is Pad.1.



 

5.  Click the First arrow  to move to the first feature, that is Plane.1 (the first feature after 

the two datum points).

In case there are several datum features, the application highlights the last one as there 
are all scanned at the same time.

6.  Click the Next arrow  to move to the next feature, that is Point.1.

Scanning Next and Previous skip datum and deactivated features.

7.  Click the Last arrow  to move to the last feature, that is EdgeFillet.3.

Moving to the next or last feature enables to update elements that are not up-to-date.

8.  Click the First to Update  icon to move to the first element to be updated and 

consequently update it.

If both geometry and part are up-to-date, an information panel appears:

9.  Click this icon again to find the next element to be updated and so on until an information panel 

appears to inform you that both geometry and part are up-to-date.

10.  Click the Play Update icon  to replay the update of the geometry.

A progression bar is displayed, while the scenario is being replayed.

In case of update errors, the replay stops at the first error. The Update Error dialog box opens.



11.  Click the Exit button  to exit the command.

In the geometry area and the specification tree, the application highlights the current object.
If the object was in no show, it is put in show as long as it stays current.

 
●     Defining a feature as current without scanning the whole part 

is possible using the Define in Work Object contextual 
command on the desired feature. This feature is put in show if 
needed, and keeps its status even if another feature is defined 
as the in work object.

●     When clicking a sub-element in the 3D geometry, it is in fact 
the feature used to generate this sub-element which is 
selected as the in work object. Likewise, this feature is edited 
when double-clicking a sub-element.

●     When a collapsed contextual element is highlighted, it is the 
node of its set that is highlighted in the Scan Graph.

●     To display 3D parameters attached to Part Design features, 
check the Parameters of features and constraints option 
in the Tools -> Options -> Infrastructure -> Part 
Infrastructure -> Display.

 



Performing a Draft Analysis 

This task shows how to analyze the draft angle on a surface.
The Draft Analysis command enables you to detect if the part you drafted will be easily removed.

●     This type of analysis is performed based on color ranges identifying zones on the analyzed 
element where the deviation from the draft direction at any point, corresponds to specified 
values.
These values are expressed in the unit as specified in Tools -> Options -> General -> 
Parameters -> Unit tab. 
You can modify them by clicking on their corresponding arrow or by entering a value directly in 
the field.

●     The mapping texture accuracy depends of the video card used. Therefore, colors displayed on 
surfaces could be wrong according to the color scale, when the value displayed on the fly is right 
because the analysis is recomputed at the cursor location.
Sometimes, in the case of very closed values, it is recommended to switch to the Quick mode to 
improve the color display accuracy.

●     The maximal draft analysis accuracy is 0.1 deg. According to the graphic card performance, this 
accuracy can be debased.

This command is only available with:
●     FreeStyle Shaper 2

●     Part Design 2

●     Generative Shape Design 2

●     Wireframe and Surface for Building 1.

Open the FreeStyle_12.CATPart document.

●     The visualization mode should be set to Shading With Edges in the View -> Render Style 
command

●     The discretization option should be set to a maximum: in Tools -> Options -> Display -> 
Performances, set the 3D Accuracy -> Fixed option to 0.01.

●     Check the Material option in the View -> Render Style -> Customize View command to be 
able to see the analysis results on the selected element. Otherwise a warning is issued.

●     Uncheck the Highlight faces and edges option in Tools -> Options -> Display -> 
Navigation to disable the highlight of the geometry selection.

1.  Select a surface.

 

2.  Click the (Feature) Draft Analysis icon:  
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The Draft Analysis dialog box is displayed. It gives information on the display (color scale), 
the draft direction and the direction values.
The Draft Analysis.1 dialog box showing the color scale and identifying the maximum and 
minimum values for the analysis is displayed too.

 



The mode option lets you choose between a quick and a full analysis mode. These two modes 
are completely independent.
The default mode is the quick mode. It simplifies the analysis in that it displays only three 
color ranges.

 
●     Quick mode:

●     Full mode, this mode is P2-only:

 
3.  Double-click on a color in the color scale to display the Color dialog box in order to modify 

the color range.

 

Mode option



 
4.  Exit the dialog box.

 
5.  Double-click on the value in the color scale to display the Value Edition dialog box.

 

●     Enter a new value (negative values are allowed) to redefine the color scale, or use the 
slider to position the distance value within the allowed range, and click OK.

●     The value is then frozen, and displayed in a green rectangle.

The color scale settings (colors and values) are saved when exiting the command, meaning 
the same values will be set next time you edit a given draft analysis capability.
However, new settings are available with each new draft analysis.

 
6.  Exit the dialog box.



Display option
 

7.  Uncheck the Color Scale checkbox to hide the Draft Analysis.1 dialog box, this dialog box 

only appears in edition mode.

 
8.  Activate the On the fly checkbox and move the pointer over the surface. This option enables 

you to perform a local analysis.

 Arrows are displayed under the pointer, identifying the normal to the surface at the pointer 
location (green arrow), the draft direction (red arrow), and the tangent (blue arrow). As you 
move the pointer over the surface, the display is dynamically updated. Furthermore, circles 
are displayed indicating the plane tangent to the surface at this point.

 

 The displayed value indicates the angle between the draft direction and the tangent to the 
surface at the current point.
It is expressed in the units set in using the Tools -> Options -> General -> Parameters -
> Units tab.

The On the fly analysis can only be performed on the elements of the current part.



Note that you can activate the On the fly option even when not visualizing the materials. It 
gives you the tangent plane and the deviation value.

 
9.  Click the Inverse button to automatically reverse the draft direction.

 When several elements are selected for analysis, the draft direction is inverted for each 
element when the button is clicked.

 

In case of an obviously inconsistent result, do not forget to invert locally the normal direction 
via the Inverse button.

 The manipulator on the draft direction allows you to materialize the cone showing the angle 
around the direction:

●     Direction in the cone:



●     Direction out of the cone:

 
10.  Right-click the cone angle to display the Angle Tuner dialog box.

 When you modify the angle using the up and down arrows, the value is automatically updated 
in the color scale and in the geometry.

 

Note that you cannot modify the angle below the minimum value or beyond the maximum 
value.



 

●      

Full mode:

●     Quick mode:

 
11.  Right-click the Direction vector to display the contextual menu.



 

From the contextual menu you can:

●     Hide/show the cone.

●     Hide/show the angle.

●     Hide/show the tangent.

●     Lock/unlock the analysis position.

●     Keep the point at this location, this command is P2-only
A Point.xxx appears in the specification tree.

 

Direction
 By default the analysis is locked, meaning it is done according to a specified direction: the 

compass w axis.
In P1 mode, the default analysis direction is the general document axis-system's z axis.

 

12.  Click the Locked direction icon , and select a direction (a line, a plane or planar face 

which normal is used), or use the compass manipulators, when available.



●     Using the compass manipulators:

●     Selecting a specific direction:

 

13.  Click the Compass icon  to define the new current draft direction.

●     The compass lets you define the pulling direction that will be used from removing the 
part.

●     You can display the control points by clicking the Control Points  icon, yet the draft 

analysis is still visible, then allowing you to check the impact of any modification to the 
surface on the draft analysis.



 

 



 
14.  Once you have finished analyzing the surface, click OK in the Draft Analysis dialog box.

The analysis (identified as Draft Analysis.x) is added to the specification tree. The persistency 
of the draft analysis is P2-only.

●     Note that settings are saved when exiting the command, and redisplayed when you select 
the Draft Analysis icon again.

●     Be careful, when selecting the direction, not to deselect the analyzed element.

●     A draft analysis can be performed just as well on a set of surfaces.

●     If an element belongs to an analysis, it cannot be selected simultaneously for another 
analysis, you need to remove the current analysis by deselecting the element to be able 
to use it again.

●     In some cases, even though the rendering style is properly set, it may happen that the 
analysis results are not visible. Check that the geometry is up-to-date, or perform an 
update on the involved geometric elements.

●     The analysis results depend of the current object. May you want to change the scope of 
analysis, use the Define in Work object contextual command.



Performing a Surface Curvature Analysis 

This task shows how to analyze the mapping curvature of a surface.

●     Surfacic curvature analyses can be performed on a set of surfaces.

●     If an element belongs to an analysis, it cannot be selected simultaneously for another analysis, you 
need to remove the current analysis by deselecting the element to be able to use it again.

●     In some cases, even though the rendering style is properly set, it may happen that the analysis results 
are not visible. Check that the geometry is up-to-date, or perform an update on the involved 
geometric elements.

●     The analysis results depend of the current object. May you want to change the scope of analysis, use 
the Define in Work object contextual command.

This command is only available with:
●     FreeStyle Shaper 2

●     Part Design 2

●     Generative Shape Design 2

●     Wireframe and Surface for Building 1.

Open the FreeStyle_02.CATPart document:

●     The discretization option should be set to a maximum: in Tools -> Options -> Display -> 
Performances, set the 3D Accuracy -> Fixed option to 0.01

●     Uncheck the Highlight faces and edges option in Tools -> Options -> General -> Display -> 
Navigation to disable the highlight of the geometry selection.

●     Check the Material option in the View -> Render Style -> Customize View command to be able to 
see the analysis results on the selected element. You can now perform an analysis On the Fly even if 
the Material option is not checked, see On the Fly option. No warning message is issued as long as no 
element is selected.

1.  Select Surface.1

 

2.  Click the Surfacic Curvature Analysis icon:  

 The Surfacic curvature dialog box is displayed, and the analysis is visible on the selected 
element.
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 The Surfacic curvature dialog box displays the following information:

●     Type analysis option allows you to make the following analyses:

❍     Gaussian

❍     Minimum

❍     Maximum

❍     Limited

❍     Inflection Area

●     Display Options are:

❍     Color Scale option allows you to display the Surfacic Curvature Analysis.n dialog box 
associated with the current analysis.

❍     On the Fly option allows you to make a local analysis:

■     The On the fly analysis can be performed on the elements, selected or not, of the 
current part only. It is not available with the Inflection Area analysis type.

■     The curvature and radius values are displayed at the cursor location (for Gaussian 
analysis radius value is not displayed), as well as the minimum and maximum curvature 
values and the minimum and maximum curvature directions. As you move the pointer 
over the surface, the display is dynamically updated.

■     The displayed values may vary from the information displayed as the Use Max/Use 
Min values, as it is the precise value at a given point (where the pointer is) and does 
not depend on the set discretization.

■     You cannot snap on point when performing an On the Fly analysis.

■     Click a location and right-click the On the Fly curvature/radius label to display the 
contextual commands.
These commands are not available in P1 mode:



■     Keep Point: create the point at the clicked location.

■     Keep Min Point: create the point corresponding to the minimum value.

■     Keep Max Point: create the point corresponding to the maximum value.

■     3D MinMax option allows you to locate the minimum and maximum values for the 
selected analysis type, except for Inflection Area analysis type.

●     Analysis Options are:

❍     Positive only option allows you to get analysis values as positive values, available with 
Gaussian, Minimum and Maximum analysis types only.

❍     Radius Mode option allows you to get analysis values as radius values, available with 
Minimum and Maximum analysis types only.

 The Surfacic Curvature Analysis.1 dialog box appears and shows the color scale and identifying 
the maximum and minimum values for the analysis.

 



●     You can right-click on a color rectangle in the color scale to display the contextual menu:

❍     Edit contextual command allows you to modify the values in the color range to highlight 
specific areas of the selected surface. The Color dialog box is displayed allowing the user to 
modify the color range.

❍     Unfreeze contextual command allows you to perform a linear interpolation between non 



defined colors.

❍     No Color contextual command can be used to simplify the analysis, because it limits the 
number of displayed colors in the color scale. In this case, the selected color is hidden, and 
the section of the analysis on which that color was applied takes on the neighboring color.



●     You can also right-click on the value to display the contextual menu:

❍     Edit contextual command allows you to modify the edition values.
The Value Edition dialog box is displayed: enter a new value (negative values are allowed) 
to redefine the color scale, or use the slider to position the distance value within the 
allowed range, and click OK.
The value is then frozen, and displayed in a green rectangle.

❍     Unfreeze contextual command allows you to perform a linear interpolation between non 
defined values, meaning that between two set (or frozen) colors/values, the distribution is 
done progressively and evenly. This command is available for all values except for 
maximum and minimum values.
The unfreezed values are no longer highlighted in green.

❍     Use Max / Use Min contextual commands allow you to evenly distribute the color/value 
interpolation between the current limit values, on the top/bottom values respectively, 
rather than keeping it within default values that may not correspond to the scale of the 
geometry being analyzed. Therefore, these limit values are set at a given time, and when 
the geometry is modified after setting them, these limit values are not dynamically 
updated.

■     These commands are available for maximum and minimum values only.

■     The Use Max command is available if the maximum value is higher or equal to the 
medium value, otherwise you need to unfreeze the medium value first.



■     The Use Min command is available if the minimum value is lower or equal to the 
medium value, otherwise you need to unfreeze the medium value first.

●     Use Min Max button in the Surfacic Curvature Analysis.1 dialog box makes in one action 
the both Use Max / Use Min contextual commands operation.

●     The Surfacic Curvature Analysis.1 in created in the specification tree under the Free Form 
Analysis.1

Analysis Types and Display Options

3.  Select the Gaussian analysis type and the On the Fly option.

 



4.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 Maximum and minimum values are set according to the computed values displayed below the color 
scale.

 



5.  Move the cursor on the surface.

You can also right-click On the Fly curvature/radius label to display the contextual commands, see 
On the Fly option.

Case of a Ruled Surface

 
6.  Select Surface.2

7.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

Values are equal to 0.



 

8.  Move the cursor on the surface.



 
9.  Select Surface.1

10.  Select the Minimum analysis type.

11.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 

12.  Move the cursor on the surface.

Minimum curvature and radius values are displayed.



The color scale in the Surfacic Curvature Analysis.1 dialog box corresponds to the previous type 
analysis (Gaussian).
The color scale doesn't change when you select another analysis type or element. This behavior 
allows you keep a reference when you compare curvature values.

13.  Select the Maximum analysis type.

14.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 



15.  Move the cursor on the surface.

Maximum curvature and radius values are displayed.



16.  Select the Limited analysis type.

 In the Surfacic curvature dialog box:

●     You are able to modify the radius value. The value is automatically updated in the color scale.

●     Positive only and Radius mode options have been disabled.

 

 The Surfacic Curvature Analysis.1 dialog box has been modified: the color scale has been 
reduced: four colors and three values.

 

17.  Edit the top color and the maximal and minimal values in the Surfacic Curvature Analysis.1 

dialog box as follow, see Edit color and Edit edition values.



 

 Minimum curvature and radius values are displayed.

18.  Select the Inflection Area analysis type.

 In the Surfacic curvature dialog box only the Color Scale option is available.



 

 The Surfacic Curvature Analysis.1 dialog box has been modified.

 

 This analysis enables to identify the curvature orientation:

●     In green: the areas where the minimum and maximum curvatures present the same 
orientation.

●     In blue: the areas where the minimum and maximum curvatures present opposite orientation.



 See also Creating Inflection Lines. Note that these inflection lines are always created within the 
green area, i.e. when the curvature orientation is changing.

19.  Select the Minimum analysis type and the 3D MinMax option.

20.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 



 Maximum and minimum values are displayed and located on the selected element according to the 
computed values displayed below the color scale.



21.  Select the Positive only option and keep unselected the Radius Mode option.

22.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 Minimum value is set to 0 below the color scale

 

 Only positive values are displayed and located on the selected element. Minimum value is set to 0 
below the color scale

 

Analysis Options



23.  Select the Radius Mode option and unselect the Positive only option.

24.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

25.  Edit the minimal value in the Surfacic Curvature Analysis.1 dialog box as follow, see Edit edition 

values.

 



 Maximum and minimum radius values are displayed and located on the selected element according 
to the computed values displayed below the color scale.

26.  Select the Gaussian analysis type.



27.  Click the Use Min Max button in the Surfacic Curvature Analysis.1 dialog box.

 
28.  Click OK in the Surfacic curvature dialog box.

 

29.  Click the Control Points icon: 

You can display the control points still viewing the surfacic curvature analysis. This allows you to 
check any modification which affect the surface.



 
30.  Click Cancel in the Control Points dialog box.



Analyzing Taps and Threads  

This task shows you how to display and filter out information about threads and taps contained in a 
CATPart document.

Open the ThreadAnalysis.CATPart document.

 1.  Click the Tap/Thread Analysis icon .

The Thread/Tap Analysis dialog box is displayed, providing display options already checked by 

default:

❍     Show symbolic geometry: shows the representations of the threads and taps in the 
geometry area. The representation's color can be customized via the Tools > Options > 
General (Display) command (you just need to access the Visualization tab and the 
Selected elements option).

❍     Show numerical value: shows three values defined for threads and taps as follows: 
diameter x depth x pitch

The dialog box also displays the total number of threads and taps contained in your document. 

Two threads and one tap have been detected, as indicated in the Numerical Analysis frame.

2.  Click Apply to display the representations and the values of the threads and tap contained in the 

document.

The representations and the values (diameter x depth x pitch) are displayed in orange and 
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yellow respectively:

Unchecking Show symbolic geometry lets you display numerical values only. In the same 

way, unchecking Show numerical values lets you display representations only.

3.   Click More to access display filters.

4.  By default, the Show thread and Show tap options are on. Uncheck Show thread to display 

taps only.

5.  Click Apply to run the analysis. 

Only one tap has been detected and is therefore displayed:



6.  Check Show thread again to continue the scenario.

7.  Check the option Diameter and enter 70 as the diameter value in the Value field.

8.  Click Apply.

The application displays only one thread with 70 as diameter value.

9.    Click Close when done.



Creating Datums

 

This task shows how to create geometry with the History mode deactivated.
 In this case, when you create an element, there are no links to the other entities that were used to 
create that element.

1.  Click the Create Datum icon  to deactivate the History mode.

❍     It will remain deactivated until you click on the icon again. 

❍     If you double-click this icon, the Datum mode is permanent. You only have to click 
again the icon to deactivate the mode. 

❍     A click on the icon activates the Datum mode for the current or the next command. 

❍     The History mode (active or inactive) will remain fixed from one session to another: it 
is in fact a setting.

 

 



Isolating Geometric Elements

 

This task shows you how to isolate a geometric element, that is how to cut the links the feature has with 
the geometry used to create it.

To perform this task, create a plane using an offset of 20mm from a pad's face.

1.  Prior to isolating the plane, note that if you edit the offset value...

...you can obtain this kind of result:

2.  Right-click the plane as the element you want to isolate. The element you can isolate can be:

❍     a plane

❍     a line

❍     a point

❍     a circle

3.  Select the xxx object -> Isolate command from the contextual menu.



The geometrical link between the plane and the face is no longer maintained. This means that the 

face is no longer recognized as the reference used to create the plane, and therefore, you can no 

longer edit the offset value.

The way the plane was created is ignored. You can check this by double-clicking the plane: the 

Plane Definition dialog box that appears indicates that the plane is of the explicit type.

In the specification tree, the application indicates isolated elements via a red symbol in front of 

the geometrical element.

An isolated feature becomes a datum feature. For more information, refer to Creating 
Datums.

 



Applying a Material

 

This task explains how to apply a pre-defined material as well as to interactively re-position the mapped material. 
Keep in mind that applying materials onto elements affects the physical and mechanical properties, such as the 
density, of these elements.

A material can be applied to: 
●     a PartBody, Surface, Body or Geometrical Set (in a .CATPart document). You can apply different materials to 

different instances of a same CATPart. 

●     a Product (in a .CATProduct document)

●     instances of a  .model, .cgr, .CATPart (in a .CATProduct document).

 
Materials applied to .CATPart, .CATProduct and .cgr documents can be saved in ENOVIAVPM. 
For detailed information on ENOVIAVPM, refer to the ENOVIAVPM User's Guide on the ENOVIAVPM Documentation 
CD-ROM.

 

Within a CATProduct, you should not apply different materials to different instances of a same part because a 
material is part of the specific physical characteristics of a part. Therefore, this could lead to inconsistencies.

Open the ApplyMaterial.CATProduct document. 

 
To visualize the applied material, click Shading with Material  in the View toolbar.

1.  Select the element onto which the material is to be applied. 

If you want to apply a material simultaneously to several elements, simply select the desired elements 

(using either the pointer or the traps) before applying the material.
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 2.  Click Apply Material . 

 The Library dialog box opens. It contains several pages of sample materials from which to choose. 
For a complete description of the families provided with the default material library, refer to "Material 
Sample Library" in this guide.

Each page is identified either by a material family name on its tab (each material being identified by an 
icon) if you select the Display icons mode... 

 

 ...or by a material family name in a list if you select the Display list mode:

 

 

Clicking the Open a material library  button opens the File Selection dialog box which lets you 
navigate through the file tree to your own material libraries. 
You can, of course, use the default library (see What You Should Know Before You Start in this guide) 
by choosing Default Material Catalog.

The list displays the list of previously opened material libraries. When you reopen the dialog box, the 
last chosen material library is placed on top of the list and used by default unless you select another 
one.

 

Depending on the document environments (i.e. the method to be used to access your documents) you 
allowed in Tools > Options > General > Document, an additional window such as the one displayed 
below might appear simultaneously to the File Selection dialog box to let you access your documents 
using an alternate method:
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 In our example, four document environments have been allowed among which the DLName 
environment. If you want to access your texture files using DLNames, for instance, click the Logical 
File System button: this opens a specific dialog box dedicated to the DLName environment.
For detailed information on this dialog box, refer to Opening Existing Documents Using the Browse 
Window.

3.  Select a material from any family, by a simple click. 

 Once a material is selected, you can drag and drop or copy/paste it onto the desired element directly 
from the material library.

Unless you select in the specification tree the desired location onto which the material should be 

mapped, dragging and dropping a material applies it onto the lowest hierarchical level (for instance, 

dragging and dropping onto a part in the geometry area will apply the material onto the body and not 

onto the part itself).

However, note that a material applied onto a body has no impact on the calculation of the part physical 

properties (mass, density, etc.) since only the physical properties of the part, and not those of the 

body, will be taken into account.

4.  Select the Link to file check box if you want to map the selected material as a linked object and have it 

automatically updated to reflect any changes to the original material in the library. 

Two different icons (one with a white arrow  and the other without ) identify linked and non-
linked materials respectively in the specification tree.
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 Another method is to use the Paste Special... command which lets you paste a material as a linked 
object. You can copy both unlinked and linked materials. For example, a linked material can be pasted 
onto two different elements in the same document or onto the same element in two different 
documents. 
For more information, see Copying & Pasting Using Paste Special... in this guide. 

When no object is selected in the specification tree, you can select Edit > Links to identify the library 
containing the original material. You can then open this library in the Material Library workbench if 
needed.

 
5.  Clickthe Apply Material button to map the material onto the element. 

The selected material is mapped onto the element and the specification tree is updated. In our 
example, the material was mapped as a non-linked object. 

 

A yellow symbol may be displayed next to the material symbol to indicate the inheritance mode. For 
more information, refer to Setting Priority between Part and Product in this guide. 

Material specifications are managed in the specification tree: all mapped materials are identified. 
To edit materials (for more information, see Modifying Materials), right-click the material and select 
Properties (or use one of the other methods detailed in About Material Properties). 

6.  Click OK in the Library dialog box. 

The object looks the following way: 



 

7.  Right-click the material just mapped in the specification tree and select Properties. 

The Properties dialog box is displayed:

 



8.  Click the Rendering tab to edit the rendering properties you applied on the element. 

9.  If necessary, change the material size to adjust the scale of the material relative to the element.

10.  Click OK in the Properties dialog box, when you are satisfied with the material mapping on the element. 

Do not forget that appropriate licenses are required to use the Analysis and Drafting tabs. 

11.  Use the 3D compass to interactively position the material: 

Note that material positioning with the 3D compass is only possible in the Real Time Rendering, Product 
Structure, Part Design and DMU Navigator workbenches.

 

●     Select the material in the specification tree:

 

The compass is automatically snapped and the mapping support (in this case, a cylinder) 
appears, showing the texture in transparency.
If necessary, zoom in and out to visualize the mapping support which reflects the material 
size.

 

●     Pan and rotate the material until satisfied with the result. You can:
❍     Pan along the direction of any axis (x, y or z) of the compass (drag any compass axis)

❍     Rotate in a plane (drag an arc on the compass)

❍     Pan in a plane (drag a plane on the compass)

❍     Rotate freely about a point on the compass (drag the free rotation handle at the top of 
the compass):



 

 
●     Use the mapping support handles to stretch the material texture along u- and v- axes (as you can 

do it with the slider in the Scale U, V fields displayed in the Texture tab):

 

For more information on manipulating objects using the 3D compass, refer to the Version 5 - 
Infrastructure User's Guide.

 
More about materials



 

●     The application of a material cannot be recorded in a macro file

●     You can run searches to find a specific material in a large assembly (for more information, see Finding 
Materials in this guide) or use the copy/paste or drag/drop capabilities.

●     If you are working in "Materials" visualization mode (i.e. Materials is selected in the Custom View Modes 
dialog box) with no material applied to your object, this object is visualized using default parameters that only 
take into account the color defined in the object graphic properties. 
As a consequence, an object with no mapped material appears as if made of matte plastic, non-transparent 
and without any relief.

●     Contrary to materials with no texture (such as "Gold"), materials with a texture (such as "Teak") are applied 
with an external link to their texture image. Therefore, this link is displayed when selecting File > Desk, Edit 
> Links or File > Send To.
In the example below, "Italian Marble" has been applied onto Chess.CATPart and the link to the corresponding 
.jpg image appears when displaying the Links dialog box:

 

 

 

 



Extracting Geometry 

The Extract capability lets you generate separate elements from initial geometry, without deleting 
geometry. This operation may be especially useful to solve drafting difficulties, as illustrated below.

 

The angle value used for drafting the face generates a twisted face. The application then informs you 
via an error message window that the operation cannot be properly performed.

 Closing the error message window displays a new dialog box providing with a solution: you can 
deactivate the draft and extract its geometry.

After clicking Yes to confirm these operations, Draft.1 appears as deactivated in the specification tree. 
A node Extracted Geometry (Draft.1) is displayed in the tree too. This category includes the 
elements created by the application, namely two surfaces.



You then just have to fillet these surfaces (for more information, refer to Generative Shape Design 
User's Guide) and use Thick Surface, Split and Add capabilities available in Part Design workbench to 
complete the draft.



Displaying Parents and Children 

 

The Parent and Children command enables you to view the genealogical relationships between the different 
components of a part.  

It also shows links to external references and explicitly provides the name of the documents containing these 
references.

If the specification tree already lets you see the operations you performed and re-specify your design, the graph 
displayed by the Parent and Children capability proves to be a more accurate analysis tool. We recommend the 
use of this command before deleting any feature.

 

Open the Parent_R9.CATPart document.

 
1.  Select the feature of interest, that is Pad1.

2.  Select Tools > Parent/Children... (or the Parent/Children... contextual command).

A window appears containing a graph. This graph shows the relationships between the different elements 

constituting the pad previously selected.
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If you cannot see the element of interest in the specification tree because you have created a large number of 
elements, right-click this element in the graph then select the Center Graph contextual command: the element 
will be more visible in the specification tree.

3.  Right-click Pad 1 and select Show All Children .

You can now see that Sketch 2 and Sketch 3 have been used to create two additional pads.

Here is the exhaustive list of the diverse contextual commands allowing you to hide parents and children. 

These commands may prove quite useful whenever the view is overcrowded. 

❍     Show Parents and Children

❍     Show Children

❍     Show All Children

❍     Hide Children

❍     Show Parents

❍     Show All Parents

❍     Hide Parents

4.  Right-click Sketch.1 and select Show Parents and Children. 

We can see that Sketch.1 has been created on xy plane. Moreover, you can see that it is a published 

element.



5.  Now, select EdgeFillet1 in the graph.

The application highlights the fillet in the specification tree, in the graph and in the geometry area.

6.  Position the cursor on EdgeFillet1 and select the Show Parents and Children contextual command.

The parent Pad.1 is displayed.

 ●     Double-clicking on the components alternately shows or hides parents and children.

●     The Edit contextual command can be accessed from any element. For example, right-click EdgeFillet.1 and 
select Edit. The Edge Fillet dialog box appears. You can then modify the fillet. When done, the Edge Fillet 
dialog box closes as well as the Parents and Children window close and the fillet is updated.

7.  Close the window and select MeasureEdge3 from the specification tree.

8.  Select Tools > Parent/Children... 

The graph that displays shows Pad.2 as MeasureEdge3's parent.

9.  Right-click and select Show All Parents.

Sketch.2 as Pad.2's parent is now displayed. In turn, Sketch.2's own parent Pad.1 is displayed and so 

on.



Defining An Axis System

This task explains how to define a new three-axis system locally. There are two ways of defining it: either by 
selecting geometry or by entering coordinates.

Open the PowerCopyStart1.CATPart document.

1.  Select the Insert -> Axis System  command or click the Axis System icon .

The Axis System Definition dialog box is displayed.

An axis system is composed of an origin point and three orthogonal axes. For instance, you can start 
by selecting the vertex as shown to position the origin of the axis system you wish to create. The 
application then computes the remaining coordinates. Both computed axes are then parallel to those 
of the current system. The axis system looks like this:

It can be right or left-handed. This information is displayed within the Axis System Definition dialog 
box. 
You can choose from different types of axis system:
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❍     Standard: defined by a point of origin and three orthogonal directions. 

If an axis system is selected before launching the command, the new axis system is a copy of the 

pre-selected axis system. Moreover, if the compass is attached to the 3D geometry, the new axis 

system orientations are the same as the compass'. Otherwise, the new axis system orientations 

are as per the current axis system's.

Here only the point was selected and nothing specified for the axes.

❍     Axis rotation: defined as a standard axis system and a angle computed from a selected 

reference.

Here the Y axis was set to the standard axis system Y axis, and a 15 degrees angle was set in 
relation to an edge parallel to the X axis.



❍     Euler angles: defined by three angle values as follows:

Angle 1= (X, N)
a rotation about Z transforming vector X into vector N.

Angle 2= (Z, W)
a rotation about vector N transforming vector Z into vector W.

Angle 3= (N, U)
a rotation about vector W

2.  Select the point as shown to position the origin of the axis system you wish to create. The application 

then computes the remaining coordinates. Both computed axes are then parallel to those of the 

current system. The axis system looks like this:

 
Instead of selecting the geometry to define the origin point, you can use one of the following 
contextual commands available from the Origin field:



❍     Create Point: for more information, refer to Points

❍     Coordinates: for more information, refer to Points

❍     Create Midpoint: the origin point is the midpoint detected by the application after selection of a 
geometrical element.

❍     Create Endpoint: the origin point is the endpoint detected by the application after selection of a 
geometrical element 

3.  If you are not satisfied with x axis, for instance click the X Axis field and select a line to define a new 



direction for x axis.

The x axis becomes collinear with this line.

❍     It can be a line created along the surface edge, for example, using the Create Line 
contextual menu on the selection field, and selecting two surface vertices.
Similarly you can create points, and planes.

❍     You can also select the Rotation contextual menu, and enter an angle value in the X Axis 
Rotation dialog box.

4.  Click the y axis in the geometry to reverse it.

Checking the Reverse button next to the Y Axis field reverses its direction too.



5.  You can also define axes through coordinates. Right-click the Z Axis field and select the Coordinates 

contextual command. The Z Axis dialog box appears.

6.  Key in X = -1, retain the Y and Z coordinates, and click Close.

The axis system is modified accordingly, and is now left-handed.

7.  Click More... to display the More... dialog box.



The first rows contains the coordinates of the origin point. The coordinates of X axis are displayed in 
the second row. The coordinates of Y and Z axis are displayed in the third and fourth row 
respectively.

❍     If no value is selected, the new axis system matches the current one.

❍     If the origin is selected, the new axis system origin is set to the origin.

❍     The first specified axis defines the corresponding axis of new axis system.
i.e., if the x-axis is specified by Line.1, then the x-axis of new system is a vector along Line.1.

❍     The second specified axis defines the plane between the corresponding first and second axes of 
the new axis system.
i.e., if the z-axis is specified by Line.2, then the xz plane is defined by the plane between vectors 
along Line.1 and Line.2.

❍     The third specified axis defines the orientation of the corresponding axis of new axis system.
i.e., if the y-axis is specified by Line.3, then Line.3 defines which side of the xz plane the y-axis of 
new system lies. 

❍     The order of selection of the axes is important: to change the order, select the No Selection 
contextual item on the appropriate axes.
For instance, if the axes have been selected in the order x, y, z and you wish to change the order 
to x, z, y, you must select the No Selection contextual item on y, and select it again.

8.  Uncheck the Current option if you do not want to set your axis as the reference. The absolute axis at 

the bottom right of the document then becomes the current three axis system.

9.  Uncheck the Under the axis system node option if you do not want the axis system to be created 

within the Axis system node in the specification tree.

It will be created either in the current geometrical set or right after the current object in an ordered 
geometrical set. In this case, the axis system becomes the new current object.



10.  Click OK.

The axis system is created.
When it is set as current, it is highlighted in the specification tree.

11.  Right-click Axis System.1 from the specification tree and select the Axis System.1 object -> Set as 

current contextual command. Axis System.1 is now current. You can then select one of its plane, to 

define a sketch plane for example.

❍     You can change the location of the axis system and put it in a geometrical set.
To do so, select it in the specification tree, right-click and select Axis System.1 object -> 
Change Geometrical Set. Choose the destination of the axis system using the drop-down 
list.
Refer to the Managing Geometrical Sets chapter to have more information.

❍     If you create a point using the coordinates method and an axis system is already defined 
and set as current, the point's coordinates are defined according to current the axis system. 
As a consequence, the point's coordinates are not displayed in the specification tree.

❍     You can contextually retrieve the current local axis direction.
Refer to the Stacking Commands chapter to have more information.

❍     You can use the Shift key while creating the axis system to select the implicit elements that 
belong to the axis system.
Refer to the Selecting Implicit Elements chapter to have more information.

❍     There is an associativity between the feature being created and the current local axis 
system. Therefore when the local axis system is updated after a modification, all features 
based on the axis direction are updated as well.

❍     Local axes are fixed. If you wish to constrain them, you need to isolate them (using Isolate 
contextual command) before setting constraints otherwise you would obtain over-
constrained systems.

❍     The display mode of the axes is different depending on whether the three-axis system is 
right-handed or left-handed and current or not. 

Three-Axis System Current Axis Display Mode

right-handed yes solid

right-handed no dashed

left-handed yes dotted

left-handed no dot-dashed

 

Editing an Axis System
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You can edit your axis system by double-clicking it and entering new values in 
the dialog box that appears. You can also use the compass to edit your axis 
system. 

Note that editing the geometrical elements selected for defining the axes or 
the origin point affects the definition of the axis system accordingly.

Right-clicking Axis System.X object in the specification tree lets you access 
the following contextual commands:

●     Definition...: redefines the axis system

●     Isolate: sets the axis system apart from the geometry

●     Set as Current/Set as not Current: defines whether the axis system is 
the reference or not.

 The Under the axis system node option is not available when editing 
an axis system.

 



Publishing Elements  

 

Publishing geometrical elements is the process of making geometrical features available to different users. This 
operation is very useful when working in assembly design context

This task shows you the method for making elements publicly available: you will publish a plane, a sketch then a 
parameter not visible in the specification tree.

In this page, you will also find information about the following subjects:

●     Publishing Part Design Features

●     Assembly Constraints and Published Generative Shape Design Geometry

●     Publishing in Assembly Design

●     Replacing a Published Element

●     Publishing Parameters

●     Importing and Exporting Published Names

●     What Happens When Deleting a Published Element?

 

Open the Publish.CATPart document.

 
1.  Select Tools > Publication.

The Publication command lets you:

❍     Publish a geometric element

❍     Edit the default name given to the published element

❍     Replace the geometric element associated with a name

❍     Create a list of published elements

❍     Import a list of published elements

❍     Delete a published element.

The Publication dialog box appears.
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If you are working in Assembly Design, the dialog box also displays a Browse button. For more information, refer to 
Publishing in Assembly Design. 

 
2.  Select the element to be published. For example, select Plane.1.

You can publish the following elements: 

❍     points, lines, curves, planes

❍     sketches

❍     bodies (selecting a feature selects the body it belongs to)

❍     Generative Shape Design features (Extrudes Surfaces, Offsets, Joins etc.)

❍     Free Style Features (Planar patches, curves etc.)

❍     parameters

❍     sub-elements of geometrical elements: when switched on, the option Publish a face, edge, vertex or 
extremity lets you directly select faces, edges, vertices. axes. extremities. 

❍     Part Design features.

 
To select axes, select cylindrical faces and use the Other Selection contextual command. For more 

about this command, please refer to CATIA Infrastructure User's Guide.

The dialog box displays the name and status of the selected element as well as "Plane.1", that is the default name 

given to the published element



3.  Click Plane.1 in the dialog box. The plane 

is highlighted in the geometry. 

4.  Rename it as New plane.

The plane is published as New plane. However, you can notice that the geometric element Geometrical 

Set.1/Plane1 has not been renamed.

5.  Before publishing another element, click Options to access rename options.

When using the Publication command, you can actually decide to rename or not the elements you are 

publishing. Prior to renaming, you can set one of the three following work modes:

❍     Never: the application will not allow you to rename the published element. This is the default option.

❍     Always: the application will always allow you to rename the published element

❍     Ask: the application will ask you what you decide to do, namely rename or not the published element.

Note that:

❍     You can rename any element except for axes, edges and faces.

❍     Some characters, such as the exclamation mark, are not allowed for renaming elements.

6.  Check Ask and click OK to exit.



7.  Prior to selecting the element to be published, deselect New plane if not already done. 

8.  Select Sketch.1 as the new element to be published.

9.  Rename it as "New sketch". A message is issued asking you whether you wish to rename the published 

element "Sketch.1" as "New sketch".

10.  Click Yes to confirm. The published element's name is "New sketch" and the geometric element is renamed 

too.

 Notes
●     Pointing at or selecting published elements simultaneously highlights the geometry, the element node and the 

publication node.

 

 
●     The Publish capability lets you give a specific name to a geometrical element in a given context (for example, 

in a "defined in work object"). If this geometrical element is to be used in a different context (another "defined in 
work object"), the application does not recognize this element from its published name. In short, you need to 
select this object from the geometrical area, not from the Publication node in the specification tree.

Publishing Part Design Features

Publishing Part Design Features requires that the Enable to publish the features of a body capability available in 
the Options dialog box is on. If your administrator did not lock the option, you can activate the option yourself.

Assembly Constraints and Published Generative Shape Design 
(GSD) Geometry

Depending on your geometry, there are cases where constraints pointing to a certain type of published GSD features 
do not reconnect if, for example, you replace constrained parts. What happens is that links between constraints and 
the geometry do not take advantage of the publication. You can notice this behavior even if you selected the 
geometry through the Publication node.



GSD features concerned are those whose geometrical results depend on the number and type of the parents used for 
the result. This is the case of features such as Intersect or Project.

The solution to this, is to publish the geometrical result, not the feature itself. In concrete terms, rather than 
publishing the Intersect feature, you recommend you publish the vertex, not the point.

The application reminds you of this behavior when you are setting constraints on published features through the 
following warning message:

 

Publishing in Assembly Design 

When publishing geometry in the Assembly Design workbench, the Browse button is available in the Publication 
dialog box. Clicking the button launches the Component Publication dialog box that displays only the published 
elements belonging to the levels inferior to the active level.

In the following example, the user is publishing an element of CRIC_BRANCH_1. When clicking the Browse button, 
the Component Publication dialog box displays published faces belonging to CRIC_BRANCH_3.

 



 

This capability works as a filter: it does not display the whole publications of the assembly. Thus, you will use it as an 
help for selecting already published elements whenever you wish to replace published elements. 

 

Replacing a Published Element

11.  Click "Geometrical Set.1/Plane.1" to replace it with another geometric element.

12.  Select "Plane.2" as the replacing element. 

The orientation of both elements is displayed. The green arrow indicates the orientation for the new element, 

the red arrow indicates the orientation of the published element. A message is issued asking you to confirm 

the change.

13.  Click Yes to confirm.

Plane.2 has been published.Plane.1 is not published any more. The dialog now displays the following 

information:



 

Publishing Parameters

14.  You can publish the parameters of a part that are not displayed in the specification tree. To do so, click the 

Parameter... button available in the Publication dialog box. This displays a new window listing all 

parameters defined for the feature previously selected in the specification tree.

15.  If the list of parameters is too long, you can filter out the parameters by entering a character string in the 

Filter Name field. For example, enter "offset".

The list now displays only the parameters including the string "offset". 

16.  Select the parameter of interest. You can also use one of the following filter types:

❍     All

❍     Renamed parameters

❍     Hidden

❍     Visible

❍     User

❍     Boolean

❍     Length

❍     Angle

❍     String



17.  Click OK when done. 

This closes the dialog box. The selected parameter is displayed in the Publication dialog box.

 

Importing and Exporting Published Names

Published names can be gathered in ASCII .txt files.

To export published names to an ASCII .txt file,  

●     click the Export button.

●     enter a name for the file you are creating in the Export dialog box that displays.

●     click Save : the file is created: it contains the list of all published elements as specified in the Publication dialog 
box.

To import published names to an ASCII .txt file,  

●     click the import button.

●     navigate to the file of interest in the Import dialog box that displays.

●     select the file containing the list of published elements.

●     click Open: the names are added to the list of the Publication dialog box

18.  Click OK when satisfied.

The Publication entity has been added to 

the specification tree. The three published 

elements are displayed below Publication 

node: 

 

What Happens When Deleting a Published Element?

When deleting a published element, the application informs you that this element is published. What you need to do is 
confirm the deletion (Yes) or cancel it (No).



Working with a 3D Support

This command is only available with the Automotive BiW Templates product. 
To access this command in the Part Design workbench, Automotive Class A, Automotive BiW Templates 
or FreeStyle Optimizer licenses are required.

This task shows how to create a 3D support. It is composed of three regular grid of lines, generally set 
on the three main planes of the part, that aggregates 3 selectable work on supports.
It allows you to create reference points on the fly on each support, whenever you need a reference point 
to create other geometric elements. You will no longer have to explicitly select the support element.
It also allows you to create sub-elements of the grid on the fly (points, edges). These features do not 
appear neither in the specification tree nor in the 3D geometry but are aggregated under the feature 
using them.

Open the WorkOnSupport1.CATPart document.

 1.  Click the Work on Support 3D icon .

The Work on Support 3D dialog box appears.
Part Design default configurations do not provide this icon in the standard toolbar. If you wish to 
access it, simply use the Customize capability to add this icon to the toolbar of your choice. 
Otherwise, select the Tools -> Work on Support 3D item from the menu bar.
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❍     Each of three grid lines has one default primary spacing of 100mm for each direction. 
The three directions of the main axis system define the grids directions.
You can edit the spacing values by clicking on the spacing tag to edit and modify them.
Note that you can modify these values at creation, not at edition, and that there can 
only be one value per grid.
Grids are used both as an input to create geometry as well as visual help.

❍     You can also modify the name of the labels of the main directions by clicking on the 
direction tag.

❍     Labels' directions and primary spacing are defined in Tools -> Options -> Shape -> 
Generative Shape Design.
Refer to the Customizing section for further information.

2.  Choose the Labels position:

❍     Full screen: labels are displayed all around the screen

❍     Bottom/Left: labels are displayed on the bottom left of the screen

❍     None: no label is displayed

3.  Define the Support Type: 

❍     Reference: the 3D support is created according to the main axis system. There can be only 

one reference 3D work on support.

❍     Local: a local axis system must be specified. There can be as many local 3D works on 
support as desired.

4.  Click OK in the dialog box. 

The elements (identified as Working support 3D.xxx) are added to the specification tree under 
the Working supports node.
Here is an example with a reference and a local 3D work on support.



5.  Select the Top View icon  from the Quick View toolbar.

The active work on support is visualized and labels are displayed on each straight line. 
 

❍     The work on support must be parallel to one of the three planes to be visualized. As a 

consequence, the active 3D work on support may be seen independently in each view of 

the same document.

❍     If you move the compass, the 3D work on support is no longer parallel to the screen.

❍     There can only be one active 3D work on support at the same time.

When the local axis system is modified, all related features are updated.



 
Setting a work on support as current

 By default, the last created working support is displayed in red in the specification tree.
Use the Set As Current/Set As Not Current contextual menu on the working support features, or the 

Working Supports Activity icon  to define which is the default current support that will be 
automatically selected when entering a command that requires a working support.
You can also set the axis system as not current to deactivate the three planes and define the reference 
support as the current support.

 

 
Snapping to a point

 Click the Snap to point icon  to snap the point being created onto the nearest intersection point on 
the grid.

 
Switching the featurization to lines or planes

 Use the Grid Featurization Switch icon  to create either featurized lines or featurized planes on 
the grid lines. Featurized planes are created normal to the current grid.

 

●     Use the Get Features on Support contextual menu on the 
working support features to retrieve the features created from a 
single or a multi-selection works on support. As a result, the 
retrieved features are selected in the current editor and 
highlighted in the specification tree, therefore allowing you to 
use them more easily.

●     Activate the Work on Support Selection State icon  in 
the User Selection Filter toolbar to be able to select sub-
elements from the grid.
For further information, refer to the Selecting Using A Filter 
chapter in the CATIA Infrastructure User's Guide.

●     Once you choose to work on the 3D support, you can directly 
click onto the support to create points. This capability is 
available with commands such as point, line, spline, polyline, 
and most commands where you need to select points as inputs.
The created points using a support are aggregated under the 
parent command that created them and put in no show in the 
specification tree.



●     Each 3D working support can be edited, updated, or deleted just 
as any other feature.

 
●     In case you are working in a CATProduct environment, and 

providing there are several parts, you can only see the 3D 
working support whose part is active. If the product is active, 
3D working supports cannot be applied.

●     The Work on Support 3D command can now be used along with 
the Measure between command.
Refer Using the Measure Between Command With a 3D Support 
chapter for further information.

 



Using Powercopies

A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that are grouped in 
order to be used in a different context, and presenting the ability to be re-specified according to the context 
when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater reusability 
and efficiency.

This chapter includes the following tasks:

Create Powercopies: Select Insert >Knowledge Templates > PowerCopy..., the elements 
making up the Powercopy from the specification tree, define a name for the Powercopy and its 
reference elements then choose an icon for identifying it.

●     Instantiate Powercopies: Select Insert > Instantiate From Document..., select the document 
or catalog containing the  powercopy, complete the Inputs within the dialog box selecting 
adequate elements in the geometric area.

●     Instantiating Power Copies Using Step By Step Instantiation

●     Instantiating Power Copies Using Part Instantiation Comparaison

●     Instantiating a Power Copy From a VB Macro

Save Powercopies into a Catalog: Select the Powercopy from the specification tree, the Insert > 
Knowledge Templates  > Save In Catalog... , enter the catalog name and click Open.



  Creating PowerCopies   

 

This task shows how to create PowerCopy elements, to be reused later.
A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that are 
grouped in order to be used in a different context, and presenting the ability to be completely redefined 
when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater 
reusability and efficiency.

 

Open the PowerCopyStart.CATPart document.

 
1.  Select Insert ->Knowledge Templates > Power Copy... .

The Powercopy Definition dialog box is displayed.

2.  Select the elements making up the PowerCopy from the specification tree. For the purposes of 

our scenario, select Part Body.
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The dialog box is automatically filled with information about the selected elements.

3.  Define the PowerCopy as you wish to create it:

The Definition tab lets you assign a name to the powercopy and presents its components in the 

3D viewer. For example, enter Test in the Name: field.



4.  The Inputs tab lets you define the reference elements making up the PowerCopy. You can 

rename these elements for a clearer definition by selecting them in the viewer and entering a 

new name in the Name field. In parentheses you still can read the elements' default name 

based on its type. For example, select xy plane and rename it as "Plane1".

The Parameters tab lets you define which of the parameter values used in the PowerCopy you 

will be able to modify at instantiation time. This can be a value, or a formula for example. 

5.  Simply select the parameters and check the Published Name button. In case of a formula, you 

can set it to false or true. For example, select PartBody/Hole.1/Diameter.

Use the Name field to give a more explicit name to this element. For example, enter Hole.1.



The Documents tab shows the complete path and role of Design tables that are referenced by 

an element included in the Power Copy.

6.  The Icon tab lets you modify the icon identifying the PowerCopy in the specifications tree. A 

subset of icons is available from the Icon choice button. If you click ... the Icon Browser opens, 

showing all icons loaded on your application session. Click the envelope icon .



7.  The Grab screen button lets you capture an image of the PowerCopy to be stored with its 

definition. Click the Grab screen button. You can zoom in or out the image to adjust it. 

8.  Click the Remove preview button if you do not need this image.

9.  Click OK to create the PowerCopy.

The PowerCopy is displayed close to the top of the specification tree.



 

 

●     Double-click Test in the specification tree to display the PowerCopy Definition dialog box and edit 
its contents.

●     A formula is automatically included in a Power Copy definition when all its parameters are included.
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you have to 

manually select the formula to make it part of the definition. If you do so, all the formula's 
parameters that have not been explicitly selected, are considered as inputs of the Power Copy.

●     Measures and user features cannot be used as elements making up powercopies.
 

A Few Recommendations  



●     As far as possible, minimize the number of elements making up the Powercopy.

●     Once your power copy is created, do not delete the referenced elements used to make up the PowerCopy.

●     Avoid access to sketch sub-elements.

Sketches
●     Before creating your powercopies, make sure that your sketch is not over-constrained.

●     It is preferable not to use projections nor intersections in your sketch if you want to use your sketch in a 
Powercopy.

●     Avoid constraints defined with respect to reference planes.

If you are using positioned sketches

Generally speaking we recommend the use of positioned sketches instead of sliding sketches.

●     If you are using positioned sketches, constrain your geometry with respect to HV absolute axis.

●     Avoid constraining elements with respect to external references such as faces, edges, reference or explicit 
planes.

If you are using sliding sketches

●     When defining Powercopies including sliding sketches, use profiles constrained with respect to edges or 
faces rather than to planes. Additionally, set the Create geometrical constraints option off before 
sketching. 

●     Generally speaking, it is always preferable to use profiles both rigid and mobile. Make sure that your 
sketch is iso-constrained (green color). You can use non-iso-constrained sketches, but it will be more 
difficult to understand and control the result after instantiation.

●     Avoid constraining your 2D elements with respect to  HV absolute axis. The result you obtain after 
instanciating the powercopy could be unstable. Actually, you cannot control the position of the origin of the 
absolute axis nor its orientation.



●     Constrain elements with respect to external references such as faces, edges, reference or explicit planes:

Knowledgeware
●     Formulas are automatically included if you select all the parameters.

●     For complex design, integrate knowledge rules.



Managing inputs 
●     Always rename your inputs to help the end user to understand what he needs to select.

●     A formula is automatically included in a Power Copy definition when all its parameters are included. 
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you have to manually 
select the formula to make part of the definition. If you do so, all the formula parameters that have not 
been explicitly selected are considered as inputs of the Power Copy.

●     Note that when including parameters sets containing hidden parameters in a PowerCopy, the hidden 
parameters are automatically instantiated when instantiating the PowerCopy.

Preview 
●     In a CATPart document, create only one PowerCopy reference. It is not a technical restriction, but there 

are at least two reasons for this: the cost of an instantiation will be smaller in the document is smaller. The 
end user can more easily understand the feature to be instantiated.

●     Put in 'show mode' only the input and the result (to help the end user to understand what he needs to 
select).

●     Use colors to differentiate inputs (put transparency on results for example).

●     Choose a pertinent viewpoint before saving the CATPart document reference, default viewpoint in preview 
during instantiation will be the same.

Hybrid Design

●     In hybrid design environments, bodies that underwent Boolean operations are located below the nodes 
corresponding to these operations. Consequently, they cannot be selected to define a powercopy. If, for 
example, you try to select Body.5 as an input element making up a powercopy, a warning message 
displays warning you that because Body.5 is aggregated into Assemble.3, you cannot select it as an input 
component.





  Instantiating PowerCopies  

 

This task shows how to instantiate Power Copies once they have been created as described in Creating 
PowerCopies.
There are two ways of doing this: 

●     using the PowerCopy Instantiate From Document command

●     using a catalog

 

Open the PowerCopyDestination.CATPart document.

 
Using the PowerCopy Instantiate From Document command 

1.  Select Insert > Instantiate From Document....

The Select PowerCopy dialog box is displayed allowing you to navigate to the document or 

catalog where the  powercopy is stored. Navigate to C:/Program Files/Dassault 

Systemes/B14doc/online/prtug/samples directory.

2.  Select the document containing the Powercopy, i.e. PowerCopyResults.CATPart.

The Insert Object dialog box is displayed.

Use the Reference list to choose the correct PowerCopy when several have been defined in the 

document.
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3.  Complete the Inputs within the dialog box by selecting the adequate element in the geometric 

area: select Pad1's upper face as the planar element replacing Plane1. 

4.  Click on the Use identical name button to automatically select all the elements with the same 

name. This command searches for features, publications, sub-elements or parameters having the 



name of the input. If a feature, publication, sub-element or parameter with the input name is 

found, this element is automatically used as input.

Here, zx plane and yz plane are selected. This is especially useful when the input is the same 

one repeated several time.

5.  Click on the Parameters button to display the Parameters dialog box.

6.  Enter 18mm as the new diameter value.

You can use the Create formulas button to automatically create a formula on every parameters 

with the same name provided there are any.



7.  Click Close to confirm the operation and close the dialog box.

The Documents button lets you access the list of documents (such as design tables) pointed by 

one of the elements making up the Power copy. 

If there are documents, the Documents dialog box opens and you can click the Replace button 

to display the File Selection dialog box and navigate to a new design table to replace the initial 

one.

When no document is referenced, the Documents button is grayed within the Insert Object 

dialog box.

8.  Click OK to create the PowerCopy instance.

The PowerCopy is instantiated in context, meaning its limits are automatically re-defined taking 

into account the elements on which it is instantiated.

 

Check the Repeat option to be able to repeat the instantiation. In this case, once you have clicked OK 
in  the Insert Object dialog box, the latter remains open, the PowerCopy's Inputs are listed and ready 
to be replaced by new inputs, as described above. To exit the command, uncheck the Repeat button or 
click Cancel.

 

Once instantiated, powercopies are no more linked to the original PowerCopies used to define them.



 Using a catalog 

You need to have a catalog available, created either: 

●     using the Catalog capability, see the Infrastructure User's Guide.

●     using Insert > Knowledge Templates > Save In Catalog...

1.  Click the  icon .

If accessing a catalog for the first time, you need to navigate to the catalog location. This location 

is stored in the settings for faster access later on. 

2.  Select the catalog containing the PowerCopy you wish to instantiate. 

3.  Select the PowerCopy to be instantiated, then you can: 

❍     double-click the PowerCopy 

❍     or right-click on the PowerCopy in the dialog box and use the Instantiate contextual menu.

From then on, you instantiate the PowerCopy as described above starting on step 3. 

To know more about the Insert Object dialog box... 
●     The Comments & URLs icon is available with user features and document templates only. It is 

always grayed out when instantiating Power Copies. If a URL was added to a user feature or a 
Document template, click this icon enables the user to access the URL. To know more about this 
function, see the Knowledge Advisor User's Guide. 

●     The Name field enables the user to change the name of the user feature instance.

Recommendations  
●     Prior to instantiating a powercopy containing a draft created with versions before V5R14, we strongly 

recommend you to open the CATPart document containing the powercopy, edit the draft, update it 
and then save the CATPart document in your session.



●     Here is a list of the elements you can select for instanciating PowerCopies:

 

Object

Can include

Geometrical 
Set

Ordered 
Geometrical 

Set
Body Solid Body Part

Geometrical Set  YES   YES YES

Ordered 
Geometrical Set  YES YES  YES

Body  YES   YES

Solid Body     YES

Solid   YES YES  

Volume

From 
GS YES   

  
From 
OGS  YES  

Surface,

Wireframe,

Point

From 
GS YES   

  
From 
OGS  YES YES

Sketch YES YES YES YES  



 Saving Power Copies into a Catalog 

 

This task shows you how to store Power Copy elements into a catalog, for later use as described in 
Instantiating PowerCopies.

 

Open the PowerCopyResults.CATPart document.

 
1.  Select the PowerCopy from the specification tree for example.

2.  Choose Insert > Knowledge Templates > Save In Catalog....

The Catalog Save dialog box is displayed: 

When creating a catalog for the first time, click the ... button to display the Open dialog box, 

and navigate to the location where you wish to create a catalog.

3.  Then simply key in the catalog name and click Open.

If you wish to add a PowerCopy to an existing catalog, simply activate the Update an existing 

catalog option in the Catalog Save dialog box.

By default, the Catalog Save dialog box recalls the catalog accessed last.

4.  Click OK. 

The PowerCopy has been stored in the catalog.
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Instantiating Power Copies
Using Step By Step Instantiation

This command is only available with the Generative Shape Design 2 product and providing you have KT1 or PKT licenses.

 

This task shows how to instantiate Power Copies using Step by step instantiation once they have been created as described in 
Creating Power Copies.

This instantiation mode is only available providing the Power Copy to be created is ordered and the chosen destination (that is the 
current feature) respects ordering rules.

Open the PowerCopyDestination2.CATPart document.

 1.  Click the Instantiate From Document  icon or select the Insert -> Instantiate From Document menu item.

The File Selection dialog box is displayed allowing you to navigate to the document where the PowerCopy is stored.

2.  Select the document containing the Powercopy, and click Open.

Here we selected the PowerCopyReference2.CATPart document.
The Insert Object dialog box is displayed.
Use the Reference list to choose the correct Power Copy when several have been defined in the document.

3.  Select the Step by step instantiation mode.

The Inputs field is grayed out.
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4.  Click OK.

A PowerCopy Instances node is automatically created in the specification tree of the current document. The Comparison 
Window opens and the Scan and Synchronization toolbars are launched. 

The Power Copy instance feature stores several information:
❍     A link to the referenced Power Copy. This link will be later used to retrieve the referenced CATPart and the inputs' 

geometry.

❍     The list of inputs to valuate in the current CATPart as well as their role.

❍     The list of parameters published by the Power Copy during its creation.

❍     The mapping between referenced objects and instantiated objects.

You cannot delete the Power Copy instance feature as long as instantiated features inputs are not valuated. An error 
message is displayed if you do so. Deletion is possible only when instantiated features have all their inputs valuated, i.e. 
when the instantiation is completed, or when all instantiated features are deleted.
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5.  Click the First  or the First to update  icon in the Scan toolbar to update the features instantiated by the 

PowerCopy.

Only the Structure mode is available here.

Each time the scan finds a feature that needs inputs, a dialog box is launched to valuate them. Only the necessary inputs 
are requested.
Here Circle.1 is the first instantiated feature that need inputs.

Note that:
❍     The visualization is automatically synchronized on Circle.1 (in the right viewer). It lets you visualized the reference 

model with the exact display during the circle creation.

❍     Indicators are displayed in the right viewer to identify the previous inputs and each input is highlighted.

❍     After the inputs are selected, the scan command is still active. 

❍     You must select inputs in the order they appear in the dialog box.

6.  Select the value for each input.

After each selection, an indicator is displayed in the left viewer, with orientation when necessary. Click on the green arrow 
to reverse orientation if needed.

 
7.  Click OK.

Circle.1 is updated.

8.  Click the Next  or the Play update  icon to continue the inputs valuation.
9.  Once the update is finished, you can close the Scan command as well as the Comparison Window. 



❍     The Scan command can be interrupted at any step if you need to create or modify a feature to valuate an input. 
You can do so while the Comparison window is still active: simply re-launch the Scan command once the creation 
or modification is done. 

❍     The Power Copy instance feature that contains all the information is persistent. Therefore you can save the 
CATPart before (or during) the Scan update, close your session, launch a new session and launch the Scan 
command again to valuate the inputs. Step by step instantiation is completed when all inputs are correctly 
selected.

❍     If you skip some steps (by direct selection in the tree during the Scan command or by using Go To Last button 
for instance), you will still need to valuate the inputs of all intermediate steps and a warning message is issued. 

Indeed the Scan command stops as soon as a feature needs inputs valuation and this feature is then defined as 
the in work object, in order to prevent the selection of inputs which are below it.

 
❍     If the reference CATPart is not found, the scan and the input valuation can be performed but the Comparison 

Window is not available and the old inputs (with reference orientation) cannot be displayed.

 
Nested Power Copies

This instantiation mode is only available providing the Power Copy to be created is ordered and the chosen destination (that is the 
current feature) respects ordering rules.

It lets you perform several Power Copies instantiation at the same time.

Perform steps 1 to 5 of the Step by step instantiation.

 In this scenario, we are not going to select the point as input for Circle.1: indeed the center of the circle is to be created using 
another Power Copy.

 
6.  Click Cancel in the Definition dialog box.

7.  Click the Instantiate From Document  icon (or select the Insert -> Instantiate From Document menu item) and 

navigate to the PowerCopyReference3.CATPart document in the File Selection dialog box.

8.  Select the Step by step instantiation mode.
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9.  Click OK.

A new Comparison Window is created with the destination CATPart on the left and the TwoPointOnASurface PowerCopy 
reference on the right. You can either work from this window or switch to the initial window containing the destination 
CATPart.
The new instantiated features are inserted after the current one: here after Point.2.
The scan command is launched.

A new Power Copy instance is added under the PowerCopy Instances node: 

10.  Click the the First  or the First to update  icon in the Scan toolbar to update the features instantiated by the 

Power Copy.

Only the Structure mode is available here.

Each time the scan finds a feature that needs inputs, a dialog box is launched to valuate the inputs. Here Point.3 is the first 
instantiated feature that need inputs.

file:///E|/www/celr16/Doc/online/cfyug_C2/images/powerstep05NLS.gif


11.  Select the value for the Reference Surface.

After each selection, an indicator is displayed in the left viewer, with orientation when necessary. Click on the green arrow 
to reverse orientation if needed.

12.  Click OK.
Point.3 is updated.

The instantiation of TwoPointsOnASurface Power Copy is now completed. All instantiated features are updated and you 
may delete the Power Copy instance feature if desired and the corresponding Comparison Window can be closed.

13.  Click the Next  or the Play update  icon.
The next feature that needs inputs is Circle.1. 



❍     As this feature belongs to the first instantiated Power Copy, the Comparison Window automatically changes to display 
the CATPart containing the right Power Copy reference.

❍     Even if the previous Comparison Window (corresponding to the TwoPointsOnASurface Power Copy instance) has not 
been closed, the Comparison Window corresponding to the right Power Copy instance (TwoSurfacicHoles) appears in 
the right viewer.

❍     Indicators are displayed in the right viewer to identify the previous inputs and each input is highlighted. 

14.  Select the value for each input.
The first input can now be valuated with one of the two previously created features.
After each selection, an indicator is displayed in the left viewer, with orientation when necessary. Click on the green arrow 
to reverse orientation if needed.

15.  Click OK.
Circle.1 is updated.

16.  Click the Next  or the Play update  icon.
An input is requested for Circle.2.

17.  Select the other created point and click OK.

Circle.2 is now updated and all inputs of TwoSurfacicHoles are valuated.



18.  Close the Comparison Window.

Once all Power Copies have been instantiated, you can close the comparison windows that are still open and delete 
the Power Copy instance features.

 

 



Instantiating Power Copies
Using Part Comparison Instantiation

This command is only available with the Generative Shape Design 2 product and providing you have KT1 or PKT licenses.

 

This task shows how to instantiate Power Copies using Part comparison instantiation once they have been created as described 
in Creating Power Copies.

This instantiation mode is only available providing the Power Copy to be created is ordered and the chosen destination (that is 
the current feature) respects ordering rules.

Open the PowerCopyDestination2.CATPart document.

 1.  Click the Instantiate From Document  icon or select the Insert -> Instantiate From Document menu item.

The File Selection dialog box is displayed allowing you to navigate to the document where the Power Copy is stored.

2.  Select the document containing the Power Copy, and click Open.

Here we selected the PowerCopyReference2.CATPart document.
The Insert Object dialog box is displayed.
Use the Reference list to choose the correct PowerCopy when several have been defined in the document.

3.  Select the Part comparison instantiation mode.
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4.  Complete the Inputs within the dialog box by selecting the adequate element in the geometric area. 

After each selection, an indicator is displayed in the left viewer, with orientation when necessary. Click on the green 
arrow to reverse orientation if needed.

5.  If needed, click on the Use identical name button to automatically select all the elements with the same name.

This is especially useful when the input is the same one repeated several time.

6.  You can also click on the Parameters button to display the Parameters dialog box and modify values.

Here we increased the Radius1 value to 25 mm.

7.  Use the Create formulas button to automatically create a formula on every parameters with the same name provided 

there are any.

8.  Click Close.

9.  Click OK to create the Power Copy instance.

A PowerCopy Instances node is automatically created in the specification tree of the current document. The Comparison 
Window opens and the Scan and Synchronization toolbars are launched. 
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Note that:
❍     All the inputs must have been provided before launching the instantiation. Otherwise, the OK button is grayed out.

❍     Instantiated features are not updated to let you update them one by one and check the consistency of the result.

❍     The current feature is not yet synchronized at this step. It allows you to see the result of the Power Copy on the right 
side.

❍     A new PowerCopy Instances node has been created in current document. This node allows the mapping between 
referenced objects and instantiated objects.

10.  Click the the First  or First to update  icon.

The Scan command is automatically launched.

11.  Then click the Next  or the Play update  icon to scan the instantiated features and update them.

Only the Structure mode is available here.

All inputs of TwoSurfacicHoles are valuated.

12.  Close the Comparison Window.

Once the Power Copy has been instantiated, you can close the comparison window and delete the Power Copy 
Instance features.

The feature defined as the current object corresponds to the last instantiated component of the Power Copy.
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 Instantiating a Power Copy From a VB Macro   

This topic provides you with information about the instantiation of Power Copies using macros. To find out more, see the 
Methodology section of the Product Knowledge Template User's Guide.

To perform the scenario described below, you will need the following files:

●     PktInstantiatePowerCopyVB.CATScript This is the macro. Open this script and edit the path referencing the 
PowerCopyReference.CATPart file (Line 24).

●     PowerCopyReference.CATPart This is the file that contains the Power Copy that is going to be instantiated. 
Note that the inputs of the Power Copy are 2 points and an extrude.

●     PktDestinationPart.CATPart This is the part that will host the instantiated Power Copy. It also contains 2 
points and an extrude, which are the inputs of the Power Copy.
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1.  Open the PktDestinationPart.CATPart file. Note that this file is made up of an Extrude and of 2 points. These are the 

inputs of the Power Copy stored in the PowerCopyReference.CATPart file.

2.  From the Tools->Macro->Macros... command, access the Macros dialog box in CATIA. Click the Macro libraries... 

button. 

3.  In the Macro libraries dialog box, select the Directories option in the Library type scrolling list. Click the Add 

existing library... button.

4.  In the Open a directory of macros dialog box, select the directory that contains the 

PktInstantiatePowerCopyVB.CATScript file that you have just modified. Click OK when done. Click Close in the Macro 

libraries dialog box:  The macro contained in this directory is displayed in the Macros dialog box. 

5.  Click the Run button. Your macro is launched and your Power Copy is instantiated.
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Reusing Your Design

Capabilities Purposes 

 Copy and  Paste 

Provides a quick way of reusing simple features or bodies. This 
command is to be used when you need to rework one specification or 
no specifications at all.

 Cut and  Paste 

Provides a quick way of reusing simple features or bodies. This 
command is to be used when you need to rework one specification or 
no specifications at all.

Drag and Drop Provides a quick way of copying simple features or bodies at  different 
locations.

Paste Special Reuses bodies with or without their specifications.

●     Paste as Result with Link If this option is used, only the geometry is copied, not the 
specifications. Pasted bodies reflect the changes to the initial bodies. 
This command is mostly used in a multi-model environment.

●     As specified in Part Document If this option is used, bodies are pasted as well as their design 
specifications. The capability is the same as the commonly used Copy 
and Paste command  

 Rectangular Pattern
Creates several identical features from one feature or more or even 
from bodies, and simultaneously positions them on an part. 

You position instances with respect to a rectangular or circular grid, or 
using sketched points. Circular Pattern 

 User Pattern

 PowerCopy
Creates a set of features (geometric elements, formulas, constraints 
and so on) that are grouped in order to be used in a different context. 
You can completely redefine these entities when you paste them. As it 
captures the design intent and know-how of the designer, it enables 
greater reusability and efficiency. We recommend you to use this 
command for bodies, features, sketches and design tables that require 
new specifications. 

To benefit from the best level of performance in the long term, use 
this capability to enrich your feature catalogs.

User Defined Feature Creates hybrid features, intended to be stored in catalogs and 
instantiated later on. For more information, refer to Product 
Knowledge Template User's Guide Version 5.
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Cutting, Copying and Pasting

 

The steps below describe how to cut and paste or how to copy and paste Part Design features.  

We recommend you to use these commands when you do not need to re-specify the features you paste 
or if you do so, these features should not require too many specifications. Basically, you should use 
these commands for simple features.

 
1.  Select the element you want to cut or copy.

Cutting

To cut, you can either: 

❍     click the Cut icon 

❍     select Edit>Cut

❍     right-click and select Cut, or

❍     in the geometry area or the specification tree, drag the selection (although not a graphical 
cut, this is equivalent to the cut operation).

This places what you cut in the clipboard.

Copying

To copy, you can either: 

❍     click the Copy icon 

❍     select Edit>Copy

❍     right-click and select Copy, or

❍     in the geometry area or the specification tree, press and hold down the Ctrl key and drag the 
selection.

This places what you copy in the clipboard.

Pasting

To paste, you can either: 



❍     click the Paste icon 

❍     select Edit >Paste

❍     right-click and select Paste , or

❍     in the geometry area or the specification tree, drop what you are dragging (see above).

 
Dragging and dropping objects (features or bodies) onto objects (features or bodies) is a quick way to 
copy objects too. Note however, that the Enable Drag-Drop option must be on to use the capability.

In the example below, the second body is a copy of  Part Body. The user just modified the profile.

 

Copying/Pasting Boolean Operations

To copy/paste Boolean Operations, you need to select the operation node as well as the operated body. 
For more about Boolean Operations, refer to Associating Bodies.



Optimizing Part Design Application
 

Here are some tips and tricks for making your design easier.
●     How to Improve Update Operations

●     How to Improve Performances when Editing

●     How to Improve Performances when Using the Preselection Navigator

●     How to Reduce Data Size when Positioning Pasted Bodies

How to Improve Update Operations

 

●     Generally speaking, using the manual update mode improves the application performances. To 
activate this option, select Tools > Options, then in the Infrastructure > Part Infrastructure 
category, check Manual from the General tab.

●     When working on large parts, you can improve the time necessary for updating your geometry by 

customizing the Undo command . What you need to do is restrict the number of commands that 
can be undone for the current CATPart document. To do so, just select Tools > Options, then in the 
General category, click the Performances tab. In the Stack size field, enter 0 to make sure that 
only local transactions of the current command can be undone. This considerably reduces the time of 
update operations.

General Recommendations For Part Design Features 

Pad, Pocket, Hole, Shaft, Groove

To improve update performances, especially if you are working on complex and large documents, we 
recommend you to:

●     Set parameterized limits (Dimension option) for Pad, Pocket and Hole features, as far as 
possible, instead of Up to Next, Up to Last, Up to Plane, Up to Surface options.

●     Use closed profiles, as much as possible.

Patterns

Moreover, when working on patterns with a large number of instances, to reduce update times :

●     Remember that applying the Keep Specifications Option is meaningless when you set the 
Dimension option for the feature to be patterned. 

●     We recommend you to create the feature to be patterned as well as the pattern feature 
into a new Body, then assemble the new Body with the Part Body. Patterns created in that 



way are not affected by the updates of previous operations. 

The following scenarios illustrate the traditional method, then the method we recommend. 

Traditional Method

The user designed an up to surface pocket, then patterned it: updates of the document take a long time.

 

Recommended Method

Using the recommended method, the user created a new body, set a dimension for the pocket, patterned 
it, then assembled the body to the Part Body: update times are greatly reduced because the update 
process does not re-compute the new body (the application performs calculations again if the geometry 
within the body is linked to the geometry outside of the body, which is the case of constraints or use 
edges for example).



 

  

How to Improve Performances when Editing

You can improve performances when editing features by acting on the application visualization settings:

●     Activate the Only the current body option available via Tools > Options, or just click the Only 

Current Body icon  available in the Tools toolbar. For more information on the capability, 
refer to the Display documentation of the Customizing section.

●     Set values larger than the default ones to define 2d and 3D accuracy for the geometry visualization. 
To do so, select Tools > Options, then in the General > Display category, click the Performances 
tab. Set the settings as explained in the documentation of the Customizing Display section in the 
Infrastructure User's Guide.

●     When filleting, for example, it is often unnecessary to display smooth edges. Therefore, hide them by 
clicking the Customize View Parameters icon from the View toolbar and checking the No smooth 
edges option from the dialog box that appears. For more information, refer to Customizing the View 
Mode in the Infrastructure User's Guide.



How to Improve Performances when Using the Pre-
selection Navigator

●     If you decide to use the Pre-selection Navigator for selecting hidden elements, for example, you can 
improve the application performances by checking the Display the pre-selection navigator 
after... seconds option and setting the time delay to 2 or more seconds. 
To access the option, select Tools > Options, then in the General > Display category, click the 
Navigation tab. For more information, refer to the documentation of the Customizing Display section 
in the Infrastructure User's Guide.

How to Reduce Data Size when Positioning Pasted 
Bodies

There are two ways of positioning bodies you copied and then pasted using the As Result With Link 
option.

1.  By defining the position of the part within a product (reference-instance link). 

When the body is pasted, you cannot modify its position since it inherits the position of the part. 
Consequently, to define a particular location for the pasted body, you can apply transformation on it 
afterwards.

2.  By defining its location in relation to its reference (reference-reference link). 

At creation, not in a product context, it is possible to position the pasted geometry in a non-associative 
way and this at a location different from its reference. Using the compass does this.

In both ways, transformations are applied on the pasted bodies. The problem is that each transformation 
duplicates the geometry data, which may considerably increase the data size. To solve this problem, we 
recommend the use of the Add Position... contextual command.

Add Position

Add Position... creates a set called "Positioning Set" associated with the pasted body, just below the 
Solid.x entity. In this set, an axis system is added as a parameter. When you are applying isometric 
transformations (such as Rotation, Translation, Symmetry etc.) onto the pasted geometry, apply in GSD 
workbench a similar transformation onto this axis system. From a geometrical point of view, the result is 
the same. This is just a way of reducing the data size as well as maintaining the associativity of the 
pasted body's position. 



Note: the size of the CATPart document reduces only if the Solid is complex enough.

In addition to performing these operations, the command also reroutes existing transformations.

Before applying the Add Position... 
command

After applying the Add Position... 
command

Note: If a Positioning Set or any of its entities is defined as the current object (defined in work object), 
the application visualizes only these entities. All the other geometric elements are hidden in the 
geometry area.

Deleting a Positioning Set

Deleting a positioning set as well as its content resets the import's position.



Managing User Features

Refer to the Quick Reference topic for a comprehensive list of interactions to be carried out on user 
features. Refer to To find out more about User Features to find out more about these features.

 

Create User Features: Select the Insert -> UserFeature -> UserFeature Creation ... command, 
select the elements making up the User Feature from the specification tree, define a name for the User 
Feature and its reference elements then choose an icon for identifying it.

Instantiate User Features from Document: Select the Insert -> Instantiate From Document 
command, select the document or catalog containing the  User Feature, complete the Inputs within the 
dialog box selecting adequate elements in the geometric area or from the specification tree.

Save User Features into a Catalog: Select the User Feature from the specification tree, select the Insert -
> Save in Catalog command, enter the catalog name and click Open.

About User Features
About the User Feature Definition Window

Creating a User Feature
Saving a User Feature in a Catalog

Instantiating a User Feature
Modifying a User Feature

Debugging a User Defined Feature (UDF)
Assigning a Type to a User Feature

Referencing User Features in Search Operations
User Features: Useful Tips
User Features: Limitations
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About User Features 

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User 
Features. 

The UserFeature command can be accessed by selecting the Insert->UserFeature command from the 

following workbenches: 

●     Part Design

●     Generative Shape Design

and by clicking the Create a User Feature icon ( ) from the Product Knowledge Template workbench.

A User Feature is a template that works at the part level. From a collection of features (geometry, literals, 
formulas, constraints, etc.), you can create your own feature. The result is a Part Design feature or a Shape 
Design feature that can be reused in the design of another part. The created feature can be saved in a 
catalog. 

A User Feature:

●     Allows you to create applicative features 

●     Allows you to hide design specifications and preserve confidentiality (for instance to sub-contractors) 

User Features (like a line for Drafting or a check for Knowledge Advisor) are open and shareable objects. This 
capability significantly increases the potential application of User Features since it enables you to: 

●     Find User Features by attributes.

●     Generate User Features with the Scripting language to simplify the process of creating scripts .

●     Define expert rules working on User Features with Knowledge Expert (to know more, see the Knowledge 
Expert User's Guide).

●     Use User Features in Knowledge Advisor reactions.

●     Develop CAA functions based on user defined variables.
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About the User Feature Definition Window 

The Userfeature Definition window is accessed by selecting the Insert->UserFeature->UserFeature Creation... 

command or by clicking the Creates a UserFeature icon ( ).

Reference file: PktModifyingMainResult.CATPart

The Definition tab

The Definition tab lets you define the User Feature as you wish to create it. It lets you assign a name to the User Feature 
and presents its components in the viewer. The tree structure displayed in the Definition tab under Components differs 
from the structure of the selected feature. The Body.1 object does not appear as an Assemble.1 child. The components 
displayed under Inputs of components are the features which are not aggregated to the selected object but are required 
to build it. These are the inputs that will be requested at instantiation.
The Change/Update Components button enables you to modify the definition, i.e. the list of the components making up 
User Features after changing the tab page in the definition dialog box or even later after closing the User Feature 
definition window. To find out more, see Modifying a User Defined Feature.
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  The Inputs tab
●     The Inputs tab shows you the inputs (elements to be selected at instantiation) of the User Feature. You can rename 

these elements for a clearer definition by selecting them in the viewer and entering a new name in the Name: field. In 
parentheses you still can read the elements' default name based on its type. When the Inputs tab is selected, the User 
Feature inputs are indicated by red arrows in the geometry area. To know more, see Renaming an input.

  

The Meta Inputs tab
●     The Meta Inputs tab lets you define the meta inputs, and their association with real inputs. It also allows you to 

optionally associate a type with each meta input.

The Add/Remove buttons enable you to add/remove meta inputs. The Role field enables you to enter the name 

assigned to the meta input.  The  enables you to remove inputs from the list of inputs making up the meta input. 

The  button enables you to add inputs to those making up the meta input. 
The ... button enables you to associate a type to the meta input. To find out more, see Assigning a Type to the Meta 
Input.
The Force meta inputs instantiation option enables you to decide if you want the user to select the instantiation 
mode. If checked, only the Meta inputs instantiation mode will be available in the Insert Object dialog box. If 
unchecked, the user will be able to choose the instantiation mode he wants to use i.e. Meta inputs instantiation 
mode or Meta inputs normal instantiation.
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The Parameters tab
●     The parameters tab lets you define which of the parameter values used in the User Feature you will be able to modify 

at instantiation. This can be a value or a formula.
Simply select the parameters and check the Published check box. Use the Name: field to give another name to this 
element. To publish parameters, see Publishing parameters.
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The Documents tab
●     The Documents tab shows the complete path and role of Design tables referenced by an element included in the User 

Feature. This tab exhibits no document because only design tables belonging to the selected object are displayed. 
When instantiating or editing the User Feature, you will be able to change the document pointed by the internal design 
table.



  

The Properties tab
●     The Properties tab lets you modify the icon identifying the User Feature in the specification tree. A subset of icons is 

available from the Icon choice button. If you click ... the Icon Browser opens, showing all icons loaded in your CATIA 
session.
The Grab screen button allows you to capture an image of the User Feature to be stored with its definition. Click the 
Grab screen button. You can zoom in or out the image to adjust it. Click the Remove preview button if you do not 
need this image.

●     The Instantiation Mode combo box list enables you to choose the view that will be created at instantiation.

❍     If you want the end-user to display the User Feature internals, select the White box mode.

❍     If you want the end-user to be able to lock and unlock the User Feature instance, select the Black Box mode. 
This mode is the standard User Defined Feature view. 

❍     If you don't want the end-user to access the internals of the User Defined Feature, select the Black Box 
Protected mode.



  

The Outputs tab
●     The Outputs tab provides you with a way to define the result to be carried forward from the User Feature to another 

document during the instantiation process. To know more, see Modifying the Main Result.
Note that the dimension of the secondary outputs should always be inferior to the Main result. 
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The Type tab
●     The Type tab provides you with a way to associate a type with a User Feature.  This type can be used in search 

operations, Expert checks, and in Product Knowledge Template.



Super  Type Click Auto. Note that the super type is automatically displayed by the application. The super 
type can be MechanicalFeature or Skinfeature. 

Type1 (Standard Inputs)Enables you to enter the name of the type that you want to assign to the User Feature 
(MyPadType in the image above) and click Generate.

Type2 (Meta Inputs) Enables you to define a type for the meta input. 
If you want to reuse the generated type in another CATIA session, save the CATGScript file in 
the Directory indicated in the Reference Directory for Types field (see Tools->Options-
>Parameters and Measure->Knowledge Environment tab).

 



Creating a User Feature

Creating a User Feature
Creating a NLS User Feature 



Creating a User Feature    

The scenario below describes in detail how to create a User Feature. A first User Feature has already been 
created. A new User Feature is now created.  

Note that datums (features that cannot be calculated) cannot be inputs of User Features. To find out more 
about the User Feature limitations, click here.

1.  Open the PktcreateaUDF.CATPart file. Note that this file already contains a User Feature located below 

the KnowledgeTemplates node.

2.  From the Start->Knowledgeware menu, access the Product Knowledge Template workbench.

3.  Click the Create a UserFeature icon ( ). The UserFeature Definition dialog box is displayed. 

Replace the default User Feature name with Pad2, then select the Assemble.2 object in the specification 

tree. The dialog box looks like the one below:
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 When creating the User Feature, the Selected components view shows the 
components that you selected in the geometry and that make up the User Feature 
(see picture opposite).
If, after creating the User Feature, you double-click it, the dialog box that is 
displayed shows the Internal components of the User Feature, i.e, the instances 
of the selected components.

4.  Select the Outputs tab. By default, the Assemble.2 object is displayed as the main result.

5.  Click OK in the dialog box. The Pad2 User Feature is added to the specification tree. 

6.  Save your file.

7.  Keep this document open and proceed to Saving a User Feature in a Catalog.

To find out more about the User Feature definition window, see Introducing the Userfeature Definition window. 
Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User 
Features.

 

file:///E|/www/celr16/Doc/online/cfyugpkt_C2/cfyugpktudf0011.htm


Creating a NLS User Feature    

The scenario below describes how to create a NLS User Feature. The following features can now be displayed in 
your language at instantiation:

●     The input role ●     The parameters (names and string multiple values)

●     The output role after the instantiation ●     The update error message

In the scenario below, the input role and the parameters are NLS.
To create a NLS User Feature:

●     Create the User Feature and click the Type tab in the User Feature definition window to create the type 
associated with the User Feature as well as the associated .CATGScript file. 

●     Create the CATNls file (See below).

●     Close CATIA and relaunch it.

●     In CATIA, open the file into which the template will be inserted.

●     Instantiate the User Feature.

The created CATNls file:
●     Should be stored in the installation directory in the resources\msgcatalog directory.

●     Should have the following name: CATTypeTypeName.CATNls. If the type name is Wheel, the CATNls name 
will be: CATTypeWheel.CATNls.

●     Should be structured as follows (Note that the role corresponds to the role assigned to each input in the 
Inputs tab of the User Feature Definition window): 

❍     Role1="NlsRole";

❍     Role2="NlsRole"; ... 

❍     Optionally for an NLS error message: UpdateErrorMessage = "Message";

Please find below the example of a .CATGscript file and its corresponding .CATNLS file.

GSDPackage isa Package
        {
          CATWheel isa SkinFeature
           {
            NLSName = UserFeature1;
            Fill = 0 , Type : Feature ;
            `Main result` = 0 , Type : Feature 
             NLSName :`Main result` ;
             Point = 0 , Type : Feature ;
             Plane = 0 , Type : Feature ;
             Configuration = 0 , Type : String ;
             Distance = 0 , Type : LENGTH ;
             Radius = 0 , Type : LENGTH ;
             }
        }

In the .CATGscript opposite, the Point, the Plane, the 
Configuration, the Distance, and the Radius are the 
inputs of the User Feature. These inputs will be required 
when instantiating the User Feature. Note that these 
inputs can be the roles you assigned to the inputs.

 



Point = "Input point";
Plane = "Support";
Configuration = "Distance configuration";
Configuration.Item1="Short"; 
Configuration.Item2="Normal";
Configuration.Item3="Long";
Distance = "Wheel distance";
Radius = "Wheel radius";
Fill = "Fill";
//For the Nls message of update error
UpdateErrorMessage = " UPDATE ERROR MESSAGE IN 
ENGLISH"

The inputs of the .CATGscript file are listed in the 
opposite cell along with their NLS names: Point = 
"Input Point".

Note that:

●     Inputs names should not contain blank spaces.

●     All NLS names are indicated between quotes "" and 
are separated by ;.

●     It is possible to add an error message that will be 
launched if an update error occurs.

●     The name of the file is: CATTypeCATWheel.CATNls 

1.  From the Tools->Options->General menu, click Parameters and Measure, and select the 

Language tab. Click the   button and select the directory that will contain the types file 

(.CATGScript file). Click OK when done.

2.  Open the PktcreateaUDF.CATPart file. Note that this file already contains a User Feature located below 

the KnowledgeTemplates node.

3.  From the Start->Knowledgeware menu, access the Product Knowledge Template workbench.

4.  Click the Create a UserFeature icon ( ). The UserFeature Definition dialog box is displayed. Replace 

the default User Feature name with NLSUDF, then click the Assemble.2 object in the specification tree. 

The dialog box now looks like the one below:
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5.  Click the Inputs tab and assign a role to each input:

❍     Click Point.2 in the User Feature Definition window, and enter First_input in the Name field.

❍     Click Point.3 in the User Feature Definition window, and enter Second_input in the Name field.

❍     Click Extract.1 in the User Feature Definition window, and enter Third_input in the Name field.

Note that the role you assign in this tab is the one that will be used to create the .CATNls file (step 
9.)

6.  Click the Parameters tab and select the `Body.2\OpenBody.1\Circle.2\Circle center radius.1\Radius` 

parameter. Click Published Name and assign it a name: Cylinder_Radius.

7.  Assign a type to the User Feature. 

❍     Click the Type tab. 

❍     In the Super Type field, click the Auto button.

❍     In the Type1 field, enter the name of the type that you want to create and click the Generate 
button. The type is created as well as the associated .CATGScript file which is saved in the directory 
you previously selected (Step 1.)



❍     Click Save and Close when done.

❍     Click OK to exit the User Feature definition window.

8.  Save your file and Close CATIA.

9.  Open a Text Editor and enter the following text to create the .CATNls file:

First_input ="Select 1st Point";
Second_input ="Select 2nd 
Point";
Third_input ="Select the 
surface";
Cylinder_Radius="Radius of the 
UDF";

Note that Point.2, Point.3, and Extract.1 are the inputs of the User 
Feature.

Japanese users should use Japanese characters in this file.

10.  Save your file under the following name: CATTypeCATWheel.CATNls in the resources\msgcatalog 

directory. Close the Text Editor.

11.  Open CATIA and open the PktForInstantiation.CATPart file. 

12.  In the PKT workbench, click the Instantiate From Document icon ( ). The File Selection window is 

displayed. Select the PktcreateaUDF.CATPart file that you have just saved and click Open. The following 

image is displayed:
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13.  Select the first point, the second point, and the surface: The User Feature is instantiated.

To find out more about the User Feature definition window, see Introducing the User Feature Definition window. 
Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User 
Features.
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Saving a User Feature in a Catalog 

The task below explains how to store User Features in a catalog. This task is not actually a Product 
Knowledge Template task, but in the context of the Product Knowledge Template product, you will have to 
carry it out quite often. 

You have just created two User Features (Pad1 and Pad2). The main interest of User Features lies in the 
instantiation process whereby a User Feature stored in a catalog can be reused in a document.  

The PktcreatedUDF.CATPart document containing both User Features should be open. 

Using the Save Object in a Catalog Command

1.  Click the Save object in a catalog icon ( ) from the standard menu bar in the PKT workbench. 

The 'Catalog save' dialog box is displayed.

Note that this command is also available from the Part Design and the GSD 

workbenches.

2.  Select the Create a new catalog option and click the button on the right-hand side of the Catalog 

name field. The dialog box which is displayed allows you to specify a .catalog file where to store the 

created User Features. Enter a file name and click Open. Then click OK in the Catalog save dialog 

box.

3.  Open the catalog you have just created (File->Open from the standard menu bar). The catalog 

which is displayed looks like the one below (depending on the name assigned to the catalog): 
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The left pane displays the two User Features created within a tree structure (Pad1 has two inputs 

while Pad2 has three inputs). Selecting a User Feature (3 inputs for example) displays in the right 

pane the characteristics of the User Feature.

About the Reference tab

The User Feature name as well as the document it originates from is displayed.

About the Keywords tab

The User Feature name as well as its inputs are displayed.

About the Preview tab

The icon you have associated with the User Feature (if any) is displayed.

About the Generative Data tab

The resolved queries: A resolved query is relevant for parts with design tables only since it aims at 

storing a filtered view of the design table data.

  

To find out more about the Catalog Editor, see the Infrastructure User's Guide.

 

Using the Catalog Editor

1.  From the Start->Infrastructure menu, access the Catalog Editor.

2.  Double-click Chapter.1 and click the Add Family icon ( ). The Component Definition Family is 

displayed.

3.  Change the name of the family: Pads in this scenario and click OK.

4.  Double-click the Pads family and click the Add Component ( ) icon.

5.  In the Description Definition dialog box, click the 

 button, go back the PktCreateaUDF.CATPart 

file and select the Pad1 User Feature in the specification tree and click OK.

6.  Repeat the previous step to insert the Pad2 User Feature into the catalog.



7.  Save your catalog and proceed to the next task: Instantiating a User Feature.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on 
User Features.
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Instantiating a User Feature 
This section describes the different methods available to instantiate a User Feature.

Instantiating a User Feature From a Catalog, From a Document, From a Selection
Instantiating a User Feature From a VB Macro

Instantiating a User Feature Using the Knowledge Pattern



Instantiating a User Feature From a Catalog, From a 
Document, From a Selection     

The scenario described below shows how to instantiate a User Feature
●     from a catalog 

●     from  a document containing a User Feature

●     from a selection

From a Catalog

1.  Open the PktForInstantiation.CATPart document. 

2.  In the standard toolbar, click the  icon. The catalog browser is displayed.

3.  Click the  icon. In the dialog box which is displayed, select the catalog containing the User Features 

you want to instantiate. Click Open to open the selected catalog. The dialog box which is displayed 

next enables you to navigate through the chapters and the families of the catalog until you can access 

the desired User Feature. 

4.  Double-click the '3 inputs'  object and the 'Pad.2' object. The Insert Object dialog box is displayed.
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To find out more about the Insert Object dialog 

box, click here. 

 

Note that in some cases, when instantiating a 

User Feature, the replacing element does not 

present the same sub-elements as the replaced 

element. Therefore you need to clearly indicate 

in a specific dialog box, the Replace Viewer, 

how to rebuild the geometry from the replacing 

element.

5.  To instantiate Pad2 into the document:

a.  If need be, select Point.2 in the Insert Object dialog box, then select the Point.2 object in the 

document geometry area or in the specification tree.

b.  Select Point.3 in the Insert Object dialog box, then select the Point.3 object in the document 

geometry area or in the specification tree.

c.  Select Extract.1 in the Insert Object dialog box, then select the face highlighted on the graphic 

below.

6.  Click OK to instantiate the Pad2 User Feature and exit the Insert Object dialog box. The User Feature 

Pad2 is instantiated into the document. This is what you can see on screen. 
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From a Document

1.  Open the PktForInstantiation.CATPart document. 

2.  Click the Instantiate an element stored in a document icon ( ). The File Selection dialog box 

is displayed.

3.  Select the PktInstantiateUDFfromDocument.CATPart file and click Open.

4.  The Insert Object dialog box is displayed.

❍     In the Reference scrolling list, select the 

User Feature that you want to 

instantiate (Pad2 in this scenario).

❍     If need be, select Point.2 in the Insert 

Object dialog box, then select the 

Point.2 object in the document geometry 

area or in the specification tree.

❍     Select Point.3 in the Insert Object dialog 

box, then select the Point.3 object in the 

document geometry area or in the 

specification tree.

❍     Select Extract.1 in the Insert Object 

dialog box, then select the face 

highlighted on the figure below.
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5.  Click OK when you are done. The 

User Feature is instantiated.

Click here to find out more about the Insert Object Dialog box.

From a Selection

1.  Open the PktInstantiateUDFfromDocument.CATPart and the PktForInstantiation.CATPart files.

2.  Tile the window vertically.

3.  Expand the KnowledgeTemplates node in the PktInstantiateUDFfromDocument.CATPart file and click 

the Pad2 User Feature.

4.  Go to the PktForInstantiation.CATPart file and click the Instantiate from Selection icon ( ). The 

Insert Object dialog box is displayed.

5.  Click the Use identical name button and click the face highlighted in the picture below.

6.  Click OK when done. The User Feature is instantiated.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User 
Features.
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Instantiating a User Feature From a VB Macro   

This topic provides you with instructions concerning the instantiation of User Features from VB Macros. Two different protocols are 
available to instantiate User Features. To find out more about these 2 protocols, refer to the Methodology section of the Product 
Knowledge Template User's Guide.

●     First instantiation protocol

●     Second instantiation protocol

First instantiation protocol
The first protocol is dedicated to User Feature instantiation only. It is defined by a single method: AddInstance (To find 
out more about this method, refer to the Automation documentation). 

Note that:

●     This method is to be used when you want to perform only one instantiation of the reference. 

●     As the document containing the reference is released from the session at the end of the instantiation, it is not 
recommended to use this method if you want to perform several instantiations of the same reference in a loop. To 
perform a loop, use the second protocol.

To perform the scenario described below, you will need the following files:

●     InstantiateUDFFromVB.CATScript This is the macro. Open this script and edit the path referencing the 
UserFeatureStartSweep.CATPart file (Line 24).

●     UserFeatureStartSweep.CATPart This is the file that contains the User Feature that is going to be instantiated. 
Note that the inputs of the User Feature are a point and an extrude.
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●     PktDestinationPart.CATPart This is the part that will host the instantiated User Feature. It also contains 2 
points (select one of them when instantiating) and an extrude, which are the 
inputs of the User Feature.

1.  Open the PktDestinationPart.CATPart file. Note that this file is made up of a surface and of 2 points. They are the 

inputs of the User Feature stored in the UserFeatureStartSweep.CATPart file.

2.  From the Tools->Macro->Macros... command, access the Macros dialog box in CATIA. Click the Macro 

libraries... button. 

3.  In the Macro libraries dialog box, select the Directories option in the Library type scrolling list. Click the Add 

existing library... button.

4.  In the Open a directory of macros dialog box, select the directory that contains the 

InstantiateUDFFromVB.CATScript file that you have just modified. Click OK when done. Click Close in the Macro 

libraries dialog box: The macros contained in this directory are displayed in the Macros dialog box. 

5.  Select InstantiateUDFFromVB.CATScript (if need be) and click the Run button. The macro is launched and the User 

Feature is instantiated.

 

 

Second instantiation protocol
The second protocol is dedicated to User Features and Power Copies instantiation. It is defined by several methods that 
must be called in order.

Note that it is recommended to use this protocol to perform several instantiations of the same reference in a loop.

To perform the scenario described below, you will need the following files:

●     PktInstantiateUserFeatureVB2.CATScript This is the macro. Open this script and edit the paths referencing the 
UserFeatureStartSweep.CATPart file (Line 25).

●     UserFeatureStartSweep.CATPart This is the file that contains the User Feature that is going to be 
instantiated. Note that the inputs of the User Feature are a point and an 
extrude.
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●     PktDestinationPart.CATPart This is the part that will host the instantiated User Feature. It also 
contains 2 points (select one of them when instantiating) and an 
extrude, which are the inputs of the User Feature.

1.  Open the PktDestinationPart.CATPart file. Note that this file is made up of an Extrude and of 2 points. They can be 

used as inputs of the User Feature stored in the UserFeatureStartSweep.CATPart file.

2.  From the Tools->Macro->Macros... command, access the Macros dialog box in CATIA. Click the Macro 

libraries... button. 

3.  In the Macro libraries dialog box, select the Directories option in the Library type scrolling list. Click the Add 

existing library... button.

4.  In the Open a directory of macros dialog box, select the directory that contains the 

PktInstantiateUserFeatureVB2.CATScript file that you have just modified. Click OK when done. Click Close in the 

Macro libraries dialog box: The macros contained in this directory are displayed in the Macros dialog box. 

5.  Select PktInstantiateUserFeatureVB2.CATScript (if need be) and click the Run button. The macro is launched and 

the User Feature is instantiated.
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 Instantiating a User Feature Using the Knowledge 
Pattern   

The task below shows how to instantiate a User Feature using the Knowledge Pattern. This scenario is based on 
ARM and on the new Knowledge directories structure. To find out more, see Managing Knowledge Applications 
Resources in the CATIA Infrastructure User's Guide.

To perform this scenario, you will need the following files:

●     PktBoxUDF.CATPart This document contains a User Feature that will be instantiated from the 
Knowledge Pattern. The inputs of this User Feature are 2 planes.

●     PktBox.CATGScript This file contains the information concerning the typed User Feature.

●     PktQuantifierUDF.CATPart This document will contain the Knowledge Pattern and the instantiated User 
Features.

●     PktARMcatalog2.catalog This document is the ARM catalog referencing the physical resources used in 
this scenario.

Prior to performing this scenario, make sure that you have:
●     Selected the directory that contains the PktBox.CATGScript in the Reference Directory For Types field in 

the Tools->Options->General->Parameters and Measures->Knowledge Environment tab.

●     Selected the Architect Resources Creation Path in the Tools->Options->General->Parameter and 
Measures->Knowledge Environment tab. Remember that the directory selected here can only be the 
knowledge directory of the Knowledge directories structure. To find out more about this structure, see 
Managing Knowledge Applications Resources in the CATIA Infrastructure User's Guide.

Saving the Required Data into the New Directories Structure

1.  Save the provided data in the appropriate directories:

❍     Save PktBoxUDF.CATPart in the 
CATKnowledgePath\knowledge\knowledgeResources directory.

❍     Save PktARMcatalog2.catalog in the 
CATKnowledgePath\knowledge\knowledgeResourcesCatalogs 
directory. 

❍     Save PktBox.CATGScript in the knowledgeTypesCustom 
directory referenced in the Reference Directory For Types.

2.  Open the PktQuantifierUDF.CATPart file.

Creating the NbInstances Parameter

This parameter will enable you to determine the number of User Features you want to instantiate

3.  Click the Formula icon ( ). The Formula editor opens.

4.  In the New parameter of type combo box, select Integer and click the New parameter of type 
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button.

5.  In the Edit name or value of the current parameter field, double-click Integer.1 and enter 

NbInstances. Click OK. The NbInstances parameter is created.

Creating the Knowledge Pattern

This feature will enable you to instantiate the User Features

6.  From the Start->Knowledgeware menu, select the Product Knowledge Template workbench.

7.  Click the Create a Knowledge Pattern icon ( ). The Knowledge Pattern Editor opens.

8.  Enter the following code in the editor or copy/paste the code contained in this file:

let udf (PktBox) 1
let prev (PktBox) 1
let p (Plane) 1

let i (Integer) 1

i = 1

For i while i <= NbInstances 2
              {
               udf = CreateOrModifyTemplate("PktARMcatalog2|BoxUDF", PartBody, Boxes, i)
              if i == 1
                        udf.BoxInputPlane = FirstBoxPlane 3
              else
              {
                        prev = Boxes.GetItem(i - 1)
                        udf.BoxInputPlane = prev.NextBoxInputPlane 4
                        udf.PreviousBoxLength = prev.L
               }
               udf.SketchPlane = SketchPlane

               EndModifyTemplate(udf)

               udf.Name = "Box" + ToString(i) 6

               i = i +1
}

In the script above, you first declare the local variables (1), 2 corresponding to the type associated 
to the User Feature (in the .CATGScript file), then a plane and an integer. Then you perform a loop 
based on the number of instances set by the NbInstances parameter. The loop instantiates the 
User Features contained in the PktARMcatalog2 catalog via the CreateOrModifyTemplate function 
into the PartBody.
When instantiating the first User Feature, i=1, the input of the User Feature is FirstBoxPlane. For 
the other instantiations, the input of the User Feature is the plane of the last instantiated User 
Feature. The length of the instantiated User Feature corresponds to the exposed parameter (L) of 
the last User Feature instantiated. At the end of the instantiation process, a name is assigned to 
the instantiated User Feature. This name is based on the concatenation of "Box" and the number 
associated to the User Feature. (6).

9.  Click the Add button. List.1 = 0 elements is displayed in the Knowledge Pattern Lists field. This list will 

list the number of instantiated User Features.

10.  Click it and replace it with Boxes in the Name field.
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11.  In the Mode combo box, select Automatic execution (before root update). This way, when you 

change the number of desired instantiated User Features, the script will be launched automatically.

12.  In the specification tree, click the NbInstances parameter. Use the spin box to indicate the number of 

instances you want to instantiate (5 in this scenario.)

13.  Click Execute now. The 5 boxes are instantiated. Click OK to close the Knowledge Pattern window.

14.  Double-click twice the parameter in the specification tree. The Edit parameter dialog box displays. 

15.  Use the spin box to set the number of instances to 3 and click OK. 2 instances are removed. Click here to 

open the Part containing the Knowledge Pattern.
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 Modifying a User Feature  

This task shows how to edit a User Feature. It is divided into 2 parts:
●     Creating and Editing a New User Feature

●     Creating and Editing a User Feature Created with an Old CATIA Version. 

Open the PktcreateaUDF.CATPart file. Note that this file already contains a User Feature located 
below the KnowledgeTemplates node.

Creating and Editing a New User Feature

1.  From the Start->Knowledgeware menu, access the Product Knowledge Template 

workbench.

2.  Click the Create a UserFeature icon ( ). The UserFeature Definition dialog box is 

displayed. 

Replace the default User Feature name with Pad2, then select the Assemble.1 object in the 

specification tree. 

3.  Click OK to validate. The new User Feature is created and is displayed below the 

KnowledgeTemplates node.

4.  Expand the KnowledgeTemplates node, and double-click Pad2.

5.  In the Userfeature definition window, click the Change/Update Components button. A 

warning message is displayed:

6.  Click Yes. The User Feature and its internal components are highlighted in the specification 
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tree.

7.  Click Assemble.1 and Formula.1 in the specification tree to remove them from the internal 

components list and click Assemble.2. Click OK. Click OK in the warning box. The User 

Feature is modified.

Editing an Old User Feature

1.  Double-click Pad1.

2.  In the Userfeature definition window, click the Change/Update Components button. A 

warning message  is displayed.

3.  Click Yes. A new dialog box is displayed indicating that if you edit the User Feature, the 

published parameters will be lost.

4.  Click Yes. The User Feature and its internal components are highlighted in the specification 

tree.

5.  Click Assemble.1 and Formula.1 in the specification tree to remove them from the internal 

components list and click Assemble.2. Click OK. A message displays indicating that some 

outputs cannot be re-rerouted. Click OK. The User Feature is modified.

Note that when editing existing user features you may need to re-select all the components.



 Debugging a User Feature         

This task shows how to use the debugging capabilities added to the User Features.
●     Creating and Instantiating a User Feature Using the White Box Mode

●     Creating and Instantiating a User Feature Using the Black Box Protected Mode

●     Creating and Instantiating a User Feature Using the Black Box Mode

Open the PktcreatedUDF.CATPart file. Note that this file already contains a User Feature located below the KnowledgeTemplates 
node.

●     The debugging capability is available only if you have the PKT license. If you do not have the PKT license, a White box User 
Feature or a Back box User Feature are seen as Black Box protected ones.

●     Note that this command is available in the PKT workbench only.

Creating and Instantiating a User Feature Using the White Box Mode
The White Box mode enables you to visualize what is inside the User Feature instance, 
and to modify it. The internals of the User Feature are visible in the tree and can be 
modified.

1.  Expand the KnowledgeTemplates node and double-click Pad2 to open the Userfeature Definition dialog box.

2.  Click the Properties tab and select White Box in the Mode combo box. 

3.  Click OK when done. 

4.  Save your file but do not close it.

5.  Open the PktForInstantiation.CATPart file. 

6.  Click the Instantiate From Selection icon ( ) and from the Window menu, access the PktcreateaUDF.CATPart file. A 

dialog box is displayed:

7.  Click OK. Click Point.2, Point.3 and Draft.1 in the geometry and click OK. The User Feature is instantiated. Expand the User 

Feature (Pad2.1) node in the specification tree: The User Feature internals are displayed. Close PktForInstantiation.CATPart 

without saving it.

Creating and Instantiating a User Feature Using the Black Box Mode

The Black Box mode is the standard mode. It simplifies the 
user view, and limits the exposition of the User Feature 
internals.
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1.  In the PKtcreatedUDF.CATPart file, expand the KnowledgeTemplates node and double-click Pad2 to open the Userfeature 

Definition dialog box.

2.  Click the Properties tab and select Black Box in the Mode combo box.

3.  Click OK when done. Save your file but do not close it.

4.  Open the PktForInstantiation.CATPart file. 

5.  Click the Instantiate From Selection icon ( )  and from the Window menu, access the PktcreatedUDF.CATPart file.

6.  Click Point.2, Point.3 and Draft.1 in the geometry and click OK. The User Feature is instantiated.

7.  Click the instantiated User Feature (Pad2.1) in the specification tree and click the UDF Debug icon ( ). A warning 

message is displayed: 

8.   Click OK. The Pad2.1 node expands and the User Feature internals are displayed.

Creating and Instantiating a User Feature Using the Black Box Protected Mode
The Black Box Protected mode ensures a locked view of the User Features thus 
ensuring secure exchanges.

1.  In the PKtcreatedUDF.CATPart file, expand the KnowledgeTemplates node and double-click Pad2 to open the Userfeature 

Definition dialog box.

2.  Click the Properties tab and select Black Box Protected in the Mode combo box. A dialog box is displayed informing you 

that after clicking Yes, you will not be able to access the User Feature internals. click Yes. 

3.  Click OK when done. Save your file but do not close it.

4.  Open the PktForInstantiation.CATPart file. 

5.  Click the Instantiate From Selection icon ( )  and from the Window menu, access the PktcreateaUDF.CATPart file.

6.  Click Point.2, Point.3 and Draft.1 in the geometry and click OK. The User Feature is instantiated.

7.  Click the instantiated User Feature (Pad2.1) in the specification tree and click the UDF Debug icon ( ). A dialog box is 

displayed informing you that you cannot display the internals of the User Feature.

If you want to protect your data and ensure IP protection, it is recommended to create the User Feature in White Box or Black Box 
and to delete the items making up the User Feature.

file:///E|/www/celr16/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktForInstantiation.CATPart
file:///E|/www/celr16/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktForInstantiation.CATPart


 Assigning a Type to a User Feature

This task explains how to reference User Features like any other existing types.

●     User Features can define new types of objects created by you and can therefore be searched for like any 
other type. They are also available in the Knowledge Expert browser.

●     If you want other users to use the User Feature you created, you will have to provide them with the User 
Feature, the catalog in which it is stored (if stored in a catalog), and the CATGScript file.

Select a Reference Directory For Types in the Tools->Options->General->Parameters and Measure-
>Language tab. This directory will contain the created user types (.CATGScript files). This way, user types will 
be persistent from a CATIA V5 session to another.

1.  Open the Pktudfcreateatype.CATPart document. 

Pay attention to the Assemble.2 object. This object is the one we are going to use to create a User 

Feature.

2.  Select the Insert->KnowledgeTemplates->Userfeature... command from the standard menu bar if 

you are currently working with the Part Design or Generative Shape Design workbenches or click the 

Create a User Feature icon ( ) if you are in the PKT workbench. 

3.  The Userfeature definition window opens.

❍     In the Definition tab, replace the default User Feature name (enter Pad2 as a new name for 
example) then select the Assemble.2 object in the specification tree. 

❍     In the Parameters tab, publish the parameter that will be published. To do so, select 
`Body.2\Open_body.1\Circle.2\Circle center radius.1\Radius`, click the Published Name 
check box and change the name of the parameter (Radius for example).

❍     In the Super type field, click the Auto button. MechanicalFeature is displayed in the Super type 
field. 
Note that the super type is automatically displayed by the application. The super type can be: 
MechanicalFeature or Skinfeature. 

❍     In the Type 1 field, enter the name of the type that you want to assign to the User Defined 
Feature (MyUDFType in this scenario) and click Generate. 
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Note that if you want to publish parameters later, you will have to re-generate the CATGScript 

in the Manage Type window.

4.  Click OK to exit the User Feature dialog. The Pad2 User Feature is added to the specification tree right 

below the KnowledgeTemplates node.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User 
Features.
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   Referencing User Features in Search Operations  

This task explains how to reference User Features like any other existing types and how to perform search operations on these types.

●     User Features can define new types of objects you created and can therefore be searched for like any other type.

●     If you want other users to use the type you created, you will have to provide them with the User Feature, the catalog in which it is 
stored (if stored in a catalog), and the CATGScript file.

Prior to performing this scenario, indicate the reference directory for types (Tools->Options->General->Parameters and 
Measure->Language tab).

1.  Open the Pktudfcreatedtype.CATPart document and access the Product Knowledge Template workbench (if needed). 

2.  Click the Create a UserFeature icon ( ). The UserFeature Definition dialog box is displayed. 

Replace the default User Feature name with Pad3, then select the Assemble.2 object in the specification tree. 

3.  Click the Parameters tab, select the 5th line in the list of available parameters, click the Published Name check box and 

enter the new name: Radius.

4.  Click the Type tab. In the Super type field, click the Auto button. MechanicalFeature is displayed in the Super type field. 

Note that the super type is automatically displayed by the application. The super type can be: MechanicalFeature or 

Skinfeature.

5.  In the Type 1 field, enter the name of the type that you want to assign to the User Defined Feature (MyPadType in this 

scenario) and click Generate.  Click OK to close the User Feature dialog box. Your type is created.

6.  Select the Insert->UserFeature->Save In Catalog... command from the standard menu bar or click the Save object in a 

catalog icon ( ). The Catalog save dialog box is displayed.

7.  Select the Create a new catalog option and click the button on the right-hand side of the Catalog name field. The dialog box 

displayed allows you to specify a .catalog file where to store the created User Features. Enter a file name and click Save. Click 

OK in the Catalog save dialog box.

10.  Open the PktForInstantiation.CATPart document. The following image is displayed.
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11.  In the standard toolbar, click the  icon. The catalog browser is displayed.

12.  Click the  icon. In the dialog box which is displayed, select the catalog which contains the User Features you want to 

instantiate. Click Open to open the selected catalog. The dialog box which is displayed next depends on your last interaction 

on this catalog. Double-click the object displayed in the left pane until you get Pad3 on screen:

13.  Double-click the Pad3  object. The Insert Object dialog box is displayed. 

 

To find out more about the Insert Object dialog box, click here. 
 

14.  Instantiate Pad3 in the document. 

❍     Select Point.2 in the Insert Object dialog box, then select the Point.2 object in the document geometrical area or in the 
specification tree.

❍     Select Point.3 in the Insert Object dialog box, then select the Point.3 object in the document geometrical area or in the 
specification tree.

❍     Select Draft.1\PartBody in the Insert Object dialog box, then select the face highlighted on the figure below. Click OK 
and Close. Pad3 is instantiated. Click Close to exit the Catalog Browser.
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15.  Select the Edit->Search (CTRL+F) command. The Search window opens. 

16.  Select the Advanced tab.

17.  Select Knowledgeware under Workbench. The type generated when creating the User Feature are located in the 

Knowledgeware package.

18.  Select MyPadType (this is the type assigned to the User Feature) under Type. 

19.  Select Radius under Attribute. The Attributes' criterium dialog box opens. Enter 20mm in the = field. Click OK.

Note that MyPadType is now considered like any other type and can therefore be searched for.

20.  Click Search: the Pad3 instance (Pad3.1) is displayed in the Object found field and is highlighted both in the specification tree 

and in the geometrical area (click the graphic below to enlarge it.)



Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out on User Features.
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 User Features: Useful Tips 

Creating a User Feature
Note that the limitations that apply to Power Copies also apply to User Features. 

●     As far as possible, minimize the number of elements making up the User Feature.

●     When defining User Features including sketches, use profiles constrained with respect to edges or faces 
rather than to planes. Additionally, set off the option Create geometrical constraints before sketching. 
Generally speaking, it is always preferable to use profiles both rigid and mobile.

●     It is preferable to constrain elements with respect to external references such as faces, edges, reference 
or explicit planes.

●     It is preferable not to use projections nor intersections in your sketch if you want to use your sketch in a 
User Feature.

●     Avoid using constraints defined with respect to reference planes.

●     Before creating your User Features, make sure that your sketch is not over-constrained.

●     Make sure that your sketch is iso-constrained (green color). You can use non-iso-constrained sketches, 
but it will be more difficult to understand and control the result after instantiation.

●     To create a User Feature, create first a Power Copy, and try it in different contexts. When the 
instantiation is OK, create the User Feature by selecting the Power Copy. It is easier to understand and 
modify a Power Copy.

●     Provide basic and full User Features on the same geometry (with or without final Trim for example). If an 
update error occurs, you can try the basic User Feature and perform the last operations manually. 

●     When working with Knowledgeware relations, make sure you rename those relations. For example, if you 
work with formulas and you don't rename them, since the instances are shown, they will all have the 
same name.  

Managing inputs: 

●     Always rename your inputs to help the end user understand what he needs to select. 

●     A formula is automatically included in a User Feature definition when all its parameters are included.
Otherwise, if at least one parameter is not selected as part of the User Feature, you have to select the 
formula manually to make it part of the definition. If you do so, all the formula parameters that have not 
been explicitly selected, are considered as inputs of the User Feature.

●     Note that when including parameters sets containing hidden parameters in a User Feature, the hidden 
parameters are automatically instantiated when instantiating the User Feature.



Preview: 

●     In a Part document, create only one User Feature reference. It is not a technical restriction, but there are 
at least two reasons for this: The cost of an instantiation will be reduced if the Part document is smaller. 
The end user can understand the feature to be instantiated more easily.

●     Put in "show" mode only the input and the result (to help the end user understand what he needs to 
select).

●     Use colors to differentiate inputs (put transparency on result for example). 

●     Choose a pertinent view point before saving the Part document reference, default view point in preview 
during instantiation will be the same. 

Geometry: 

●     Create sketches on an axis system, in order to better control the Sketch position. 

●     Avoid constraining your 2D elements with respect to  HV absolute axis. The result you obtain after 
instantiating the Power Copy could be unstable. Actually, you cannot control the position of the origin of 
the absolute axis nor its orientation.

Catalog: 

●     Do not forget catalog integration if you want to provide several User Features.

Instantiating a User Feature

●     Always check the orientation of curves and surfaces. 

●     If you need to instantiate a User Feature several times on the same input, rename your inputs and use 
the "Use identical name" option. 



 User Features: Limitations 

●     Datums (features that cannot be calculated) cannot be inputs of User Features. 

●     Sub-elements cannot be inputs of User Features. For example, the face of a pad cannot be an input.

●     User Feature graphical properties (such as color, show/hide status, ...) depend on the graphical properties 
of its components at creation. As soon as the User Feature is created, i.e. as soon as the components are 
defined and validated (either by clicking OK in the definition window or by changing tabs), the graphical 
properties of the User Feature are "frozen" and thus independent from the graphical properties of its 
components.
The reason why the User Feature graphical properties are independent from its internal graphical properties 
is that the User Feature is a feature with its own graphical properties. Those properties can be modified 
using the Properties contextual command. If the User Feature properties were dependant from the User 
Feature internal components, you would not be able to modify the User Feature graphical properties using 
the Properties contextual command, or the graphical properties available from the contextual command 
and graphical properties defined by parameter would not match.
So it is highly recommended not to use Knowledge parameters inside the User Feature to drive its graphical 
properties.

●     It is not possible to manage real inputs orientation in Meta Inputs instantiation mode. If allowed in the 
template definition, you can switch to a standard instantiation mode, select the input to edit and then 
change the orientation.



Managing Part and Assembly Templates

Refer to the Quick Reference topic for a comprehensive list of interactions to be carried out on 
part and assembly templates. Refer to To find out more about Part and Assembly Templates to 
find out more about these features.

 

Creates a Document Template: Select the Insert -> Document Template Creation ... 
command, select the elements making up the document template from the specification tree, 
define a name for the document template and its reference elements then choose an icon for 
identifying it.

About Part and Assembly Templates
About the Document Template Definition Window

Creating a Part Template
Creating a Document Template Containing Meta Inputs

Instantiating a Part Template
Adding an External Document to a Document Template

Instantiating a Document Template Containing Meta Inputs
Document Templates: Methodology
Document Templates: Limitations
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About Part and Assembly Templates

Part and Assembly Templates are templates that work at the part or at the assembly level.  

The Document Template Definition window can be accessed by selecting the Insert->Document 

Template Creation... command from the following workbenches: 

●     Part Design

●     Generative Shape Design

●     Wireframe and Surface Design

●     Assembly Design

●     Product Structure

Working with Part Templates

A part created in Catia may contain user parameters and geometry data. It is not a contextual part. You can 
create a part template that references that part. This template is a feature that is created in the CATPart 
document itself (very similar to the PowerCopy definition) and stored in a catalog. Several part templates may 
be defined in the same CATPart document.

To create a part template, you: 

●     select parameters and geometry data that will be considered as the template inputs (you can assign a role 
and a comment to each input). 

●     publish some internal parameters (name and comment). The part number is automatically published. 

●     give a name, comment, URL, icon to this template.

In product structure context, the part is inserted as a component of the current product.

Working with Assembly Templates

You create an assembly interactively and you want to create an assembly template that references the root 
product of this assembly.

To create an assembly template, you:



●     select parameters and geometry data that will be considered as the template inputs (you can assign a 
name to each input). 

●     publish some internal parameters (name and comment). 

●     choose if: 

- the part numbers of replicated components are automatically published.

- for each part or each sub-assembly, this sub-component will be replicated at instantiation  or if 
only a reference to this sub-component will be created (a standard component). 

- you want to select external documents (Drawings / Analysis) that references elements of the 
product structure. Those elements will be replicated at instantiation.

●     assign a name, comment, URL, icon to this template.

The template definition is a feature located in the CATProduct document itself. Several assembly 
templates may be defined in the same CATProduct document.



  About the Document Template Definition Window   
     

The Document Template Definition window can be accessed by:

●     Clicking the Create a Document Template icon ( ) in the Product Knowledge Template workbench. 

●     Selecting the Insert->Document Template Creation... command from the following workbenches:

❍     Product Structure

❍     Part Design

❍     Assembly Design

❍     Generative Shape Design

❍     Wireframe and Surface Design

The Documents tab  

 



The Documents tab shows the complete path and Action of the files referenced in the Template. The Action status 
can be either:

●     Same Document or

●     New Document.

If the document is seen as New Document, it is then duplicated and does not have any link with the original 
component (equivalent of the New from... command.)

If the document is seen as Same Document, a link is maintained with the original file.

The  button enables you to modify the Action of the components.

The  buttons of the External documents sections enable you to select external documents and 
insert them into the template.

It is now possible to associate non-CATIA (ENOVIA LCA, ...) documents with a template. To do so, make 
sure you have enabled the desired environment in the Document Environments field (Tools->Options-
>General->Document.) Your documents will be accessible via the Document Chooser.  

The Inputs tab

 



The Inputs tab enables you to define the reference elements making up the Template by selecting them in the 
geometry or in the specification tree. 
 

The Accept instantiation even if not all inputs are filled option enables users to determine if the 
template can be instantiated even if not all inputs are valuated. If all inputs are not valuated, old inputs 
will be kept and isolated at instantiation. This option can be useful if there is more than one way to 
position the template in context, if you want all these combinations to be available but you want to use 
only one of them at the same time. To see an example, see Creating a Part Template and lnstantiating a 
Part Template.

For a clearer definition, you can select these items in the viewer and enter a new name in the Role field.

The Role field enables you to select one of the items displayed in the window and to rename  it. It is used at 
instantiation through the Use identical name button in the Insert object window.

The Type column indicates if the input is manual or automatic. The inputs are considered as 

●     Manual if they are added manually

●     Automatic if they are external references that point an object defined outside the template. 

The Meta Inputs tab
 

 

The Meta Inputs tab lets you define the meta inputs, and their association with real inputs. It also allows you to 
optionally associate a type with each meta input.

 



The Add/Remove buttons enable you to add/remove meta inputs. The Role field enables you to enter the name 

assigned to the meta input.  The  enables you to remove inputs from the list of inputs making up the meta 

input. The  button enables you to add inputs to those making up the meta input. 
The ... button enables you to associate a type to the meta input. To find out more, see Assigning a Type to the 
Meta Input.
The Force meta inputs instantiation option enables you to decide if you want the user to select the instantiation 
mode. If checked, only the Meta inputs instantiation mode will be available in the Insert Object dialog box. If 
unchecked, the user will be able to choose the instantiation mode he wants to use i.e. Meta inputs instantiation 
mode or Meta inputs normal instantiation. To find out more, see Creating a Document Template Containing 
Meta Inputs and Instantiating a Document Template Containing Meta Inputs.

The Published Parameters tab
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The Published Parameters tab enables you to define which parameter value used in the Template you will be 
able to modify when instantiating it. 

The Edit List... button enables you to access the list of parameters, and to select those you want to publish. These 
parameters are displayed in the Part Numbers viewer.

The Auto modify part numbers with suffix check box, if checked, automatically modifies the part numbers at 
instantiation if the part numbers already exist.

●     Note that if you want to manage the way part numbers are modified at instantiation, you just need to 
uncheck this option and click, at instantiation, the Parameters button in the Insert Object dialog box. 
This way you can access the part numbers that you want to modify.

●     The unicity of part numbers is now ensured when instantiating document templates into different 
documents or when the document template is used by different users. When the part numbers 
renaming mode is set to automatic, a suffix parameter is automatically published by the document 
template. At instantiation, after valuating the inputs of the document template, suffixes can be 
changed by clicking the Parameters button in the Insert Object window. Note that it is not possible to 
"unpublish" the suffix or to change its role.

The Icon tab
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The Icon tab enables you to modify the icon identifying the Template in the specifications tree. A subset of icons is 
available when clicking the Icon choice button. 

Clicking  ... displays the Icon Browser, showing all icons loaded in your CATIA session.

The Grab screen button enables you to capture an image of the template to be stored along with its definition. 

The Remove preview button enables you to remove the image if you do not need it.

The assembly structure of the documentation template should not be modified after the document template 
definition (you cannot add or remove documents for example.)



  Creating a Part Template   

This scenario explains how to create a part template containing a keypad that will be instantiated into a 
CATProduct document. In this scenario, you: 

●     Create 2 document templates. When creating the first document template, you do not check the Accept 
instantiation even if not all inputs are filled option (Steps 1 to 4). When creating the second document 
template, you check the Accept instantiation even if not all inputs are filled option (Steps 5 to 8). To find 
out more about this option, see Introducing the Document Template Definition Window.

●     Save both document templates in a catalog.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating the first template

1.  Open the PktMobilePhoneKeypad.CATPart file. The opposite image is displayed.

2.  From the Insert menu, select the Knowledge Templates->Document Template ... command (in the 

Part Design workbench) or, if in the Product Knowledge Template workbench, click the Create a 

Document Template icon ( ). The Document Template Definition window is displayed. 

3.  In the Document Template Definition window, click the Inputs tab to select the inputs. 
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❍     In the geometry, select the following features:  

- Curve.8

- Sharp_Sketch.3

- Arrow_down_Sketch.6

- Ok_Sketch.7

- Arrow_up_Sketch.8

- Cancel_Sketch.9

- Surface.3

❍     In the Inputs tab, select the Curve.8 feature and assign it a role in the Role field. Repeat the same 

operation for the features you selected. The final Inputs tab should look like the picture below. 

4.  Click the Published Parameters tab to publish parameters. 

❍     Click the  

button. The Select 

parameters to insert 

window is displayed. 

❍     Use the arrow to select the 

Button_Offset and the 

Button_top_angle 

parameters in the 

Parameters to publish 

column. 



 

 

 

 

❍     Click OK twice. The Document template is added to the KnowledgeTemplates node. 

❍     Right-click DocumentTemplate.1 and select the Properties command to rename the document 

template.

❍     In the Feature Name field, enter Keypad1. Click OK to validate.

Creating the second template

1.  From the Insert menu, select the Knowledge Templates->Document Template ... command (in the 

Part Design workbench) or, if in the Product Knowledge Template workbench, click the Create a 

Document Template icon ( ). The Document Template Definition window is displayed. 

2.  In the Document Template Definition window, click the Inputs tab and select the following inputs in the 

specification tree: 

❍     Curve.8

❍     Sharp_Sketch.3

❍     Arrow_down_Sketch.6

❍     Ok_Sketch.7

❍     Arrow_up_Sketch.8

❍     Cancel_Sketch.9

❍     Surface.3

3.  Check the Accept instantiation even if not all inputs are filled check box.

4.  Click the Published Parameters tab to publish parameters. 

❍     Click the  button. 

The Select parameters to 

insert window is displayed. In 

the Parameters to publish 

column, click the 

Button_Offset and the 

Button_top_angle 

parameters and use the arrow 

to select them. 



❍     Click OK twice. The Document template is added to the KnowledgeTemplates node. 

❍     Right-click DocumentTemplate.2 and select the Properties command to rename the document 

template.

❍     In the Feature Name field, enter Keypad2. Click OK to validate.

❍     Save your file.

5.  Store the document template in a catalog.  

❍     If not already in the Product Knowledge Template workbench,  from the Start-

>Knowledgeware menu, access the Product Knowledge Template workbench.

❍     Click the Save in catalog icon ( ). The Catalog save dialog box is displayed.

❍     Click OK to create a new catalog or the ... button to change the name of the catalog. The 

catalog is created.

❍     Click here to display the result catalog file. Click here to display the result .CATPart file.

6.  Close your file and proceed to the next task: lnstantiating a Part Template.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried on Document 
Templates.

 

file:///E|/www/celr16/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktKeypadscatalog.catalog
file:///E|/www/celr16/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktMobilePhoneKeypadResult2.CATPart
file:///E|/www/celr16/Doc/online/cfyugpkt_C2/cfyugpktudf0011.htm


  Creating a Document Template Containing 
Meta Inputs   

This task shows how to create a document template containing Meta Inputs. To find out more about 
meta inputs, refer to Working With Meta Inputs.

Open the PktEngine.CATProduct file. Note that you also need the following files:

●     Rod.CATPart ●     Jacket.CATPart

●     Piston.CATPart ●     EngineSkeleton.CATPart

●     Crankshaft.CATPart  

1.  From the Start->Knowledgeware menu, select the Product Knowledge Template 

workbench.

2.  From the Insert menu, select the Knowledge Templates->Document Template ... 

command or, if in the Product Knowledge Template workbench, click the Create a Document 

Template icon ( ). The Document Template Definition window is displayed. 

3.  In the Document Template Definition window, click the Inputs tab and select the inputs. To 

do so, expand the EngineSkeleton\Geometrical Set.1 node and select:

❍     Point.5 ❍     Point.6 ❍     Point.7 ❍     Point.8

❍     Point.9 ❍     Point.10 ❍     Point.11 ❍     Point.12

❍     Point.13 ❍     Point.14 ❍     Point.15 ❍     Point.16

4.  Assign them a role in the Role field:

❍     Point.5 CrankshaftPoint4

❍     Point.6 CrankshaftPoint5

❍     Point.7 RodPoint1

❍     Point.8 CrankshaftPoint6

❍     Point.9 RodPoint1
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❍     Point.10 CrankshaftPoint3

❍     Point.11 CrankshaftPoint2

❍     Point.12 CrankshaftPoint1

❍     Point.13 PistonPoint2

❍     Point.14 PistonPoint1

❍     Point.15 PistonPoint1

❍     Point.16 PistonPoint2

5.  Click the Meta Inputs tab to create the meta inputs. 

6.  Click the Add button to create a meta input. Change its name in the Role field (Rod1 in this 

scenario.)

7.  In the Remaining Inputs field, select RodePoint1 and click the  button to associate this 

point to the meta input.

8.  Click the Add button to create the first meta input. Change its name in the Role field (Piston1 

in this scenario.)

9.  In the Remaining Inputs field, select PistonPoint1 and click the  button to associate this 

point to the meta input. Then select PistonPoint2 and click the  button to associate this 

point to the meta input.

10.  Click the Add button to create a meta input. Change its name in the Role field (Crankshaft in 

this scenario.)

11.  In the Remaining Inputs field, select Crankshaft1 and click the  button to associate this 

point to the meta input. Repeat this operation for the following points: Crankshaft2, 

Crankshaft3, Crankshaft4, Crankshaft5, Crankshaft6. 

12.  Click the Add button to create a meta input. Change its name in the Role field (Piston2 in this 

scenario.)

13.  In the Remaining Inputs field, select PistonPoint1 and click the  button to associate this 

point to the meta input. Then select PistonPoint2 and click the  button to associate this 



point to the meta input.

14.  Click the Add button to create a meta input. Change its name in the Role field (Rod2 in this 

scenario.)

15.  In the Remaining Inputs field, select RodePoint1 and click the  button to associate this 

point to the meta input. 

16.  Click OK when done. The document template is created. Save your file and close it. Proceed 

to: Instantiating a Document Template Containing Meta Inputs.



lnstantiating a Part Template 

This scenario explains how to instantiate a template into a CATProduct file. It is divided into 2 different parts:
●     You instantiate Keypad1, a document template saved in the PktKeypadscatalog.catalog.

●     You instantiate Keypad2, a document template saved in the PktKeypadscatalog.catalog.

To perform this scenario, you need the following files:
●     PktMobilePhoneSupport.CATProduct that is made up of the following CATPart and CATProduct files:

PktBottomcase.CATPart PktBattery.CATPart

PktBody.CATPart PktLens.CATPart

PktIndus.CATPart PktLCD30-28.CATPart

PktFrontShell.CATPart PktElectronic.CATProduct

PktPlanarCard.CATProduct PktSpeaker.CATPart

InteractiveBoard.CATPart PktCapacitor_500.CATPart

PktCapacitor_700.CATPart PktChip_AC30.CATPart

PktChip_AC110.CATPart PktChip_AC20.CATPart

Screen2.jpg  

●     PktKeypadscatalog.catalog: This catalog contains 2 document templates: Keypad1 and Keypad2. When 
creating Keypad1, the Accept instantiation even if not all inputs are filled option was unchecked. 
When creating  Keypad2, the Accept instantiation even if not all inputs are filled option was 
checked.

Working with the Cache system: Till R14 the previous instantiation behavior was to load the whole assembly 
when the instantiation occurs, that is to say, at the very beginning of the instantiation. Now this loading is 
performed only when you enable the Use Identical Name option. 
If the Part is not loaded in the current selection, you can now click this part to load it. 

Instantiating Keypad1

1.  Open the PktMobilePhoneSupport.CATProduct file.

2.  Click the Open Catalog icon ( ) and select the PktKeypadscatalog.catalog that you created in the 

Creating a Part Template topic. The Catalog Browser opens.  

3.  Double-click DocumentTemplate, 7 inputs and Keypad1. The Insert Object window opens. (Click the 

graphic opposite to enlarge it).
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To find out more about the Insert Object dialog box, click here. 

4.  Value the Inputs by selecting the publications located below the Industrial Design node in the 

specification tree or click the Use Identical Name button in the Insert Object window.
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5.  Make the appropriate selections in the Replace Viewer window (see picture below) and click OK 

when done. 

Note that in some cases, when instantiating a part or assembly template, the replacing element does 
not present the same sub-elements as the replaced element. Therefore you need to clearly indicate in a 
specific dialog box, the Replace Viewer, how to rebuild the geometry from the replacing element.



6.  Click OK in the Check warning box, then Close. The keypad is instantiated (see picture below.) 

7.  Close your file.

Instantiating Keypad2

1.  Open the PktMobilePhoneSupport.CATProduct file.

2.  Click the Open Catalog icon and select the PktKeypadscatalog.catalog that you created in the 

Creating a Part Template topic. The Catalog Browser opens.  

3.  Double-click Document Template,  7 inputs and Keypad2. The Insert Object window opens.

4.  Click OK in the Insert Object window. The keypad is instantiated. Note that you do not have to value 

the inputs since the Accept instantiation even if not all inputs are filled option was checked when 

creating the Keypad2 part template.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried on Part 
Templates.
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 Adding an External Document to a Document 
Template 

This task shows how to insert a drawing into a part template and how it is updated at instantiation. The 
scenario is divided into the following steps:

●     Creating a drawing from an existing part

●     Creating the part template

●     Instantiating the part template and updates the generated drawing.

Note that the document(s) that can be added to part and assembly templates must belong to one of 
the following types:

●     .CATDrawing

●     .CATProcess

●     .CATAnalysis

Prior to performing this scenario, make sure that the Keep link with selected object is checked 
(Tools->Options...->Infrastructure->Part Infrastructure->General).

1.  Open the PktPadtoInstantiate.CATPart file. 

2.  From the Start->Mechanical Design menu, access the Drafting workbench. The New 

Drawing Creation Window is displayed. 

3.  Select the All views configuration and click OK.

4.  The drawing corresponding to the pad is generated. 
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4.  Save your drawing and close the file. Click here to see the generated drawing.

5.  Go back to the PktPadtoInstantiate.CATPart file to create a part template. 

❍     Select the Knowledge Templates->Document Template ... command. The Document 

Template Definition window is displayed.

❍     Click the Add... button in the External documents field and select the .CATDrawing file 

you have just created in the File Selection window (or use the 

PktPadDrawing.CATDrawing). Click Open.

❍     Click the Inputs tab and select Sketch.1 and Sketch.2 in the geometry or in the 

specification tree.
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❍     Click the Published Parameters tab and click the Edit List... button. The Select 

parameters to insert window is displayed. Select the following parameters using the 

arrow button:

 
❍     PartBody\Pad.1\FirstLimit\Length

 
❍     PartBody\Pad.2\FirstLimit\Length

❍     In the Published Parameters tab, select PartBody\Pad.1\FirstLimit\Length and rename it 

to Pad_Width in the Name: field, then select PartBody\Pad.2\FirstLimit\Length and rename 

it to Pad_Length.

❍     Click OK to validate. Save your file and close it.

6.  Open the PktProduct.CATProduct  file.

7.  From the Start->Knowledgeware menu, access the Product Knowledge Template 

workbench (if need be).

8.  Click the Instantiate From Document icon ( ) and select the 

PktPadtoInstantiate_result.CATPart containing the document template. Click Open. The Insert 

Object dialog box is displayed.

9.  Expand the PartBody\Pad.1 node in the specification tree, select Sketch.1, and make the 

appropriate selections in the opening Replace Viewer window (see graphic below). Click Close 

when done.
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10.  Select Sketch.2 in the geometry or in the specification tree.

11.  Click the Parameters button and enter 10mm in the Pad_Width field and 90 in the 

Pad_Length field.



12.  Click Close and OK to validate. A message is fired indicating that the external document was 

regenerated. Click OK. The document template was instantiated. (see picture below).



13.  From the Window menu, access the generated .CATDrawing file. Right-click CATDrawing2 in 

the left part of the window and select the Update Selection command. The drawing is updated 

and matches the new product.



Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out 
on document templates.
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Instantiating a Document Template 
Containing Meta Inputs     

This scenario explains how to instantiate a document template containing meta inputs. 

Open the PktEngine2.CATProduct file. Note that you also need the following files:

●     PktRod.CATPart ●     PktJacket.CATPart

●     Pktpiston.CATPart ●     PktCrankshaft.CATPart

1.  From the Start->Knowledgeware menu, select the Product Knowledge Template 

workbench.

2.  Click the Instantiate From Document icon ( ) and select the PktEngine.CATProduct file 

containing the Document Template. The Insert Object dialog box is displayed showing the 

meta inputs.

3.  Select the first rod, the first piston, the crankshaft, the second piston then the second rod.  

4.  Click OK when done. The document template is instantiated.
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 Document Templates: Methodology  

●     It is possible to define document templates based on contextual products and parts or on isolated parts and 
products. It is highly recommended to work with isolated documents: not so many documents will be 
instantiated (when working with contextual products, the context products are needed for instantiation).

●     The assembly structure of the documentation template should not be modified after the document template 
definition (you cannot add or remove documents for example.)



Document Templates: Limitations

A publication cannot point an object already published more than once. When creating the import link, the 
published object is looked for and the import is created on the first publication found which might not be the 
one that has the same name as the input.
The only information that the Document Template can provide is the final object itself (infrastructure does not 
allow you to specify the publication, but only the pointed object). The publication is then automatically 
retrieved by the link infrastructure.



Workbench Description
The Part Design window looks like this:

Click the sensitive areas to see the related documentation.

Part Design Menu Bar

Sketch-Based Features Toolbar

Dress-Up Features Toolbar

Surface-Based Features Toolbar

Transformation Features Toolbar



Reference Elements Toolbar

Boolean Operations Toolbar

Sketcher Toolbar

Constraints Toolbar

Analysis Toolbar

Annotations Toolbar

Tools Toolbar

Insert Toolbar

Symbols Used in the Specification Tree
Part Design Specification Tree Icons

Miscellaneous Symbols

Symbols Reflecting an Incident in the Geometry Building

Referenced Geometry Symbols

 



Part Design Menu Bar
This section presents the main menu bar tools and commands dedicated to Part Design.

Start File Edit View Insert Tools Windows Help

Edit
For... See... 

Update Updating Parts 

Cut

Copy

Paste

Cutting, Copying, Pasting

Paste Special...

Handling Parts in a Multi-Document 
Environment 

Specification Tree

Delete Deleting Features 

Properties Displaying and Editing Properties 

Scan or Define in Work 
Object...

Scanning a Part and Defining in Work Objects 

XXX object... Redefining Feature Parameters 

Displaying and Editing Properties

Reordering Features

Insert
For... See...
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Body Inserting a New Body

Body in a Set... Inserting a Body into an Ordered 
Geometrical Set

Geometrical Set... Inserting a Geometrical Set

Ordered Geometrical Set... Inserting an Ordered Geometrical Set

Insert in new body Inserting Features into a New Body

Annotations Creating Annotations

Constraints Setting Constraints

Sketcher... Sketcher User's Guide

Axis System... Axis System

Sketch-Based Features Sketch-Based Features 

Dress-Up Features Dress-Up Features 

 Surface-Based Features Surface-Based Features

 Transformation Features Transformation Features 

 Boolean Operations Associating Bodies

 Advanced Dress-Up Features Creating Advanced Drafts

Knowledge Templates PowerCopy

Managing User Features (UDFs) 

Managing Part and Assembly 
Templates   
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Instantiate From Document... Instantiating PowerCopies 

Tools
For... See...
  

  

Parent/Children Parents and Children

Options... Customizing

Publication... Publishing Elements
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Sketch-Based Features Toolbar
 

 

   

The Sketch-Based Features toolbar is available in extended or compact display mode. To choose your 
display mode, use View > Toolbars > Sketch-Based Feature (Extended/Compact).

 
See Creating Pads

See Creating Drafted Filleted Pads

 
See Creating Pockets 

See Creating Drafted Filleted Pockets

 
See Creating Shafts

See Creating Multi-Pads

See Creating Multi-Pockets

 
See Creating Grooves 

 
See Creating Holes 

 
See Creating Ribs 

 
See Creating Slots

See Creating Solid Combines



See Creating Stiffeners 

See Creating Multi-sections Solids

See Creating Removed Multi-sections Solids



Dress-Up Features Toolbar 

 

   

 
See Creating Edge Fillets

 
See Creating Variable Radius Fillets  

 
See Creating Face-Face Fillets 

See Creating Tritangent Fillets 

 
See Creating Chamfers 

 
See Creating Basic Drafts 

See Creating Draft from Reflect Lines

See Creating Variable Angle Drafts 

See Creating Advanced Drafts

 
See Creating Shells  

 
See Creating Thicknesses

See Creating Threaded Holes

See Creating Replace Face Features

See Creating Remove Face Features



Surface-Based Features Toolbar 

The Surface-Based Features toolbar is available in extended or compact display mode. To choose your display mode, use View > 
Toolbars > Surface-Based Feature (Extended/Compact).

See Creating Splits 

See Creating Thick Surfaces

See Creating Close Surface Features

See Creating Sew Surfaces

 



Transformation Features Toolbar

 

 

See Creating Translations

See Creating Rotations

See Symmetry

 
See Mirror

 
See Creating Rectangular Patterns

 
See Creating Circular Patterns  

See Creating User Patterns

 
See Creating Scalings 

 



Reference Elements Toolbar 

 

 

You can display the Reference Elements toolbar using View > Tool bars > Reference Elements 
(extended/compact).

 
See Creating Points

 
See Creating Lines

 
See Creating Planes

 



Boolean Operations Toolbar 

 

 

These toolbars are optional. You can display them using View > Toolbars.

See Assembling Bodies

See Adding Bodies

See Removing Bodies 

See Intersecting Bodies

See Trimming Bodies

See Keeping and Removing Faces



Sketcher Toolbar

See Sketcher User's Guide.

See Changing a Sketch Support.

 



Constraints Toolbar 

 
See Setting 3D Constraints

 
See Setting Constraints Defined in Dialog Box



Analysis Toolbar 

 
See Performing a Draft Analysis 

 
See Performing a Surface Curvature Analysis  

See Analyzing Taps and Threads



Annotations Toolbar 

 
See Creating a Text With Leader

 
See Creating a Flag Note



Tools Toolbar

 
See Updating Parts 

See Axis System

See Computing Mean Dimensions

See Creating Datums

See Display in the Geometry Area

See Optimizing Part Design Application

See Component Catalog Editor User's guide Version 5.



Insert Toolbar

 

See Inserting a New Body

See Inserting a Body into an Ordered Geometrical Set

See Inserting a Geometrical Set

See Inserting an Ordered Geometrical Set

See Inserting Features into a New Body



Part Design Specification Tree Icons

Body, Part Body
Body

Solid Bodies (bodies created with versions up 
to Version 5 Release 14).

 Pad

Drafted Filleted Pad

 Pocket 

Drafted Filleted Pocket

 Shaft

Multi-Pad

Multi-Pocket

 Groove 

 Hole 

 Rib 

 Slot

 Stiffener 

Loft

Remove Lofted Material

 Edge Fillet

 Variable Radius Fillet  



 Face-Face Fillet 

Tritangent Fillet 

  Chamfer 

 Basic Draft 

Draft from Reflect Lines

Variable Angle Draft 

Advanced Draft

 Shell  

  Thickness

Thread

Split 

Thick Surface

Close Surface

Sew Surface

Translation

Rotation

Symmetry

 Mirror

 Rectangular Pattern

 Circular Pattern  

User Pattern



 Scaling 

 Points

 Lines

 Planes

 Draft Analysis 

 Curvature Analysis  

Tap-Thread Analysis

 Textual Annotations

 Flag Notes



Miscellaneous Symbols

 Bodies and PartBodies

Depending on the chosen environment type, icons representing bodies (and partbodies) are assigned distinct 
colors as summarized in this table:

Environment type  Solid body Body Insert Body command

Solid body

Body

Note

When creating a new body (using Insert->Body or Insert->Body in a Set), the icon associated to the inserted body 
is assigned the green color in the specification tree.
 

  PartBody

 

 

A Part Body. This type of partbody can include solids, wireframe and surface 
elements.

The icon identifying part bodies is: 

●     green in a hybrid environment (default environment).

●     yellow in a non-hybrid environment.

  PartBody

A solid PartBody. This type of Part Body cannot include wireframe nor surface 
elements. 

The icon identifying solid part bodies is: 

●     gray in a hybrid environment (default environment)

●     green in a non-hybrid environment.



 Body.3

 

 

A Body. This type of body can include solids, wireframe and surface elements. 

The icon identifying bodies is:

●     green in a hybrid environment (default environment).

●     yellow in a non-hybrid environment.

  Body.1

A solid body. This type of body cannot include wireframe nor surface 
elements. 

The icon identifying solid bodies is:

●     green in a non-hybrid environment.

●     gray in a hybrid environment (default environment).

 Miscellaneous

xy plane
xy plane, yz plane or zx plane. You can click the desired reference plane either 
in the geometry area or in the specification tree.

 Body.1

A model with a geometrical representation.

 Sketch.1

Sketch. For more information about Sketcher Workbench, refer to : Entering 
the Sketcher Workbench in Sketcher User's Guide.

 AbsoluteAxis

Absolute Axis: contains information about Origin, HDirection and VDirection.



 Origin

Origin. 

 HDirection

HDirection or VDirection.

 Geometry

Geometry (Point, Line,...): Wireframe and Surfaces features.

 Constraints

Constraints: Parallelism, Perpendicularity, etc.

 face

Publication : a CATPart or CATProduct element is published that is to say its 
geometrical data is exposed. For more information refer to Managing a Product 
Publication in Assembly User's Guide.

Hole.1

Assembly hole. For detailed information about Assembly features, refer to 
Assembly Design User's Guide Version 5. 

 Open_body.1

External references branch of the part : external geometry (a face, a point or 
a line) is copied/imported from driving parts to contextual parts that are being 
driven (Design in context). You can customize External References as follows: 
select Tools > Options > Infrastructure > Part Infrastructure, click the 
General tab and check the Keep links with selected object option.

  Product4

A product in NO SHOW mode. For information about the SHOW/NO SHOW 
modes, see Displaying Hidden Objects in Infrastructure's User Guide.

 Part5

A part in NO SHOW mode. For information about the SHOW/NO SHOW modes, 
see Displaying Hidden Objects in Infrastructure's User Guide.

The Sketcher symbol is by default in NO SHOW mode. 



Symbols reflecting an incident in the Geometry building
Miscellaneous Incidents

Incidents on Constraints

Miscellaneous Incidents

Part1
Part to be updated

 Product1

No visualization of the product or the part. The product's reference cannot be found. The geometry of 
the component disappears.

 PartBody

A broken link. The access to this product is impossible because the link with the root document has been 
lost.

Shaft.1
A broken shaft.

Pocket.1
The pocket's representation is deactivated.

Plane.1
Isolated plane (can no longer be edited)

Incidents on Constraints

 Offset.1
A broken constraint. The access to this product and the information about its constraints cannot be 
retrieved.

 Parallelism.1
A deactivated constraint (a parallelism constraint).

 Perpendicularity.1
A constraint to be updated (a perpendicularity constraint).



Referenced Geometry

 Referenced Geometry

Geometry copied from a document different from the 
CATPart document in which it is pasted.

Initial geometry has undertaken modifications in the 
original CATPart document: solid to be synchronized.

Initial geometry has been deleted in the original CATPart 
document or the original CATPart document has not 
been found

Pointed document found but not loaded (use the Load 
contextual command or the Edit > Links command)

External link deactivated so that geometry cannot be 
synchronized during the update of the part (even if the 
option "Synchronize all external references for update" is 
on).

Geometry pasted (using the As Result with Link option) 
within the same CATPart document from which it is has 
been copied

Point referenced in the CATPart document is a published 
element.

Sketch referenced in the CATPart document is a 
published element which has undertaken modifications 
so that a synchronization is required.



Customizing

A certain number of settings is available to let you customize your Part Design workbench.

The customization you perform is stored in permanent setting files, meaning that these settings are not lost when you end 

your session.

To access them, proceed as follows:

1.  Select Tools > Options.

The Options dialog box displays.

2.  From the Infrastructure category, select the Part Infrastructure sub-category in the left-hand box. 

The General, Display and Part Document tabs appear.

The General tab provides options dealing with: 

❍     External References

❍     Update

❍     Delete Operation 

❍     Replace

The Display tab provides option dealing with: 

❍     Display in Specification Tree

❍     Display in Geometry Area 

❍     Checking Operation When Renaming

The Part Document tab provides option dealing with: 

❍     When Creating Parts

❍     Hybrid Design 

From V5R16 onward, any modifications made to the Part Infrastructure settings can now be recorded in a 
Visual Basic file using Tools>Macro>Start Recording.  See Recording, Running and Editing Macros in the 
Infrastructure User's Guide for details about running macros. Additionally, you can now launch a dedicated Visual 
Basic macro in order to set parameters for Part infrastructure.

3.  To access settings about annotations, select the 3D Annotations Infrastructure category.

Click the tabs of interest.



●     Tolerancing 

●     Display

●     Manipulators

●     Annotation

●     View/Annotation Plane

4.  Change these options according to your needs.

5.  Click OK when done to validate your settings.
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Display  

This tab deals with these categories of options:

●     Display in Specification Tree

●     Display in Geometry Area

●     Checking Operation When Renaming

Display in Specification Tree

There are six types of elements you can display or not in the Specification tree. If you want them to be 
displayed, just select them.

●     External References

●     Constraints

●     Parameters

●     Relations

●     Bodies under operations

●     Expand sketch-based feature nodes at creation

External References

Copies with links of geometry from other documents: 

 By default, this option is selected.



Constraints

Dimensional and geometrical constraints created in the CATPart document: 

 By default, this option is not selected.

Parameters 

Parameters created using the Knowledge Advisor capability: 
If you wish to know what parameters and relations are, refer to the CATIA Knowledge Advisor Users Guide 
Version 5.

 By default, this option is not selected.

Relations

Relations (formulas) created using the Knowledge Advisor capability: 
If you wish to know what relations are, refer to the CATIA Knowledge Advisor Users Guide Version 5.

 By default, this option is not selected.

Bodies under operations 

Bodies attached to other bodies in different ways (Add, Assemble, Remove, Intersect, Union Trim). 

The option is selected: The option is not selected:

This option is available only with Part Design application. For more, refer to "Associating Bodies" in the CATIA 
Part Design Users Guide Version 5.



 By default, this option is selected.

Expand sketch-based feature nodes at creation

This option is not a new option: it has just been renamed.

If the Expand sketch-based feature nodes at creation option is selected, sketch-based features nodes are 
expanded so as to display sketch nodes. If not selected, sketch nodes are present in the tree but you need to 
click the plus sign to the left of features to expand them.

 By default, this option is selected.

Display in Geometry Area

There are five options available for customizing the geometry display:

●     Only the current operated solid

●     Only current body

●     Geometry located after the current feature

●     Parameters of features and constraints

●     Axis system display size 

 



Only the current operated solid   

This option is used when editing features belonging to attached bodies (bodies that underwent Boolean 
operations) only. It displays

●     only the features of the current body,

●     all the other bodies and geometrical sets directly aggregated to the part. 

In the following example, the option is on: you can see Body.2 and Set.1.

This setting can greatly improve the application performances whenever you edit these features. 

Note: Instead of accessing this option via Tools > Options, you can click this icon  available in the 
Tools toolbar.

 By default, this option is not selected.

Only Current Body 

This option displays the geometry of the current part body or open body only. In the example above, we could 
not see Set.1.

 By default, this option is not selected.

Geometry located after the current feature



This option is reserved for Ordered Geometrical Sets (OGSs) and bodies that can include both Part Design 
features and GSD features (for more information, refer to Hybrid Design in the CATIA Part Design Users Guide 
Version 5.). If selected, the application displays:

●     the geometry of the current feature and

●     only the GSD and wireframe geometry located after the current feature.

In the example below, since the option is on, you cannot see EdgeFillet.1 nor Hole.1 in the geometry area:

  By default, this option is not selected.

Parameters of features and constraints

This option permanently displays parameters attached to Part Design features and Sketcher constraints.

 By default, this option is not selected.

Axis system display size (in mm)

This option lets you define the size of axis systems in mm.

 By default, this option is not selected.

Checking Operation When Renaming



Three options let you define rules for renaming geometric elements (using the Properties command).

No name check 

Use this option if you wish to allow all types of rename operations whatever the locations of the elements in 
the specification tree.

 By default, this option is checked.

Under the same tree node

Check this option to prevent two elements belonging to a common node from having the same name. If you 
are giving an identical name, a warning message is issued informing you that the element you are renaming 
will be suffixed as 'Renamed'. The check operation in case-insensitive.

 By default, this option is not selected.

In the main object

Check this option to prevent two elements belonging to the same main node from having the same name. The 
check operation in case-insensitive.

 By default, this option is not selected.





General   

This tab deals with these categories of options:

●     External References

●     Update

●     Delete Operation

●     Replace

External References

 

Keep link with selected object 

Checking this option lets you maintain the links between external references, (copied elements and imported 
elements), and their origins when you are editing these elements. This option is used as you are editing parts 
included in assemblies. For more about designing parts in assembly context, refer to the CATIA Assembly 
Design Users Guide Version 5. If later on you need to cut the link between external references and their origin, 
you just need to use the Isolate command.

In the example below, the option is selected:



Now, when the option is not selected:



 

 By default, this option is not selected.

Show newly created external references

This option is not a new option: it has just been renamed.

If this option is selected, all external references you create from the moment the option is on, are visible in the 
geometry area. The option does not affect external references created before the option was active.

 By default, this option is not selected.

Confirm when creating a link with selected object

Selecting this option enables you to be warned that links are created when you are pasting or importing 
elements from a separate part. This is the warning message that is displayed:



This option is valid if Keep link with selected object is selected as well. 

 By default, this option is not selected.

Use root context in assembly

Check this option to ensure that the root of the assembly is the context used. Uncheck this option if you prefer 
to use the minimal context. For more about changing contexts, please refer to the task describing the Define 
Contextual Links command in the Product Structure User's Guide.

 By default, this option is selected.

Restrict external selection with link to published elements

This option is not a new option: it has just been renamed.

Check this option  if you want to allow only published elements to be selected as external geometry. This 
restricts and therefore controls the selections that can be made when selecting elements belonging to a 
different part.

If Keep link with selected object is not on, although selected, this option has no effect.

 By default, this option is not selected.

Allow publication of faces, edges, vertices, and axes extremities

This option is not a new option: it has just been renamed.

Selected, this option enables you to directly select faces, edges, vertices, axes extremities when defining a 
Publication.

 By default, this option is selected.

Update



Automatic/Manual

Check Automatic if you want parts to be updated automatically. Conversely, check Manual if you wish to 
control your update operations. 

 By default, the Automatic option is selected.

Stop Update on first error

Check this option to stop the update process as soon as the application finds an error when building the 
geometry. 

 By default, this option is selected.

Update all external references

This option is not a new option: it has just been renamed.

Check this option to make sure that the application updates elements copied from other parts. Synchronizing 
assumes that all modifications to the other parts affect external references included in your part. If this option 
is deactivated, the application will update your part only. 

 By default, this option is selected.

Activate local visualization 

Check this option to visualize features as they are being rebuilt during the update process.

 By default, this option is not selected.

Delete Operation



Display the Delete dialog box 

Check this option if you wish to access filters for deletion (see "Deleting Features" in the Part Design Users 
Guide Version 5).

 By default, this option is selected.

Delete exclusive parents

Check this option if you wish to delete the parents of the features you are deleting. The parents will be deleted 
only if they are exclusive, in other words, if they are not shared by other features. Conversely, if they are 
shared by other features they will not be deleted. 

When this setting is active, the option is selected in the Delete dialog box. Even if the option is selected in the 
Delete dialog box, you can uncheck it if you wish to. If Display the Delete dialog box is not selected, this 
setting has no effect. For more information, refer to Deleting Features in the Part Design Users Guide Version 
5.

 By default, this option is not selected.

Replace
 

Do replace only for elements situated after the In Work Object

Checking this option makes the Replace... operation possible only for features located below the feature in 
Work Object and in the same branch. This option is available for bodies and ordered geometric sets, not for 
solid bodies.

 By default, this option is not selected.



Part Document 

This tab deals with these categories of options:

●     When Creating Parts

●     Hybrid Design

When Creating Parts 

Create an axis system

Select this option if you wish to create a three-axis system which origin point is defined by the intersection of 
the three default planes that is plane xy, plane yz, and plane zx. When the CATPart document is open, the axis 
system is displayed both in the geometry and in the specification tree. For more information about Axis 
System, refer to the Part Design User's Guide. 

 By default, this option is not selected.



Create a geometrical set

Check this option if you wish to create a geometrical set as soon as you create a new part. From V5R15 
onward, geometrical sets created with this option on, are located above Part Bodies in the specification tree.

For more information about geometrical sets, refer to Generative Shape Design User's Guide.

 By default, this option is not selected.

Note: data contained in the CGR format are saved within the CATPart format when you are saving your part in 
order to improve performances when working in Assembly Design workbench. 

Create an ordered geometrical set

Check this option if you wish to create an ordered geometrical set as soon as you create a new part. For more 
information about ordered geometrical sets, refer to Generative Shape Design User's Guide.

 By default, this option is not selected.

Create a 3D work support

Check this option if you wish to create a 3D work on support as soon as you create a new part. 

 By default, this option is not selected.

Display the New Part dialog box

Check this option if you wish to display the New Part dialog box as soon as you create a new part (using Start 
>Mechanical Design or File > New... part). 
This dialog box lets you name the new part and access options defining whether you wish to:

●     work in a hybrid design environment

●     create a geometrical set

●     create an ordered geometrical set 



Note that you can also access these options by using Tools>Options as described above. For more 
information about the New part dialog box, refer to Part Design User's Guide.

 By default, this option is selected.

Hybrid Design

Enable hybrid design inside part bodies and bodies

Check this option if you wish you to work in a hybrid design environment, that is with bodies that can include 

wireframe and surface elements. 

Note: 

If your CATPart document already contains traditional bodies, that is bodies that cannot include surface nor 

wireframe elements, the application identifies them with a gray icon:



If the option is deactivated, then on insertion of a traditional body (body not allowed to contain wireframe nor 

surface elements), icons identifying existing bodies likely to include wireframe and surface elements turn 

yellow.

See hybrid design for reference information. See also the Miscellaneous list identifying icons available in the 

Part Design workbench. 

 By default, this option is selected.

Locate wireframe and surface elements

When the option described above is on, meaning that you have chosen to work in a hybrid environment, you 

still can then choose between inserting wireframe and surface elements within bodies by checking In a body, 



or within geometrical sets by checking In a geometrical set. For more information about geometrical sets, 

refer to the Generative Shape Design User's Guide. 

 By default, the In a body option is selected.



Tolerancing 

This page deals with the options concerning:
●     The Tolerancing Standard.

●     The Leader associativity to the geometry.

Tolerancing Standard

Defines conventional standard options:

Default standard at creation

●     ASME: American Society for Mechanical Engineers

●     ASME 3D: American Society for Mechanical Engineers

●     ANSI: American National Standards Institute

●     JIS: Japanese Industrial Standard

●     ISO: International Organization for Standardization

 By default, the ISO standard is selected.

Leader associativity to the geometry

Defines the leader associativity options:

●     Free: specifies that leader annotations are freely positioned relative to their geometrical elements.

●     Perpendicular: specifies that leader annotations are positioned perpendicular to their geometrical elements.

 By default, the Free option is selected.



Display 

This page deals with the options concerning:
●     The Grid.

●     The Annotations in Specification Tree.

Grid

Defines the grid options:

Display

Defines whether the grid is displayed.

 By default, this option is not selected.

Snap to point

Defines whether annotations are snapped to the grid point. 

 By default, this option is not selected.

Allow Distortions

Defines whether grid spacing and graduations are the same horizontally and vertically.

 By default, this option is not selected.

H Primary spacing

Defines the grid horizontal spacing.

 By default, the value is 100mm.

H Graduations

Defines the grid horizontal graduations.

 By default, the number of graduation is 10.

V Primary spacing

Defines the grid vertical spacing, available only if Allow Distortions is selected.

 By default, the value is 100mm.



V Graduations

Defines the grid  vertical graduations, available only if Allow Distortions is selected.

 By default, the number of graduation is 10.

Annotations in Specification Tree

Defines the annotations in specification tree options:

Under Geometric Feature nodes

Defines that 3D annotations should be displayed under the geometric feature nodes in the specification tree. This lets you view 3D 
annotations under the Part Design or Generative Shape Design feature nodes to which they are applied.

 By default, this option is not selected.

Under View/Annotation Plane nodes

Defines that 3D annotations should be displayed under the view/annotation plane nodes in the specification tree. This lets you view 
3D annotations under the view node to which they are linked.

 By default, this option is not selected.

Under Annotations Set node

Defines that 3D annotations should be displayed under the annotation set node in the specification tree, available only if Under 
View/Annotation Plane nodes is selected.

 By default, this option is selected.



Manipulators

This page deals with the options concerning:
●     The Manipulators.

Manipulators

Defines the manipulator options:

Reference size

Defines the annotation manipulator's size.

 By default, the reference size is 2mm.

Zoomable

Defines whether the annotation manipulator is zoomable or not.

 By default, this option is selected.



View/Annotation Plane 

This page deals with the options concerning:
●     The View/Annotation Plane Associativity.

●     The View/Annotation Plane Display.

View/Annotation Plane Associativity

Defines the View/Annotation Plane associativity options:

Create views associative to geometry

Creates views associative to the geometry, so that views and their annotations are automatically updated when the geometry is 
modified.

 By default, this option is selected.

View/Annotation Plane Display

Defines the View/Annotation Plane display options:

Current view axis display

Defines whether the active annotation plane axis system is displayed.

 By default, this option is selected.

Zoomable

Defines whether the annotation plane axis is zoomable.

 By default, this option is selected.

Visualization of the profile in the current view

Defines whether the view/annotation plane profile on the part/product is displayed. 

 By default, this option is not selected.



Glossary

            

A

absolute coordinates Coordinates that specify a location in relation to the current coordinate system origin 
(0,0,0).

aggregation The collecting of features or sketches into a Part Design feature in the specification 
tree.

annotation An entity that provides information for the drawing. Texts are annotation entities.

associativity The interdependent relationships between entities.

B

body See part body.

C

chamfer A cut through the thickness of the feature at an angle, giving a sloping edge.

child A status defining the genealogical relationship between a feature or element and 
another feature or element. For instance, a pad is the child of a sketch. See also 
parent.

constraint A geometric or dimension relation between two elements. These relations are 
restrictions for these elements.

D

deactivate To suppresses the behavior of a feature, visually and geometrically.

draft angle A feature provided with a face with an angle and a pulling direction.

F

feature A component of a part. For instance, shafts, fillets and drafts are features.

fillet A curved surface of a constant or variable radius that is tangent to, and that joins 
two surfaces. Together, these three surfaces form either an inside corner or an 
outside corner.



G

groove A feature corresponding to a cut in the shape of a revolved feature.

H

hole A feature corresponding to an opening through a feature. Holes can be simple, 
tapered, counterbored, countersunk, or counterdrilled.

M

mirror A feature created by duplicating an initial feature. The duplication is defined by 
symmetry.

O

origin The 3D point having the location 0,0,0 in any coordinate system.

P

pad A feature created by extruding a profile.

parent A status defining the genealogical relationship between a feature or element and 
another feature or element. For instance, a pad is the parent of a draft.

part A 3D entity obtained by combining different features.

part body A component of a part made of a combination of several features. From Version 5 
Release 14, bodies and part bodies include shape design features.

pattern A set of similar features repeated in the same feature or part.

pocket A feature corresponding to an opening through a feature. The shape of the opening 
corresponds to the extrusion of a profile.

profile An open or closed shape including arcs and lines created by the profile command in the 
Sketcher workbench.

R

reorder An operation consisting in reorganizing the order of creation of the features.

rib A feature obtained by sweeping a profile along a center curve.

S

scaling An operation that resizes features to a percentage of their initial sizes.



shaft A revolved feature

shell A hollowed out feature

sketch A set of geometric elements created in the Sketcher workbench. For instance, a sketch 
may include a profile, construction lines and points.

slot A feature consisting of a passage through a part obtained by sweeping a profile along a 
center curve.

solid body A body created with application versions prior to Version 5 Release 14. Such a body 
contains no shape design features.

split A feature created by cutting a part or feature into another part or feature using a plane 
or face.

stiffener A feature used for reinforcing a feature or part.
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Activate 

contextual menu item  

activating  
Add 
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Annotations 

toolbars  

annotations  
Apply Material 

command  
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Axis System 
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B
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Body 
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body 
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editing  
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name  

Boolean operation       
Boolean operation computation 

interrupting       
Boolean Operations 
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Boundary 

command  

boundary  

C
canceling 

Update  

catalog  

CATPart documents  

cavity    
Chamfer 



command  
Change Geometrical Set 

command  
Change to XXX 

contextual menu item  

changing a sketch support  
Circular Pattern 

command    
Clear selection 

contextual menu item  
Close Surface 

command  

color scale   
command 
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AutoSort   
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Change a Sketch Support  
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Copy  

Create a Document Template  
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Create Datum   



Cut  

Deactivate  

Delete...   

Draft Analysis    

Draft Angle    

Draft from Reflect Lines  

Drafted Filleted Pad  

Drafted Filleted Pocket  

Edge Fillet   

Extract      

Extrapolate  

Face-Face Fillet  

Flag Note with Leader   
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Hole     

Hole Feature    

Insert Body in a Set  

Insert Geometrical Set  

Insert Ordered Geometrical Set  
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Parent Children  

Paste  

Plane  
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Point  

PowerCopy Creation  

PowerCopy Instantiate From Document  

PowerCopy Instantiation   

PowerCopy Save in Catalog  

Projection  

Publication  

Rectangular Pattern    
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Reorder Children   

Replace Face  

Rib  

Rotate  

Scaling  
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Symmetry  
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Thick Surface  
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Thread/Tap  

Translation  

Tritangent Fillet  

Union Trim  

Update  

User Pattern  

Variable Radius Fillet  
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commands 
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Edit-Links  
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command  
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editing  
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setting  

type  
Constraint Defined in Dialog Box 

command  
Constraints 

toolbars  
contextual command 



Reset Properties  

Show Parents and Children  
contextual menu item 

Activate  

Add Position  

Change to XXX  

Clear selection  

Create Technological Results  

Deactivate   

Define in Work Object  

Definition  

Edit Parameters  

Explode Pattern  

Go to Profile  

hide components  

open pointed document  

Paste Special  

Properties   

Reorder  

Replace   

Reset Deleted Technological Result  

Show All Children  

show components  

Synchronize  

Synchronize All  

Tangency propagation  

contextual part  

controlled by reference  
Copy 

command  

corner  

reshaping  
counterbored 



Hole  
counterdrilled 

Hole  
countersunk 

Hole  
Create Datum 

command  
Create Technological Results 

contextual menu item  
creating 
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curves  

datum  

elements by intersection  

elements by projection  

feature  

hole features    

line  

plane  

creating a NLS user feature  

creating a part template  

creating a user feature  

creating point  

cube  
Cut 

command  

D
data size  

datum    

datums  
Deactivate 



contextual menu item   

deactivating  

features  
deactivating/activating 

constraint  

debuggin a user feature  
Define in Work Object 

contextual menu item  

define in work object  
defining 

local axis-system  
Definition 

contextual menu item  
Delete... 

command   
deleting 

feature  

pattern  

un-referenced features  
density 

part  
difficulties 

Draft Angle  

document chooser  
document template 

creating  

external document  

instantiating a document template containing meta inputs  

methodology  

part template   

window  
document template window 

auto modify part numbers with suffix option  

automatic input  

edit list button  



manual input  

new document  

same document  

document template with meta input  
Draft Analysis 

command   

draft analysis  
Draft Angle 

command    

difficulties  

neutral element   

parting element  
Draft from Reflect Lines 

command  

parting element  
Drafted Filleted Pad 

command  

drafting  

filleting  

neutral element  
Drafted Filleted Pocket 

command  

drafting  

filleting  
drafting 

Drafted Filleted Pad  

Drafted Filleted Pocket  
Dress-Up Features 

toolbars  

dress-up features  

E
Edge Fillet 



command   

inside corner  

Edit List... button  
Edit Parameters 

contextual menu item  
editing 

body  

constraint  

feature  

part  

pattern  

Edit-Links command  
elements 

isolate  
entering 

Part Design workbench  
Explode Pattern 

contextual menu item  
exploding 

User Pattern  

external document  

external reference  
Extract 

command     

extract  
extracting 

elements  

propagation  

extrapolate  
extrapolating 
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F
Face-Face Fillet 

command  
face-face fillet 

spine  
feature 

creating  

deleting  

editing  

parameter  

positioning  

feature list    
features 

deactivating  

file  
fillet computation 

interrupting     

filleting  

Drafted Filleted Pad  

Drafted Filleted Pocket  
Flag Note with Leader 

command  
flat end 

Hole  

G
geometrical set 

removing  

sorting  
geometrical sets 

inserting  

moving  

reordering  



Go to Profile 

contextual menu item  
graphic properties 

hybrid design  

graphical properties  
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H
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I
improving 

Update  

insert a body in a set  
Insert Geometrical Set 

command  
Insert Ordered Geometrical Set 

command  
inserting 
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body in an ordered geometrical set  
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Power Copies using part comparison  

Power Copies using step by step comparison  
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from a document  

from a selection  
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instantiating a user feature using the knowledge template  
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Update  
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J
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surfaces  

K
knowledge pattern 
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M
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applying  

link  

mapping  
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